Jump to content
Калькуляторы

Compex PS2216 + 802.1Q как управлять/мониторить? Магистральный порт в транк = свич недоступен

Доброго всем LOCAL_TIME!

 

Строим планы по переходу на схему доступа через пользовательские VLAN-ы. На доступе используем DES-3526 + PS2216.

Сейчас PS2216 сконфигурены с изоляцией портов на основе port-based VLAN. Мониторятся и конфигурятся без проблем.

Сконфигурили одни с VLAN-ом на порт и магистральный перевели в транк - свич не отзывается на RRCP. У кого есть

положительный опыт в такой конфигурации?

!
! Config for generic rtl8316b switch at 00:80:48:67:79:da@eth1
! generated by OpenRRCP CLI ver 0.2.1
!
version rtl8316b
!
mac-address-table aging-time 300
!
no ip igmp snooping
rrcp enable
rrcp echo enable
no rrcp loop-detect enable
!
vlan dot1q
! vlan numbers: 1122,601,1100,1101,1105,1102,1104,1103,1103,1123,1102,0,1101,0,1123,0,0,0,0,0,0,
0,0,0,0,0,0,0,0,0,0,0
no vlan drop invalid_vid
!
no mls qos trust dscp
no mls qos trust cos
wrr-queue ratio 4:1
!
flowcontrol dot3x
flowcontrol backpressure
no storm-control broadcast
no storm-control multicast
!
spanning-tree bpdufilter enable
!
interface FastEthernet0/1
switchport access vlan 1122
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 601
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 1100
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 1101
switchport mode access
!
interface FastEthernet0/5
switchport access vlan 1105
switchport mode access
!
interface FastEthernet0/6
switchport access vlan 1102
switchport mode access
rrcp enable
!
interface FastEthernet0/7
switchport access vlan 1104
switchport mode access
!
interface FastEthernet0/8
switchport access vlan 1103
switchport mode access
!
interface FastEthernet0/9
switchport access vlan 1103
switchport mode access
!
interface FastEthernet0/10
switchport access vlan 1123
switchport mode access
!
interface FastEthernet0/11
switchport access vlan 1102
switchport mode access
!
interface FastEthernet0/12
switchport access vlan 0
switchport mode access
!
interface FastEthernet0/13
switchport access vlan 1101
switchport mode access
!
interface FastEthernet0/14
switchport access vlan 0
switchport mode access
!
interface FastEthernet0/15
switchport access vlan 1123
switchport mode access
!
interface FastEthernet0/16
switchport trunk allowed vlan 601,1100-1105,1122-1123
switchport mode trunk
rrcp enable
!
end

Edited by Yoda

Share this post


Link to post
Share on other sites

написал самописный веб интерфейс, заточил под работу с вланами и красота)))

Edited by Davion

Share this post


Link to post
Share on other sites

написал самописный веб интерфейс, заточил под работу с вланами и красота)))

Можно взглянуть хотя-бы на рабочий конфиг компекса PS2216?

Share this post


Link to post
Share on other sites

Yoda, RRCP не будет ходить по транковым портам. Особенности чипсета.

Share this post


Link to post
Share on other sites

Yoda, RRCP не будет ходить по транковым портам. Особенности чипсета.

Печально. Полное фиаско...

Share this post


Link to post
Share on other sites

Однако если взглянуть вооруженным глазом, например tcpdump-ом, то свитч таки отвечает на RRCP запросы.

Вот только отвечает уже тэгированными кадрами. Что интересно - подставляется VID = 0!

Стоит вырезать тэг, пропустив трафик через антэггед порт - вуаля! Свич пингуется и конфигурится 8)

Share this post


Link to post
Share on other sites

Yoda, vid0 = влан приоритета. Остальные вланы при этом нормально работают?

И как вы при этом на него RRCP запросы отправляете? Нетегом?

Share this post


Link to post
Share on other sites

управление этими свичами возможно только через нетегированный порт.

Поэтому можно разтегировать управление, заняв таким образом 2 порта(петля кабелем).

Share this post


Link to post
Share on other sites

Сейчас PS2216 сконфигурены с изоляцией портов

Они разве управляемые?

Share this post


Link to post
Share on other sites

mikevlz, там 1 таблица MAC адресов на все вланы. ЗАпетляв 2 порта кабелем, скорее всего, получится именно петля, а не растегирование :)

Share this post


Link to post
Share on other sites

если к пс 2216 добавить лайт_ком лс 100-8, то можно получить очень нормальную схему

Share this post


Link to post
Share on other sites

если к пс 2216 добавить лайт_ком лс 100-8, то можно получить очень нормальную схему

По-моему эффективность данного решения будет похожа на костыль, а стоимость сравнима с нормальным умным оборудованием :)

Share this post


Link to post
Share on other sites

Есть управляемые оптические конверторы Palnet.

В дом такой конвертор за 1,5Круб + компекс рублей за 800 руб = вполне себе рабочее решение.

Только компексы чувствительны к стабильности питания - виснут от бросков напряжения.

Share this post


Link to post
Share on other sites
Есть управляемые оптические конверторы Palnet.

В дом такой конвертор за 1,5Круб + компекс рублей за 800 руб = вполне себе рабочее решение.

Только компексы чувствительны к стабильности питания - виснут от бросков напряжения.

Пользовались несколько лет и planet и compex, да и много чего перепробовали.

 

Остановили свой выбор именно на compex, эти мыльницы лучше всего показали себя на деле.

Были иногда проблемы с блоками питания, пришлось найти другие БП.

 

Взяли пару раз небольших партий оборудования от planet, разный моделей и управляемое оборудование в том числе. Позже все коммутаторы planet выбросили на склад.

Из всей этой линейки работает нормально только 100-ые медиаконверторы (д-линковские медиаконвертора работают не хуже).

Наши выводы planet редкостное Г.

 

Share this post


Link to post
Share on other sites
Сейчас PS2216 сконфигурены с изоляцией портов
Они разве управляемые?

Управляемые по L2.

 

Yoda, vid0 = влан приоритета. Остальные вланы при этом нормально работают?

И как вы при этом на него RRCP запросы отправляете? Нетегом?

Угу... "Рано радовался Иван-Царевич..."

Запрос приходит на свич нетэгированный, ответ уходит от свича с тэгом.

В общем попа с ручками...

Share this post


Link to post
Share on other sites

А не подскажет ли кто-нибудь, как этот compex PS2216 настраивается при помощи переключателей? А то попалась в руки модель 2004 г.в, а настроить пока не получается. На сайте у них даже программа для настройки есть (Winsmart 4.0), но она, если я правильно понял подходит только для моделей >2005 г.в. Итак, что у нас есть. У нас есть несколько переключателей: Trunk1, Trunk2, Priority и Vlan. Собственно и вопрос в том, как будет работать этот свитч при включении различных переключателей. И какие комбинации возможны, или наоборот бессмысленны.

Пока примерно ясно как работает Vlan: с портов 2-16 друг друга не видно, но есть доступ к порту 1 (т.е. имемем 15 port-based vlan на портах 2-16 и общий порт 1 (он trunk?) (поправьте, если не так)).

Про режимы trunk1 и trunk2 здесь где-то уже встречал: trunk1: порты 1,2,9,10 могут использоваться для подключения к другому управляемому свитчу на скорости 400 mb/s; trunk2 - то же, но для портов 3,4,11,12. Так ли это?

Приходится понемногу разбираться с сетями, поэтому вопросы могут показаться некорректными. На подробное объяснение не претендую, буду признателен за объяснение его работы в общих словах при включении различных переключателей.

Share this post


Link to post
Share on other sites

Подарили кучу таких железок без блоков питания, блоки заказан на али, комуты без переключателей, конфигурируются через прогу. Имеем собственно winsmart и задачу растегировать vlan с транкового (vlan tag) на определенные порты. В 1 посте написан конфиг как это сделать, но вот как зацепиться консолькой на этот комут? Мануалов как это всё организовать через винсмарт я не могу найти. 3 часа проковырялся вслепую - толку 0. Есть мысли?

Share this post


Link to post
Share on other sites

он броадкастом ищется, насколько я помню, коммутатор подключен напрямую к компутеру?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this