Jump to content
Калькуляторы

cisco - interface multilink не разгоняется до "потолочной" скорости

Подключение к магистралу сделано двумя фреймованными Е1, собранными в мультилинк на cisco 3620:

 

c3620#sh ver
Cisco Internetwork Operating System Software
IOS (tm) 3600 Software (C3620-IK8O3S-M), Version 12.2(13), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Tue 19-Nov-02 14:03 by pwade
Image text-base: 0x60008930, data-base: 0x612B4000

ROM: System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

c3620 uptime is 1 day, 9 hours, 2 minutes
System returned to ROM by reload
System restarted at 08:14:43 CHE Tue Apr 20 2010
System image file is "flash:c3620-ik8o3s-mz.122-13.bin"

cisco 3620 (R4700) processor (revision 0x81) with 49152K/16384K bytes of memory.
Processor board ID 24807390
R4700 CPU at 80Mhz, Implementation 33, Rev 1.0
Channelized E1, Version 1.0.
Bridging software.
X.25 software, Version 3.0.0.
SuperLAT software (copyright 1990 by Meridian Technology Corp).
Primary Rate ISDN software, Version 1.1.
1 FastEthernet/IEEE 802.3 interface(s)
2 Serial network interface(s)
2 Channelized E1/PRI port(s)
DRAM configuration is 32 bits wide with parity disabled.
29K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

 

Фрагмент конфига, касающийся мультилинка:

 

controller E1 1/0
framing NO-CRC4
channel-group 0 timeslots 1-31
description To Rostelecom
!
controller E1 1/1
framing NO-CRC4
channel-group 0 timeslots 1-31
description To Rostelecom
!
!
!
interface Multilink1
description ### MultiLink to Rostelecom
bandwidth 4096
ip address 94.хх.хх.хх 255.255.255.252
ip verify unicast reverse-path
no ip redirects
no ip proxy-arp
no cdp enable
ppp multilink
no ppp multilink fragmentation
multilink-group 1
hold-queue 4096 in
hold-queue 4096 out
!
interface FastEthernet1/0
description ### To Local
ip address 10.1.2.2 255.255.255.248 secondary
ip address 87.ххх.ххх.х 255.255.255.248
no ip redirects
no ip unreachables
no ip proxy-arp
ip accounting output-packets
no ip mroute-cache
duplex auto
speed auto
hold-queue 4096 in
hold-queue 4096 out
!
interface Serial1/0:0
description To Rostelecom
bandwidth 2048
no ip address
ip verify unicast reverse-path
no ip redirects
no ip unreachables
no ip proxy-arp
encapsulation ppp
no ip route-cache cef
no fair-queue
no cdp enable
ppp multilink
multilink-group 1
hold-queue 4096 in
hold-queue 4096 out
!
interface Serial1/1:0
description To Rostelecom
bandwidth 2048
no ip address
ip verify unicast reverse-path
no ip redirects
no ip unreachables
no ip proxy-arp
encapsulation ppp
no ip route-cache cef
no fair-queue
no cdp enable
ppp multilink
multilink-group 1
hold-queue 4096 in
hold-queue 4096 out

 

В пределе (нагружали несколькими потоками wget-а) канал дает около 3,5 мбит/сек, вместо ожидаемых 3,8-3,9 :(

На той стороне стоит Juniper, никаких шейперов/полисеров как утверждается там нет (да и не нужны они, т.к. линк собран из 2-х Е1).

Может что не так в конфиге?

Параметр "clock rate " на Serial Interface в этом случае имеет значение?

 

Share this post


Link to post
Share on other sites

Т.е. балансировка per-packet ?

Интерфейсы нагружаются равномерно ?

 

>timeslots 1-31

типа framed ? значит - 1 таймслот на каждом E1. Итого -128k

Так я понимаю ?

 

Edited by Ivan Rostovikov

Share this post


Link to post
Share on other sites

Попробуй удалить мультилинк интерфейс, сделать default для сериалов и потестировать с конфигом без излишеств:

interface Multilink1
ip address ....
ppp multilink
ppp multilink fragment disable
ppp multilink group 1

interface Serial0/1/0:1
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 1

Ну и конечно проверить на наличие каких-либо ошибок

show controller e1

show int mu1

show int Serial1/0:0

show int Serial1/1:0

show ppp mu

 

Как раз с Ростелекомом доводилось поднимать мультилинки от 2 до 8 Е1. Если ошибок на потоках и интерфейсах не было, то с полосой было все ОК.

Edited by Картуччо

Share this post


Link to post
Share on other sites
Т.е. балансировка per-packet ?

Интерфейсы нагружаются равномерно ?

Балансировка явно не указана, но Е1 нагружаются равномерно: если посмотреть sh int mult 1 и затем сразу же show int Serial1/0:0 и show int Serial1/1:0 , то видно, что нагрузка поделена между Е1 равномерно.

 

>timeslots 1-31

типа framed ? значит - 1 таймслот на каждом E1. Итого -128k

Так я понимаю ?

Нет. Мультилинк из 2-х потоков

- фреймированный: (30 * 64) * 2 = 3840

- не фреймированный: (32*64)*2 = 4096

Т.е. в моем случае должно быть пимерно 2*30*64 = 3840 Кбит/сек = 480 Кбайт/сек, а реально выше 3500 Кбит/сек (440 Кбайт/сек) не поднимается.

 

 

сделать default для сериалов
А как - можно по-точнее подскажите?

 

show controller e1

show int mu1

show int Serial1/0:0

show int Serial1/1:0

show ppp mu

Вот что видно сейчас (утро, нагрузка около 60%):

c3620#sh controller E1
E1 1/0 is up.
  Applique type is Channelized E1 - balanced
  Description: To Rostelecom
  No alarms detected.
  alarm-trigger is not set
  Framing is NO-CRC4, Line Code is HDB3, Clock Source is Line.
  Data in current interval (378 seconds elapsed):
     0 Line Code Violations, 0 Path Code Violations
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
  Total Data (last 24 hours)
     0 Line Code Violations, 0 Path Code Violations,
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
E1 1/1 is up.
  Applique type is Channelized E1 - balanced
  Description: To Rostelecom
  No alarms detected.
  alarm-trigger is not set
  Framing is NO-CRC4, Line Code is HDB3, Clock Source is Line.
  Data in current interval (380 seconds elapsed):
     0 Line Code Violations, 0 Path Code Violations
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
  Total Data (last 24 hours)
     0 Line Code Violations, 0 Path Code Violations,
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

c3620#show int mu1
Multilink1 is up, line protocol is up
  Hardware is multilink group interface
  Description: ### MultiLink to Rostelecom
  Internet address is 94.хх.хх.хх/30
  MTU 1500 bytes, BW 4096 Kbit, DLY 100000 usec,
     reliability 255/255, txload 41/255, rxload 143/255
  Encapsulation PPP, loopback not set
  Keepalive set (10 sec)
  DTR is pulsed for 2 seconds on reset
  LCP Open, multilink Open
  Open: IPCP
  Last input 00:00:00, output never, output hang never
  Last clearing of "show interface" counters 2d00h
  Input queue: 0/4096/118/0 (size/max/drops/flushes); Total output drops: 23982
  Queueing strategy: fifo
  Output queue: 0/4096 (size/max)
  5 minute input rate 2305000 bits/sec, 494 packets/sec
  5 minute output rate 661000 bits/sec, 423 packets/sec
     74852624 packets input, 2077718393 bytes, 9318 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     66269860 packets output, 3475622159 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions

c3620#show int Serial1/0:0
Serial1/0:0 is up, line protocol is up
  Hardware is DSX1
  Description: To Rostelecom
  MTU 1500 bytes, BW 2048 Kbit, DLY 20000 usec,
     reliability 255/255, txload 41/255, rxload 143/255
  Encapsulation PPP, loopback not set
  Keepalive set (10 sec)
  LCP Open, multilink Open
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters 2d00h
  Input queue: 0/4096/1128/0 (size/max/drops/flushes); Total output drops: 70
  Queueing strategy: fifo
  Output queue: 0/4096 (size/max)
  5 minute input rate 1155000 bits/sec, 238 packets/sec
  5 minute output rate 335000 bits/sec, 206 packets/sec
     37754609 packets input, 1250760944 bytes, 2881 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 141 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     33181552 packets output, 2008302248 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 output buffer failures, 0 output buffers swapped out
     3 carrier transitions
  Timeslot(s) Used:1-31, Transmitter delay is 0 flags

c3620#show int Serial1/1:0
Serial1/1:0 is up, line protocol is up
  Hardware is DSX1
  Description: To Rostelecom
  MTU 1500 bytes, BW 2048 Kbit, DLY 20000 usec,
     reliability 255/255, txload 41/255, rxload 144/255
  Encapsulation PPP, loopback not set
  Keepalive set (10 sec)
  LCP Open, multilink Open
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters 2d00h
  Input queue: 0/4096/1322/0 (size/max/drops/flushes); Total output drops: 207
  Queueing strategy: fifo
  Output queue: 0/4096 (size/max)
  5 minute input rate 1158000 bits/sec, 241 packets/sec
  5 minute output rate 335000 bits/sec, 206 packets/sec
     37733637 packets input, 1246500376 bytes, 165 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 165 throttles
     2 input errors, 0 CRC, 2 frame, 0 overrun, 0 ignored, 1 abort
     33140429 packets output, 2000428754 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
     3 carrier transitions
  Timeslot(s) Used:1-31, Transmitter delay is 0 flags

c3620#show ppp mu

Multilink1, bundle name is 94.хх.хх.хх
  Bundle up for 2d00h
  2051777 lost fragments, 27048682 reordered, 0 unassigned
  19378 discarded, 3004 lost received, 41/255 load
  0xC071FA received sequence, 0xF3690E sent sequence
  Member links: 2 active, 0 inactive (max not set, min not set)
    Se1/1:0, since 1d15h, last rcvd seq C071FB
    Se1/0:0, since 10:22:16, last rcvd seq C071F6

 

Потоки приходят к нам по релейке, в ней конечно возможны "замирания", в sh log иногда прокскакивают записи вида

.Apr 21 00:03:06: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0:0, changed state to down
.Apr 21 00:03:09: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0:0, changed state to up
.Apr 21 22:14:56: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0:0, changed state to down
.Apr 21 22:15:01: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0:0, changed state to up

но редко - может быть раз в 3-4 дня.

Share this post


Link to post
Share on other sites
Т.е. в моем случае должно быть пимерно 2*30*64 = 3840 Кбит/сек = 480 Кбайт/сек, а реально выше 3500 Кбит/сек (440 Кбайт/сек) не поднимается.
Ну, вообще-то мультилинк имеет еще и свои накладные расходы.

Например, в документации на RADовские RICi-8E1 сразу оговорено, что будет не 16 мбпс, а только 14.5

Но, если правильно помню, на мультилинках 2Е1 рисовалось в максимуме все же побольше, чем 3.5 мбпс

 

сделать default для сериалов

А как - можно по-точнее подскажите?

имел в виду чтобы конфиг на интерфейсах построчно не зачищать

default int Serial1/0:0

 

 

2051777 lost fragments, 27048682 reordered, 0 unassigned

19378 discarded, 3004 lost received, 41/255 load

 

И вот какие у меня sh ppp mu:

Multilink1, bundle name is UAK5-R1

Endpoint discriminator is UAK5-R1

Bundle up for 2w2d, total bandwidth 4096, load 1/255

Receive buffer limit 24000 bytes, frag timeout 1000 ms

0/0 fragments/bytes in reassembly list

0 lost fragments, 527797 reordered

1/42 discarded fragments/bytes, 2 lost received

0x309BC0 received sequence, 0x492D07 sent sequence

Member links: 2 active, 0 inactive (max not set, min not set)

Se0/1/1:1, since 2w2d

Se0/1/0:1, since 2w2d

No inactive multilink interfaces

 

Multilink1, bundle name is UAK8-R1

Endpoint discriminator is UAK8-R1

Bundle up for 14w3d, total bandwidth 3968, load 2/255

Receive buffer limit 24000 bytes, frag timeout 1000 ms

0/0 fragments/bytes in reassembly list

6 lost fragments, 89518206 reordered

0/0 discarded fragments/bytes, 0 lost received

0xC6CF21 received sequence, 0xC4A632 sent sequence

Member links: 2 active, 0 inactive (max not set, min not set)

Se0/3/1:1, since 5d08h

Se0/1/0:1, since 6w5d

No inactive multilink interfaces

Edited by Картуччо

Share this post


Link to post
Share on other sites
имел в виду чтобы конфиг на интерфейсах построчно не зачищать

default int Serial1/0:0

Попробую переделать в период наименьшей нагрузки.

 

2051777 lost fragments, 27048682 reordered, 0 unassigned

19378 discarded, 3004 lost received, 41/255 load

Как можно диагностировать причину этой гадости, т.к. "2051777 lost fragments" из "27048682 reordered" это 7,5% - похоже как раз именно та полоса, которую я недобираю из мультилинка.

На контроллерах ошибок не видно:

c3620# sh controller E1 1/0
E1 1/0 is up.
  Applique type is Channelized E1 - balanced
  Description: To Rostelecom
  No alarms detected.
  alarm-trigger is not set
  Framing is NO-CRC4, Line Code is HDB3, Clock Source is Line.
  Data in current interval (259 seconds elapsed):
     0 Line Code Violations, 0 Path Code Violations
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
...
  Total Data (last 24 hours)
     0 Line Code Violations, 0 Path Code Violations,
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

c3620# sh controller E1 1/1
E1 1/1 is up.
  Applique type is Channelized E1 - balanced
  Description: To Rostelecom
  No alarms detected.
  alarm-trigger is not set
  Framing is NO-CRC4, Line Code is HDB3, Clock Source is Line.
  Data in current interval (259 seconds elapsed):
     0 Line Code Violations, 0 Path Code Violations
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
...
  Total Data (last 24 hours)
     0 Line Code Violations, 0 Path Code Violations,
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

 

Share this post


Link to post
Share on other sites

Для начала надо переделать конфигурацию как я выше приводил и потестировать снова.

Конфиг будет несколько отличаться, та как железки и софт разные.

Так же не мешает РТ попросить проверить с их стороны.

Edited by Картуччо

Share this post


Link to post
Share on other sites
Для начала надо переделать конфигурацию как я выше приводил и потестировать снова.
ОК. Завтра с утра.

 

Так же не мешает РТ попросить проверить с их стороны.
Говорят, что проверяли. Даже мерили с ними канал iperf-ом, но получили противоречивые данные.

Share this post


Link to post
Share on other sites
- фреймированный: (30 * 64) * 2 = 3840

- фреймированный: 31 * 64 * 2 = 3968

куда вы еще один TS дели? ;)

channel-group 0 timeslots 1-31

Share this post


Link to post
Share on other sites
куда вы еще один TS дели? ;)
Синхра.

 

Картуччо, вобщем сделал я как вы советовали:

c3620#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
c3620(config)#int mult 1
c3620(config-if)#shut
c3620(config-if)#no int mult 1
% Removed 'multilink-group' from interface Serial1/0:0
% Removed 'multilink-group' from interface Serial1/1:0
c3620(config)#default int Serial1/0:0
Building configuration...

% Cannot enable CDP on this interface, since CDP is not running
Interface Serial1/0:0 set to default configuration
c3620(config)#default int Serial1/1:0
Building configuration...

% Cannot enable CDP on this interface, since CDP is not running
Interface Serial1/1:0 set to default configuration

 

и потом

 

interface Multilink1
ip address 94.хх.хх.хх 255.255.255.252
ppp multilink
ppp multilink fragment disable
ppp multilink group 1

interface Serial1/0:0
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 1

interface Serial1/1:0
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 1

 

Получившийся конфиг:

interface Multilink1
description ### MultiLink to Rostelecom
bandwidth 4096
ip address 94.хх.хх.хх 255.255.255.252
ip verify unicast reverse-path
no ip redirects
no ip proxy-arp
no cdp enable
ppp multilink
no ppp multilink fragmentation
multilink-group 1
hold-queue 4096 in
hold-queue 4096 out
!
...
!
interface Serial1/0:0
no ip address
no ip proxy-arp
encapsulation ppp
no cdp enable
ppp multilink
multilink-group 1
!
interface Serial1/1:0
no ip address
no ip proxy-arp
encapsulation ppp
no cdp enable
ppp multilink
multilink-group 1

 

После 50 минут работы lost fragments опять присутствуют и со временем счетчики растут, хотя в % остается примерно на том же уровне:

 

Multilink1, bundle name is 94.хх.хх.хх
  Bundle up for 00:49:52
  15502 lost fragments, 270928 reordered, 0 unassigned
  29 discarded, 0 lost received, 36/255 load
  0x101B51 received sequence, 0xD25F1 sent sequence
  Member links: 2 active, 0 inactive (max not set, min not set)
    Se1/0:0, since 00:49:52, last rcvd seq 101B50
    Se1/1:0, since 00:49:52, last rcvd seq 101B4F

c3620#sh int mult 1
Multilink1 is up, line protocol is up
  Hardware is multilink group interface
  Description: ### MultiLink to Rostelecom
  Internet address is 94.хх.хх.хх/30
  MTU 1500 bytes, BW 4096 Kbit, DLY 100000 usec,
     reliability 255/255, txload 35/255, rxload 138/255
  Encapsulation PPP, loopback not set
  Keepalive set (10 sec)
  DTR is pulsed for 2 seconds on reset
  LCP Open, multilink Open
  Open: IPCP
  Last input 00:00:02, output never, output hang never
  Last clearing of "show interface" counters 3d00h
  Input queue: 0/4096/118/8 (size/max/drops/flushes); Total output drops: 23986
  Queueing strategy: fifo
  Output queue: 0/4096 (size/max)
  5 minute input rate 2226000 bits/sec, 423 packets/sec
  5 minute output rate 567000 bits/sec, 362 packets/sec
     113411787 packets input, 199253776 bytes, 9318 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     99563569 packets output, 582474035 bytes, 0 underruns
     0 output errors, 0 collisions, 6 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions

 

sh controller E1 ошибок не показывает.

Share this post


Link to post
Share on other sites

Total output drops: 23986

Этот счетчик тянется с прошлого конфига. Он почему-то не обнулился несмотря на то, что я убивал мультилинк-интерфейс и сбрасывал в дефаулт сериалы. Растет этот счетчик крайне медленно - за день на 4.

Share this post


Link to post
Share on other sites

Сейчас загрузка

5 minute input rate 3407000 bits/sec, 642 packets/sec

 

Пытаюсь нагрузить канал:

wget -O /dev/null ftp://ftp.drweb.com/pub/drweb/iso/drweb-600-livecd.iso

 

Одновременно смотрел iperf:

 

iperf -c 89.хх.хх.хх -d

------------------------------------------------------------

Server listening on TCP port 5001

TCP window size: 85.3 KByte (default)

------------------------------------------------------------

------------------------------------------------------------

Client connecting to 89.хх.хх.хх, TCP port 5001

TCP window size: 16.0 KByte (default)

------------------------------------------------------------

[ 6] local 87.226.хх.х port 50959 connected with 89.237.хх.хх port 5001

[ 6] 0.0-10.1 sec 2.08 MBytes 1.73 Mbits/sec

 

Т.е. грубо можно сложить показания циски (3,4 мбит/сек) и iperf-а (1,73 Мбит/сек) = более 5 Мбит/сек.

Странный результат. Либо я неверно трактую полученные данные.

Share this post


Link to post
Share on other sites

Лучше добавить интерфейс мультилинка в какой-нибудь мониторинг и уже потом трактовать графики.

Share this post


Link to post
Share on other sites

В лабораторных условиях собрали мультилинк на 2х Е1 на цисках - результат тот же ~3,5 мбит/с

Share this post


Link to post
Share on other sites

Не, джентльмены, что-то где-то у вас не так.

Ради интереса прогрузил в двух разных узлах такие же мультилинки 2хЕ1, тоже Ростелеком.

Верхний график на картинке с анфреймед:

controller E1 0/1/0

channel-group 1 unframed

нижний график с настройками как у ТС:

controller E1 0/1/0

channel-group 1 timeslots 1-31

Полосы по 4 мегабита уже слабо актуальны, поэтому мультики стоят на самый крайний резервный случай почти пустые.

Поток трафика выставил в 3.8 Mbps.

98c2c417286ct.jpg

Share this post


Link to post
Share on other sites
куда вы еще один TS дели? ;)
Синхра.

для синхронизации используется TS0

один из 32.

32-1 = 31.

не?

Share this post


Link to post
Share on other sites
Лучше добавить интерфейс мультилинка в какой-нибудь мониторинг и уже потом трактовать графики.
Мониторинг есть, вот картинка, которую рисует mrtg (oid - 1.3.6.1.2.1.2.2.1.10.1):

00939d08aa6b.png

 

 

 

что-то где-то у вас не так.
Согласен. Вот и ищу - где?

 

Полосы по 4 мегабита уже слабо актуальны
В небольших городках зауралья еще актуальны

Share this post


Link to post
Share on other sites
для синхронизации используется TS0

один из 32.

32-1 = 31.

не?

На сколько я помню, таймслоты нумеруются с 1 по 31, 16-й синхра, остальные 30 - собственно полезная нагрузка.

Share this post


Link to post
Share on other sites

Картинку перевести в биты, а то смотрится как порнография.

Насчет таймслотов неправильно. Да и полки как таковой на графике не видно. Надо поддать нагрузки :)

Share this post


Link to post
Share on other sites
для синхронизации используется TS0

один из 32.

32-1 = 31.

не?

На сколько я помню, таймслоты нумеруются с 1 по 31, 16-й синхра, остальные 30 - собственно полезная нагрузка.

нет.

0 -- фреймовая синхронизация (для образования структуры Е1)

1-31 -- полезная нагрузка.

Если в потоке Е1 присутствует еще и телефонная сигнализация (не путать с синхронизацией), то тогда таймслотов для проключения телефонных, разговорных, каналов дйствительно 30.

У вас же не PRI, а данные. Вы описали channel-group 1 timeslots 1-31 , то есть все 31 TS. И скорость у вас должна быть еще больше, чем вы думаете :)

а вот почему "не грузится"...

по графику MRTG у вас вроде как и грузится, кстати. т.к. мртг у вас отображает в байтах/с

график мртг рисует, на мой взгляд, неправильно хотя бы потому, что автор MRTG думал, что в одном килобите 1024 бита.

а не 1000, как есть в реале.

может, и вы тоже думаете так же? :)

31*2*64к=3968кбит/с

3968 / 8 = 496 кбайт/с

 

если взять поправку на ошибку мртг 1024/1000 получится 484,375 кбайт/с

надо, разумеется, еще понимать, что мртг с мультилинка снимает уже нагрузку tcp/ip (без учета служебного пакетирования для мультилинка и собственно PPP)

 

не знаю, как помне -- нагрузка, судя по графику, абсолютно адекватна.

 

IMHO

Edited by fenix-vt

Share this post


Link to post
Share on other sites

Может не тот oid смотрю?

sh-2.05b# snmpwalk 87.ххх.ххх.ххх -v 2c -c public 1.3.6.1.2.1.2.2.1.10

IF-MIB::ifInOctets.1 = Counter32: 3423022484

IF-MIB::ifInOctets.2 = Counter32: 0

IF-MIB::ifInOctets.5 = Counter32: 3892130191

IF-MIB::ifInOctets.6 = Counter32: 3885977698

IF-MIB::ifInOctets.7 = Counter32: 2804261320

 

На графике 1.3.6.1.2.1.2.2.1.10.1 и 1.3.6.1.2.1.2.2.1.16.1

 

Картинку перевести в биты, а то смотрится как порнография.
Как? В лог-то подают циферки правильные:

sh-2.05b# snmpwalk 87.ххх.ххх.ххх -v 2c -c public 1.3.6.1.2.1.2.2.1.10.1

IF-MIB::ifInOctets.1 = Counter32: 3513626768

sh-2.05b# snmpwalk 87.ххх.ххх.ххх -v 2c -c public 1.3.6.1.2.1.2.2.1.16.1

IF-MIB::ifOutOctets.1 = Counter32: 409904023

 

Да и полки как таковой на графике не видно. Надо поддать нагрузки :)
Сейчас запустил wget с 4х разных терминальных сессий с сервака тянет:

wget -O /dev/null ftp://ftp.drweb.com/pub/drweb/iso/drweb-600-livecd.iso

Share this post


Link to post
Share on other sites

Для перевода картинки в биты надо указать в опциях для этого таргета параметр bits.

Оиды вовсе не нужны, можно указать таргет по индексу интерфейса.

Share this post


Link to post
Share on other sites
график мртг рисует, на мой взгляд, неправильно хотя бы потому, что автор MRTG думал, что в одном килобите 1024 бита.

а не 1000, как есть в реале.

может, и вы тоже думаете так же? :)

31*2*64к=3968кбит/с

3968 / 8 = 496 кбайт/с

 

если взять поправку на ошибку мртг 1024/1000 получится 484,375 кбайт/с

надо, разумеется, еще понимать, что мртг с мультилинка снимает уже нагрузку tcp/ip (без учета служебного пакетирования для мультилинка и собственно PPP)

Было бы 496 кбайт/с или хотя бы 484, я бы может и не спрашивал бы.

К тому же для меня mrtg - всего лишь ориентир. Наиболее реально наверное отражает ситуацию данные, получаемые по

sh int mult 1

sh int FastEthernet1/0

Вот тут-то больше 3500000 bits/sec и не бывает

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this