Jump to content
Калькуляторы

Посоветуйте литературу по OSPF

Добрый день.

У меня сеть в небольшом городе, порядка 3000 абонентов. Оборудование 3 уровня - Telesyn, D-Link, Linux router. Возникла проблема того, что в логах Telesyn'а появилось сообщение:

Apr 1 17:16:47 main OSPF:OSPF/00029, Too long Router LSA 192.168.x.y: router ID: 192.168.x.y, length: 1992, max allowed: 1980

В результате этого отваливается половина маршрутов.

В техподдержке посоветовали использовать summary и разные area.

Ситуация в сети такая - есть серая внутренняя адресация, во внешний мир люди выходят через РРРоЕ и получают белые адреса. Железо третьего уровня является еще и концентраторами РРРоЕ. Белые адреса в большинстве своем выдаются динамически, то есть каждый раз разные.

Типовая конфигурация Linux роутера:

 

/etc/quagga/ospfd.conf

 

hostname nnn

password pass

router ospf

 

area 0.0.0.1 stub no-summary

ospf rfc1583compatibility

 

router-id 192.168.a.b

 

network 192.168.10.0/24 area 0.0.0.1 #внутренняя системная подсеть

network d.f.g.h/j area 0.0.0.1 #подсеть, в которой выдаются белые адреса

network 10.u.i.o/24 area 0.0.0.1 #подсеть с серой адресацией

 

neighbor 192.168.c.v poll-interval 18

<...>

neighbor 192.168.c.z poll-interval 19

 

no redistribute static

 

interface eth0.111

 

log syslog

 

И примерно также на каждом роутере. Я понимаю, что сделано неправильно (area должны быть разные, у каждого роутера своя как я понял, что-то нужно сделать с summary), но как сделать правильно не понимаю. Конфиг этот является синтезом гугления и примеров чужих работающих сетей. Я читал документацию по протоколу OSPF - там разобраны потраха протокола, но не описано как этим добром пользоваться в реальных сетях. Я читал документацию по quagga - там описаны директивы конфигурационных файлов и механизмы управления службой через командную строку, но опять же без описания того, как этим всем воспользоваться в реальных условиях и сделать по уму инфрастурктуру ospf.

Собственно сам вопрос - посоветуйте литературу, где описано как всё это делать правильно, или если в этом ничего сложного нет и можно описать парой сообщений - буду весьма признателен.

Edited by DukeNukem3D

Share this post


Link to post
Share on other sites

http://book.pdfchm.net/ospf-network-design.../9781578700462/

полнее некуда

 

в router lsa (type 1) Описан сам нейбор, его свойства, количество директли коннектед сетей, и свойства этих сетей.

в вашем случае размер этого lsa превышает максимально поддерживаемый оборудование (что насчет этого стандарт говорит не помню, почитайте rfc).

lsa type 1 ходит по всей area, так что сумаризировать нужно на ее границе.

 

Share this post


Link to post
Share on other sites

В network добавляйте только сети интерфейсов, смотрящих в сторону других роутеров. Для остального - redistribute kernel/connected/static, лучше сразу в iBGP, но можно пока и в OSPF.

Share this post


Link to post
Share on other sites

А внутреннюю системную подсеть разве не нужно в area 0.0.0.0 помещать?

Просто если я клиентские сети помещаю на роутере в отдельную зону, например 0.0.0.4 - то информация о маршрутах до них передаваться перестает.

chocholl, благодарю, сел за чтение.

Тут у знакомых поспрошал - говорят что для моих условий лучше подойдет BGP - вы как более опытные что можете сказать по этому поводу?

Edited by DukeNukem3D

Share this post


Link to post
Share on other sites
А внутреннюю системную подсеть разве не нужно в area 0.0.0.0 помещать?

Просто если я клиентские сети помещаю на роутере в отдельную зону, например 0.0.0.4 - то информация о маршрутах до них передаваться перестает.

chocholl, благодарю, сел за чтение.

Тут у знакомых поспрошал - говорят что для моих условий лучше подойдет BGP - вы как более опытные что можете сказать по этому поводу?

ну bgp тоже не панацея.

я бы выдал каждому концентратору pppoe по пулу адресов для выдачи.

на концентраторах pppoe:

либо вытащить эту сеть в отдельную зону и делать сумаризацию между зонами,

либо делать редистрибьюцию с последующей сумаризацией на этом же концентраторе pppoe. чтоб от каждого концентратора pppoe шел только один маршрут на большой блок.

 

если выдача своих блоков концентраторам pppoe по каким-то причинам не возможна, я бы делал редистрибьюцию на них, так как lsa 5 во многом схожа с distanve vector и требует гораздо меньше ресурсов при пересчете.

 

Share this post


Link to post
Share on other sites

Ага, значит синтезировав полученную информацию, сделал пока что на виртуалках следующее дело на рисунке.virtnet.png

 

На роутерах сделал следующую конфигурацию:

router-1:~# cat /etc/quagga/ospfd.conf
router ospf

passive-interface eth3+

network 192.168.99.0/24 area 0.0.0.0

network 10.3.2.0/24 area 0.0.0.1
area 0.0.0.1 range 10.3.2.0/24

network 10.10.80.0/24 area 0.0.0.3
area 0.0.0.3 range 10.10.80.0/24

 

router-1:~# cat /etc/quagga/zebra.conf
hostname router-1
password 4me
interface eth1.111
        ip address 192.168.99.1/24

 

router-2:~# cat /etc/quagga/ospfd.conf
router ospf

passive-interface eth10+

network 192.168.99.0/24 area 0.0.0.0

network 10.90.10.0/24 area 0.0.0.4
area 0.0.0.4 range 10.90.10.0/24

 

router-1:~# cat /etc/quagga/zebra.conf
hostname router-2
password 4me
interface eth1.111
        ip address 192.168.99.2/24

 

Вот на данном этапе скажите с точки зрения евангелия это правильно, всё ли я понял правильно?

По крайней мере роутеры маршрутами между собой обменялись, и клиенты друг на друга зайти могут.

 

chocholl,

либо вытащить эту сеть в отдельную зону и делать сумаризацию между зонами

В моем случае подсеть например 10.90.10.0/24 - area 0.0.0.4 - если я в эту area добавлю еще одну подсеть, то я правильно понял, что будет происходить эта самая так называемая суммаризация?

Выделить РРРоЕ адреса в отдельные блоки и раскидать их по роутерам к сожалению возможности нет, буду выделять в отдельную зону значит и прописывать её на каждом роутере, так, вроде этого:?

network 212.123.123.0/24 area 0.0.0.9
area 0.0.0.9 range 212.123.123.0/24

и таким образом получу желаемого эффекта?

И area которые у меня для клиентских сетей надо объявлять как stub (no-summary)?

Edited by DukeNukem3D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this