Jump to content
Калькуляторы

Странности связки VoIP, Cisco, АТС Непонятная тишина.

есть связка: Облако VoIP -> 2621ХМ -> POTS. Если инициатором звонка выступает POTS - то все ОК. Если инициатором звонка выступает 2621 - то звонок проходит, телефоны звенят, но в трубке - тишина.

 

АТС - Юнител TS004, порт Е1.

 

Кошка - 2621ХМ с модулем AIM-VOICE-30 и карточкой VWIC-2MFT-E1= c2600-adventerprisek9_ivs-mz.124-15.T8.bin

 

По конфигу: пр наборе из города 5455383 звонок уходит куда надо и все слышно.

При наборе из VoIP 202 - звонок приходит на нужный телефон, но в трубке - тишина. В воип плече - то-же тихо, но что-то таинственно потрескивает.

 

 

 

voipgw.eqv.ru#sh run

Building configuration...

 

Current configuration : 3101 bytes

!

! Last configuration change at 16:47:30 Msk Fri Mar 26 2010

! NVRAM config last updated at 16:47:31 Msk Fri Mar 26 2010

!

version 12.4

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime localtime

service timestamps log datetime localtime

service password-encryption

no service dhcp

!

hostname voipgw.eqv.ru

!

boot-start-marker

boot-end-marker

!

enable password 7 121E17181504000B2D

!

aaa new-model

!

!

!

!

aaa session-id common

clock timezone Msk 3

clock summer-time MSD recurring last Sun Mar 2:00 last Sun Oct 2:00

no network-clock-participate wic 0

voice-card 0

codec complexity high

no dspfarm

no local-bypass

!

ip cef

!

!

!

!

ip domain name eqv.ru

ip name-server 10.173.0.1

!

multilink bundle-name authenticated

isdn switch-type primary-net5

!

!

voice rtp send-recv

!

voice service pots

supported-language ru

!

voice service voip

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711alaw

sip

rel1xx disable

!

!

voice class codec 729

codec preference 1 g711ulaw

!

!

!

voice class h323 1

call start fast

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

username sol password 7 094B5C061E0A1B1D0C

archive

log config

hidekeys

!

!

!

!

controller E1 0/0

clock source line primary

pri-group timeslots 1-16

!

controller E1 0/1

shutdown

!

gw-accounting aaa

!

!

!

!

!

interface FastEthernet0/0

ip address 10.173.121.10 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-5ess

isdn incoming-voice voice

isdn send-alerting

isdn sending-complete

 

no cdp enable

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 10.173.121.254

!

!

no ip http server

no ip http secure-server

!

!

!

!

!

!

control-plane

!

!

!

voice-port 0/0:15

echo-cancel coverage 32

cptone RU

bearer-cap Speech

!

!

!

!

dial-peer cor custom

!

!

!

dial-peer voice 5455383 voip

description VoIP DISA AND Other Servises

huntstop

destination-pattern 5455383

voice-class codec 729

session protocol sipv2

session target sip-server

session transport udp

dtmf-relay h245-alphanumeric

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711alaw

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711alaw

ip qos dscp cs5 media

ip qos dscp cs3 signaling

ip udp checksum

no vad

!

dial-peer voice 2 pots

permission orig

huntstop

destination-pattern 545....

direct-inward-dial

!

dial-peer voice 200 pots

huntstop

max-conn 30

destination-pattern 2..

direct-inward-dial

port 0/0:15

forward-digits all

!

dial-peer voice 5450000 voip

voice-class codec 729

incoming called-number 2..

no vad

!

!

sip-ua

credentials username voipgw password 11584D564E445B realm ipv4:10.173.0.1

authentication username voipgw password 7 15435F5F5D7C7B realm ipv4:10.173.0.1

retry invite 3

retry response 3

retry bye 3

retry cancel 3

timers trying 1000

registrar ipv4:10.173.0.1 expires 60

sip-server ipv4:10.173.0.1

 

line con 0

line aux 0

line vty 0 4

!

ntp clock-period 17208396

ntp server 10.173.0.1

!

end

 

 

 

Что делать - то?

Edited by sol

Share this post


Link to post
Share on other sites

А зачем мне ехать в Никольское? 8/

 

А что из того, что умеет циска есть российский ISDN ? Дя и судя по трейсам, звонок в ПОТС чудесно проходит и Б канал занимается. Да и пробовал играть типом свитча.

 

 

 

Share this post


Link to post
Share on other sites

Не вопрос, телефон в ПМ.

 

Share this post


Link to post
Share on other sites
Поить меня пятничным пивом:)

У вас есть ряд замечаний по конфигу, а пятничным вечером так тяжжело печатать:)

А вы из Юнитела? :) А то у меня есть много вопросов по недавно купленной TS-004, на которые по почте мне не отвечают.

Share this post


Link to post
Share on other sites

По юнителу, наверное, я смогу проконсультировать.

В чем вопрос?

Share this post


Link to post
Share on other sites

Вопросы по TS-004 остались в почте на работе. То, что вспомнилось:

 

1. Есть ли в нем батарейка? После отключения питания станция теряет дату/время и после включения начинает писать cdr-ы с неверной датой/временем.

 

2. Можно ли как-либо сохранить конфиг в текстовом читабельном виде, как это можно сделать на МР-ке от mt200.ru?

 

3. Можно ли в Cdr-ы писать категорию абонента? Поясню: имеем присоединение к МРК и весь междугородный трафик направляем через их сеть на сети разных операторов МгМН-связи, подставляя нужную категорию абонента на TS-004. Причем, например с Ростелекомом имеем агентский договор, биллингуем для них трафик, идущий от наших абонентов на их сеть, собираем денежку и т.д. С ТТК агентского договора нет, расчеты ТТК ведет напрямую с абонентами. Возникает вопрос - как отличить трафик, ушедший на РТ от трафика на ТТК? Вариантов 2: либо по номеру А, либо по категории абонента. Была бы в Cdr-е категория - было бы значительно проще.

 

4. На стороне МРК стоит МТ-20. TS-004 не ловит АОН, отправляемый нам с МТ-20. SNTLite-ом сняли временные и частотные характеристики, отправили в Юнител, те обещали новую прошивку, но пока так и нет ничего - живем без АОНов :(. Причем что странно:

- если звонок пришел к нам с другой АТС транзитом через МТ-20, то все ОК, если от абонента МТ-20 - АОНа нет.

- если запустить терминальный режим программы управления TS-004, то там АОНы видны, но в cdr они не попадают.

 

5. Есть глюки в программе управления, но мы к ним уже привыкли. Описывать их долго.

 

6. Было что-то еще... Сходу не вспомнил.

 

PS. А есть какие-нибудь форумы по юнителовскому оборудованию? Оборудование довольно-таки распространено, но таких ресурсов не нашел.

 

nterface Serial0/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-5ess

isdn incoming-voice voice

isdn send-alerting

isdn sending-complete

У меня на кошке 3725 (правда там не voip, а dialup) на Е1, смотрящем на TS-004, конфиг вот такой:

 

interface Serial1/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice modem 64
isdn calling-number 52277
no cdp enable

Share this post


Link to post
Share on other sites

1. Батарейки нет. Но есть опция в терминале настройки "брать время с компа". Время берется с подключенного к RS-232 компьютера.

2. Он и так текстовый. Во всяком случае, тот конфиг, который сохраняется в web управлялке. Но вот вид его... Примерно такой:Y21<1.2.2.3.4>=21,"Блок АЦК-256 ",0

Y21<1.3.2.1.1.2.3>="","",0

Y21<1.3.2.2.1.2.3>="","",0

Y21<1.3.2.3.1.2.3>="","",0

Y21<1.3.2.4.1.2.3>="","",0

Y21<1.3.2.5.1.2.3>="","",2

Y21<1.3.2.6.1.2.3>="","",2

Y21<1.3.2.7.1.2.3>="","",2

Y21<1.3.2.8.1.2.3>="","",2

Y21<1.3.2.9.1.2.3>="","",2

Y21<1.3.2.10.1.2.3>="","",2

 

Y21 - идентификатор данных конфига, то, что в <> - адрес параметра, = значение параметра.

 

3. Вид CDR настраивается. параметр %ta0 - это только цифры АОН а %tak - АОН + категория, а %tk - только категория

 

4. Как и все в нашем отечестве. На пинковой тяге. Пинайте.

 

5. Имеются и масса

 

Форумов, насколько мне известно, нету...

Share this post


Link to post
Share on other sites
2. Он и так текстовый.
Не нашел куда он сохраняется.

 

3. Вид CDR настраивается. параметр %ta0 - это только цифры АОН а %tak - АОН + категория, а %tk - только категория
То, что настраивается - понятно.

"%ta0 - это только цифры АОН " - это в документации есть

"%tak - АОН + категория, а %tk - только категория" - этого в документации нет.

 

Может быть потому, что у нас 1U-модификация TS-004 (8 Е1), которую в Юнител называют МК-8/16 ?

Share this post


Link to post
Share on other sites

2 - Сохраняется в ту папку, куда укажешь. правой гайкой по изображению CPU в дереве модулей, "Прочитать Всю Конфигурацию"

 

3 - У меня - TS004 в варианте 6U

 

Share this post


Link to post
Share on other sites
2 - Сохраняется в ту папку, куда укажешь. правой гайкой по изображению CPU в дереве модулей, "Прочитать Всю Конфигурацию"
Не нашел "изображение CPU в дереве модулей".

Если в дереве модулей на модуле 8PCM по правой кнопке мыши выбрать "Прочитать всю конфигурацию в файл", но файл получается 0й длины и пустой. :(

Share this post


Link to post
Share on other sites
У меня - TS004 в варианте 6U
Только что заменили на 1U TS-004 юнителовский же АЦК ЮНИТ варианте 6U (все лежит без дела в рабочем состоянии):

- шасси 6U

- плата питания 48 вольт

- плата управления

- 3 платы потоков, по 2 Е1 на каждой (2ВСК, EDSS1)

- комплект кабелей.

 

Share this post


Link to post
Share on other sites

Это какой-то странный TS-004. У меня плата процессора с 4 Е1 НА БОРТУ.

 

http://ts004.ru/produkt/v_i_k.html

 

Читать после слов "АБОНЕНТСКИЙ МОДУЛЬ"

ts_pic.JPG

Edited by sol

Share this post


Link to post
Share on other sites

Проверил на счет записи категории абонента в Cdr (добавил в шаблон cdr-строки %a%tk): в cdr всегда пишется 1 (РТ) для всех абонентов, хотя для части абонентов должна быть 6 (ТТК). :( Категорию 6 мы подставляем на ts-004, т.к. все остальные устройства (АТС, циска, потоковые voip-шлюзы) подключены к ts-004 по edss1 - там категория абонента не передается. С ТТК мы созванивались, они наш трафик видят, т.е. категорию мы подставляем правильно. Но в cdr она не попадает :(.

 

У меня вот такой - http://ts004.ru/produkt/uzli.html

Мультисервисный Коммутатор 8

8 потоков E1 (8 PCM - 1)

Как прицепить сюда скриншот - не понял.

Share this post


Link to post
Share on other sites

Строчите вопрос в Юнител...

Share this post


Link to post
Share on other sites

Проверил на счет записи категории абонента в Cdr (добавил в шаблон cdr-строки %a%tk): в cdr всегда пишется 1 (РТ) для всех абонентов, хотя для части абонентов должна быть 6 (ТТК). :( Категорию 6 мы подставляем на ts-004, т.к. все остальные устройства (АТС, циска, потоковые voip-шлюзы) подключены к ts-004 по edss1 - там категория абонента не передается. С ТТК мы созванивались, они наш трафик видят, т.е. категорию мы подставляем правильно. Но в cdr она не попадает :(.

Разобрались: в свойствах системы надо было поставить "В биллинг вставляются исходящий номер А".

Share this post


Link to post
Share on other sites

А по исходному вопросу есть соображения?

Share this post


Link to post
Share on other sites

Замена

isdn switch-type primary-5ess

на

isdn switch-type primary-net5

не помогает?

Share this post


Link to post
Share on other sites

Не помогает...

Share this post


Link to post
Share on other sites

Тишина с потрескиванием? В таких случаях проверяю совместимость по кодекам, наличие НАТ и его настройку.

Share this post


Link to post
Share on other sites

Тишина с потрескиванием, да.

НАТа нету, все в одной подсети.

Кодеки совместимы, испробовал все виды, RTP поднимается и идет.

 

Более того, если инициатором вызова выступает АТС - то все отлично слышно.

А вот если Циска - то описаная ситуация.

 

 

Share this post


Link to post
Share on other sites

А за циской кто инициатор? Может там софтфон за НАТом?

Share this post


Link to post
Share on other sites

НАТа нету, все в одной подсети.

Кодеки совместимы, испробовал все виды, RTP поднимается и идет.

 

Проблема вылечилась уменьшением кол-ва таймслотов в потоке Е1.

 

Было

 

controller E1 0/0

clock source line primary

pri-group timeslots 1-16

 

Стало

 

controller E1 0/0

clock source line primary

pri-group timeslots 1-4

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this