Jump to content
Калькуляторы

FreeBSD 8 if_bridge не пропускает vlanы

if_bridge на 8рке не могу заставить пропускать тегированные vlanы. Просто в акцессе работает.

 

uname -a
FreeBSD acl_bridge.nts.su 8.0-RELEASE FreeBSD 8.0-RELEASE #0: Fri Mar  5 13:13:55 NOVT 2010 
    root@acl_bridge.nts.su:/usr/src/sys/amd64/compile/GENERIC  amd64

 

ifconfig

bge0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=19b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4>
        ether 00:0b:cd:69:80:31
        media: Ethernet autoselect (100baseTX <full-duplex>)
        status: active

bge1: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=19b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4>
        ether 00:0b:cd:69:80:30
        media: Ethernet autoselect (100baseTX <full-duplex>)
        status: active

bridge0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        ether 36:e1:be:b5:c3:47
        id 00:00:00:00:00:00 priority 32768 hellotime 2 fwddelay 15
        maxage 20 holdcnt 6 proto rstp maxaddr 100 timeout 1200
        root id 00:00:00:00:00:00 priority 32768 ifcost 0 port 0
        member: bge1 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
                ifmaxaddr 0 port 2 priority 128 path cost 2000000
        member: bge0 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
                ifmaxaddr 0 port 1 priority 128 path cost 2000000

 

ipfw show
00100    0      0 allow ip from any to any via lo0
00200    0      0 deny ip from any to 127.0.0.0/8
00300    0      0 deny ip from 127.0.0.0/8 to any
65000 1612 231554 allow ip from any to any

 

 

 

На 7.2 if_bridge работает без проблем, пропуская все виланы в транке полностью.

 

В чем может быть загвоздка в 8рке ?

Share this post


Link to post
Share on other sites

Так нужные вланы, видимо, описать надо?

Share this post


Link to post
Share on other sites

fenix-vt Для чего? L2 должен полностью бриджеваться, без разницы какие там метки или теги. В том то похоже и дело, видимо 8рка смотрит на заголовки кадров на присутствие в них тегов или QoS меток

 

Share this post


Link to post
Share on other sites

а может затык в том, что на интерфейсах mtu 1500, а для dot1q надо вроде 1518?

Share this post


Link to post
Share on other sites

Дело было в опции VLAN_HWTAGGING После её снятия, vlanы засквозились как надо :)

Edited by white_skY

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this