Jump to content
Калькуляторы

Приоритизация голоса на cisco

Будьте так добры помогите мне настроить приоретизацию голосового трафика SIP на cisco 1751 fxs, 6 портов fsx и один ethernet с саб-интерфейсами, на саб-интерфейсе 0.2 интернет канал не очень широкий:

 

!

interface FastEthernet0/0.2

encapsulation dot1Q 2

ip address XXX.XXX.XXX.XXX 255.255.255.240

ip nat outside

!

interface FastEthernet0/0.3501

encapsulation dot1Q 3501

ip address 192.168.8.254 255.255.255.0

ip nat inside

!

Edited by iMax

Share this post


Link to post
Share on other sites

policy-map хороши, когда voip-устройства стоят в локалке.

Например, если на 192.168.8.250-192.168.8.253 стоят voip-устройства, то создать полисимапы:

 

access-list 150 remark voip-traffic

access-list 150 permit ip host 192.168.8.250 any

access-list 150 permit ip host 192.168.8.251 any

access-list 150 permit ip host 192.168.8.252 any

access-list 150 permit ip host 192.168.8.253 any

access-list 150 deny ip any any

 

class-map match-all voip-traffic

match access-group 150

 

policy-map voip

class voip-traffic

bandwidth percent 50

class class-default

fair-queue

random-detect

 

и потом навесить все это на интерфейс:

 

interface FastEthernet0/0.2

service-policy output voip

 

А вот что делать, когда fxs-порты на борут устройства...

Share this post


Link to post
Share on other sites
А вот что делать, когда fxs-порты на борут устройства...

вот у меня именно такая ситуация.

Share this post


Link to post
Share on other sites
А вот что делать, когда fxs-порты на борут устройства...

вот у меня именно такая ситуация.

class-map match-any Voice-Signaling
  match ip dscp af31 
  match ip dscp cs3 
class-map match-any Voice-RTP
match ip dscp ef 
!
!
policy-map Voice-QoS
  description VoIP QoS
  class Voice-RTP
    priority percent 50
  class Voice-Signaling
    bandwidth percent 10
  class class-default
    fair-queue

interface FastEthernet0/0.2
  service-policy output Voice-QoS

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this