Jump to content
Калькуляторы

Cisco SCE Series Service Control Engine

А кто какой FTP сервер использует? Поставил proftpd на Debian, все клиенты заходят, файл забирают, а SCE ругается:

SCE1000(config if)#> sce-url-database import cleartext-file ftp://xxx:yyy@192.168.0.80/acl_black_reestr_url.cfg
Error - Exception during file reading operation:com.pcube.management.framework.functionality.NativeMethodStatusFailException: Error Code = 1,
Description: "unable to access file or directory ftp://xxx:yyy@192.168.0.80/acl_black_reestr_url.cfg", Detailed: "" (FFS_OpenFile:{flags=0,
fileName=ftp://xxx:yyy@192.168.0.80/acl_black_reestr_url.cfg, mode=644})

Пробовал и с паролем и без, фаерволла нет. И в логах ничего интересного нет.

 

А вот с виндового OpenServer прекрасно забирает.

Edited by Voronok

Share this post


Link to post
Share on other sites

С vsftpd ситуация не изменилась.

Edited by Voronok

Share this post


Link to post
Share on other sites

А так копирует

 

SCE1000#>copy-passive ftp://ftp:dfkthbz@10.1.2.80/acl_black_reestr_url.cfg 1.txt
SCE1000#>dir
File list for /tffs0/
    512    FRI MAY 05 09:22:00 2006       DIAG                   DIR
    512    FRI MAY 05 09:22:44 2006       SYSTEM                 DIR
    512    FRI MAY 05 09:30:06 2006       APP                    DIR
    512    FRI MAY 05 09:30:08 2006       IMAGES                 DIR
1056782    FRI NOV 10 05:27:18 2006       ENG21805.PQI
    249    FRI NOV 10 05:35:22 2006       WINNY2.CLI
    512    TUE DEC 12 04:38:40 2006       ENGAGE                 DIR
      0    TUE JAN 23 08:16:32 2007       ADSL_NOW.CSV
   2841    TUE JAN 23 08:16:32 2007       ADSL.CSV
2672867    TUE APR 21 16:00:26 2009       ENG31679.PQI
18251836    THU DEC 12 08:17:44 2013       RELEASE_.SLI
 126094    TUE MAY 20 16:28:34 2014       1.TXT
               12 File(s)              22113229 bytes
                       382353408  total bytes used
                       12017664   total bytes free

Share this post


Link to post
Share on other sites

Разобрался, так работает:

 

SCE1000(config if)#> sce-url-database import cleartext-file ftp://xxx:yyy@192.168.0.80//url.cfg

 

То есть, ДВА слэша и имя файла в формате 8.3

Share this post


Link to post
Share on other sites

То есть, ДВА слэша и имя файла в формате 8.3

Слэшей действительно должно быть два. А вот на счет 8.3 сомневаюсь, возможно это ограничение тфтп-сервера.

Share this post


Link to post
Share on other sites

Слэшей действительно должно быть два. А вот на счет 8.3 сомневаюсь, возможно это ограничение тфтп-сервера.

Точно, сейчас проверил ещё раз - забирает с любым именем.

 

Речь, про этот слэшь ? Я использую один. Проблем с импортом нет.

Да, про этот, перед именем файла. Сейчас ещё раз проверил - с двумя слэшами забрало, с одним выдало ошибку. А если забирать с виндового сервера, то забирает с одним слэшем.

Share this post


Link to post
Share on other sites

cisco SCE 2020 стало выводить такое:

#sh system operation-status

System Operation status is Warning

Description:

1. Not enough disk space

Port status is:

Link on management port #1 is down

Link on port #3 is down

Link on port #4 is down

 

 

Подскажите, что можно удалить, чтобы освободить память

 

#dir -r

File list for /tffs0/

512 WED AUG 23 01:18:30 2006 DIAG DIR

512 WED AUG 23 01:20:24 2006 SYSTEM DIR

512 WED AUG 23 01:29:34 2006 APP DIR

512 WED AUG 23 01:29:34 2006 IMAGES DIR

18035244 TUE MAY 20 09:47:16 2014 RELEASE_.SLI

512 THU JAN 11 10:28:02 2007 ENGAGE DIR

6 File(s) 18037804 bytes

File list for /tffs0/DIAG

512 WED AUG 23 01:18:30 2006 . DIR

512 WED AUG 23 01:18:30 2006 .. DIR

2 File(s) 1024 bytes

File list for /tffs0/SYSTEM

512 WED AUG 23 01:20:24 2006 . DIR

512 WED AUG 23 01:20:24 2006 .. DIR

25808 MON MAY 19 17:57:52 2014 BOOTLOG.TX4

512 WED AUG 23 01:28:06 2006 BACKUP DIR

25810 TUE MAR 25 18:15:34 2014 BOOTLOG.TX9

17101 TUE MAY 20 10:32:32 2014 PREVDBG.HST

25808 TUE MAY 20 13:31:48 2014 BOOTLOG.TXT

0 THU SEP 03 04:04:34 2009 USRCONST.TXT

512 THU MAR 05 05:28:02 2009 PQIINST DIR

0 MON NOV 25 21:55:56 2013 BSPFAIL.TXT

512 WED NOV 22 00:01:04 2006 PREVCONF DIR

25813 SAT APR 26 14:52:12 2014 BOOTLOG.TX8

25856 TUE MAY 20 10:38:02 2014 BOOTLOG.TX1

25810 MON MAY 19 14:33:04 2014 BOOTLOG.TX7

25856 MON MAY 19 15:16:08 2014 BOOTLOG.TX6

25810 MON MAY 19 17:24:32 2014 BOOTLOG.TX5

25807 TUE MAY 20 10:06:42 2014 BOOTLOG.TX2

25854 TUE MAY 20 00:06:42 2014 BOOTLOG.TX3

3096 TUE MAY 20 13:56:54 2014 CONFIG.TXT

10645024 TUE MAY 20 10:32:32 2014 PREVDBG.TXT

20 File(s) 10926013 bytes

File list for /tffs0/SYSTEM/BACKUP

512 WED AUG 23 01:28:06 2006 . DIR

512 WED AUG 23 01:28:06 2006 .. DIR

2952 FRI FEB 28 21:26:32 2014 DBG_LOG.DF2

5449044 MON MAY 19 15:12:48 2014 DBG_LOG.DF1

4 File(s) 5453020 bytes

File list for /tffs0/SYSTEM/PQIINST

512 THU MAR 05 05:28:02 2009 . DIR

512 THU MAR 05 05:28:02 2009 .. DIR

2 File(s) 1024 bytes

File list for /tffs0/SYSTEM/PREVCONF

512 WED NOV 22 00:01:04 2006 . DIR

512 WED NOV 22 00:01:04 2006 .. DIR

3096 TUE MAY 20 13:56:56 2014 CONFIG.TX1

3071 TUE MAY 20 10:39:36 2014 CONFIG.TX9

3071 TUE MAY 20 11:05:00 2014 CONFIG.TX8

3071 TUE MAY 20 11:09:18 2014 CONFIG.TX7

3071 TUE MAY 20 11:25:38 2014 CONFIG.TX6

3071 TUE MAY 20 11:55:58 2014 CONFIG.TX5

3071 TUE MAY 20 12:46:36 2014 CONFIG.TX4

3071 TUE MAY 20 13:25:36 2014 CONFIG.TX3

3096 TUE MAY 20 13:34:02 2014 CONFIG.TX2

11 File(s) 28713 bytes

File list for /tffs0/APP

512 WED AUG 23 01:29:34 2006 . DIR

512 WED AUG 23 01:29:34 2006 .. DIR

17853533 TUE MAY 20 09:41:34 2014 EN41090.SLI

3 File(s) 17854557 bytes

File list for /tffs0/IMAGES

512 WED AUG 23 01:29:34 2006 . DIR

512 WED AUG 23 01:29:34 2006 .. DIR

111915256 TUE MAY 20 11:23:38 2014 SEOS.PKG

3 File(s) 111916280 bytes

File list for /tffs0/ENGAGE

512 THU JAN 11 10:28:02 2007 . DIR

512 THU JAN 11 10:28:02 2007 .. DIR

60077 TUE MAY 20 13:55:38 2014 MYENGAGE.PQB

655856 TUE MAY 20 13:55:40 2014 BATCH.SER

3673 TUE MAY 20 13:56:50 2014 TEMP.DSS

60073 TUE MAY 20 13:24:16 2014 MYENGAG2.PQB

60061 TUE MAY 20 13:32:44 2014 MYENGAG1.PQB

60061 TUE MAY 20 12:45:18 2014 MYENGAG3.PQB

8 File(s) 900825 bytes

349126656 total bytes used

45244416 total bytes free

Share this post


Link to post
Share on other sites

cisco SCE 2020 стало выводить такое:

#sh system operation-status

System Operation status is Warning

Description:

1. Not enough disk space

Port status is:

Link on management port #1 is down

Link on port #3 is down

Link on port #4 is down

 

Подскажите, что можно удалить, чтобы освободить память

 

Я логи чищу обычно

Share this post


Link to post
Share on other sites

Каждый день чистить логи ??? Есть же явно нормальный выход. Ведь как то оно должно штатно работать...

Share this post


Link to post
Share on other sites

Есть задачка. Может кто делал.

Есть список сайтов, в размере 10 штук. Нужно сделать сводную таблицу кто когда переходил на эти ресурсы.

Я создал flavor-ы, сделал классификацию в HTTP по аналогии с предустановленными. И.. встал. Что делать дальше не понятно, где брать отчет не понятно.

Т.е. классифицировать я могу, а вот вытащить данные уже теряюсь в догадках.

Share this post


Link to post
Share on other sites

Каждый день чистить логи ??? Есть же явно нормальный выход. Ведь как то оно должно штатно работать...

  1. Выводим статистику по логам;
  2. Чистим логи;
  3. Подрезаем размеры файлов журналов в N-раз, анализируя результаты с п. 1;

У нас так:

#show running-config | inc logg
logger device Debug-File-Log max-file-size 1000000
logger device User-File-Log max-file-size 100000
logger device Line-Attack-File-Log max-file-size 500000
logger device Statistics-File-Log max-file-size 2000000
logger device Statistics-Archive-File-Log max-file-size 1000000
logger device SCE-agent-Statistics-Log max-file-size 204800

Share this post


Link to post
Share on other sites

Есть задачка. Может кто делал.

Есть список сайтов, в размере 10 штук. Нужно сделать сводную таблицу кто когда переходил на эти ресурсы.

Я создал flavor-ы, сделал классификацию в HTTP по аналогии с предустановленными. И.. встал. Что делать дальше не понятно, где брать отчет не понятно.

Т.е. классифицировать я могу, а вот вытащить данные уже теряюсь в догадках.

SELECT SUBSCRIBER_ID
FROM RPT_TR
WHERE FLAVOR_ID = :MY_FLAVOR

Вы об этом?

Share this post


Link to post
Share on other sites

SELECT SUBSCRIBER_ID
FROM RPT_TR
WHERE FLAVOR_ID = :MY_FLAVOR

Вы об этом?

 

Походу да. Я так понимаю нужно лезть в сибейз. Попробуем-с. Спасибо.

Share this post


Link to post
Share on other sites

Походу да. Я так понимаю нужно лезть в сибейз. Попробуем-с. Спасибо.

Это зависит от того, куда CM складирует статистику. У нас в MySQL.

Share this post


Link to post
Share on other sites

ThreeDHead, Спасибо! Выставил пока ваши значения, а там уже буду корректировать.

Share this post


Link to post
Share on other sites

Уважаемые коллеги, прошу вашего совета. Хочу перенести шейпер на SCE8000. Сейчас режете все на Freebsd NG_CAR. Но в SCE вроде как шейпера нет, только полисинг. Трафика около 6-7 гбит. Тарифы от 20 мбит. Имеет ли смысл переносить?

Share this post


Link to post
Share on other sites

А что смущает?

Еще не имели дело с этой железкой, только приехала, поэтому и вопросы) Сначала настроим фильтр HTTP и шейпер+ редирект на стр. с отриц. балансом. Пока все это реализовано на писюках.

Share this post


Link to post
Share on other sites

roysbike, смело переносите, даже не думайте. Единственное, одновременно и на писюках и на сце, резать не надо, глючно будет.

Share this post


Link to post
Share on other sites

Прошу помощи , коллеги. Поставили SCE8000. Трафик проходит только на L2. Модули не родные. В чем может быть проблема?Если arp гуляет , значит модули рабочие и определились.?

Cчетчики тикают

SCE8000#show running-config 
#This is a general configuration file (running-config).
#Created on 12:13:39  MSK  MON  June  9  2014

#cli-type 1
#version 1

banner login 
Warning!!!, this system is for authorized users only... 
service password-encryption
ip name-server 172.29.0.4
clock timezone MSK 4
sntp server 172.29.0.3
no management-agent notifications notification-list 1417,1418,804,815,1404,1405,1406,1407,1408,400
no management-agent notifications notification-list 402,421,440,441,444,445,446,450,437,457
no management-agent notifications notification-list 3593,3594,3595,10040,4677,4678,4674,4673,4676,4614
no management-agent notifications notification-list 4615
snmp-server community "public" ro 
snmp-server view full-view OID 1 operation include 
snmp-server view none-view OID 1 operation exclude 

interface LineCard 0

connection-mode inline on-failure external-bypass
no silent
shutdown
service-bandwidth-prioritization-mode global
no protocol-pack version


attack-filter subscriber-notification ports 80
replace spare-memory code bytes 3145728

interface GigabitEthernet 1/1
ip address 172.29.0.42 255.255.255.0 

interface GigabitEthernet 1/2
ip address 172.29.0.42 255.255.255.0 

interface TenGigabitEthernet 3/0/0
bandwidth 10000000 burst-size 50000
global-controller 0 name "Default Global Controller"

interface TenGigabitEthernet 3/1/0
bandwidth 10000000 burst-size 50000
global-controller 0 name "Default Global Controller"

exit
ip default-gateway 172.29.0.11

line vty 0 4
exit
interface Mng 0/1
exit
interface Mng 0/2
exit
cdp mode bypass
interface LineCard 0
subscriber anonymous-group name "Anonymous Group" IP-range 0.0.0.0:0x00000000
exit
logging on 

username cisco password *******
username roys secret 5 54a64b2e4c5969a0449a82b1ef1ecf70
username pcube password ****
aaa authentication login default local 
aaa authentication enable default local 
no subscriber LEG dhcp-lease-query
subscriber LEG dhcp-lease-query servers 127.0.0.1
logger device SCE-agent-Statistics-Log max-file-size 204800
management-agent property "com.pcube.management.framework.install.activation.operation" "Install"
management-agent property "com.pcube.management.framework.install.activated.package" "SCA BB"
management-agent property "com.pcube.management.framework.install.activated.version" "4.1.0 build 90"
management-agent property "com.pcube.management.framework.install.activation.date" "Fri Jun 06 23:22:40 GMT+04:00 2014"
flow-filter partition name "ignore_filter" first-rule 4 num-rules 32

 

 

 

NAME: "SCE8000 optic 3/0/0", DESCR: """"
PID: ""                , VID: "" , SN: CSXSRD90260     


NAME: "SCE8000 optic 3/1/0", DESCR: "This module isn't connected"
PID: ""                , VID: "" , SN: ""         


 

 

SCE8000#show interface TenGigabitEthernet 3/1/0 counters
L2 In total octets: 226748
In good unicast packets: 3534
In good multicast packets: 3
In good broadcast packets: 2287
In packets discarded: 0
In packets with CRC/Alignment error: 0
In undersized packets: 0
In oversized packets: 0
Rx pause packets: 0
L2 Out total octets: 78009
Out unicast packets: 1265
Out good multicast packets: 0
Out good broadcast packets: 0
Out packets discarded: 0
Tx pause packets: 0
Tx regular collision events: 0
L2 Bandwidth Kbps (Rx + Tx): 0
# of packets received of length (in octets):
64: 3516, 65-127: 18, 128-255: 0,
256-511: 0, 512-1023: 0, 1024-1518: 0,
1519+: 0

Edited by roysbike

Share this post


Link to post
Share on other sites

Добрый день коллеги.

Пока еще не обновил софт до 4.1.0 т.к. пока нет возможности (я не линуксоид :( )

и вот недавно выкрутил параметры http get detections и некоторые настройки квот

стали появляться service loss

и вот сегодня застал под вечер в час пик такую картину, что service loss просто охерительных размеров (там цифра была в 800+)

(п.с. я думал там в процентах, а видимо в чем-то другом раз больше 100)

и железка стала вести себя неадекватно

канал уперся в полку (судя по всему шейпинг п2п перестал отрабатывать)

на репортере вижу резкий спад графика процентов на 80-90, то-есть через процессинг проходит очень мало трафика видимо

 

и по факту, деградация сервиса естественно т.к. канал в полку + переодически тупо интернет страницы не открываются, хотя пинг идет в интернет и аська даже не отваливается с агентом

 

в этот момент додумался сделать tech support file, но как вы можете догадаться, контракта с циской у меня нет и мне это вообще не светит на текущей работе впринципе)

 

может кто-то помоч проанализировать его и понять в чем проблема?

в момент этих сервис лоссов, на глазах рос счетчик warning'ов

 

где их смотреть, пока понятия не имею

счетчик errors (тамже где и варнинги) тоже довольно большой, но в тот момент не выростал

и тоже хз где смотреть в чем суть ошибок

Share this post


Link to post
Share on other sites

to mcdemon, резкий спад на графиках - bypass, не вывозит железка после

и вот недавно выкрутил параметры http get detections и некоторые настройки квот
. Рисовать графики загрузки CPU и интерфейсов, будет понятно в какой момент начинается и при каких pps.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this