Jump to content
Калькуляторы

Acorp WR-G(2.0) + WIVE-NG 0.3.17 = Router Помощь в настройке

Имеем сей девайс, ноут, ПК, и сеть провайдера со статическим ip 192.168.21.92(255.255.255.0) и шлюзом 192.168.21.8, DNS-нет, подключение к инету по VPN(PPTP) сервер 192.168.21.9, логин и пароль.

При начальной установке, с родной прошивкой и с помощью веб интерфейса получилось работа в режиме роутера, но была проблема, не работало встроенное подключение PPTP, VPN соединение с ПК проходило, а вот сам роутер дозваниваться не хотел :( пришлось юзать прокси, но на долго меня не хватило, и начал копать...

Прошил через tftp WIVE-NG 0.3.17

Подключился через Putty

Изменил:

IPV4_FORWARD_ENABLE=yes

BRIDGE_START=no

BR0_IPADDR=192.168.0.50/24 #ipv4=192.168.0.50 MASK=255.255.255.0

 

ETH0_ENABLED=yes

ETH0_IPADDR=192.168.0.50/24

ETH0_MACADDR=наклейка на корпусе

ETH1_ENABLED=yes

ETH1_IPADDR=192.168.21.92/24

ETH1_MACADDR=Мак адр. ПК

WLAN_ENABLED=yes

WLAN_IPADDR=192.168.1.50/24

WLAN_MACADDR=наклейка на корпусе

 

сохранил, перезагрузил

 

На ПК ставлю IP 192.168.0.100, шлюз 192.168.0.50, пробую пинг 192.168.0.50, пинга нет :(

Что и где еще нужно править чтоб заработал полноценный роутер ?

 

 

Share this post


Link to post
Share on other sites

А как быть с провайдером?, он при PPTP соединении проверяет МАС, я правильно думаю что eth1 это WAN порт ?

Share this post


Link to post
Share on other sites

Муть какая то, пробую даже так:

 

IPV4_FORWARD_ENABLE=yes

BRIDGE_START=no

BR0_IPADDR=192.168.0.50/24 #ipv4=192.168.0.50 MASK=255.255.255.0

 

ETH0_ENABLED=yes

ETH0_IPADDR=192.168.0.50/24

ETH0_MACADDR=наклейка на корпусе

ETH1_ENABLED=no

WLAN_ENABLED=no

 

перегружаю и все точка не пингуется :(

где что еще нужно изменить ?

Edited by chempic

Share this post


Link to post
Share on other sites
sfstudio О...сам гуру wive мне помог, спасибо огромное, буду пробовать.

Share this post


Link to post
Share on other sites

Ну дык уже смотреть на вас грустно. Если что можно до кучи FORCEIP ещё взвести.

Share this post


Link to post
Share on other sites

Получилось запустить только роутер только так

IPV4_FORWARD_ENABLE=yes

BRIDGE_START=yes

BR0_IPADDR=192.168.1.254/24 #ipv4=192.168.1.254 MASK=255.255.255.0

 

ETH0_ENABLED=yes

ETH0_IN_BR0=yes

ETH0_IPADDR=

ETH0_MACADDR=

 

ETH1_ENABLED=yes

ETH1_IN_BR0=no (выключил из моста)

ETH1_IPADDR=192.168.21.92/24

ETH1_MACADDR=Мак адр. ПК

 

WLAN_ENABLED=yes

WLAN_IN_BR0=yes

WLAN_IPADDR=

WLAN_MACADDR=

 

есть пинг до WAN порта, а дальше него нет, т.е. во внешнюю сеть, у меня внешняя локалка со статическими ip 192.168.21.0-192.168.21.254, в ней VPN сервак 192.168.21.9 вот до него надо пинганутся, что еще забыл прописать ?

Share this post


Link to post
Share on other sites

Включил маскарад эффекта ноль :(

Теперь конфа имеет вид:

 

IPV4_FORWARD_ENABLE=yes

START_IPTABLE=yes

MASQUARDE=yes

BRIDGE_START=no

BR0_IPADDR=192.168.1.254/24 #ipv4=192.168.1.254 MASK=255.255.255.0

 

ETH0_ENABLED=yes

ETH0_IN_BR0=no

ETH0_IPADDR=192.168.1.254

ETH0_MACADDR=

 

ETH1_ENABLED=yes

ETH1_IN_BR0=no

ETH1_IPADDR=192.168.21.92/24

ETH1_MACADDR=Мак адр. ПК

 

WLAN_ENABLED=yes

WLAN_IN_BR0=no

WLAN_IPADDR=192.168.2.254

WLAN_MACADDR=

 

IPTABLES

iptables -F FORWARD

iptables -A FORWARD -m conntrack --ctstate ESTABLISHED,RELATED -j ACCEPT

iptables -A FORWARD -m conntrack --ctstate NEW -i eth0 -s 192.168.1.0/24 -j ACCEPT #

iptables -P FORWARD DROP

iptables -t nat -F POSTROUTING

iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE

 

 

Edited by chempic

Share this post


Link to post
Share on other sites

sfstudio Так это я по памяти писал, мож и ошибся в синтаксисе где, но в wive все нормально.

Настройки клиента 192.168.1.100 (255.255.255.0) шлюз 192.168.1.254, при пинге до 192.168.21.9 пишет

"ответ 192.168.1.254 заданная сеть недоступна", а до своего eth1 192.168.21.92 есть пинг, не работает походу маскарад :(

Т.е. ты считаешь что все остальное верно настроено и должно работать, может что еще нужно ?

Edited by chempic

Share this post


Link to post
Share on other sites
sfstudio Так это я по памяти писал, мож и ошибся в синтаксисе где, но в wive все нормально.

Т.е. ты считаешь что все остальное верно настроено и должно работать, может что еще нужно ?

Я считаю что я не медиум и без доступа к железки могу только медитировать, но т.к. медитировать я не умею см. начало фразы.

 

Писать нужно не на память а с живого девайса. Попутно как минимум ifconfig, brctl show, route -n и iptables -L -v -n и iptables -L -v -n -t nat показать. Вот только сидеть и анализировать это придётся самостоятельно, мне заниматься вами собсно некогда. Более того, проверить пинг до провайдерской сети с самого девайса религия не позволяет?

Share this post


Link to post
Share on other sites

Уфф..., ну наконец то у меня получилось, спасибо sfstudio за помощь

Конфа имеет вид:

IPV4_FORWARD_ENABLE=yes

START_IPTABLES=yes

MASQUARDE=yes

BRIDGE_START=yes

BR0_IPADDR=192.168.1.254/24

 

ETH0_ENABLED=yes

ETH0_IN_BR0=yes

ETH0_IPADDR=192.168.1.254

ETH0_MACADDR=

 

ETH1_ENABLED=yes

ETH1_IN_BR0=no # из моста

ETH1_IPADDR=192.168.21.92

ETH1_MACADDR=Мак адр. ПК

 

WLAN_ENABLED=yes

WLAN_IN_BR0=yes

WLAN_IPADDR=192.168.1.244

WLAN_MACADDR=

 

IPTABLES

iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE

 

Все заработало и появился выход во внешнюю сеть, но теперь встала следующая задача, нужно установить VPN(PPTP) соединение и настроить его раздачу в свою локалку.

 

PPTP_CALL_START=yes

PPTP_AUTO REDIAL=yes

 

Появился интерфейс ppp0

Пробовал тупо заменить eth1 на ppp0

 

iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE

 

При обращении к интернету с клиента Акорп подвисает :(

Походу нужно ковырять iptables, пока додумался только до этого

#Br0 = eth0+wlan0

#Eth1=192.168.21.92 internet

 

iptables -A FORWARD -i eth1 -o br0 -m state --state ESTABLISHED,RELATED -j ACCEPT

iptables -A FORWARD -i br0 -o eth1 -j ACCEPT

iptables -t nat -A POSTROUTING -o eth1 -s 192.168.1.0/24 -j MASQUERADE

 

Господа сисадмины, помогите написать скрипт:

1)Для раздачи с ppp0 на br0

2)Допустить к раздаче один узел с eth1

Edited by chempic

Share this post


Link to post
Share on other sites

Вылезла одна серьезная проблема, Акорп виснет при подключении PPTP

настройки PPTP такие:

PPTP_CALL_START=yes

PPTP_MPPE=auto

PPTP_MTU=

PPTP_MRU=

PPTP_DEFROUTE=no

PPTP_PEERDNS=yes

PPTP_AUTO_REDIAL=yes

 

Соединение происходит и в ifconfig мне виден интерфейс ppp0, но буквально, через 10сек, роутер виснет :(

настройки PPTP:

Проверка подлинности MS CHAP V2

Шифрование MPPE=128

Сжатие=нет

Формирование пакетов=нет

 

 

Share this post


Link to post
Share on other sites
free что говорит?
Без PPTP подключения Total-13948 Used-8025 Free-5920

C PPTP подключением Total-13948 Used-8516 Free-5432

Подвисает через 30сек :(

Если сделать PPTP_AUTO_REDIAL=no, то как звонить принудительно, и как посмотреть логи PPTP ?

Share this post


Link to post
Share on other sites
MASQUARDE=yes

ETH1_ENABLED=yes

ETH1_IN_BR0=no # из моста

ETH1_IPADDR=192.168.21.92

ETH1_MACADDR=Мак адр. ПК

iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE

Появился интерфейс ppp0

Пробовал тупо заменить eth1 на ppp0

 

iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE

по иделогии конфигов и скриптов ты маскарад уже включил MASQUARDE=yes , в iptables уже не надо ничего про это.

бридж включи обратно чтобы свитч на eth0 и wlan0(wifi) туда попал.

в iptables пока оставь все по дефолту.

PPPOE_DEFAULTROUTE=yes сразу ставь.

Вообще сделай все как здесь (с поправкой на статику)http://sadnet.ru/?WIVE-NG_8186_%28revA%2FB%29:Dokumentaciya:Dlya_NetByNet и все будет работать - основные моменты я тебе сказал.

p.s. рекомендую flash restore (восстанвовить дефолт настройки - или как там 15 секунд подержать ресет еще осталось ?) и потом уже настраивать по статье никуда не отвлекаясь ;-).

http://sadnet.ru/?WIVE-NG_8186_%28revA%2FB...a:Dlya_NetByNet

- здесь то что не описано значит остается из настроек по умолчанию. в iptables если не разбираешься, только добавляешь, ничего не убирая.

Edited by alecs-art

Share this post


Link to post
Share on other sites

Вообще родная прошивка настраивается и коннектится нормально вроде бы. И работает через маскарад в два раза шустрее чем Wive.

Так что если вам не надо russian ppoe ;-) , т.е. со всякими там настройками прямых маршрутов в лок сеть то родную рекомендую - шьется так же как и wive.bin. У меня вот эта работала без всяких нареканий:

http://www.i4wifi.cz/img.asp?attid=100921

Share this post


Link to post
Share on other sites
Вообще сделай все как здесь (с поправкой на статику)http://sadnet.ru/?WIVE-NG_8186_%28revA%2FB%29:Dokumentaciya:Dlya_NetByNet и все будет работать
так вроде у меня все точно так же, только

 

START_DHCPSERVER=no (обойдусь)

START_IGMPPROXY=no (хз че такое)

 

И вместо PPOE запускаю PPTP

Вот iptables -L -v -n -t nat, тоже вроде ничего особенного:

 

iptables -A FORWARD -i eth1 -o br0 -m state --state ESTABLISHED,RELATED -j ACCEPT

iptables -A FORWARD -i br0 -o eth1 -j ACCEPT

iptables -t nat -A POSTROUTING -o eth1 -s 192.168.1.0/24 -j MASQUERADE

 

После старта виснет через 10-30сек и перезагружается, с PPTP_AUTO_START=no все робит норм, но подключения ppp0 нет :(

Share this post


Link to post
Share on other sites
PPTP_DEFROUTE=no
?

но на висячесть это не повлияет скорее всего ;-).

а чтобы не гадать чего ты там накосячил - ресетни настройки и сделай все сначала как я посоветовал. рабочий вариант ;-)

1 Делаем мост br0 : в него по умолчанию включен eth0 и wlan0, IP им сотвественно не ставим(хотя скорее всего они проигнорируются).

2 настраиваем pptp

3 включаем маскарад и роутинг.

iptable по умолчанию не трогали.

все уже должно работать.

дальше в iptable добавляем что нужно и роутинг прямой куда нужно.

 

 

 

 

 

Share this post


Link to post
Share on other sites
alecs-art Кароче, поставил, твою прошивку 1.4.6 (моя родная была 1.4.7), так вот соединение PPT происходит, но обрывается при первом же обращении к интернету с клиента, скрин внизу. Что интересно при fixed IP и Enable PPTP pass through on VPN connection, PPTP соединение с клиента из винды работает нормально.

post-69200-1266514531_thumb.jpg

Edited by chempic

Share this post


Link to post
Share on other sites

alecs-art Кароче, поставил, твою прошивку 1.4.6 (моя родная была 1.4.7), так вот соединение PPT происходит, но обрывается при первом же обращении к интернету с клиента, скрин внизу. Что интересно при fixed IP и Enable PPTP pass through on VPN connection, PPTP соединение с клиента из винды работает нормально.

какие то чудеса. надо дальше анализировать. может провайдер у вас "классный" ;-). ну пробуй дальше wive-ng. учти перепрошивка не уничтожает настроек - и лучше их после такой перепрошивки инициализировать.

Edited by alecs-art

Share this post


Link to post
Share on other sites
учти перепрошивка не уничтожает настроек - и лучше их после такой перепрошивки инициализировать.
Я настройки обнуляю, чищу кэш, с помощью заливки black_fw.bin, перед заливкой прошивки.
ну пробуй дальше wive-ng
В том то и дело что wive-ng вообще перезагружает роутер, при PPTP соединении, 1.4.6 хотябы просто его обрывает.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this