Jump to content
Калькуляторы

freebsd виснет при установке куда копать?

прикупили сервер, вот такой:

Intel core i5 750, intel server board s3420gplc, ...

 

При установке любой версии (пробовались 6.4, 7.2, 8.0, и amd64 и i386), виснет наглухо. Это происходит уже при первом шаге - после меню из 7 пунктов - normal, safe mode и пр. При этом виндоуз7 поставилась на ура и память тестится норм. Какие данные еще нужно указать для определения в какую сторону копать? Или сразу продавцам возвращать? Как доказывать, ибо они перед продажей под виндой краш-тесты проводят? Гугл не помог.

Share this post


Link to post
Share on other sites

А в списке совместимого с фрёй оборудования ваше железо есть?

Как вариант не ставить фрю, а вставить её.

Share this post


Link to post
Share on other sites
Попробуйте другой cdrom
не помогло

 

А в списке совместимого с фрёй оборудования ваше железо есть?

Как вариант не ставить фрю, а вставить её.

Если я правильно понимаю этот список, то да.

Подсовывать винт с установленной фрей пробовали.

Share this post


Link to post
Share on other sites

Загрузку без ACPI пробовали?

да, и with ACPI disabled, и Safe mode - одинаково.

Share this post


Link to post
Share on other sites

Ну что, если у вас даже при установленной фре на другом харде виснет, то высовывайте все что есть в материнке и пробуйте загржаться, проблема в той железке, после которой все подвисло.

Share this post


Link to post
Share on other sites
Ну что, если у вас даже при установленной фре на другом харде виснет, то высовывайте все что есть в материнке и пробуйте загржаться, проблема в той железке, после которой все подвисло.

на матери остались только проц и память, ну и либо винт, либо dvd.

Озадачил продавцов, думают.

Самого озадачивает что виндоус нормально работает, и один livecd на линухе тоже запустился без проблем.

Share this post


Link to post
Share on other sites

Ядро после загрузочного меню хоть что-то выдаёт ( "Copyright © 1992-2009 The FreeBSD Project.", etc. ) ?

 

Покажите вывод команд (в loader'е):

lsdev -v
lsmod -v
show

 

Попробуйте (в loader'е):

set boot_verbose=1
boot

и покажите вывод.

Share this post


Link to post
Share on other sites
Ядро после загрузочного меню хоть что-то выдаёт ( "Copyright © 1992-2009 The FreeBSD Project.", etc. ) ?

 

Покажите вывод команд (в loader'е):

lsdev -v
lsmod -v
show

 

Попробуйте (в loader'е):

set boot_verbose=1
boot

и покажите вывод.

Нет, ничего не выдаёт. полоска две секунды крутится и останавливается навсегда.

Вывод lsmod -v и окончание вывода lsdev-v - в прикрепленном файле. В этом случае был подключен только dvd, винты отключены.

 

вывода от

set boot_verbose=1

boot

нет, ибо, как и после меню, сразу зависло (через 2 сек).

post-43374-1264084642_thumb.jpg

Edited by aelfwine

Share this post


Link to post
Share on other sites

Биос обновляли на матери?

Там биос вообще стандартный (авард)?

Может какой EFI или ещё чего, поэтому стандартный загрузчик фри его не понимает.

Share this post


Link to post
Share on other sites

Там-то EFI, но это на причину не тянет.

Вот у человека FreeBSD на такой же плате работает.

 

aelfwine, пообщайтесь с счастливым владельцем по ссылке на предмет настроек BIOS, может какой-нибудь memory mapping мешает.

 

Ещё можно попробовать запустить с HDD PAE-ядро. (сколько там памяти-то? И расставлена ли она по слотам согласно рекомендациям из спецификации?)

Share this post


Link to post
Share on other sites

Новая венда как раз EFI понимает, и GPT соотвественно.

А если подсунуть GPT диск с gptboot ?

Share this post


Link to post
Share on other sites

COM-порты в биосе включены?

И вообще, сбросьте его в настройки по умолчанию.

Share this post


Link to post
Share on other sites

Читал о похожих проблемах, система точно виснет? Сколько времени ждали? На одной восьмисокетной железке система определяла оборудование почти полчаса, владельцы сначала тоже считали, что виснет

Share this post


Link to post
Share on other sites
Читал о похожих проблемах, система точно виснет? Сколько времени ждали? На одной восьмисокетной железке система определяла оборудование почти полчаса, владельцы сначала тоже считали, что виснет
*мат в отношении себя*

ждали около 20 минут, оставленный на ночь сервер показал уже следующий шаг - выбор страны. Т.е. действительно не виснет, а долго определяет оборудование. Но он же каждый раз так будет включаться? Или есть вероятность что если повырубать драйвера ненужные, то дело быстрее пойдет?

Share this post


Link to post
Share on other sites

Или есть вероятность что если повырубать драйвера ненужные, то дело быстрее пойдет?

Насколько я помню, после пересборки ядра с выбрасыванием всего лишнего, система стала грузиться нормально, правда они ещё шедулер меняли с нового на старый

Share this post


Link to post
Share on other sites

У меня примерно такая же проблема

Пытаюсь поставить FreeBSD на машину:

CPU Intel Core i5-750

M/B GigaByte GA-P55A-UD3

Kingston ValueRAM <KVR1333D3N9K2/4G>

1Gb <PCI-E> DDR-5 GigaByte <ATI RADEON HD5850>

 

машина намертво зависает после определения USB, DVD. последние сообщения

SMP: AP CPU #1 Launched!

SMP: AP CPU #2 Launched!

SMP: AP CPU #3 Launched!

 

Пытался ждать как здесь написано - бесполезно.

Железо рабочее - WinXP работает нормально и LiveCD Ubuntu 9.10 грузится нормально. Можете что-нибудь посоветовать?

Share this post


Link to post
Share on other sites

через биос отрубай если можно ядра

либо HT

 

фря поставится

потом обновись

и верни все обратно

 

ехал на этом со своими 24 ядрами :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this