Jump to content
Калькуляторы

Резервирование внутрисетевого канала через Upstreamov

Здравствуйте!

 

В нашей сети имеются два граничных маршрутизатора Cisco 7206VXR-G2 и 7204VXR-G2. Каждый из этих маршрутизаторов подключен к своему UpStream-у и получает по eBGP от него Full View. Также маршрутизаторы соединены между собой прямым каналом где поднят iBGP. В такой схеме работы нас все устраивало до тех пор пока по независящим от нас причинам нам не перерубили на несколько часов кабель между маршрутизаторами (т.е. линк с iBGP). В результате наша сеть оказалась разделена на две не сообщающиеся между собой части, до момента восстановления канала.

В свете возникшей проблемы, мне руководством была поставлена задача организовать резервный канал через UpStream-ов, но без аренды дополнительных физических каналов.

 

Решение мне видится в организации туннеля между интерфейсами 7206 и 7204 подключенными к UpStream-ам. (Жизненная ли это схема?)

 

Конфиг для 7206

 

interface Tunnel0

bandwidth 20000

ip address 192.168.2.9 255.255.255.252

delay 100

tunnel source FastEthernet2/0

tunnel destination YYY.YYY.137.6 /*интерфейс на 7204

tunnel mode ipip

tunnel bandwidth transmit 18000

tunnel bandwidth receive 18000

max-reserved-bandwidth 90

 

interface GigabitEthernet0/1

description This interface connect to 7204VXR-G2

ip address ZZZ.ZZZ.161.145 255.255.255.252 /*внутренний линк который резервируется

 

 

interface FastEthernet2/0

description UpStream1 Internet Exit

ip address VVV.VVV.52.245 255.255.255.252

 

 

router bgp AS_OUR

no bgp enforce-first-as

bgp log-neighbor-changes

neighbor ZZZ.ZZZ.161.146 remote-as AS_OUR

neighbor VVV.VVV.52.246 remote-as AS_UpStream1

neighbor VVV.VVV.52.246 description UpStream1

maximum-paths 2

address-family ipv4

neighbor ZZZ.ZZZ.161.146 activate

neighbor ZZZ.ZZZ.161.146 next-hop-self

neighbor ZZZ.ZZZ.161.146 weight 100

neighbor ZZZ.ZZZ.161.146 soft-reconfiguration inbound

neighbor VVV.VVV.52.246 activate

neighbor VVV.VVV.52.246 send-community both

neighbor VVV.VVV.52.246 remove-private-as

neighbor VVV.VVV.52.246 weight 100

neighbor VVV.VVV.52.246 soft-reconfiguration inbound

neighbor VVV.VVV.52.246 route-map UpStream1_out out

neighbor VVV.VVV.52.246 filter-list 5 out

maximum-paths 2

no auto-summary

no synchronization

network ZZZ.ZZZ.160.0 mask 255.255.252.0

exit-address-family

 

ip route YYY.YYY.137.6 255.255.255.255 FastEthernet2/0

 

ip as-path access-list 1 permit ^AS_UpStream2$

ip as-path access-list 5 permit ^$

 

 

route-map TEST permit 10

match as-path 1

set weight 300

 

route-map TEST permit 20

set weight 100

 

route-map UpStream1_out permit 10

set local-preference 130

set as-path prepend AS_OUR

 

 

 

Конфиг для 7204

 

interface Tunnel0

bandwidth 20000

ip address 192.168.2.10 255.255.255.252

delay 100

tunnel source FastEthernet0/0

tunnel destination XXX.XXX.52.245 /*интерфейс на 7206

tunnel mode ipip

tunnel bandwidth transmit 18000

tunnel bandwidth receive 18000

max-reserved-bandwidth 90

 

interface FastEthernet0/0

description UpStream2 Internet Exit

ip address YYY.YYY.137.6 255.255.255.252

 

 

interface GigabitEthernet0/1

description This interface connect to 7206VXR-G2

ip address ZZZ.ZZZ.161.146 255.255.255.252 /*внутренний линк который резервируется

 

 

 

router bgp AS_OUR

bgp log-neighbor-changes

neighbor ZZZ.ZZZ.161.145 remote-as AS_OUR

neighbor YYY.YYY.137.5 remote-as AS_UpStream2

neighbor YYY.YYY.137.5 description UpStream2

maximum-paths 2

maximum-paths ibgp 2

address-family ipv4

neighbor ZZZ.ZZZ.161.145 activate

neighbor ZZZ.ZZZ.161.145 next-hop-self

neighbor ZZZ.ZZZ.161.145 weight 110

neighbor ZZZ.ZZZ.161.145 soft-reconfiguration inbound

neighbor ZZZ.ZZZ.161.145 route-map TEST in

neighbor YYY.YYY.137.5 activate

neighbor YYY.YYY.137.5 send-community

neighbor YYY.YYY.137.5 remove-private-as

neighbor YYY.YYY.137.5 weight 100

neighbor YYY.YYY.137.5 soft-reconfiguration inbound

neighbor YYY.YYY.137.5 route-map UpStream2_out out

neighbor YYY.YYY.137.5 filter-list 5 out

maximum-paths 2

maximum-paths ibgp 2

no auto-summary

no synchronization

network ZZZ.ZZZ.160.0 mask 255.255.252.0

exit-address-family

address-family nsap

maximum-paths 2

no synchronization

exit-address-family

 

 

ip route VVV.VVV.52.245 255.255.255.255 FastEthernet0/0

 

 

ip as-path access-list 1 permit ^AS_UpStream1$

ip as-path access-list 5 permit ^$

 

 

route-map TEST permit 10

match as-path 1

set weight 300

 

route-map TEST permit 20

set weight 110

 

route-map UpStream2_out permit 10

set local-preference 130

set as-path prepend AS_OUR

 

 

Однако в такой конфигурации мне не удается настроить такой резервный канал т.к. в зависимости от состояния таблиц маршрутизации BGP, то один интерфейс, то другой становятся недоступными.

В связи с этим прошу помочь разобраться с проблемой и посоветовать как лучше решить возникшую проблему.

 

С Уважением, Виктор

 

Share this post


Link to post
Share on other sites

Читаем http://www.opennet.ru/docs/RUS/bgp_rus/ind...l#xtocid2375319

Узнаем что чем больше weight, тем приоритетнее маршрут.

Медитируем

neighbor ZZZ.ZZZ.161.146 weight 100
neighbor VVV.VVV.52.246 weight 100
neighbor ZZZ.ZZZ.161.145 weight 110
neighbor YYY.YYY.137.5 weight 100
и пытаемся понять зачем оно так.

Ты точно хочешь, чтобы исходящий трафик с 7204 фигачил на 7206 ???

А на 7206 часть трафика может и назад на 7204 вернуться....

И так кольцом ;)

 

 

neighbor YYY.YYY.137.5 route-map UpStream2_out out
Опять же несовсем понятно зачем на исходящие анонсы лепить local-pref ;)

 

 

 

Поменять и добавить на 7206

ip route YYY.YYY.137.6 255.255.255.255 VVV.VVV.52.246

router bgp AS_OUR

neighbor 192.168.2.10 remote-as AS_OUR

neighbor 192.168.2.10 activate

neighbor 192.168.2.10 next-hop-self

neighbor 192.168.2.10 weight 90

neighbor 192.168.2.10 soft-reconfiguration inbound

neighbor ZZZ.ZZZ.161.146 weight 95

 

на 7204

ip route VVV.VVV.52.245 255.255.255.255 YYY.YYY.137.5

neighbor 192.168.2.9 remote-as AS_OUR

neighbor 192.168.2.9 activate

neighbor 192.168.2.9 next-hop-self

neighbor 192.168.2.9 weight 90

neighbor 192.168.2.9 soft-reconfiguration inbound

neighbor ZZZ.ZZZ.161.145 weight 95

 

удалить

neighbor ZZZ.ZZZ.161.145 route-map TEST in

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this