Jump to content
Калькуляторы

MSM64i, Extreme BlackDiamond 6808 как сбрасывается? и странно себя ведёт?

всем привет

 

имею такое вот устройство Extreme BlackDiamond 6808, с двумя одинаковыми модулями управления MSM64i.

 

с одним модулем подружися, а со вторым никак. проблема в том, что на консоль вываливаются в лучше случае бессмысленные (?) комбинации символов, например вот так:

 

Добро пожаловать в minicom 2.3

ПАРАМЕТРЫ: I18n
Дата компиляции Feb 24 2008, 16:35:15.
Port /dev/ttyS0

               Нажмите CTRL-A Z для получения подсказки по клавишам                         
                                                                                            
J(((                                                                                        
Joo|(Mol}lm(9:(I]O(8;(~8.9                                                                  
==========================                                                                  
Mmmozy([izm:(88888888


Xzm{{({xikmjiz(noz(joo|(mmn}

]IZ\(|m{|(in(xzoozm{{....
MZZOZ:((]IZ\(|m{|(niilml.


KX](mmmozy(|m{|(in(xzoozm{{....
KX](mmmozy(|m{|(xi{{ml.

]nkomxzm{{ino(xzimizy(imiom(nzom(nli{h.......................................................................
................................................

 

Лучший случай - это когда модуль имеет две планки RAM памяти. Именно с двумя планками на консоль вываливается испорченный вариант текста процесса загрузки устройства. Худший, это когда в модуле одна планка памяти (мне вот так дали, с одной планкой), и на консоли после подачи питания на аппарат появляется всего 1 (один) символ, тоже бессмысленный, что-то вроде знака вопроса в белом овале.

 

Я ставил память (и одну и две планки) с другого, рабочего модуля, но это не решило проблему.

 

В чём дело может быть? Я точно не помню, но кажется испорченные символы могут появляться когда выставлены разные значения baud rate на обоих устройствах. Поскольку модуль не "нулячий", то вполне возможно кто-то настроил его на работу с нестандартным значением baud rate. Я проверил 115200, 3400, 9600 (стандартное, на котором выдаёт вот такую кашу из символов.) Но нормально модуль так и не "заговорил".

 

На модулях, как вы наверно знаете, есть кнопка сброса, но не могу найти документацию, где описывается как это делается у Extreme именно для этих модулей. Попробовал подержать 10 сек., 30 сек. но похоже не сбрасывается. Кто-нибудь знает как это делается правильно?

 

Вообще, такое поведение модуля вам о чём-то говорит?

 

Спасибо.

Edited by xCrucialDudex

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this