Jump to content
Калькуляторы

PADT и висящее pppoe соединение

Доброго времени суток!

 

Обнаружил в своей сети такую проблему: некоторые pppoe клиенты жалуются, что "интернет работает-работает, а потом не работает" до перегрузки модема/компьютера. При внимательном рассмотрении обнаружилось, что BRAS получает (почему то) от абонента PADT на завершение сессии, сессию закрывает, но! у абонента в модеме или на компьютере (смотря где поднят PPPoE) сессия остается активной, но трафик к клиенту разумеется перестает поступать. А раз CPE считает, что сессия активная - то не пытается пересоединиться. Если вручную закрыть это висящее соединение и заново пересоединиться - то все ok.

BRAS - это стопка цисок 2811, разные атс приходят в разных вланах (на атс - port protected между dslam'ами), но каждый влан поднят на каждой циске, на соответствующих интерфейсах отключен proxy arp.

 

Вот лог:

Dec 30 10:36:47.655: PPPoE 3050: I PADT R:0019.6672.e8c2 L:001b.d409.f3b9 211 Fa0/1.211

Dec 30 10:36:47.655: [276]PPPoE 3050: Destroying R:0019.6672.e8c2 L:001b.d409.f3b9 211 Fa0/1.211

 

Почему так может быть?

Share this post


Link to post
Share on other sites

Я сталкивался с тем, что кривые "домашние" роутеры шлют PADT "чужим" сессиям

Share this post


Link to post
Share on other sites
А раз CPE считает, что сессия активная - то не пытается пересоединиться.

А почему СРЕ не проверяет наличие соединения? У нас борд, например, раз в 30 секунд шлет LCP echo. И если ответа нет, то пытается еще несколько раз, после чего пытается переконнектиться.

Share this post


Link to post
Share on other sites

Вообще по сути, если сессии на циске нет, а пришли данные, циска должна прислать PADT CPE, и CPE тоже разорвет сессию.

Share this post


Link to post
Share on other sites
некоторые pppoe клиенты жалуются, что "интернет работает-работает, а потом не работает"
ага, была такая гадость на UTM.. надо было абоненту в личном кабинете интернет выкл.вкл

 

Share this post


Link to post
Share on other sites

Проблема решилась... :-) Виноват был SRA, который не корректно отрабатывал между zyxel dslam'ом IES1248 и dlink модемами последних прошивок. Проблемы были такие: дропающиеся и не пересоединяющиеся pppoe сессии (при поднятом adsl линке), низкая скорость прокачки, проблемы с adsl линками. Отключение SRA на dslam'е все решает ;-)

 

P.S.

SRA на зухелях настроили уже полгода как... раньше все работало нормально.

Share this post


Link to post
Share on other sites

Похоже проблема решилась только частично, так как остались еще некоторые клиенты, у которых время от времени (чаще всего при простое) рвется pppoe и не всегда восстанавливается, а влогах радиуса: TCP Foreign Host Close

 

Не знаете что это такое?

 

keepalive у меня включен.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this