Jump to content
Калькуляторы

Проблемы совместимости mikrotik и nanostation

Старую тему не нашел, поэтому создал новую.

 

Что заметил у себя - на микротике с карточками R52n и довольно таки нормальными уровнями сигнала получаю регулярные дисконнекты клиентов. Скорости так же не блещут. Стал разбираться в чем дело.

 

Прошивки на наносах 3.5-rc

Прошивки на MT 4.3

 

В списке клиентов на микротике, скорости у всех в основном 54/1 - заходим на наносы и видим в них конечно же скорость 54/54. Почему же микротик видит их как 1 мбит? В наносе стоял RATE ALGORITM - optimistic. Убрал в микротике из доступных скорость 1,2,5 и оставил только 11мбит. В наносе все так же 54/54, но микротик видит уже 54/6 - уже что-то.

Поставил rate algoritm - conservative или EWMA - сразу в наносе появились реальные скорости, которые микротик так же подтверждает. Так же при удалении горелого буллета с выпаянной микрухой (очень пригодился для такого рода тестирования, мощность в нем маленькая, и удаление на метр равносильно 10 километров с нормальной аппаратурой) скорости пропорционально снижались.

 

Отсюда вывод - наносы не правильно управляют скоростью в режиме optimistic или микротик неправильно отрабатывает подтверждение повышения скоростей.

 

Вопрос - каким образом можно включить механизм RTS/CTS в наносах?

Share this post


Link to post
Share on other sites

постав в микротит онли-G и в дата-реит убири галочки с рате стандарта B . эшо Hw. protection mode постав none .

 

 

Share this post


Link to post
Share on other sites

кроме рабочего рейта, есть такой параметр как начальный рейт на которых точка ищет новых клиентов, либо ловит отвалившихся, он должен стоять чем меньше, тем лучше, для Б-1мбит, для Г-6Мбит, если его поменял на 11мбит, то отсюда и частые дисконекты, так как при невозможности держать 11мбит, точка просто выкидывает клиента и все

Share this post


Link to post
Share on other sites

Так это я для теста менял, чтобы понять почему скорости несогласовываються.

А так стоит 1 и 6 мбит в начальном рейте. Надо будет попробовать что измениться если там все галочки поставить.

 

Кстати вот почему клиенты отваливаються, в логах пишет - disconnect, group key exchange timeout.

Edited by Saab95

Share this post


Link to post
Share on other sites

У меня бывают например такие бока. На наносе вручную выставляю ACK равным 35, база тик в упор ставит на клиента значение 400us с лишним и хоть ты убей решения не нашел, такое на случайных клиентах, у остальных тик ставит 56-60us.

Edited by zulu_radist

Share this post


Link to post
Share on other sites
Не все клиенты смогут работать в G.

кроме наносов другие тоже работают ? . я советую вибрать одну режим работи , Б или Г . эесли радиус деиствия сегмента не болше чем 1.5 км то лучше работать в Г режим - можно достич хорошую производительность .

 

Вопрос - каким образом можно включить механизм RTS/CTS в наносах?
565d4c12b025.jpg
Edited by misha1

Share this post


Link to post
Share on other sites

Стояло раньше шифрование WPA-TKIP, и все работало стабильно и долго, пока не обновил прошивки на наносах до 3.5-rc и микротик до 4.3

При WPA-TKIP клиенты отваливались через некоторое время, поставил сейчас WPA-AES - стало получше. Но все равно отваливаються иногда, хоть и редко. Хотя непонятно почему - сигналы сильные, CCQ хороший, а в логах пишет что не смог ключь этому клиенту обновить и он отваливаеться.

Думаю попробовать WPA2 может что измениться.

 

За RTS/CTS спасибо=) не думал что все так просто=)

Share this post


Link to post
Share on other sites
Стояло раньше шифрование WPA-TKIP, и все работало стабильно и долго, пока не обновил прошивки на наносах до 3.5-rc и микротик до 4.3

При WPA-TKIP клиенты отваливались через некоторое время, поставил сейчас WPA-AES - стало получше. Но все равно отваливаються иногда, хоть и редко. Хотя непонятно почему - сигналы сильные, CCQ хороший, а в логах пишет что не смог ключь этому клиенту обновить и он отваливаеться.

Думаю попробовать WPA2 может что измениться.

 

За RTS/CTS спасибо=) не думал что все так просто=)

тоже уже слышал что ткип глюкавый пока что на 4-ке...

Share this post


Link to post
Share on other sites

Наблюдая за наносами обнаружил, что уж больно часто там в CCQ 100 процентов стоит, что насторожило. Иногда на эти точки и достучаться-то нельзя, поэтому решил провести небольшой эксперимент.

 

 

Удаленный клиент с плохим сигналом. На картинках в самом низу расположен. Пинг к нему размером 50000.

 

Ставлю ему optymistic и что же вижу - на самом наноса скорость 54/54 в его веб интерфейсе, микротик ловит его 36/6, CCQ большой. Но пинги с потерями.

 

optymistic.gif

 

 

Ставлю его в conservative и что же - в вебморде скорости соответствуют реальности, в микротике скорости подросли до 48/18, CCQ понизился но зато пинги без потерь.

 

conservative.gif

 

В EWMA какая-то фигня, скорости опять прыгают, но иногда точка не подключаеться к базе в этом режиме - вообще непонятка, и пинги кстати тоже с потерями.

 

EWMA.gif

 

 

Получаеться всем надо консерватив ставить.

Edited by Saab95

Share this post


Link to post
Share on other sites
У меня бывают например такие бока. На наносе вручную выставляю ACK равным 35, база тик в упор ставит на клиента значение 400us с лишним и хоть ты убей решения не нашел, такое на случайных клиентах, у остальных тик ставит 56-60us.

Поставь на МТ аск вручную. Такие проблемы наблюдаются когда МТ видит помеху в канале от клиента и для того чтоб не было дисконекта ставить ему аск большой тем самым прокачки не будет пинги будут большие. Возьми R52n карту посмотри анализатором МТ что у тебя твориться в канале. То что ты ставиш на наносе аск 35 никак не влияет на передачу от БС к клиенту, это от клиента к БС аск.

Share this post


Link to post
Share on other sites

Меняйте карточку, r52n криво работает в b/g режиме, сам наступил на эти грабли. Поставил r52, все стало как в сказке

Share this post


Link to post
Share on other sites
Меняйте карточку, r52n криво работает в b/g режиме, сам наступил на эти грабли. Поставил r52, все стало как в сказке

В N режиме она работает так же, у некоторых клиентов в виде наносов M так же имеются проблемы с ACK, несмотря на более новую прошивку с тех времен.

Share this post


Link to post
Share on other sites
Меняйте карточку, r52n криво работает в b/g режиме, сам наступил на эти грабли. Поставил r52, все стало как в сказке

В N режиме она работает так же, у некоторых клиентов в виде наносов M так же имеются проблемы с ACK, несмотря на более новую прошивку с тех времен.

Скорей всего проблема в наностейшене.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this