Jump to content
Калькуляторы

Помогите с проблемой Cisco 1751-V

Доброго всем времени суток, господа. Приобрел в недавнем времени такую вещь: Cisco 1751 VoIP E1 Bundle для конвертации трафика с E1 в VoIP. Бьюсь вторую неделю - не могу понять причин неработоспособности.. точнее намеки есть, но хотелось бы быть точно уверенным. Итак, сначала описание:

 

Конфиг шлюза:

 

VoIP_cisco#sh run
Building configuration...

Current configuration : 1285 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname VoIP_cisco
!
boot-start-marker
boot-end-marker
!
!
memory-size iomem 25
tdm clock E1 0/0 both export line
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
voice-card 0
!
aaa new-model
!
!
aaa authentication login default local
aaa session-id common
ip subnet-zero
ip cef
!
!
!
isdn switch-type primary-net5
!
!
!
voice service voip
h323
!
voice class codec 1
codec preference 1 g711alaw
codec preference 2 g711ulaw
!
!
!
!
!
!
!
!
!
username admin secret 5 <вырезано цензурой>/
!
!
controller E1 0/0
framing NO-CRC4
pri-group timeslots 1-31
!
!
!
!
interface FastEthernet0/0
ip address 192.168.2.50 255.255.255.0
speed auto
full-duplex
!
interface Serial0/0:15
no ip address
encapsulation hdlc
no logging event link-status
isdn switch-type primary-net5
isdn incoming-voice voice
no cdp enable
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.2.254
ip http server
!
!
voice-port 0/0:15
!
!
!
dial-peer voice 1 voip
destination-pattern 5941736
voice-class codec 1
session target ipv4:195.88.76.xx
!
!
line con 0
line aux 0
line vty 0 4
privilege level 15
line vty 5 15
privilege level 15
!
end

 

Модули:

 

VoIP_cisco#sh inv
NAME: "1751 chassis", DESCR: "1751 chassis, Hw Serial#: 2472228613, Hw Revision: 0x600"
PID: 1751              , VID: 0x600, SN: JAD064207GW (2472228613)

NAME: "Chassis Slot", DESCR: "1700 Chassis Slot"
PID: 1700 Chassis Slot , VID:    , SN:

NAME: "C1751 Mainboard", DESCR: "C1751 Mainboard"
PID: C1751 Mainboard   , VID: 0x600, SN: JAD064207GW (2472228613)

NAME: "Daughter card slot:0", DESCR: "1700 DaughterCard Slot"
PID: 1700 DaughterCard Slot, VID:    , SN:

NAME: "WIC/VIC 0", DESCR: "One port E1 voice interface daughtercard"
PID: One port E1 voice interface daughtercard, VID: 1.0, SN: 33504710

NAME: "E1 0/0", DESCR: "E1 0/0"
PID: E1 0/0            , VID:    , SN:

NAME: "FastEthernet0/0", DESCR: "PQUICC_FEC"
PID: PQUICC_FEC        , VID:    , SN:

NAME: "Daughter card slot:1", DESCR: "1700 DaughterCard Slot"
PID: 1700 DaughterCard Slot, VID:    , SN:

NAME: "Daughter card slot:2", DESCR: "1700 DaughterCard Slot"
PID: 1700 DaughterCard Slot, VID:    , SN:

NAME: "DSP Module Slot", DESCR: "Packet Voice DSP Module Slot 0"
PID: Packet Voice DSP Module Slot 0, VID:    , SN:

NAME: "DSP Module", DESCR: "Packet Voice DSP Module with 3 C549 DSPs"
PID: Packet Voice DSP Module with 3 C549 DSPs, VID: 2.2, SN: ICP044002W7

NAME: "DSP Module Slot", DESCR: "Packet Voice DSP Module Slot 1"
PID: Packet Voice DSP Module Slot 1, VID:    , SN:

NAME: "DSP Module", DESCR: "Packet Voice DSP Module with 3 C549 DSPs"
PID: Packet Voice DSP Module with 3 C549 DSPs, VID: 2.2, SN: ICP044002W7

 

 

Статус потока:

 

VoIP_cisco#sh isdn status
Global ISDN Switchtype = primary-net5
ISDN Serial0/0:15 interface
        dsl 0, interface ISDN Switchtype = primary-net5
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 0 CCBs = 0
    The Free Channel Mask:  0xFFFF7FFF
    Number of L2 Discards = 0, L2 Session ID = 33
    Total Allocated ISDN CCBs = 0

 

Статус DSP:

 

VoIP_cisco#sh voice dsp

DSP  DSP             DSPWARE CURR  BOOT                         PAK     TX/RX
TYPE NUM CH CODEC    VERSION STATE STATE   RST AI VOICEPORT TS ABORT  PACK COUNT
==== === == ======== ======= ===== ======= === == ========= == ===== ============

Active Voice Call details


Current total analog signalling channels: 0
Current max allowed digital timeslot for voice: 36
Current number of DSP group: 1
Group 0:
Current allocated analog signalling channels: 0
Current free analog signalling channels: 0
Current allocated digital signalling channels: 30
Current free digital signalling channels: 6
Port(s) served: 0/0
Current Available MIPS: 600
SPMM  DSPRM  State   Image     D-sig  D-sig     A-sig  A-sig  Mips Voice/Xcode
  Dsp   Dsp                  allocate   free  allocate   free  Free     Chan
  0/0     0      UP   FLEX6         6      0         0      0   100        0
  0/1     1      UP   FLEX6         6      0         0      0   100        0
  0/2     2      UP   FLEX6         6      0         0      0   100        0
  1/0     3      UP   FLEX6         6      0         0      0   100        0
  1/1     4      UP   FLEX6         6      0         0      0   100        0
  1/2     5      UP   FLEX6         0      6         0      0   100        0

 

Включаем дебаг:

VoIP_cisco#debug isdn q931
debug isdn q931 is              ON.

 

Смотрим:

VoIP_cisco#term mon

 

И видим при звонке:

 

VoIP_cisco#

*Mar 1 02:46:17.223: ISDN Se0/0:15 Q931: RX <- SETUP pd = 8 callref = 0x0027

Bearer Capability i = 0x8090A3

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA18381

Preferred, Channel 1

Calling Party Number i = 0x2181, '9**12770*1'

Plan:ISDN, Type:National

Called Party Number i = 0x81, '9**306*2'

Plan:ISDN, Type:Unknown

*Mar 1 02:46:17.251: ASSERTION FAILED: file "../src-m860-les/if_ipm_c54x_idma.c", line 655

*Mar 1 02:46:17.251: ISDN Se0/0:15 Q931: TX -> CALL_PROC pd = 8 callref = 0x8027

Channel ID i = 0xA98381

Exclusive, Channel 1

*Mar 1 02:46:17.251: ISDN Se0/0:15 Q931: TX -> CONNECT pd = 8 callref = 0x8027

*Mar 1 02:46:17.347: ISDN Se0/0:15 Q931: RX <- CONNECT_ACK pd = 8 callref = 0x0027

*Mar 1 02:46:43.723: %IPM_C54X-1-DSP_TIMEOUT: dsp 0 NOT RESPONDING.

*Mar 1 02:46:43.723: ASSERTION FAILED: file "../src-m860-les/ipm_dsprm_c1700.c", line 3310

*Mar 1 02:46:43.735: ISDN Se0/0:15 Q931: TX -> DISCONNECT pd = 8 callref = 0x8027

Cause i = 0x8090 - Normal call clearing

*Mar 1 02:46:43.799: ISDN Se0/0:15 Q931: RX <- RELEASE pd = 8 callref = 0x0027

*Mar 1 02:46:43.803: ISDN Se0/0:15 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x8027

*Mar 1 02:46:53.723: %IPM_C54X-1-DSP_TIMEOUT: dsp 2 NOT RESPONDING.

 

"Интересное" выделено жирным. Судя по похожим проблемам трабла в битых модулях PVDM (их там два). Вопрос извечный - кто виноват и что делать? В присланном вместе с бандлом протоколе тестирования значится только инвентаризация (конечно же в ней все есть). Или все-таки у меня что-то напутано в конфиге (не похоже, но все-таки..)?

Edited by sumjohn

Share this post


Link to post
Share on other sites

Всё правильно - битый PVDM. У меня была та же проблема. Проверьте PVDM по одному. И вычислите битый. Обратитесь в НАГ(если там покупали). Они без проблем заменят.

Share this post


Link to post
Share on other sites

Всё правильно - битый PVDM. У меня была та же проблема. Проверьте PVDM по одному. И вычислите битый. Обратитесь в НАГ(если там покупали). Они без проблем заменят.

Спасибо за ответ, обращусь к менеджеру по поводу замены. Не отвечают же оба модуля, судя по дебагу? Или есть вероятность, что один нормальный?.. дело в том, что физически манипуляции с роутером затрудненны ввиду отсутствия доступа к нему (находится в другом городе и мотаться туда-сюда ради вычисления не совсем целесообразно. Точнее, хотелось бы по максимуму оценить ситуацию удаленно, насколько возможно)

Share this post


Link to post
Share on other sites

В эти бандлы ставят PVDM-12 вместо PVDM-256k-12, которые должны ставится согласно напутствию Cisco.

Проверяется это командой sh diag, которую предлагаю опубликовать.

 

Share this post


Link to post
Share on other sites
В эти бандлы ставят PVDM-12 вместо PVDM-256k-12, которые должны ставится согласно напутствию Cisco.

Проверяется это командой sh diag, которую предлагаю опубликовать.

Интересно. Вот инфа с магазина: Cisco 1751 E1 bundle.

 

Вот sh diag:

VoIP_cisco#sh diag
Slot 0:
        C1751 1FE VE DV Mainboard Port adapter, 2 ports
        Port adapter is analyzed
        Port adapter insertion time unknown
        EEPROM contents at hardware discovery:
        Hardware Revision        : 6.0
        PCB Serial Number        : JAD064207GW
        Part Number              : 73-5128-06
        Board Revision           : B0
        Fab Version              : 04
        Product (FRU) Number     : CISCO1751
        EEPROM format version 4
        EEPROM contents (hex):
          0x00: 04 FF 40 02 4D 41 06 00 C1 8B 4A 41 44 30 36 34
          0x10: 32 30 37 47 57 82 49 14 08 06 42 42 30 02 04 FF
          0x20: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x30: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x40: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x50: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x60: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

        Packet Voice DSP Module Slot 0:
        Hardware Revision        : 2.2
        Part Number              : 73-3691-01
        Board Revision           : A0
        Deviation Number         : 0-0
        Fab Version              : 02
        PCB Serial Number        : ICP044002W7
        RMA Test History         : 00
        RMA Number               : 0-0-0-0
        RMA History              : 00
        Processor type           : 02
        Number of DSP's          : 3
        DSP memory size(in kwords): 192
        Type of DSP              : TMS320C549
        Product (FRU) Number     : PVDM-12=
        EEPROM format version 4
        EEPROM contents (hex):
        0x00:   04 FF 40 01 5C 41 02 02 82 49 0E 6B 01 42 41 30
        0x10:   80 00 00 00 00 02 02 C1 8B 49 43 50 30 34 34 30
        0x20:   30 32 57 37 03 00 81 00 00 00 00 04 00 09 02 FF

        Packet Voice DSP Module Slot 1:
        Hardware Revision        : 2.2
        Part Number              : 73-3691-01
        Board Revision           : A0
        Deviation Number         : 0-0
        Fab Version              : 02
        PCB Serial Number        : ICP044002W7
        RMA Test History         : 00
        RMA Number               : 0-0-0-0
        RMA History              : 00
        Processor type           : 02
        Number of DSP's          : 3
        DSP memory size(in kwords): 192
        Type of DSP              : TMS320C549
        Product (FRU) Number     : PVDM-12=
        EEPROM format version 4
        EEPROM contents (hex):
        0x00:   04 FF 40 01 5C 41 02 02 82 49 0E 6B 01 42 41 30
        0x10:   80 00 00 00 00 02 02 C1 8B 49 43 50 30 34 34 30
        0x20:   30 32 57 37 03 00 81 00 00 00 00 04 00 09 02 FF

        WIC/VIC Slot 0:
        E1 (1 port) Multi-Flex Trunk WAN daughter card
        Hardware revision 1.0   Board revision B0
        Serial number     0033504710    Part number    800-04475-03
        FRU Part Number   WIC/VIC-E1=

        Test history      0x00          RMA number     00-00-00
        Connector type    PCI
        EEPROM format version 1
        EEPROM contents (hex):
        0x20:   01 21 01 00 01 FF 3D C6 50 11 7B 03 00 00 00 00
        0x30:   58 00 00 00 02 12 23 00 FF FF FF FF FF FF FF FF

 

То есть и правда установлены PVDM-12.

Edited by sumjohn

Share this post


Link to post
Share on other sites

Все нормально, производят замену. Сейчас тестируют новые (для нас, на самом деле они, конечно же, б/у) и вышлют. Собственно, спасибо всем, тему можно закрывать.

Share this post


Link to post
Share on other sites

хмм.. спасибо за уточнение. Выслал информацию а расхождении инфы о модулях менеджеру, надеюсь меры приняты будут. Высланы, опять-таки надеюсь, будут PVDM-12.

Share this post


Link to post
Share on other sites

У них продано более сотни таких коробок. Проблем именно PVDM-12 vs. PVDM-256k-12 не было.

Собственно на сайте cisco.com в одном месте пишут PVDM12, в другом уже PVDM-256k-12 что для NM-HDV, что для 1700.

И тот и другой тип сделан на базе одного и того же с549.

Share this post


Link to post
Share on other sites
Собственно на сайте cisco.com в одном месте пишут PVDM12, в другом уже PVDM-256k-12 что для NM-HDV, что для 1700.
дайте ссылку на cisco.com где такое написано

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this