Jump to content
Калькуляторы

Проброс pppoe

есть такая схема

 

[c2950] - [c2950] - [3550] - [5350]

В 2950 подключен народ, некоторые из них должны видить друг-друга, а некорые нет. У каждого свой vlan. В 5350 запущен pppoe сервер.

Собственно вопрос, как пробросить pppoe через 3550 ? relay pppoe на 3550 нет (

 

Есть возможность сделать на интерфейсах bridge, но как сделать чтобы бриджить только на определенный интерфейс (на тот куда подключена 3550)?

 

Кто что посоветует ?

Share this post


Link to post
Share on other sites

Эмм... в чем проблема то пропускай вланы и все... или чего то не указано в начальных условиях?

Share this post


Link to post
Share on other sites
Эмм... в чем проблема то пропускай вланы и все... или чего то не указано в начальных условиях?
Забыл, что возможен такой варинт. Проброс vlan не возможен.

       [3550] ------------[3550]-------- [5350]
         |                     |
[c2950] - [c2950]     [c2950]-[c2950]

 

В пределах каждой 3550 стоит уникальные vlan (на 3550 vlan агрегируются). Две 3550 и 5350 общаются по своему vlan. На 3550 уже настраивается route куда кому ходить.

Edited by AdmSasha

Share this post


Link to post
Share on other sites

http://www.cisco.com/en/US/docs/switches/l...e/swfallbk.html

 

за производительность не ручаюсь, я не пробовал, может быть он процом бридж делает.

 

перечитал первое сообщение :)

на 3550 routed порты между друг другом и 5300? тогда вы сможете создать один бридж домен, допустим для всех пппое клиентов, да при этом надо сделать один влан в пределах 3550 на этих клиентов.

транк надо было сразу делать, и пару-тройку вланов выделить вот под такие специфические нужды.

Share this post


Link to post
Share on other sites

А что мешает пропустить по всем свичам отдельный PPPoE влан ?

И кого надо (абонентов) переводить в это влан.

Share this post


Link to post
Share on other sites

Переходите на EoIP.

Edited by photon

Share this post


Link to post
Share on other sites
А что мешает пропустить по всем свичам отдельный PPPoE влан ?

И кого надо (абонентов) переводить в это влан.

pppoe нужен всем, в вот доступ друг с другом не всем.

 

Переходите на EoIP.
Можно чуть подробнее, кодом ? Что это такое прочитал, но как это реализуется на cisco так и не нашел.

 

Незнаю, оно или нет, но есть xconnect. Но её опять же нет на 3550..

Share this post


Link to post
Share on other sites
Эмм... в чем проблема то пропускай вланы и все... или чего то не указано в начальных условиях?
Забыл, что возможен такой варинт. Проброс vlan не возможен.

В пределах каждой 3550 стоит уникальные vlan (на 3550 vlan агрегируются). Две 3550 и 5350 общаются по своему vlan. На 3550 уже настраивается route куда кому ходить.

Не вижу в чем невозможность проброски всех вланов на 5350? Пусть себе 3550 роутят что угодно куда угодно, это абсолютно не мешает транком кинуть все уникальные вланы абонентов на 5350. На пустом месте проблему нарыли.

Share this post


Link to post
Share on other sites
Переходите на EoIP.
Можно чуть подробнее, кодом ? Что это такое прочитал, но как это реализуется на cisco так и не нашел.

Малость буквы перепутал. Имелось в виду IPoE -- просто IP и Ethernet, без использования PPPoE. Аутентификацию можно делать с помощью DHCP с option 82 и привязкой к MAC. Хорошо бы еще и свичи на доступе поддерживали какие-то возможности фильтрации и port security. Вопросы о преимуществах и недостатках этих решений обсуждались в следующих темах:

http://forum.nag.ru/forum/index.php?showto...48543&st=80

http://forum.nag.ru/forum/index.php?showtopic=41369

Полезная ссылка: http://xgu.ru/wiki/DHCP_option_82

Edited by photon

Share this post


Link to post
Share on other sites

>pppoe нужен всем, в вот доступ друг с другом не всем.

 

Заворачиваете всех на PPPoE. Там и определяете кому и куда ходить.

 

Share this post


Link to post
Share on other sites
Эмм... в чем проблема то пропускай вланы и все... или чего то не указано в начальных условиях?
Забыл, что возможен такой варинт. Проброс vlan не возможен.

В пределах каждой 3550 стоит уникальные vlan (на 3550 vlan агрегируются). Две 3550 и 5350 общаются по своему vlan. На 3550 уже настраивается route куда кому ходить.

Не вижу в чем невозможность проброски всех вланов на 5350? Пусть себе 3550 роутят что угодно куда угодно, это абсолютно не мешает транком кинуть все уникальные вланы абонентов на 5350. На пустом месте проблему нарыли.

Во первых, 1000vlan == 1000 интерфейсов на 5350 ?

Vlan уникальный только до своей 3550. Если я пропускать буду транком эти vlan, то нужно делать уникальным во всей сети ?

 

 

Хорошо бы еще и свичи на доступе поддерживали какие-то возможности фильтрации и port security.
2950 не неподдеживают port security.

 

Заворачиваете всех на PPPoE. Там и определяете кому и куда ходить.
Будет ли разумно гонять всех до 5350 и обратно, если можно гонять трафик только до 3550 ?

 

Share this post


Link to post
Share on other sites
2950 не неподдеживают port security.

sw2>sh ver

Cisco Internetwork Operating System Software

IOS C2950 Software (C2950-I6Q4L2-M), Version 12.1(22)EA13, RELEASE SOFTWARE (fc2)

Model number: WS-C2950T-24

 

interface FastEthernet0/1

switchport access vlan 4

switchport mode access

switchport port-security

switchport port-security maximum 2

switchport port-security aging time 2

switchport port-security violation restrict

switchport port-security aging type inactivit

 

 

 

Share this post


Link to post
Share on other sites
interface FastEthernet0/1

switchport access vlan 4

switchport mode access

switchport port-security

switchport port-security maximum 2

switchport port-security aging time 2

switchport port-security violation restrict

switchport port-security aging type inactivit

Да, но этим от подделки IP не спасешь

Share this post


Link to post
Share on other sites

Если у вас влан на клиента, то зачем еще сюда пристраивать костыль в виде pppoe?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this