Перейти к содержимому
Калькуляторы

wccp 2 wccp 2

пытаюсь настроить wccp 2

написал

ip wccp vers 2

ip wccp web-cache redirect-list ProxyUsers

ip access-list standard ProxyUsers

permit 10.0.98.0 0.0.0.255

 

на циске есть интерфейсы

interface Tunnel0

description Tunnel To Net

ip address 77.95.184.6 255.255.255.252

ip nat outside

ip virtual-reassembly

tunnel source 192.168.10.10

tunnel destination 192.168.10.2

tunnel mode ipip

tunnel bandwidth transmit 3000

!

interface FastEthernet0/0

ip address 77.95.191.220 255.255.255.224 secondary

ip address 10.90.90.1 255.255.255.0 secondary

ip address 77.95.188.1 255.255.255.128

ip wccp web-cache redirect in

ip nat inside

ip virtual-reassembly

speed auto

full-duplex

no mop enabled

!

interface FastEthernet0/1

no ip address

no ip unreachables

speed auto

full-duplex

no mop enabled

!

interface FastEthernet0/1.1

encapsulation dot1Q 2

ip address 192.168.10.10 255.255.255.248

no cdp enable

!

interface FastEthernet0/1.2

encapsulation dot1Q 3

ip address 192.168.1.12 255.255.255.248

no cdp enable

 

сквид стоит на бсд 7.2

на нем же есть тунель

gre0: flags=d051<UP,POINTOPOINT,RUNNING,LINK0,LINK2,MULTICAST> metric 0 mtu 1476

tunnel inet 77.95.191.193 --> 77.95.191.220

inet 10.9.9.9 --> 10.9.9.10 netmask 0xff000000

 

но

sh ip wccp

Global WCCP information:

Router information:

Router Identifier: 192.168.10.10

Protocol Version: 2.0

 

Service Identifier: web-cache

Number of Service Group Clients: 0

Number of Service Group Routers: 0

Total Packets s/w Redirected: 0

Process: 0

Fast: 0

CEF: 0

Redirect access-list: ProxyUsers

Total Packets Denied Redirect: 0

Total Packets Unassigned: 0

Group access-list: -none-

Total Messages Denied to Group: 0

Total Authentication failures: 0

Total Bypassed Packets Received: 0

 

смущает

1) почрему Router Identifier:192.168.10.10 и как его изменить на 77.95.191.220 ? так как 192.168.10.10 на другом вилане и прокси он не увидит даже если очень захочет

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

кусок с моего мануала к настройке одной фичи к биллингу:

 

# Для WCCP2 нужно добавить "link2". Например:
#/sbin/ifconfig gre0 xxx.xxx.149.3 xxx.xxx.149.2 netmask 255.255.255.255 link2 up

# 192.168.100.3 – IP прокси-сервера, 192.168.100.2 – IP Cisco.
/sbin/ifconfig gre0 create
/sbin/ifconfig gre0 192.168.100.3 192.168.100.2 netmask 255.255.255.255 up
/sbin/ifconfig gre0 tunnel 192.168.100.3 192.168.100.2
/sbin/route delete 192.168.100.2
# 127.0.0.1,3128 - адрес и порт, куда будут направляться запросы клиентов.
/sbin/ipfw add 400 fwd 127.0.0.1,3128 tcp from any to any http via gre0

# Блок выше нужно повторить для каждого интерфейса Cisco, на котором установлен IP-адрес,
# т.к. Cisco может произвольно выбрать IP интерфейса, с которого пойдет запрос. (Точнее
# Cisco выберет последний созданный интерфейс в системе, которому присвоен IP)
# Не забудьте дать разные имена интерфейсам (gre1, gre2 и т.д.)

Т.е. в блоках меняете только адреса интефейсов циски, адреса сквида оставляете как есть.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

а исходя из чего она выбирает ? так как тот интерфейс на котором WCCP2 сейчас не имеет ничего общего ни с интернетом ни с маршрутизаторами ни с серверами ... с этого интерфейса невозможно их увидать .. они все в другом вилане

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
а исходя из чего она выбирает ? так как тот интерфейс на котором WCCP2 сейчас не имеет ничего общего ни с интернетом ни с маршрутизаторами ни с серверами ... с этого интерфейса невозможно их увидать .. они все в другом вилане
Это индусам с циски задавайте такие вопросы. Сделайте как написано выше и все должно заработать. Я на этих граблях в свое время две недели мучился... И в инете нигде вообще ни строчки об этом.

На линуксе такой пляски нет, создал if-gre0 и забыл и про роутер-идентиферы и всякую прочую фигню.

Изменено пользователем Vicus

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

сделал гре на все ип адреса что в циске ... 0 реакции .... идентификатор указывает на ип того интерфейса в котором вилан ид не совпадает с вилан ид прокси

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
сделал гре на все ип адреса что в циске ... 0 реакции .... идентификатор указывает на ип того интерфейса в котором вилан ид не совпадает с вилан ид прокси
Да что вы заладили со своим Router Identifier'ом....

 

#sh ip wccp web-cache        
Global WCCP information:
    Router information:
        Router Identifier:                   192.168.144.1
        Protocol Version:                    2.0

    Service Identifier: web-cache
        Number of Service Group Clients:     1
        Number of Service Group Routers:     1
        Total Packets s/w Redirected:        3779959474
          Process:                           50042
          Fast:                              399
          CEF:                               3779909033
        Service mode:                        Open
        Service access-list:                 -none-
        Total Packets Dropped Closed:        0
        Redirect access-list:                111
        Total Packets Denied Redirect:       345785725
        Total Packets Unassigned:            2470356386
        Group access-list:                   -none-
        Total Messages Denied to Group:      0
        Total Authentication failures:       0
        Total Bypassed Packets Received:     0

 

#sh ip wccp web-cache detail 
WCCP Client information:
        WCCP Client ID:          xx.yyy.149.4
        Protocol Version:        2.0
        State:                   Usable
        Initial Hash Info:       00000000000000000000000000000000
                                 00000000000000000000000000000000
        Assigned Hash Info:      FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
                                 FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
        Hash Allotment:          256 (100.00%)
        Packets s/w Redirected:  483822930
        Connect Time:            3d04h
        Bypassed Packets
          Process:               0
          Fast:                  0
          CEF:                   0

Подсети разные, но оно все прекрасно видится... крутите гайки.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Извините, вклинюсь в тему: а под солярой GRE не придумали есчё ? Хотел на соляре SQUID организовать...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Извините, вклинюсь в тему: а под солярой GRE не придумали есчё ? Хотел на соляре SQUID организовать...

А вам обязательно wccp нужен? Может сойдет и route-map?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Наплодил тунелей

 

gre0: flags=f051<UP,POINTOPOINT,RUNNING,LINK0,LINK1,LINK2,MULTICAST> metric 0 mtu 1476

tunnel inet 77.95.191.193 --> 10.0.90.253

inet 192.168.22.22 --> 192.168.22.23 netmask 0xfffffffc

gre2: flags=d051<UP,POINTOPOINT,RUNNING,LINK0,LINK2,MULTICAST> metric 0 mtu 1476

tunnel inet 77.95.191.193 --> 77.95.188.1

inet 192.168.22.33 --> 192.168.22.34 netmask 0xfffffffc

gre3: flags=d051<UP,POINTOPOINT,RUNNING,LINK0,LINK2,MULTICAST> metric 0 mtu 1476

tunnel inet 77.95.191.193 --> 192.168.1.12

inet 192.168.22.36 --> 192.168.22.37 netmask 0xfffffffc

gre4: flags=d051<UP,POINTOPOINT,RUNNING,LINK0,LINK2,MULTICAST> metric 0 mtu 1476

tunnel inet 77.95.191.193 --> 77.95.191.220

inet 192.168.22.38 --> 192.168.22.39 netmask 0xfffffffc

gre5: flags=d051<UP,POINTOPOINT,RUNNING,LINK0,LINK2,MULTICAST> metric 0 mtu 1476

tunnel inet 77.95.191.193 --> 77.95.184.6

inet 192.168.22.42 --> 192.168.22.43 netmask 0xfffffffc

gre6: flags=d051<UP,POINTOPOINT,RUNNING,LINK0,LINK2,MULTICAST> metric 0 mtu 1476

tunnel inet 77.95.191.193 --> 10.0.90.252

inet 192.168.22.47 --> 192.168.22.48 netmask 0xfffffffc

 

в сквиде

wccp2_router 192.168.10.10

wccp2_address 77.95.191.193

 

sh ip wccp

Global WCCP information:

Router information:

Router Identifier: 192.168.10.10

Protocol Version: 2.0

 

Service Identifier: web-cache

Number of Service Group Clients: 0

Number of Service Group Routers: 0

Total Packets s/w Redirected: 0

Process: 0

Fast: 0

CEF: 0

Redirect access-list: ProxyUsers

Total Packets Denied Redirect: 0

Total Packets Unassigned: 0

Group access-list: -none-

Total Messages Denied to Group: 0

Total Authentication failures: 0

Total Bypassed Packets Received: 0

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

00400 497567 66775903 fwd 127.0.0.1,3128 tcp from any to any dst-port 80 in via gre0 пахало пока идент не сменился вот я и прицепился

00600 0 0 fwd 127.0.0.1,3128 tcp from any to any dst-port 80 in via gre1

00700 0 0 fwd 127.0.0.1,3128 tcp from any to any dst-port 80 in via gre2

00800 0 0 fwd 127.0.0.1,3128 tcp from any to any dst-port 80 in via gre3

00900 0 0 fwd 127.0.0.1,3128 tcp from any to any dst-port 80 in via gre4

01000 0 0 fwd 127.0.0.1,3128 tcp from any to any dst-port 80 in via gre5

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Извините, вклинюсь в тему: а под солярой GRE не придумали есчё ? Хотел на соляре SQUID организовать...
А вам обязательно wccp нужен? Может сойдет и route-map?

Да совершенно не хотелось бы маршрутизацию на соляре поднимать, как то постандартней будет WCCP

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Да совершенно не хотелось бы маршрутизацию на соляре поднимать, как то постандартней будет WCCP
Дык спрашивайте у солярщиков тогда :) Есть ли у них реализация gre.

 

 

asternet, у вас проблема не с gre сейчас имхо. Раз циска не видит кэша, значит от сквида не доходит wccp-пакеты инициализации...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

как раз о этом я и толдычу кеш находится на vlan 1 а интерфейс на который прилип этот четров wccp vlan 2 а свич умный .. и по этому трафик туда не гонится :)

 

кстате

ping ip 77.95.191.193 source 192.168.10.10

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 77.95.191.193, timeout is 2 seconds:

Packet sent with a source address of 192.168.10.10

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

 

ping -c 5 -S 77.95.191.193 192.168.10.10

PING 192.168.10.10 (192.168.10.10) from 77.95.191.193: 56 data bytes

64 bytes from 192.168.10.10: icmp_seq=0 ttl=255 time=0.709 ms

64 bytes from 192.168.10.10: icmp_seq=1 ttl=255 time=0.694 ms

64 bytes from 192.168.10.10: icmp_seq=2 ttl=255 time=0.690 ms

64 bytes from 192.168.10.10: icmp_seq=3 ttl=255 time=1.448 ms

64 bytes from 192.168.10.10: icmp_seq=4 ttl=255 time=1.182 ms

 

--- 192.168.10.10 ping statistics ---

5 packets transmitted, 5 packets received, 0.0% packet loss

round-trip min/avg/max/stddev = 0.690/0.945/1.448/0.314 ms

 

Изменено пользователем asternet

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

сообразил включить лог :)

000974: *Nov 13 12:30:59.201 UTC: %SYS-5-CONFIG_I: Configured from console by astermon on vty0 (10.0.98.13)

000975: *Nov 13 12:31:03.445 UTC: WCCP-PKT:S00: Sending I_See_You packet to 77.95.191.193 w/ rcv_id 00000001

000976: *Nov 13 12:31:13.445 UTC: WCCP-EVNT:S00: Here_I_Am packet from 77.95.191.193 w/bad rcv_id 00000000

000977: *Nov 13 12:31:13.445 UTC: WCCP-PKT:S00: Sending I_See_You packet to 77.95.191.193 w/ rcv_id 00000002

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Предлагаю работу в сети(инвестиционный проект)! заработок 25-100.. тыс в месяц (не лохотрон и не кидалово) всем кто заинтересован : icq 451222144

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

tcpdump -i bce1 src 192.168.10.10 or src 77.95.191.193 and proto UDP and port not domain

tcpdump: verbose output suppressed, use -v or -vv for full protocol decode

listening on bce1, link-type EN10MB (Ethernet), capture size 96 bytes

19:28:15.649961 IP gate.asternet.am..dls-monitor > 192.168.10.10.dls-monitor: UDP, length 144

19:28:25.650978 IP gate.asternet.am..dls-monitor > 192.168.10.10.dls-monitor: UDP, length 144

19:28:35.652966 IP gate.asternet.am..dls-monitor > 192.168.10.10.dls-monitor: UDP, length 144

19:28:45.653864 IP gate.asternet.am..dls-monitor > 192.168.10.10.dls-monitor: UDP, length 144

19:28:55.654829 IP gate.asternet.am..dls-monitor > 192.168.10.10.dls-monitor: UDP, length 144

19:29:05.655794 IP gate.asternet.am..dls-monitor > 192.168.10.10.dls-monitor: UDP, length 144

 

обратно пакеты не идут с ответом эт так и должно быть?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

дорвался до истины

в настройках сквида wccp2_router надо пиусать ип того интерфейса циски которая в той же физической сети что и кеш в не зависимости от того что пишит раутер идентифаер

а гре тунель должен быть именно на тот айпи который указан в раутер идентифаер

к примеру

айпишники физически интерфейсков циски и бсд 10.80.80.1 10.80.80.2 соответственно .. в циске раутер идентифаер 192.168.10.10

в сквиде

wccp2_router 10.80.80.1 (ip cisco)

wccp2_address 10.80.80.2 (ip bsd)

 

конфиг тунеля

ifconfig gre0 plumb

ifconfig gre0 link2 ip1 ip2 mask ect

ifconfig gre0 tunnel 10.80.80.2 192.168.10.10

ifconfig gre0 up

ну и правила ipfw для заварота трафика на проксю из gre0

надеюсь эта инфа еще кому нибудь поможет :)

 

Изменено пользователем asternet

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Поэтому и сказал создать интерфейсы на все IP-ники. Попробуйте сейчас назначить новому интерфейсу IP-ку. Смотрите и улыбайтесь :)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

да циска тупо переводит идентифаер на новый интерфейс .. хотя не передовит на новый влан .. одного и того же интерфейса ... в общем муть :)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Весь день промучился со вторым wccp, в результате сменил в squid wccp_address 10.0.1.5 на wccp2_address 10.0.1.5 и все забегало. :)

В общем настройки у меня следущие:

cisco router (2821, ios c2800nm-advipservicesk9-mz.150-1.XA.bin)

(config)#ip wccp version 2

(config)#ip wccp web-cache redirect-list REDIRECT_HTTP

(config)#int GigabitEthernet0/0

(config-subif)#ip wccp web-cache redirect in

 

На FreeBSD сервере в конфиге squid(squid-3.0.19):

wccp2_return_method 1

wccp2_address 10.0.1.5

wccp2_router 10.0.1.1

wccp2_rebuild_wait on

wccp2_forwarding_method 1

wccp2_assignment_method 1

wccp2_service standard 0

 

cat /etc/rc.conf | grep gre0

cloned_interfaces="gre0"

ifconfig_gre0="tunnel 10.0.1.5 192.168.255.253 link2 up"

 

ipfw show | grep gre0

fwd 10.0.1.5,3128 tcp from any to any dst-port 80 recv gre0

 

На cisco

#sh ip wccp summary

WCCP version 2 enabled, 1 service

 

Service Clients Routers Assign Redirect Bypass

------- ------- ------- ------ -------- ------

Default routing table (Router Id: 192.168.255.253):

web-cache 1 1 HASH GRE GRE

 

#sh ip wccp web-cache detail

WCCP Client information:

WCCP Client ID: 10.0.1.5

Protocol Version: 2.0

State: Usable

Redirection: GRE

Packet Return: GRE

Assignment: HASH

Initial Hash Info: 00000000000000000000000000000000

00000000000000000000000000000000

Assigned Hash Info: FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF

FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF

Hash Allotment: 256 (100.00%)

Packets s/w Redirected: 122890

Connect Time: 01:20:05

GRE Bypassed Packets

Process: 0

CEF: 0

Errors: 0

 

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас