Jump to content
Калькуляторы

Mikrotik и проблема с PPTP подключением Проблема с одинаковыми айпи адресами

Здравствуйте. Имеется один канал который получаю по PPPoE и вот недавно появилась возможность подключить еще один, но через PPTP, они подключаются на Mikrotik 3.30. Но вот появилась проблема с подключением канала через PPTP, оказывается что сетевой айпи VPN сервера, совпадает с адресом сервера в PPTP подключении, и впн как бы закольцовывается, соответственно доступ в интернет не работает. Способ по замене в PPP профиле Remote Address не помог, при таком способе PPTP на провайдера не может подключится.

Помогите, уже не знаю в какую сторону копать.

Share this post


Link to post
Share on other sites

прописывайте маршрутизацию не на IP шлюза, а на целевой интерфейс:

 

ip route add default dev pppp10

вместо ip route add default via 192.168.0.1

 

в случае с ppp это одно и тоже, т.к. это тунельный интерфейс, и данные туда (в тунель) отправленные любым способом сенепременнейше попадут на другую сторону.

 

и вообще, уточняйте интерфейс при вводе маршрутов, иногда очень помогает.

Edited by [anp/hsw]

Share this post


Link to post
Share on other sites

Роуты указаны на интерфейсы, но при подключении PPTP он создаёт себе динамический роут с меньшей метрикой на себя....

 

10.0.10.0/24 - адресное пространство провайдера

10.0.10.223 - адрес интерфейса смотрящего в сторону провайдера

10.0.10.1 - VPN сервер провайдера

 

Добавляю шлюз по умолчанию 0.0.0.0/0 10.0.10.1

Создаю PPTP подключение на адрес 10.0.10.1

При подключении PPTP провайдер выдаёт:

Адрес клиента 10.1.1.3

Адрес сервера опять же 10.0.10.1

 

Проверял как это работает на Windows XP. При поднятии vpn шлюзом становится 10.1.1.3

Edited by guruks

Share this post


Link to post
Share on other sites

в конфиге ppp напишите nodefaultroute, и добавляйте роут на интерфейс вручную уже потом (например из if-up)

шлюз по умолчанию на локалке вам добавлять не нужно (ведь pptp-сервер провайдера находится в той же подсети)

 

Share this post


Link to post
Share on other sites

Выдача дефолтного роута на интерфейсе pptp-out1 выключена, дефотный роут на pptp-out1 я добавлял вручную, вобще странная ситуация...

 

Вот роуты

 

# DST-ADDRESS PREF-SRC GATEWAY DISTANCE

0 A S 0.0.0.0/0 pptp-out1 1

1 ADC 10.0.10.0/24 10.0.10.223 ether1 0

2 ADC 10.0.10.1/32 10.1.1.3 pptp-out1 0

 

 

Самое интересное что поснифил интерфейс ether1 на наличие pptp сесий, а там пусто! и только иногда появляется строка с pptp конектом на 10.0.10.1 .

Знач трафик начинает лезть в сам pptp-out1, а не на ether1 поэтому и нет интернета и шлюз 10.0.10.1 не пингуется при подключеном pptp-out1

Edited by guruks

Share this post


Link to post
Share on other sites

Решил проблему, в Addresses удалил динамически созданный айпи и шлюз впн подключения, создал вручную, только указал айпи отличный от провайдерского шлюза. Надеюсь кому то поможет

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this