Jump to content
Калькуляторы

Организация резервного канала при помощи туннеля Организация резервного канала при помощи туннеля

Здравствуйте!

 

Пытаюсь решить следующую задачу: имеются маршрутизаторs 7204VXR-G2 и 7206VXR-G2 соединенные между собой прямым линком с поднятым iBGP (коннект на адреса Loopback0). Каждый маршрутизатор принимает от апстрима Full BGP таблицу. Другим интерфейсом каждый маршрутизатор смотрит во внутреннюю сеть где на нескольких Catalyst 3550 поднят EIGRP. Необходимо организовать резервный канал на случай повреждения оптического кабеля (специфика такова, что при повреждении кабеля (уже были прецеденты) вся сеть "разрезается" практически пополам, т.к. линки между 7206-7204 и 3550-3550 проходят по одному кабелю). Для этих целей я пытаюсь настроить нешифрованный туннель через сети апстримов, однако опыты показали что туннель работает только через наши собственные линки.

 

 

конфиг CISCO 7204VXR-G2

 

interface Tunnel0

bandwidth 20000

ip address xxx.xxx.160.153 255.255.255.252

delay 100

tunnel source FastEthernet0/0

tunnel destination zzz.zzz.52.245

tunnel mode ipip

tunnel bandwidth transmit 18000

tunnel bandwidth receive 18000

max-reserved-bandwidth 90

 

interface Loopback0

ip address 172.16.2.1 255.255.255.0

 

interface FastEthernet0/0

description upstream2

ip address yyy.yyy.137.6 255.255.255.252

 

 

interface GigabitEthernet0/1

description link between 7206 and 7204 (рвется при повреждении)

ip address xxx.xxx.161.146 255.255.255.252

 

 

router eigrp 1

passive-interface FastEthernet0/0

passive-interface Loopback0

network xxx.xxx.160.112 0.0.0.3 (к ближайшей 3550 через нее есть рвущийся линк на третью 3550 и далее на 7206)

network xxx.xxx.160.152 0.0.0.3 (туннель)

network xxx.xxx.161.144 0.0.0.3 (прямой линк между 7204 и 7206 - рвется при повреждении)

network 172.16.2.0 0.0.0.255 (loopback)

network 192.168.2.4 0.0.0.3 (еще одна удаленная 3550 - рвется при повреждении)

 

 

ip route 0.0.0.0 0.0.0.0 yyy.yyy.137.5

 

 

конфиг CISCO 7204VXR-G2

 

interface Tunnel0

bandwidth 20000

ip address xxx.xxx.160.154 255.255.255.252

delay 100

tunnel source FastEthernet2/0

tunnel destination yyy.yyy.137.6

tunnel mode ipip

tunnel bandwidth transmit 18000

tunnel bandwidth receive 18000

max-reserved-bandwidth 90

 

 

interface Loopback0

ip address 172.16.1.1 255.255.255.0

 

interface GigabitEthernet0/1

description link between 7206 and 7204 (рвется при повреждении)

ip address xxx.xxx.161.145 255.255.255.252

 

interface FastEthernet2/0

description upstream1

ip address zzz.zzz.52.245 255.255.255.252

 

router eigrp 1

passive-interface FastEthernet0/0

passive-interface FastEthernet0/1

passive-interface FastEthernet1/0

passive-interface FastEthernet2/0

passive-interface Loopback0

network xxx.xxx.160.152 0.0.0.3 (туннель)

network xxx.xxx.161.64 0.0.0.3 (вторая ближняя 3550 через нее есть рвущийся линк на 7204)

network xxx.xxx.161.144 0.0.0.3 (прямой линк между 7204 и 7206 - рвется при повреждении)

network xxx.xxx.161.244 0.0.0.3 (к ближайшей 3550 через нее есть второй рвущийся линк на третью 3550 и далее 7204)

network 172.16.1.0 0.0.0.255 (loopback)

 

ip route 0.0.0.0 0.0.0.0 zzz.zzz.52.246

 

 

Подскажите где ошибка в конфигурации, т.к. при повреждении кабеля пропадают анонсы как iBGP, так и EIGRP между маршрутизаторами 7204/7206 и EIGRP между 3550. При этом туннель "падает" и не устанавливается через апстримов.

 

P.S. Арендовать доп каналы или вкладывать средства в прокладку второго маршрута прошу не рекомендовать.

 

Спасибо.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this