Jump to content
Калькуляторы

Cisco 1751 в качестве sip-proxy

Доброго времени суток!

Имею цыску 1751 с иосом Cisco IOS Software, C1700 Software (C1700-IPVOICE-M), Version 12.3(11)T11, RELEASE SOFTWARE (fc3)

 

Вот конфиг

 

Сейчас она включена по схеме такой

Абон. Шлюз---sip/rtp----Asterisk-----sip/rtp-----CISCO---sip/rtp----PSTIN

данная схема замечательно работает, звонки ходят в обе стороны, но есть одно но, астериск выступает в данном случае в качестве проксисервера, что не есть хорошо, стоит задача разгрузить астериск с использованием реинвайта, и привести всё вот к такой схеме:

Абон. Шлюз---sip----Asterisk

....||

so.Reinvite

....||

....+---rtp---CISCO---rtp----PSTIN

 

version 12.3

service nagle

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime localtime

service timestamps log datetime localtime

service password-encryption

service sequence-numbers

no service dhcp

!

hostname PROXY

!

boot-start-marker

boot system tftp c1700-ipvoice-mz.123-11.T11.bin 85.202.0.10

boot-end-marker

!

logging buffered 4096 debugging

!

memory-size iomem 20

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

aaa new-model

!

!

aaa session-id common

ip subnet-zero

ip cef

!

!

!

!

no ip domain lookup

no ftp-server write-enable

!

!

!

voice service voip

allow-connections sip to sip

redirect ip2ip

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback none

sip

registrar server expires max 3600 min 3600

redirect contact order best-match

no call service stop

!

!

!

voice class codec 1

codec preference 1 g711alaw

codec preference 2 g729r8

!

!

!

!

!

!

!

!

!

username max privilege 15 password 7 0827455C0C1D04121F0402

archive

log config

hidekeys

!

!

!

!

interface FastEthernet0/0

no ip address

speed auto

!

interface FastEthernet0/0.1

description ASTERISK

encapsulation dot1Q 3

ip address хх.хх.0.11 255.255.255.0

!

interface FastEthernet0/0.2

description VOIP-OPERATOR

encapsulation dot1Q 719

ip address 172.16.123.62 255.255.255.252

!

ip classless

ip route 0.0.0.0 0.0.0.0 хх.хх.0.1

ip route 10.9.0.8 255.255.255.252 хх.хх.0.8

ip route 10.15.0.0 255.255.0.0 172.16.123.61

ip route 10.101.0.0 255.255.0.0 172.16.123.61

ip route 10.102.0.0 255.255.0.0 172.16.123.61

ip route 10.103.0.0 255.255.0.0 172.16.123.61

ip route 10.104.0.0 255.255.0.0 172.16.123.61

ip route 10.105.0.0 255.255.0.0 172.16.123.61

ip route 10.106.0.0 255.255.0.0 172.16.123.61

ip route 10.107.0.0 255.255.0.0 172.16.123.61

ip route 10.108.0.0 255.255.0.0 172.16.123.61

ip route 172.16.0.0 255.255.0.0 172.16.123.61

ip route 172.17.0.0 255.255.0.0 172.16.123.61

ip route 172.18.0.0 255.255.0.0 172.16.123.61

ip route 172.19.0.0 255.255.0.0 172.16.123.61

ip route 172.20.0.0 255.255.0.0 172.16.123.61

ip route 172.21.0.0 255.255.0.0 172.16.123.61

ip route 172.22.0.0 255.255.0.0 172.16.123.61

!

no ip http server

!

!

control-plane

!

!

!

!

!

dspfarm transcoder maximum sessions 16

dspfarm rtp timeout 41728

dspfarm

!

!

dial-peer voice 1 voip

description ASTERISK

destination-pattern 124[5,7].

progress_ind setup enable 1

progress_ind progress enable 1

progress_ind connect enable 1

redirect ip2ip

translate-outgoing called 1

session protocol sipv2

session target ipv4:хх.хх.0.6:5060

session transport udp

incoming called-number .

dtmf-relay rtp-nte

codec g711alaw

fax rate 14400

fax protocol pass-through g711alaw

no vad

!

dial-peer voice 2 voip

description VOIP-OPERATOR

preference 5

destination-pattern .

progress_ind setup enable 3

progress_ind progress enable 8

redirect ip2ip

voice-class codec 1

session protocol sipv2

session target ipv4:10.101.1.33:5060

session transport udp

dtmf-relay rtp-nte

fax rate 14400

fax nsf 000000

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback none

no vad

!

sip-ua

nat symmetric check-media-src

retry invite 3

retry response 3

retry bye 3

retry cancel 3

timers trying 1000

sip-server ipv4:xx.xx.0.6

!

!

telephony-service

ip source-address xx.xx.0.11 port 2000

sdspfarm units 1

sdspfarm transcode sessions 128

sdspfarm tag 1 MTPNEWONE

max-conferences 4

transfer-system full-consult

!

!

line con 0

line aux 0

line vty 0 4

 

end

 

Однако реинвайт не происходит, и трафик идёт проксированием через астериск.

На астериске везде стоит canreinvite=yes

Спасибо.

Share this post


Link to post
Share on other sites

1. Поддерживает ли Абон шлюз спрямление RTP? Если нет то и работать спрямление не будет.

2. попробуй убрать nat symmetric check-media-src (гдето я читал про глюки с этой командой но на AS серверах)

У меня спрямление работает вроде нормально если с двух сторон от Asterisk стоят 1751.

Share this post


Link to post
Share on other sites
1. Поддерживает ли Абон шлюз спрямление RTP? Если нет то и работать спрямление не будет.

2. попробуй убрать nat symmetric check-media-src (гдето я читал про глюки с этой командой но на AS серверах)

У меня спрямление работает вроде нормально если с двух сторон от Asterisk стоят 1751.

спрямление шлюз поддерживает, доказано на практике, потому что в сети есть ещё один шлюз DLINK 4FXO так вот с ним реинвайт работает....

nat symmetric check-media-src - уберу сейчас

Share this post


Link to post
Share on other sites

кинь конфиги астериска (sip.conf секции general ну и сами пиры) и версию. Да и поставь для тестов жостко alaw на шлюзе на астериске и на циске(в сторону астериска). Может там трансляция кодека идёт на астериске.

Share this post


Link to post
Share on other sites

Собственно с реиныайтом разобрались. В конфиге астериска нужно было указать directrtpsetup=yes

и всё реинвайт заработал. спасибо всем кто откликнулся, эту тему можно закрывать.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this