Jump to content
Калькуляторы

PPTP VPN на Cisco 1700 рвётся связь

есть 2 маршрутизатора Cisco 1721 и Cisco 1750 на обоих была попытка поднять pptp vpn и в обоих случая наткнулся на одни и теже грабли -- периодически раз в 40-50 минут клиент отваливается, в качестве клиента использовались разные роутеры, например asus wl500 GP, dlink dir 320 и встроеный pptp клиент вин ХР. вот такую конфигурацию я использовал:

 

ip dhcp pool 10_net
   network 192.168.10.0 255.255.255.0
   bootfile pxeboot
   next-server 192.168.0.2
   default-router 192.168.0.4
   dns-server 192.168.0.2 192.168.1.1
   domain-name вщьфшт.local

vpdn enable
!
vpdn-group 1
! Default PPTP VPDN group
accept-dialin
  protocol pptp
  virtual-template 1

username user password 0 user

interface Virtual-Template1
ip address 192.168.10.1 255.255.255.0
ip mtu 1492
ip nbar protocol-discovery
ip route-cache flow
autodetect encapsulation ppp
peer default ip address dhcp-pool 10_net
ppp encrypt mppe auto
ppp authentication ms-chap-v2

 

при этом странно что разрывы происходят внезависимости от наличия сетевой активности клиента, пподскажите пожалуйста в чём может быть причина. Заранее благодарен.

Share this post


Link to post
Share on other sites

ну в логах наверно надо попытаться поискать причину разрыва соединения

Share this post


Link to post
Share on other sites

Похожая тема уже была.

На сколько выдается IP через DHCP? Было что-то вроде:" DHCP сервер выдает новый IP и связь рвется"

Попробуйте вручную leased-time сделать поболе

Edited by jeejay

Share this post


Link to post
Share on other sites

так в том то и юмор что рвётся ровно раз в час, настройка timeout absolute какбы вообще не участвует...

Share this post


Link to post
Share on other sites

ну это повод призадуматься:)

 

у клиента по ipconfig /all что показывает?

Share this post


Link to post
Share on other sites

да тут не в dhcp дело, адреса то у меня статично прописаны, такое ощущение что где то в циске стои дефолтное значение на время pptp сессии ровно 1 час, вот только понять не могу где эта цифра закопана, циска ваторизует пользователей сама, тоесть RADIUS не используется и радиус атрибутах максимальное время сессии соответственно не передаётся

Share this post


Link to post
Share on other sites
да тут не в dhcp дело, адреса то у меня статично прописаны,
ip dhcp pool 10_net

network 192.168.10.0 255.255.255.0

bootfile pxeboot

next-server 192.168.0.2

default-router 192.168.0.4

dns-server 192.168.0.2 192.168.1.1

...

peer default ip address dhcp-pool 10_net

...

?

Вы ж ВПН поднимаете...

Share this post


Link to post
Share on other sites

BTW : IOS какой там?

 

На циско ком говорят, что дефолтное время 1 день для DHCP

Edited by jeejay

Share this post


Link to post
Share on other sites

c1700-advsecurityk9-mz.124-17

 

сейчас переделал вот так:

 

vpdn enable
!
vpdn-group 1
! Default PPTP VPDN group
accept-dialin
  protocol pptp
  virtual-template 1

username user password 0 pazz

interface Virtual-Template1
ip address 192.168.10.1 255.255.255.0
ip mtu 1492
ip nbar protocol-discovery
ip route-cache flow
timeout absolute 60000 0
autodetect encapsulation ppp
peer default ip address pool pptp
ppp encrypt mppe auto
ppp authentication ms-chap-v2

ip local pool pptp 192.168.10.2 192.168.10.254

 

и все равно те же грабли, раз в час роутер клиента отваливается, при том что IP теперь статические и DHCP больше не участвует

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this