Jump to content
Калькуляторы

Cisco7200 & vpdn accounting отсутствует периодический аккаунтинг - как настроить?

Здравствуйте All

 

Cisco 7200. PPP терминирование. Авторизация по Radius. Для поддержания сессий биллингом в активном состоянии требуется

aaa accounting update periodic 2, т.е. отсылка Radius-серверу аккаунтинга с некоторым периодом. Если циска не отправляет аккаунтинг пакеты - биллинг сбрасывает сеанс.

Но в приведенной конфигурации Radius-accoutting идет только при подключении/отключении пользователя. А надо еще и с некоторым интервалом. Подскажите пожалуйста что не так...

 

 

 

 

 

 

 

 

 

ppp>sh ver
Cisco IOS Software, 7200 Software (C7200-ADVENTERPRISEK9-M), Version 12.4(22)T,
RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2008 by Cisco Systems, Inc.

 

 

 

ppp#wr t
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname ppp
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable secret 5 ########
enable password 7 ##########
!
aaa new-model
aaa session-mib disconnect
!
!
aaa authentication login default local
aaa authentication ppp default group radius
aaa authorization exec default local
aaa authorization network default group radius
aaa accounting update periodic 2
aaa accounting network default
action-type start-stop
group radius
!
!
!
aaa session-id common
clock timezone ######
no ip source-route
no ip gratuitous-arps
ip cef
!
!
!
!
ip domain name ####################
ip name-server ##############
ip name-server 208.67.220.220
no ipv6 cef
!
multilink bundle-name authenticated
vpdn enable
vpdn authen-before-forward
vpdn search-order dnis
!
vpdn-group 1
! Default PPTP VPDN group
accept-dialin
  protocol pptp
  virtual-template 1
!
!
!
voice dsp waitstate 0
!
!
!
!
!
!
!
!
!
!
!
!
!
username admin password 7 ####################
username bill privilege 8 password 7 ####################
archive
log config
  hidekeys
!
!
!
!
!
no ip rcmd domain-lookup
ip rcmd rsh-enable
ip rcmd remote-host bill 172.####### root enable 8
ip rcmd remote-host bill 172.####### SYSTEM enable 8
ip rcmd source-interface FastEthernet4/0
!
!
!
!
interface Loopback0
ip address 95.59.####.1 255.255.254.0
!
interface FastEthernet0/0
description ForClientsConnections
ip address 192.168.250.220 255.255.255.0
ip access-group Fa0/0-in in
no ip redirects
duplex full
no cdp enable
!
interface FastEthernet1/0
no ip address
shutdown
duplex half
!
interface FastEthernet2/0
description Clients-to-Shaper
ip address 95.59.###.254 255.255.255.0
duplex full
!
interface FastEthernet4/0
description RadiusNetFlow
ip address 172.18.25.2 255.255.255.0
no ip redirects
duplex full
no cdp enable
!
interface Virtual-Template1
ip unnumbered Loopback0
no ip redirects
no ip proxy-arp
ip mtu 1492
ip flow ingress
ip flow egress
rate-limit input 1000000 96000 192000 conform-action continue exceed-action dro
p
rate-limit output 1000000 96000 192000 conform-action continue exceed-action dr
op
logging event subif-link-status
no peer default ip address
ppp max-bad-auth 3
ppp authentication ms-chap-v2 chap
ppp accounting default
ppp ipcp dns 95.59.#######
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 95.59.###.1
ip route 192.168.0.0 255.255.0.0 192.168.250.1
no ip http server
no ip http secure-server
!
ip flow-cache timeout inactive 10
ip flow-cache timeout active 1
ip flow-export version 5
ip flow-export destination 172.18.25.1 7223
!
!
ip access-list extended Fa0/0-in
permit gre any host 192.168.250.220
permit icmp any host 192.168.250.220 echo
permit tcp any any eq 1723
deny   ip any any
!
ip radius source-interface FastEthernet4/0
logging alarm informational
access-list 3 permit 172.18.25.1
access-list 3 deny   any log
access-list 11 permit 172.18.25.1
snmp-server community snmp_passwd RW 11
!
!
!
!
!
!
radius-server configure-nas
radius-server host 172.18.25.1 auth-port 1812 acct-port 1813
radius-server timeout 30
radius-server key 7 ##########################
radius-server vsa send accounting
radius-server vsa send authentication
!
control-plane
!
!

!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
transport input telnet ssh
!
ntp server ntp.ru version 2
ntp server time.nist.gov version 2
ntp server time-a.nist.gov version 2
end

Edited by vtrambovetsky

Share this post


Link to post
Share on other sites

12.4 обязательна? у меня на ней не работало. на 12.2 все нормально.

Share this post


Link to post
Share on other sites
12.4 обязательна? у меня на ней не работало. на 12.2 все нормально.
Не работало именно это или что-то другое? Поделитесь пожалуйста опытом. Второй день бубном прыгаю вокруг нее по поводу периодического аккаунтинга. Утром попробую 12.2.

 

 

А в моем конфиге нет явных проблем?

Edited by vtrambovetsky

Share this post


Link to post
Share on other sites

у меня радиус шлет Acct-Interim-Interval=XXX(тут просто в секундах можно задавать).

при тесте только START + STOP. UPDATE не приходят.

далее прописываю aaa accounting update periodic 1

все то-же самое.

откатываюсь на 12.2 все работает с первым вариантом.

 

конфиги твои не смотрел.

Share this post


Link to post
Share on other sites

А не можете более точно сказать версию софта на катором работает?

 

aaa accounting update periodic

Share this post


Link to post
Share on other sites

Покажите для cisco 7201

show ver
У кого работает aaa accounting update periodic

если не сложно

Share this post


Link to post
Share on other sites

Cisco IOS Software, 7200 Software (C7200P-ADVENTERPRISEK9-M), Version 12.2(33)SRC5, RELEASE SOFTWARE (fc2)

 

но по моему в ответе от радиуса нужен был Acct-Interval или как то так... (

точно не помню.

 

Share this post


Link to post
Share on other sites
Cisco IOS Software, 7200 Software (C7200P-ADVENTERPRISEK9-M), Version 12.2(33)SRC5, RELEASE SOFTWARE (fc2)

 

но по моему в ответе от радиуса нужен был Acct-Interval или как то так... (

точно не помню.

А можно поподробнее???

Share this post


Link to post
Share on other sites

Я точно не помню, но если мне не изменяет склероз, то циска не отдавала периодический аккаунтиг (апдейты) пока я на заслал ей из радиуса

Acct-Interim-Interval=400 (секунд)

 

Сделано это было реврйтом атрибутов:

attr_rewrite acctinteriminterval  {
attribute = Acct-Interim-Interval
searchin = reply
searchfor = "%{Acct-Interim-Interval}"
replacewith = "400"
append = yes
}

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this