Jump to content
Калькуляторы

Помогите с access-list

Хочу запретить ходить на smtp:

 

ip access-list extended denysmtp

deny tcp any any eq smtp

permit ip any any

 

Не срабатывае :( на smtp заходит

 

а если последнюю строчку убрать - то трафик вообще убивается. Где ошибка?

Share this post


Link to post
Share on other sites

Вешаете acl на правильный интерфейс? Покажите конфиг.

Share this post


Link to post
Share on other sites

interface Virtual-Template1
ip unnumbered GigabitEthernet0/1
ip access-group denysmtp in
ip virtual-reassembly
peer default ip address pool white
ppp authentication ms-chap ms-chap-v2
ppp ipcp dns 81.91.176.2 81.91.177.130

ip access-list extended denysmtp
deny   tcp any any eq smtp
permit ip any any

подключаюсь:

interface Virtual-Access2.35
ip unnumbered GigabitEthernet0/1
ip access-group denysmtp in
ip virtual-reassembly
peer default ip address pool white
ppp authentication ms-chap ms-chap-v2
ppp ipcp dns 81.91.176.2 81.91.177.130
service-policy input client2000k_in
service-policy output client2000k_out
end

 

Почему вообще на входящий трафик access-list не срабатывает :(

 

Даже если задать так:

ip access-list extended denysmtp

deny ip any any

 

в конфиге фигурировать будет, на фиртуальном интерфейсе фигурировать тоже будет, но трафик пропускает весь. Где ошибся?

Edited by terrible

Share this post


Link to post
Share on other sites

service-policy input client2000k_in

service-policy output client2000k_out

 

Вот тут и срабатывает правило permit. Так работать не будет. Снимите с темплейта ip access-group denysmtp in и допишите политику client2000k_in, что-бы в ней дропались smtp пакетики.

Share this post


Link to post
Share on other sites

пробовал и без политик запускать - не работает на in

проблема походу кроется в IOS с PIX-ом, он на in вообще ни одно правило не отрабатывает. Временно сделал на out и забил

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this