Jump to content
Калькуляторы

обучение MikroTik отправка внешнего ip на заданную почту

Дело в том что нахожусь от микротика за два километра и вне локальной сети.

Но имею канал в интерет.

Захожу на микротик через внешний ip.

Чтоб его узнать это целое дело.

Вообщем изрядно заипало.

Знаю что можно микрот научить отправлять на мыло ip!

Вот и прошу знающих помощи!

Буду рад любой помощи...

Share this post


Link to post
Share on other sites

DynDNS с микротиком подружить не пробовали?

Share this post


Link to post
Share on other sites
DynDNS с микротиком подружить не пробовали?

 

я, честно говоря, первым делом об этом тоже подумал....

Вы делали такое? Получилось?

Share this post


Link to post
Share on other sites

:local CurrentDynDNSIP [:resolve you.ddns.info]

:local TMPDynDNSIP [/ip address get [/ip address find interface=интерфейс выхода] address]

:local RealDynDNSIP [:pick $TMPDynDNSIP 0 ([:len $TMPDynDNSIP]-3)]

#:log info ("CurrentDynDNSIP = " . $CurrentDynDNSIP)

#:log info ("TMPDynDNSIP = " . $TMPDynDNSIP)

#:log info ("RealDynDNSIP-adr = " . $RealDynDNSIP)

:if ($CurrentDynDNSIP != $RealDynDNSIP) do={/tool dns-update name=you.ddns.info address=$RealDynDNSIP key-name=логин key=пароль}

 

использую ddns.info, логин и пароль это данные учетки на ddns.info, создаешь скрипт, потом в шедулер его и можешь заходить по имени, который зарегестрировал в ddns.info

 

создай еще второй скрипт, который будет иметь www перед you.ddns.info

Edited by boo

Share this post


Link to post
Share on other sites

Дайте пожалуйста более подробные разъяснения по этому скрипту...

Вот я частично заполнил его . Что где еще нужно дополнить из данных?

И потом его вставит и запустить через New terminal ? А как просмотреть через sistem -scripts ?

 

:local CurrentDynDNSIP [:resolve you.ddns.info] - что здесь вставить

:local TMPDynDNSIP [/ip address get [/ip address find interface=Telecom pppoe-out1] address]

:local RealDynDNSIP [:pick $TMPDynDNSIP 0 ([:len $TMPDynDNSIP]-3)]

#:log info ("CurrentDynDNSIP = " . $CurrentDynDNSIP)

#:log info ("TMPDynDNSIP = " . $TMPDynDNSIP)

#:log info ("RealDynDNSIP-adr = " . $RealDynDNSIP)

:if ($CurrentDynDNSIP != $RealDynDNSIP) do={/tool dns-update name=you.ddns.info address=$RealDynDNSIP key-name=yrec key=199991}

Share this post


Link to post
Share on other sites

 

Дело в том что нахожусь от микротика за два километра и вне локальной сети.

Но имею канал в интерет.

Захожу на микротик через внешний ip.

Чтоб его узнать это целое дело.

Вообщем изрядно заипало.

Знаю что можно микрот научить отправлять на мыло ip!

Вот и прошу знающих помощи!

Буду рад любой помощи...

интернет через дсл?

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this