Jump to content
Калькуляторы

Передача пакетов с двойным тэгированием через обычные L2 коммутаторы Можно ли?

Суть проблемы в том, что при добавлении второго тэгирования (q-in-q) размер пакета увеличивается и обычные коммутаторы не пропускают эти пакеты. Можно ли как-нибудь добиться прохождения этих пакетов через коммутаторы, которые не поддерживают двойное тэгирование?

Share this post


Link to post
Share on other sites

на сколько я понял: Jumbo фреймы это поддержка 9кбайт кадров в стандарте гигабитного езернета. Попробовал на EdgecorE ES3528-SFP, у котого есть поддержка jumbo фреймов - не помогло

Share this post


Link to post
Share on other sites

На циске чтобы джумбо ходили надо на интерфейсе мту указывать, может на ёжиках так же?

!
interface TenGigabitEthernet2/8/1
description DAS1 (Te1/50)
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,100,101,103,106,108,112,150,196-198,205,206
switchport trunk allowed vlan add 213,214,301,302,402,405,414,416,501
switchport mode trunk
[b] mtu 9216[/b]
channel-group 6 mode active
!

Share this post


Link to post
Share on other sites
На циске чтобы джумбо ходили надо на интерфейсе мту указывать, может на ёжиках так же?

!
interface TenGigabitEthernet2/8/1
description DAS1 (Te1/50)
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,100,101,103,106,108,112,150,196-198,205,206
switchport trunk allowed vlan add 213,214,301,302,402,405,414,416,501
switchport mode trunk
[b] mtu 9216[/b]
channel-group 6 mode active
!

да вот проблема в том, что простые l2 не умеют менять размер mtu

Share this post


Link to post
Share on other sites

да, заранее извиняюсь, не ту модель ёжика написал, этот как раз нормально qnq поддерживает :)

Share this post


Link to post
Share on other sites
да вот проблема в том, что простые l2 не умеют менять размер mtu
на интерфейсе - может быть, а глобально - должны,раз поддержка джумбо заявлена.

на простых каталистах так же вроде.

Share this post


Link to post
Share on other sites

Суть проблемы в том, что при добавлении второго тэгирования (q-in-q) размер пакета увеличивается и обычные коммутаторы не пропускают эти пакеты. Можно ли как-нибудь добиться прохождения этих пакетов через коммутаторы, которые не поддерживают двойное тэгирование?

Уменьшить MTU с обоих сторон с 1500 до ~1484?

Share this post


Link to post
Share on other sites

"Обычные коммутаторы" - это какие? Управляемые, с поддержкой вланов? Они будут просто резать такие пакеты, так как применяют "интелект".

А вот неуправляемые - зависит от размера пропускаемого фрейма, на некоторых будет работать вполне.

Edited by SergeiK

Share this post


Link to post
Share on other sites

через неуправляемые телесины всё проходит на ура. Вот только в теме написано - l2 коммутаторы

Share this post


Link to post
Share on other sites

Вы уверены, что проблема именно в размере кадра? QinQ использует другой Ethertype, не такой как 802.1q. Например, если стоит ограничение "tagged only" QinQ может не попасть в категорию "tagged"...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this