Jump to content
Калькуляторы

поднятия NAT на микротике ? используя одну сетевую карту!

Есть сеть сделана следующим образом:

Ethernet ------- Switch -------- Mikrotik

------------------------|------------------------------

//////////////////////CPU1////////////////////////////

 

CPU1 воткнут в свитч

 

Настройки :

Mikrotik :

IP – 10.204.243.124

Маска – 255.255.252.0

Шлюз - 10.204.240.1

DNS – 192.168.248.21

 

У провайдера стоит привязка по IP+MAC

Mikrotik спокойно выходит в интернет.

 

Задача.

Обеспечить интернетом CPU1 (нужна именно только эта конфигурация!!!)

Создаю VLAN смотрящий в WAN

VLAN

ip: 10.204.243.252

Маска – 255.255.252.0

 

CPU1

ip - 10.204.243.251

Маска – 255.255.252.0

Шлюз - тут все перепробывал 10.204.243.124 , 10.204.243.252 , 10.204.240.1

 

Далие делаю Firewall – Nat = Out Interface WAN …

И все … адрес пингуется но все конструкция работает как простой свитч!! Тоесть ната нет (

???? как правильно сделать ?

 

 

направте хаотичный поток мыслей в правильное русло :)

Edited by WoroN

Share this post


Link to post
Share on other sites

на езернете микрика которій смотрит на провайдера :

 

IP – 10.204.243.124

Маска – 255.255.252.0

Шлюз - 10.204.240.1

DNS – 192.168.248.21

 

На Влане микрика которій смотрит на СПУ1 :

 

ip: 10.204.243.252

Маска – 255.255.252.0

 

на компе СПУ1

 

ip - 10.204.243.251

Маска – 255.255.252.0

Шлюз - 10.204.243.252

ДНС - 192.168.248.21

 

На микрике делаешь НАТ

 

/ip firewall nat add action=masquerade chain=srcnat disabled=yes src-address=10.204.243.251

 

И все.

 

 

 

 

Share this post


Link to post
Share on other sites

я так и делал не работает (( походу косяк с Gatewey ....

 

 

вот полные мой настройки.

 

Interface (WAN , Vlan )

 

IP :

address 10.204.243.124/22

Network 10.204.240.0

Broadcast 10.204.243.255

interface WAN

___________

address 10.204.243.252/22

Network 10.204.240.0

Broadcast 10.204.243.255

interface vlan1

 

 

IP - Routes :

ASB Destination = 0.0.0.0/0 Gateway=10.204.240.1 interface=WAN Distance=1

DAC Destination=10.204.240.0/22 interface=WAN Distance=0 pref. Source =10.204.243.124

DC Destination=10.204.240.0/22 interface=vlan1 Distance=0 pref. Source = 10.204.243.252

 

 

далие Firewall - Nat как и посоветовали.

пробывал vlan делать 192.168.0.1/24

все равно шлюз 10.204.240.1 пингуеться а дальше не в какую (((

 

 

 

Share this post


Link to post
Share on other sites

а контрекинг включен ???

 

и очисти на всякий случай таблицу фильтров

Share this post


Link to post
Share on other sites
а контрекинг включен ???

 

и очисти на всякий случай таблицу фильтров

 

фильтры чисты.

контрекинг - незнаю что это (

 

 

не могли бы вы скинуть полную настройку для моего случая.

я сброшу mikrotik в default и сконфигурю сново.

 

если не сложно конечно. буду очень признателен.

 

Share this post


Link to post
Share on other sites

все всем спасибо тему можно закрывать.

 

проблема решилась следующим образом :

удалением vlan1

 

остался только WAN интерфейс:

IP :

address 10.204.243.124/22

Network 10.204.240.0

Broadcast 10.204.243.255

interface WAN

 

CPU*

IP : 10.204.243.*/22

Gatewey 10.204.243.124

 

 

 

a далие

/ip firewall nat add action=masquerade chain=srcnat src-address=10.204.243.250 CPU1

/ip firewall nat add action=masquerade chain=srcnat src-address=10.204.243.251 CPU2

/ip firewall nat add action=masquerade chain=srcnat src-address=10.204.243.252 CPU3 .. итд.

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this