Jump to content
Калькуляторы

установка бита TOS на маршрутизаторах

Вопрос к тем кто пользует Cisco старших серий - насколько процессороемкая операция по установке бита tos?

Скорости порядка гига. (PPS не считаны =) )

 

 

Share this post


Link to post
Share on other sites

На старших это делается в железе, так что мощность процессора значения не имеет.

 

--

Konstantin

Share this post


Link to post
Share on other sites

От коллег есть информация что 7609 "умирает"

подробной информации нет пока.

 

Share this post


Link to post
Share on other sites

Делал это буквально вчера для экспериментов на Sup32, траффика пару гигабит. Ничего не умерло. :)

 

--

Konstantin

 

Share this post


Link to post
Share on other sites
Делал это буквально вчера для экспериментов на Sup32, траффика пару гигабит. Ничего не умерло. :)

 

--

Konstantin

Версию иоса и кусочек конфига, если не затруднит

 

PS

Я тоже думаю что не должно умирать, коллеги что-то не так делают похоже...

 

Share this post


Link to post
Share on other sites

 

Да нету у меня уже конфигов, но это же фигня, типа:

 

access-list 100 permit ip host 1.2.3.4 any

 

route map tos permit 10

match ip address 100

set ip dscp 62

 

int t1/1

ip policy route-map tos

 

 

Кстати вспомнил, что 3550 ругался, что не может отбабатывать TOS в железе и предлагал пользовать DSCP.

 

 

 

K.

 

 

 

 

Делал это буквально вчера для экспериментов на Sup32, траффика пару гигабит. Ничего не умерло. :)

 

--

Konstantin

Версию иоса и кусочек конфига, если не затруднит

 

PS

Я тоже думаю что не должно умирать, коллеги что-то не так делают похоже...

Share this post


Link to post
Share on other sites
От коллег есть информация что 7609 "умирает"

подробной информации нет пока.

Коллеги бредят.

Share this post


Link to post
Share on other sites

Тем не менее, что то тут не так =)

 

простая конструкция

sh policy-map DSCP
  Policy Map DSCP
    Class class-default
      set ip dscp 63

!
interface Vlan4029
ip address 192.168.0.1 255.255.255.0
service-policy output DSCP
end

 

shark  -V -c 100 -i eth0.4029 | grep DSCP
Running as user "root" and group "root". This could be dangerous.
Capturing on eth0.4029
    Differentiated Services Field: 0x00 (DSCP 0x00: Default; ECN: 0x00)
    Differentiated Services Field: 0x00 (DSCP 0x00: Default; ECN: 0x00)
    Differentiated Services Field: 0x00 (DSCP 0x00: Default; ECN: 0x00)

 

Хотя на первый взгляд все просто...

7604 с SUP32

Share this post


Link to post
Share on other sites

Или я что то совсем не понимаю...

простейший вариант, поставить tos

 

access-list 1 permit any
!
route-map SET-TOS-2 permit 10
match ip address 1
set ip tos max-reliability

interface Vlan4030
ip address 192.168.0.0
ip policy route-map SET-TOS-2
end

 

в результате tos=0

 

отключаю ip policy route-map SET-TOS-2,

делаю

iptables -t mangle -A POSTROUTING   -j TOS --set-tos 0x2

и вижу пакеты с верным tos (значит по пути никто не перемаркировал)

 

Дайте хоть наводку, де покопать...

 

Share this post


Link to post
Share on other sites

Ну покопайте в сторону mls qos trust cos на всех интерфейсах.

Share this post


Link to post
Share on other sites

chainick

Если честно, не понимаю как это может согласовываться

с

и вижу пакеты с верным tos (значит по пути никто не перемаркировал)
Т.е. если на порт пришел пакет с УЖЕ установленным TOS то его пропускает, а если выставлен route-map на входе в интерфейс то на выходе перемаркировывает?

=(

Share this post


Link to post
Share on other sites

А вы так пробовали?

 

policy-map qos

class class-default

set dscp af31

 

 

interface ...

service-policy input qos

 

Share this post


Link to post
Share on other sites

Глупый вопрос: А mls qos включен?

Share this post


Link to post
Share on other sites

еще более глупый вопрос -- кто будет верить вашему TOS, кому он вообще здался?

Share this post


Link to post
Share on other sites
Глупый вопрос: А mls qos включен?
Да

 

еще более глупый вопрос -- кто будет верить вашему TOS, кому он вообще здался?
Мой же брас

Share this post


Link to post
Share on other sites

Никто не делает? Я желаю странного?

Банальная же фича, и полезная вроде. С линуксом проблем таких не было... и эти цисководы говорят что циска лучше чем линуксзапрещают мне ковыряться в носу )

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this