Jump to content
Калькуляторы

DHCP Server 3560 DHCP Server 3560

Добрый день.

Суть проблемы в том что 3560 почему- то отдает адреса по DHCP с общего пула, хотя я указываю отдельно отдавать по мак адресу.

Конфиг :

 

 

ip dhcp excluded-address 195.хх.хх.1 195.хх.хх.6

ip dhcp excluded-address 195.хх.хх.9 195.хх.хх.254

!

ip dhcp pool test

network 195.1xx.xx.0 255.255.255.0

domain-name test

dns-server 195.xx.xx.15

default-router 195.xx.xx.1

!

ip dhcp pool 195.xx.xx.8

host 195.xx.xx.8 255.255.255.0

client-identifier xxxx.xxxx.xxx

 

Спасибо всем за помощь!

Share this post


Link to post
Share on other sites

Кто-то поможет с решением вопроса?

Share this post


Link to post
Share on other sites

Для microsoft сетей идентификатором данной сети является 01 ПЕРЕД MAC-адресом. Для UNIX сетей необходимо проставлять 00

 

То есть, для компьютера с MAC-адресом 00.04.76.10.6c.bc, который работает в среде Windows строчка client-identifier будет выглядеть как:

 

client-identifier 0100.0476.106c.bc

 

Для компьютера с MAC-адресом 00.04.76.10.6c.bc который работает в среде UNIX строчка client-identifier будет выглядеть как:

 

client-identifier 0000.0476.106c.bc

 

http://xgu.ru/wiki/DHCP

Share this post


Link to post
Share on other sites
Для microsoft сетей идентификатором данной сети является 01 ПЕРЕД MAC-адресом. Для UNIX сетей необходимо проставлять 00

 

То есть, для компьютера с MAC-адресом 00.04.76.10.6c.bc, который работает в среде Windows строчка client-identifier будет выглядеть как:

 

client-identifier 0100.0476.106c.bc

 

Для компьютера с MAC-адресом 00.04.76.10.6c.bc который работает в среде UNIX строчка client-identifier будет выглядеть как:

 

client-identifier 0000.0476.106c.bc

 

http://xgu.ru/wiki/DHCP

Большое вам спасибо!

Сегодня попробую.

Share this post


Link to post
Share on other sites

Да на здоровье...

Share this post


Link to post
Share on other sites

Все работает. Теперь вопрос стал как его завязать с ip unnumbered?

Если не трудно покажите пример пожалуйста.

 

Share this post


Link to post
Share on other sites

Сейчас конфигурация выглядит так :

 

interface Loopback0

ip address 10.40.40.1 255.255.255.0

no ip redirects

 

 

ip dhcp excluded-address 195.хх.хх.1 195.хх.хх.6

ip dhcp excluded-address 195.хх.хх.9 195.хх.хх.254

!

ip dhcp pool test

network 195.1xx.xx.0 255.255.255.0

domain-name test

dns-server 195.xx.xx.15

default-router 195.xx.xx.1

!

ip dhcp pool 195.xx.xx.8

host 195.xx.xx.8 255.255.255.0

client-identifier xxxx.xxxx.xxx

 

!

interface Vlan77

description Test_Abon

ip unnumbered Loopback0

!

interface Vlan78

description Test_abon2

ip unnumbered Loopback0

!

 

 

 

ip route 195.хх.хх.7 255.255.255.255 Vlan77

ip route 195.хх.хх.8 255.255.255.255 Vlan78

 

 

Если сажаю клиента в влан 77, 78 - DHCP почему то не хочет выдавать адрес. Что не так?

Share this post


Link to post
Share on other sites

на лупбеке должна висеть белая сетка, маршрутов не надо, они сами появятся

Share this post


Link to post
Share on other sites
на лупбеке должна висеть белая сетка, маршрутов не надо, они сами появятся
Немного не так - на лупбеке должна висеть та же сетка, что и в дхцп пуле прописана. Или хотя бы адрес из неё с маской /32.

А маршруты действительно нужны только для абонентов , которые дхцп не умеют.

Вот тут аналогичная схема расписана подробно: http://forum.nag.ru/forum/index.php?showtopic=45488

Share this post


Link to post
Share on other sites

Спасибо всем большое за помощь! Буду тестить.

Share this post


Link to post
Share on other sites

Подскажите еще. В качестве unnumbered интерфейса можно использовать Vlan интерфейс ?

Share this post


Link to post
Share on other sites
Подскажите еще. В качестве unnumbered интерфейса можно использовать Vlan интерфейс ?

можно, но если упадёт "родительский" влан то упадёт и "дочерний" интерфейс.

 

Немного не так

я писал применительно к данному случаю.

 

Share this post


Link to post
Share on other sites
Подскажите еще. В качестве unnumbered интерфейса можно использовать Vlan интерфейс ?

можно, но если упадёт "родительский" влан то упадёт и "дочерний" интерфейс.

 

Немного не так

я писал применительно к данному случаю.

 

Ок, Спасибо!

Share this post


Link to post
Share on other sites

Суть проблемв такова. Попробовал поставить в качестве unnumbered интерфейса VLAN777 для вланов 77,78.

Когда вставляю пачкорд в каталист в VLAN 78 и пытаюсь получить адрес по DHCP - какталист уходит в ребут. Если адрес прописать статикоц - все отлично работает. Где косяк?

 

C3560-M uptime is 10 hours, 59 minutes

System returned to ROM by bus error at PC 0x9CE8C4, address 0x0

System image file is "flash:/c3560-advipservicesk9-mz.122-46.SE.bin"

 

 

Current configuration : 5951 bytes

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname C3560-M

!

boot-start-marker

boot-end-marker

!

enable password xxxxx

!

username admin password 0

aaa new-model

!

!

aaa authentication login default local

aaa authorization console

aaa authorization exec default local

!

!

!

aaa session-id common

system mtu routing 1500

ip subnet-zero

ip routing

ip name-server 195.xx.xx.15

no ip dhcp use vrf connected

ip dhcp excluded-address 195.xx.xx.1 195.xx.xx.6

ip dhcp excluded-address 195.xx.xx.9 195.xx.xx.254

!

ip dhcp pool test

network 195.xx.xx.0 255.255.255.0

domain-name test

dns-server 195.xx.xx.15

default-router 195.xx.xx.1

!

ip dhcp pool 195.xx.xx.8

host 195.xx.xx.8 255.255.255.0

client-identifier xxxx.xxxx.xxxx.xx

!

!

!

!

!

vlan internal allocation policy ascending

!

!

!

!

interface Loopback0

no ip address

no ip redirects

!

interface FastEthernet0/1

switchport access vlan 777

!

interface FastEthernet0/2

switchport access vlan 777

!

interface FastEthernet0/3

switchport access vlan 777

!

interface FastEthernet0/4

switchport access vlan 777

!

interface FastEthernet0/5

switchport access vlan 777

!

interface FastEthernet0/6

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 25,777

switchport mode trunk

!

interface FastEthernet0/7

switchport access vlan 77

!

interface FastEthernet0/8

switchport access vlan 78

 

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

switchport access vlan 571

!

interface FastEthernet0/23

switchport trunk encapsulation dot1q

switchport trunk native vlan 571

switchport trunk allowed vlan 571,577

switchport mode trunk

!

interface FastEthernet0/24

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 777

switchport mode trunk

!

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 5,30,35,40,45,50,55,60,777

switchport mode trunk

!

interface GigabitEthernet0/2

!

interface Vlan1

no ip address

!

interface Vlan5

ip address 10.77.77.1 255.255.255.0

!

interface Vlan25

ip address 10.10.1.254 255.255.255.0 secondary

ip address 10.77.78.1 255.255.255.0

!

interface Vlan30

ip address 10.77.79.1 255.255.255.0

!

interface Vlan35

ip address 10.10.0.254 255.255.255.0 secondary

ip address 10.77.80.1 255.255.255.0

!

interface Vlan40

ip address 10.77.81.1 255.255.255.0

!

interface Vlan45

ip address 10.77.82.1 255.255.255.0

!

interface Vlan50

ip address 10.77.83.1 255.255.255.0

!

interface Vlan55

ip address 10.10.2.254 255.255.255.0 secondary

ip address 10.77.84.1 255.255.255.0

!

interface Vlan60

ip address 10.77.85.1 255.255.255.0

!

interface Vlan77

description Test_Abon

ip unnumbered Vlan777

!

interface Vlan78

description Test_abon2

ip unnumbered Vlan777

!

interface Vlan577

description Ua

ip address 194.xx.xx.206 255.255.255.252

!

interface Vlan777

ip address 192.168.1.254 255.255.255.0 secondary

ip address 10.254.254.1 255.255.255.0 secondary

ip address 195.xx.xx.1 255.255.255.0

!

router bgp xxxx

no synchronization

bgp log-neighbor-changes

network 195.xx.xx.0

neighbor 194.xx.xx.205 remote-as xxxx

neighbor 194.xx.xx.205 transport path-mtu-discovery

neighbor 194.xx.xx.205 description UA

neighbor 194.xx.xx.205 shutdown

neighbor 194.xx.xx.205 prefix-list 1 out

no auto-summary

!

ip default-gateway 195.xx.xx.254

ip classless

no ip route static inter-vrf

ip route 0.0.0.0 0.0.0.0 195.xx.xx.254

ip route 10.51.51.0 255.255.255.0 195.xx.xx.25

ip route 195.xx.xx.0 255.255.255.0 Null0

ip route 195.xx.xx.7 255.255.255.255 Vlan77

no ip http server

no ip http secure-server

!

!

!

ip prefix-list 1 seq 5 permit 195.xx.xx.0/24

snmp-server community xxxx RO

!

control-plane

!

!

line con 0

speed 115200

line vty 5 15

!

end

 

 

Share this post


Link to post
Share on other sites

аналогичная фигня

если просто поднять дхцп на 3560г с 12.2(46)SE то все работает отлично

но как только поднимаешь его для ip unn интерфейса - ребут

по sh logg говорит вот это:

*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED: System previously crashed with the following message:
*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED: Cisco IOS Software, C3560 Software (C3560-ADVIPSERVICESK9-M), Version 12.2(46)SE, RELEASE SOFTWARE (fc2)
*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED: Copyright (c) 1986-2008 by Cisco Systems, Inc.
*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED: Compiled Thu 21-Aug-08 15:26 by nachen
*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED:
*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED: Data TLB Miss Exception (0x1100)!
*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED:
*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED: SRR0 = 0x009CE8C4  SRR1 = 0x00029230  SRR2 = 0x006113D0  SRR3 = 0x00021200
*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED: ESR = 0x00000000  DEAR = 0x3C608010  TSR = 0x8C000000  DBSR = 0x00000000
*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED:
*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED: CPU Register Context:
*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED: Vector = 0x00001100  PC = 0x009CE8C4  MSR = 0x00029230  CR = 0x33000053
*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED: LR = 0x009CE8A8  CTR = 0x009B5AA4  XER = 0xE0000044
*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED: R0 = 0x009CE8A8  R1 = 0x035D8D30  R2 = 0x00000000  R3 = 0x00000000
*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED: R4 = 0x00000000  R5 = 0x0000008C  R6 = 0x039B74E4  R7 = 0x035D8E00
*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED: R8 = 0x039B74E4  R9 = 0x3C608000  R10 = 0x02190000  R11 = 0x00000000
*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED: R12 = 0x00000005  R13 = 0x00110000  R14 = 0x00D05F1C  R15 = 0x00000000
*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED: R16 = 0x02643960  R17 = 0x00000001  R18 = 0x00000001  R19 = 0x00000002
*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED: R20 = 0x00000000  R21 = 0x059614B8  R22 = 0x039B6430  R23 = 0x035D4F0C
*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED: R24 = 0x00015180  R25 = 0x00000000  R26 = 0x039B5F84  R27 = 0x00000005
*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED: R28 = 0x039B643C  R29 = 0x00000000  R30 = 0x00000000  R31 = 0x00000000
*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED:
*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED: Stack trace:
*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED: PC = 0x009CE8C4, SP = 0x035D8D30
*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED: Frame 00: SP = 0x035D8D40    PC = 0x009CE8A8
*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED: Frame 01: SP = 0x035D8D50    PC = 0x009B5AD4
*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED: Frame 02: SP = 0x035D8DF0    PC = 0x00D038F8
*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED: Frame 03: SP = 0x035D8EC0    PC = 0x00D119D8
*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED: Frame 04: SP = 0x035D8EE0    PC = 0x00D11C78
*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED: Frame 05: SP = 0x035D8F18    PC = 0x00D128F0
*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED: Frame 06: SP = 0x035D8F38    PC = 0x00D13454
*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED: Frame 07: SP = 0x035D8F60    PC = 0x00D0500C
*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED: Frame 08: SP = 0x035D8F78    PC = 0x00D05210
*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED: Frame 09: SP = 0x035D8FB0    PC = 0x00D05810
*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED: Frame 10: SP = 0x035D91D0    PC = 0x00D05D68
*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED: Frame 11: SP = 0x035D91E8    PC = 0x00D0603C
*Mar  1 02:02:14.822 ua: %PLATFORM-1-CRASHED: Frame 12: SP = 0x035D91F0    PC = 0x00981954
*Mar  1 02:02:14.830 ua: %PLATFORM-1-CRASHED: Frame 13: SP = 0x00000000    PC = 0x0097854C
*Mar  1 02:02:14.830 ua: %PLATFORM-1-CRASHED:

 

Нид хелп....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this