Jump to content
Калькуляторы

Catalyst 6500 (SUP2/MSFC2) и Rate-limit как ограничить скорость на порту

The Catalyst 6500/6000 Policy Feature Card (PFC) and PFC2 only support ingress policing. The PFC3 supports both ingress and egress policing.

У меня SUP2/MSFC2/PFC2

Как ограничить скорость на порту?

Никак?

 

а что же тогда делать?

 

brs1#sho ver
Cisco Internetwork Operating System Software
IOS (tm) s222_rp Software (s222_rp-IPSERVICES_WAN-M), Version 12.2(18)SXF16, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2009 by cisco Systems, Inc.
Compiled Tue 03-Mar-09 14:24 by kellythw
Image text-base: 0x40101040, data-base: 0x42965660

ROM: System Bootstrap, Version 12.1(11r)E1, RELEASE SOFTWARE (fc1)
BOOTLDR: s222_rp Software (s222_rp-IPSERVICES_WAN-M), Version 12.2(18)SXF16, RELEASE SOFTWARE (fc2)

brs1 uptime is 4 weeks, 1 day, 23 hours, 27 minutes
Time since brs1 switched to active is 4 weeks, 1 day, 23 hours, 26 minutes
System returned to ROM by  power cycle (SP by power-on)
System restarted at 10:16:20 EEST Mon May 11 2009
System image file is "disk0:s222-ipservices_wan-mz.122-18.SXF16.bin"

cisco WS-C6509 (R7000) processor (revision 3.0) with 458752K/65536K bytes of memory.
Processor board ID TBM06030326
R7000 CPU at 300Mhz, Implementation 0x27, Rev 3.3, 256KB L2, 1024KB L3 Cache
Last reset from power-on
SuperLAT software (copyright 1990 by Meridian Technology Corp).
X.25 software, Version 3.0.0.
Bridging software.
TN3270 Emulation software.
4 Virtual Ethernet/IEEE 802.3 interfaces
48 FastEthernet/IEEE 802.3 interfaces
10 Gigabit Ethernet/IEEE 802.3 interfaces
381K bytes of non-volatile configuration memory.

32768K bytes of Flash internal SIMM (Sector size 512K).
Configuration register is 0x2102



brs1#sho module
Mod Ports Card Type                              Model              Serial No.
--- ----- -------------------------------------- ------------------ -----------
  1    2  Catalyst 6000 supervisor 2 (Active)    WS-X6K-SUP2-2GE    SAL0804T993
  3   48  48 port 10/100 mb RJ45                 WS-X6348-RJ-45     SAD04350CTN
  4    8  8 port 1000mb GBIC Enhanced QoS        WS-X6408A-GBIC     SAL0715BPCM

Mod MAC addresses                       Hw    Fw           Sw           Status
--- ---------------------------------- ------ ------------ ------------ -------
  1  000e.d755.a4d4 to 000e.d755.a4d5   5.0   7.1(1)       12.2(18)SXF1 Ok
  3  0030.9636.ff30 to 0030.9636.ff5f   1.1   5.4(2)       8.5(0.46)RFW Ok
  4  000c.85cf.caf8 to 000c.85cf.caff   3.0   5.4(2)       8.5(0.46)RFW Ok

Mod  Sub-Module                  Model              Serial       Hw     Status
---- --------------------------- ------------------ ----------- ------- -------
  1  Policy Feature Card 2       WS-F6K-PFC2        SAL0804T69F  3.4    Ok
  1  Cat6k MSFC 2 daughterboard  WS-F6K-MSFC2       SAL0804T6X6  2.6    Ok

Mod  Online Diag Status
---- -------------------
  1  Pass
  3  Pass
  4  Pass
brs1#


brs1#sho run int f 3/13
Building configuration...

Current configuration : 260 bytes
!
interface FastEthernet3/13
ip address 192.168.193.102 255.255.255.252
rate-limit input 1024000 256000 256000 conform-action transmit exceed-action drop
rate-limit output 1024000 256000 256000 conform-action transmit exceed-action drop
no cdp enable
end


brs1#sho int f3/13 rate-limit
FastEthernet3/13
  Input
    matches: all traffic
      params:  1024000 bps, 256000 limit, 256000 extended limit
      conformed 432682 packets, 47613843 bytes; action: transmit
      exceeded 274617 packets, 22196229 bytes; action: drop
      last packet: 14697572ms ago, current burst: 0 bytes
      last cleared 1d18h ago, conformed 2493 bps, exceeded 1162 bps
  Output
    matches: all traffic
      params:  1024000 bps, 256000 limit, 256000 extended limit
      conformed 0 packets, 0 bytes; action: transmit
      exceeded 0 packets, 0 bytes; action: drop
      last packet: 2590687056ms ago, current burst: 0 bytes
      last cleared 00:00:36 ago, conformed 0 bps, exceeded 0 bps
brs1#

Share this post


Link to post
Share on other sites

Можно ограничить, но через ж. Если L3 не на этой железке (наверное маловероятно, но бывает):

int gi1/1

switchport

switchport mode trunk

switchport allowed vlan add 3000

mls qos vlan-based

 

int f3/13

service-policy input 1M

switchport

switchport mode access

switchport access vlan 3000

 

int vlan 3000

mls qos bridged

service-policy input 1M

no shut

 

То есть у нас есть один аплинк в режиме trunk, на нем разрешен vlan 3000 и включен mls qos vlan based. На Vlan-интерфейсе прицеплен полиси и включен mls qos bridged

 

Если же L3 этого интерфейса на этой же железке, то ограничить скорость тоже можно, но еще через большую ж.:

class-map match-all fa3-13

match access-group name fa3-13

policy-map BACKBONE

class fa3-13

police 1000000 100000 100000 conform-action set-dscp-transmit 16 exceed-action drop

 

int gi1/1

description Backbone

switchport

switchport mode trunk

switchport trunk allowed vlan 10

mls qos vlan-based

 

int vlan 10

description Backbone-L3

ip addess xx.bb.xv.xx 255.255.255.240

service policy input BACKBONE

 

int fa3/13

no switchport

ip address 10.1.1.1 255.255.255.0

service-policy input 1M

 

При редактировании policy BACKBONE ее нужно сначала убрать с int vlan 10, отредактировать и "прицепить" обратно.

И смотрите логи, каталист может молча не принять команду, ругнувшись на что-то в лог

 

Share this post


Link to post
Share on other sites

L3 на этой железке.

А что делать если на ней БГП и 4 аплинка в нее воткнуты? с четырех гигабитных портов? :)

 

если создать interface vlan10 что для него будет входящим трафиком? то что с апстримов сыпется или то, что от клиента идет?

Share this post


Link to post
Share on other sites
L3 на этой железке.

А что делать если на ней БГП и 4 аплинка в нее воткнуты? с четырех гигабитных портов? :)

 

если создать interface vlan10 что для него будет входящим трафиком? то что с апстримов сыпется или то, что от клиента идет?

Только сделав декомпозицию. Нельзя совмещать border и access. А у вас еще и агрегация на этой же железке.

Ни одна железка не решит проблему с кривыми дизайном сети, сколько бы вы за нее не заплатили.

 

 

Share this post


Link to post
Share on other sites

Можно сделать монстрика с кучкой VRFов и линками между ними) Тогда можно ингрес полиси прицепить)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this