Jump to content
Калькуляторы

сервер PPPoE на Cisco871

Привет всем!

Есть Cisco871 c IOS 12.4(15)T1 Advanced IP Services. На cisco.com вот такой у нее список фич, касающийся PPPoE:

PPPoE Client

PPPoE Client DDR Idle-Timer

PPPoE MTU Adjustment

PPPoE on Ethernet

PPPoE Radius Port Identification

PPPoE Relay

PPPoE Server Restructuring and PPPoE Profiles

PPPoE Session limit

PPPoE Session Limit per NAS port

 

Из этого, я сделал вывод, что вроде как она должна уметь терминировать PPPoE у себя на интерфейсе. Но в инете в примерах везде включают "pppoe enable" на subinterface, а у этого маршрутизатора на подинтерфейсы можно разбить только WAN порт, 4 локальных не бьются. Подскажите, можно ли вообще на этом роутере настроить сервер PPPoE? И если возможно, то как это сделать?

Пока написал такой конфиг:

interface Loopback1
ip address 192.168.102.1 255.255.255.0
!
bba-group pppoe PPPoEGroupBBA
virtual-template 2
sessions auto cleanup
!
interface FastEthernet3
switchport access vlan3
!
interface Virtual-Template2
ip unnumbered Loopback1
ip nat inside
ip virtual-reassembly
peer default ip address pool PPPOEpool
ppp authentication ms-chap-v2 chap callin Radius
ppp authorization Radius
ppp accounting Radius
!
interface vlan3
ip address 10.0.0.1 255.255.255.0
pppoe enable group PPPoEGroupBBA 
!
ip local pool PPPOEpool 192.168.102.10 192.168.102.250

При этом конфиге кошка получает пакет PADI на vlan3, но не отправляет в ответ PADO. Вот, что в лог выводит:

PCTime: PPPoE 0: I PADI  R:0017.3175.1036 L:ffff.ffff.ffff Vl3
PCTime: PPPoE 0: I PADI  R:0017.3175.1036 L:ffff.ffff.ffff Vl3
PCTime: PPPoE 0: I PADI  R:0017.3175.1036 L:ffff.ffff.ffff Vl3
PCTime: PPPoE 0: I PADI  R:0017.3175.1036 L:ffff.ffff.ffff Vl3

Потом процесс соединения на компе отрубается по таймауту. Смотрел снифером, на комп PADO не приходит, видно только PADI.

Если повесть "pppoe enable group PPPoEGroupBBA" не на vlan, а на сам fast3, то циска даже эти PADI в лог не пишет.

Что тут не так? И как с этим бороться?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this