Перейти к содержимому
Калькуляторы

Cisco SPS224G4 (aka Linksys SPS224G4)

Пожалуйста

 

ip igmp snooping

bridge multicast filtering

interface vlan X

ip igmp snooping

exit

 

iptv идет в вилане с данными

понятно ... у нас оно идёт отдельно - в multicast-vlan! у вас задача проще ....

если не секрет - а почему так ? почему с данными а не отдельно ? у нас получается правильнее в отдельном.... - не копируется в каждый влан мультикаст на агрегации и в ядре....

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Если я не ошибаюсь то: switchport access multicast-tv vlan ХХ

Ну и включить снупинг на абонентском и на multicast-tv влане.

Lynx10 а вы мультикастовые группы статикой заливаете?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
почему с данными а не отдельно ? у нас получается правильнее в отдельном.... - не копируется в каждый влан мультикаст на агрегации и в ядре....

А у нас почти везде линк из центрального роутера - один или 2 влана. Зачем тянуть что то лишнее?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Если я не ошибаюсь то: switchport access multicast-tv vlan ХХ

Ну и включить снупинг на абонентском и на multicast-tv влане.

Lynx10 а вы мультикастовые группы статикой заливаете?

не совсем понятно что имелось в виду "Lynx10 а вы мультикастовые группы статикой заливаете?" - мы с выше стоящего коммутатора чтобы не морочить себе голову на стенде просто на все порты без снупинга и без фильтрации незарегистрированных груп валим мультикастом - понятно что он валит на порт куда включен линксис - дальше он попадает в отдельном влане на линксис вместе в вланом с даными - у нас влан на дом.

 

да так как вы написали выше сказано и в манах - и это не работает :) конкретно не работает снупинг и поток на клиентский порт валит даже когда на него не подключаешся - соответственно когда отключаешся валит тоже! фильтрация незарегистрированных тоже не помогает!

 

работает если включить fast leave + включить мультикастовые потоки статикой (bridge multicast address x.x.x.x) + фильтрацию незарегистрированных - вот тогда начинает работать снупинг - валит на порт когда включаешся и прекращает после отключения - как по мне бред - но работает

Изменено пользователем Lynx10

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
почему с данными а не отдельно ? у нас получается правильнее в отдельном.... - не копируется в каждый влан мультикаст на агрегации и в ядре....

А у нас почти везде линк из центрального роутера - один или 2 влана. Зачем тянуть что то лишнее?

ну понятно - если мало вланов - то не вопрос- просто если вланов много - то это неприемлемо! - неясно всё таки как у вас сеть построена тогда - но это не тема топика

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

неправильно выразился. у нас просто статикой групы на свиче залиты:

ip igmp snooping multicast-tv vlan ХХ add 230.ХХ.ХХ.ХХ

вроде и без fast leave и bridge multicast address x.x.x.x работает.

 

можно, хоть и в приват кусочек как у вас оно настроено?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Не помогло!!! - всё равно валит на порт без подписки на группу!
Победили ЧЕРЕЗ ЗАД! но работает!

 

Особенно удивляет что при кривости прошивки она датируется 2008 годом и никаких исправлений до 2010 не было! - вот это настораживает - непонятна роль сего дивайса на рынке и его будущее вообще - если под него уже сейчас свежих прошивок нету - то похоже вендор на него мягко говоря "положил"!

 

я так понял циска выдала его на рынок с таким подходом что вот вам - дешево - что то не работает - берите не линксис а каталист! и никто особо не будет его поправлять..... по крайней мере такое ощущение! Короче меня он не порадовал - хотя надежды были большие!

Что подразумевается под "Через зад"?

 

Если установить мультикаст источник за маршрутизатором(как оно и должно быть по-правильному), например Cisco Catalyst 3560/3750, то все в порядке.

Насчет кривости и отношения к багам - у циски есть русскоязычная техподдержка, которая не только помогает в настройке, но и занимается устранением багов. А как мы знаем - дитя не плачет мать не разумеет:)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Если установить мультикаст источник за маршрутизатором(как оно и должно быть по-правильному), например Cisco Catalyst 3560/3750, то все в порядке.
Что в порядке ? А давайте без общих фраз - а поконкретней - если вы знаток этих устройств... (а если нет - то плиз не морочте голову!) - давайте кусок работающего конфига "multicast-tv + igmp-snooping" - там смотришь и найдётся почему через зад.....! igmp + фильтрация незарегистрированных как по мне коректно не работает!
Насчет кривости и отношения к багам - у циски есть русскоязычная техподдержка, которая не только помогает в настройке, но и занимается устранением багов. А как мы знаем - дитя не плачет мать не разумеет:)
да.... я же сказал что работать оно заработало.... поэтому обращаться нечего (но так как оно работает + цена + достаточно убогий функционал + прошивка версии 1.02 за 2008 год за те деньги - меня не прёт! ) .... вестись на шилдик сиськи и строить сеть на нём мы не будем!
Изменено пользователем Lynx10

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Если установить мультикаст источник за маршрутизатором(как оно и должно быть по-правильному), например Cisco Catalyst 3560/3750, то все в порядке.
Что в порядке ? А давайте без общих фраз - а поконкретней - если вы знаток этих устройств... (а если нет - то плиз не морочте голову!) - давайте кусок работающего конфига "multicast-tv + igmp-snooping" - там смотришь и найдётся почему через зад.....! igmp + фильтрация незарегистрированных настраивается извратно и как по мне коректно не работает!
Насчет кривости и отношения к багам - у циски есть русскоязычная техподдержка, которая не только помогает в настройке, но и занимается устранением багов. А как мы знаем - дитя не плачет мать не разумеет:)
да.... я же сказал что работать оно заработало.... поэтому обращаться нечего (но так как оно работает + цена + достаточно убогий функционал + прошивка версии 1.02 за 2008 год за те деньги - меня не прёт! ) .... вестись на шилдик сиськи и строить сеть на нём мы не будем!

Попрошу без истерик, взрослые все люди:)

"В порядке" - трафик не флудится на все порты.

Пример конфига:

Vlan database

Vlan 34,500

Bridge multicast filtering

Ip igmp snooping

Interface vlan 34

Ip igmp snooping

Interface vlan 500

Ip igmp snooping

Ip igmp snooping multicast vlan 500 add 239.1.2.3

Interface Ethernet g1

switchport mode trunk

Switchport trunk allowed vlan add 34,500

Interface range Ethernet e12

Switchport mode access

Switchport access vlan 34

Switchport access multicast-tv vlan 500

 

P.S.: И все таки, что в данной ситуации в вашем понимании - "через жопу"?

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

+ фильтрацию незарегистрированных

чё за фильтрация? :)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Если установить мультикаст источник за маршрутизатором(как оно и должно быть по-правильному), например Cisco Catalyst 3560/3750, то все в порядке.
Что в порядке ? А давайте без общих фраз - а поконкретней - если вы знаток этих устройств... (а если нет - то плиз не морочте голову!) - давайте кусок работающего конфига "multicast-tv + igmp-snooping" - там смотришь и найдётся почему через зад.....! igmp + фильтрация незарегистрированных настраивается извратно и как по мне коректно не работает!
Насчет кривости и отношения к багам - у циски есть русскоязычная техподдержка, которая не только помогает в настройке, но и занимается устранением багов. А как мы знаем - дитя не плачет мать не разумеет:)
да.... я же сказал что работать оно заработало.... поэтому обращаться нечего (но так как оно работает + цена + достаточно убогий функционал + прошивка версии 1.02 за 2008 год за те деньги - меня не прёт! ) .... вестись на шилдик сиськи и строить сеть на нём мы не будем!

Попрошу без истерик, взрослые все люди:)

"В порядке" - трафик не флудится на все порты.

Пример конфига:

Vlan database

Vlan 34,500

Bridge multicast filtering

Ip igmp snooping

Interface vlan 34

Ip igmp snooping

Interface vlan 500

Ip igmp snooping

Ip igmp snooping multicast vlan 500 add 239.1.2.3

Interface Ethernet g1

switchport mode trunk

Switchport trunk allowed vlan add 34,500

Interface range Ethernet e12

Switchport mode access

Switchport access vlan 34

Switchport access multicast-tv vlan 500

 

P.S.: И все таки, что в данной ситуации в вашем понимании - "через жопу"?

1 вот как раз вот так всё нормально и так и дожно бы было быть чтобы не было через зад!

2 а вы это пробовали реально ? или просто с мануалом слепили ? мы не поленились попробовали - тот же компот - валит на порт невзирая на igmp

 

Тут вы раньше писали

Если установить мультикаст источник за маршрутизатором(как оно и должно быть по-правильному)

Интересно если у меня прокидывается по Л2 от источника до абонентского коммутатора - соответственно до абонента и маршрутизации мне 100 лет не надо... - то мне тоже надо "обязательно по правильному" установить источник за маршрутизатором ? - установить маршрутизатор с пимами конечно не проблема - вопрос ЗАЧЕМ ОНО в такой схеме... у нас именно плоская схема без Л3! Если проблема и вправду связана с этим - тогда непонятно почему коммутаторы 2-ух других производителей не имеют с этим проблем!

 

+ фильтрацию незарегистрированных
чё за фильтрация? :)

фильтрация незарегистрированных мультикастовых групп.

в даном коммутаторе

Bridge multicast filtering

 

в других по другому! но суть та же!

Изменено пользователем Lynx10

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
1 вот как раз вот так всё нормально и так и дожно бы было быть чтобы не было через зад!

2 а вы это пробовали реально ? или просто с мануалом слепили ? мы не поленились попробовали - тот же компот - валит на порт невзирая на igmp

Я ничего не понял в этом потоке сознания, но "у меня все работает" .

Если же Вам действительно нужна технически грамотная помощь, то не поленитесь

0. прекратить истерику

1. открыть кейс у производителя

2. показать конфиг

3. показать вывод show * всего, что относится к теме вопроса

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Так..... заработало и нормально как в мане пишет - после источника обязательно должен быть маршрутизатор который квериами должен сыпать - иначе тоже можна запустить (без маршрутизатора) но не по фен шую!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Формат опции 82 у этого свитча подскажите. В доке ничего не нашел на эту тему.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Как у цыски, это очевидно.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Спасибо. Еще один дурацкий вопрос. А кто-нибудь дружил эти свитчи с D-Link'ами DES-3200-28 или DES-3028, включенными по схеме: sps224g4 -> D-link DES-3xxx -> L3 ?

На Linksys и на D-link настроены dhcp snooping + dhcp relay + option 82.

Проблема в том, что прилетает пакет не только от Linksys но и от D-link'а (с транкового порта).

С транкового порта Linksys вылетает:

    192.168.128.40.68 > 192.168.128.1.67: [udp sum ok] BOOTP/DHCP, Request from 00:0b:6a:a8:d3:68, length 312, hops 1, xid 0xf884f059, secs 7424, Flags [Broadcast] (0x8000)
          Gateway-IP 192.168.128.40
          Client-Ethernet-Address 00:0b:6a:a8:d3:68
          Vendor-rfc1048 Extensions
            Magic Cookie 0x63825363
            DHCP-Message Option 53, length 1: Discover
            NOAUTO Option 116, length 1: Y
            Client-ID Option 61, length 7: ether 00:0b:6a:a8:d3:68
            Requested-IP Option 50, length 4: 192.168.101.36
            Hostname Option 12, length 5: "anya2"
            Vendor-Class Option 60, length 8: "MSFT 5.0"
            Parameter-Request Option 55, length 11: 
              Subnet-Mask, Domain-Name, Default-Gateway, Domain-Name-Server
              Netbios-Name-Server, Netbios-Node, Netbios-Scope, Router-Discovery
              Static-Route, Classless-Static-Route-Microsoft, Vendor-Option
            Agent-Information Option 82, length 18: 
              Circuit-ID SubOption 1, length 6: ^@^D^GM-Z^A^G
              Remote-ID SubOption 2, length 8: ^@^F<M-_^^M-jM-^ZM-^W
            END Option 255, length 0

    192.168.128.31.68 > 192.168.128.1.67: [udp sum ok] BOOTP/DHCP, Request from 00:0b:6a:a8:d3:68, length 312, hops 1, xid 0xc89f1e07, secs 1024, Flags [none] (0x0000)
          Gateway-IP 192.168.128.31
          Client-Ethernet-Address 00:0b:6a:a8:d3:68
          Vendor-rfc1048 Extensions
            Magic Cookie 0x63825363
            DHCP-Message Option 53, length 1: Discover
            NOAUTO Option 116, length 1: Y
            Client-ID Option 61, length 7: ether 00:0b:6a:a8:d3:68
            Requested-IP Option 50, length 4: 169.254.58.147
            Hostname Option 12, length 5: "anya2"
            Vendor-Class Option 60, length 8: "MSFT 5.0"
            Parameter-Request Option 55, length 11: 
              Subnet-Mask, Domain-Name, Default-Gateway, Domain-Name-Server
              Netbios-Name-Server, Netbios-Node, Netbios-Scope, Router-Discovery
              Static-Route, Classless-Static-Route-Microsoft, Vendor-Option
            Agent-Information Option 82, length 18: 
              Circuit-ID SubOption 1, length 6: ^@^D^GM-Z^@^[
              Remote-ID SubOption 2, length 8: ^@^F^@&ZM-^VM-fM-@
            END Option 255, length 0

192.168.128.31 - D-Link

192.168.128.40 - Linksys

 

В принципе можно в конфиге dhcp просто игнорировать запросы перенаправленные с транковых портов D-Link'а. Но может есть другой путь которого я не вижу?

Изменено пользователем passer

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

В сабже настроен DHCP relay + Opt.82 в режиме L3

 

ip dhcp relay enable
ip dhcp relay address xx.xx.xx.xx
!
!
interface vlan 100
ip dhcp relay enable
!
ip dhcp snooping
ip dhcp snooping vlan 100
ip dhcp information option
!
interface ethernet e24
switchport mode access
switchport access vlan 10
spanning-tree portfast
ip dhcp snooping trust
!

 

 

Заметил такую проблему, иногда на при обновлении DHCP аренды

на сервер в запросе в поле GIADDR прилетает адрес 0.0.0.0

вместо адреса свича .

 

Софт в свиче

SW version    1.0.2 ( date  18-Nov-2008 time  12:38:16 )
Boot version    1.0.2 ( date  13-Nov-2007 time  14:11:51 )

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

купили один сегодня на пробу.

понравилось что ест 100мегабитные sfp от NAG

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
купили один сегодня на пробу.

понравилось что ест 100мегабитные sfp от NAG

Если речь идёт о сабже то интересно ваше впечатление - если не трудно отпишитесь какой функционал на него вы завесили и как он вам вообще .... интересно мнение других! своё мнение я выше уже высказал!

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
купили один сегодня на пробу.

понравилось что ест 100мегабитные sfp от NAG

Если речь идёт о сабже то интересно ваше впечатление - если не трудно отпишитесь какой функционал на него вы завесили и как он вам вообще .... интересно мнение других! своё мнение я выше уже высказал!

Начал использовать его недвано для доступа,

из функционала пока задействовано DHCP opt82 и DHCP ralay, ARP inspection, .1q,

формат Circut-ID DHCP Opt82 совместим с Cisco

 

Вроде все работает, есть небольшая проблема которую выше описал, попробую обновить софт.

 

Рейт-лимит работает очень грубо, незаметно разницы между 20Mb и 40Мб при том и другом приложение (FTP) получает 2-3 Мб

Рейт-лимит нельзя использовать совместно со штормконтролои на порту либо то либо другое.

 

Планирую включить на нем маркировку входящего от абонента трафика пр dscp.

 

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Есть пара вопросов по коммутаторам:

1. Для того, чтобы запретить общение по l2 на абонентском порту обязательно указывать аплинк и он может быть только один?

2. Транковый порт (на котором добавлен упраляющий влан) нельзя сделать изолированным (protected)?

 

ЗЫ: SW version 1.0.1 ( date 03-Mar-2008 time 12:33:23 )

Boot version 1.0.2 ( date 13-Nov-2007 time 14:11:51 )

HW version 00.03.00

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Добрый день, уважаемые знатоки!

Купил в компанию сей девайс. Ранее никогда не работал с коммутаторами. Собственно насколько я понял он работает из коробки. Т.е. подключаю его в разетку и втыкаю кабели в порты и инет начинает бегать. Но столкнулся с такой проблемой. Если подключаю к 100 мегамитным портам, то они отваливаются через минуту(индикатор перестает мигать) и соответственно не работают. Самое удивительное то что Гигабитные порты работают нормально. Не могли бы Вы подсказать что может быть такое? И если есть время и желание то как пользоваться консолью, точнее как в нее зайти после подключения кабеля. Или ткните в мануалы, по возможности Русские

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

на новой прошивке по дефолту все порты сотенные вырублены.

Чтоб случайно абоненты не попали в управляющий вилан оператора на ненастроенном свитче.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас