Jump to content
Калькуляторы

Ограничение скорости на cat6509 Cколько максимум class-ов может быть в одном policy-map?

Здравствуйте, имеется Cisco Catalyst 6509.

WS-X6K-S2-MSFC2 (PFC2, MSFC2) with 512MB

IOS Ver 12.2(18)SXF12 (s222-adventerprisek9_wan-mz.122-18.SXF12a.bin)

 

Режу скорость безлимитчикам следующим образом:

 

 

ip access-list extended acl_cl_001

permit ip any host 212.88.xxx.1

ip access-list extended client_002

permit ip any host 212.88.xxx.2

ip access-list extended client_003

permit ip any host 212.88.xxx.3

ip access-list extended client_004

permit ip any host 212.88.xxx.4

ip access-list extended client_005

permit ip any host 212.88.xxx.5

.................................

.................................

ip access-list extended client_253

permit ip any host 212.88.xxx.6

ip access-list extended client_254

permit ip any host 212.88.xxx.7

 

 

class-map match-all client_001

match access-group name acl_cl_001

class-map match-all client_002

match access-group name acl_cl_002

class-map match-all client_003

match access-group name acl_cl_003

class-map match-all client_004

match access-group name acl_cl_004

class-map match-all client_005

match access-group name acl_cl_005

.................................

.................................

class-map match-all client_253

match access-group name acl_cl_253

class-map match-all client_254

match access-group name acl_cl_254

 

 

mls qos aggregate-policer 512k_cl_001 520000 65000 65000 conform-action transmit exceed-action drop

mls qos aggregate-policer 512k_cl_002 520000 65000 65000 conform-action transmit exceed-action drop

mls qos aggregate-policer 256k_cl_003 264000 33000 33000 conform-action transmit exceed-action drop

mls qos aggregate-policer 128k_cl_004 200000 25000 25000 conform-action transmit exceed-action drop

mls qos aggregate-policer 128k_cl_005 200000 25000 25000 conform-action transmit exceed-action drop

.................................

.................................

mls qos aggregate-policer 256k_cl_253 264000 33000 33000 conform-action transmit exceed-action drop

mls qos aggregate-policer 128k_cl_254 200000 25000 25000 conform-action transmit exceed-action drop

 

 

policy-map unlim

class client_001

police aggregate 512k_cl_001

class client_002

police aggregate 512k_cl_002

class client_003

police aggregate 256k_cl_003

class client_004

police aggregate 128k_cl_004

class client_005

police aggregate 128k_cl_005

.................................

.................................

class client_253

police aggregate 256k_cl_253

class client_254

police aggregate 128k_cl_254

 

 

interface FastEthernet2/1

description Interface_to_Internet

switchport

switchport access vlan 3

no ip address

speed 100

duplex full

power inline never

no cdp enable

service-policy input unlim

 

 

 

И все бы хорошо, все работало замечательно до недавнего времени. Но однажды при применении очередного class-а к policy-map unlim все встало колом - пакеты практически перестали бегать, скорость канала упала практически до нуля. Сделал отмену class-а - все стало нормально. Применяю снова - снова проблемы. Ошибки быть не может - все проверил-перепроверил. Я думаю, что наступил какой-то предел class-ов в policy-map. Посчитал, сейчас 254 class-а в одном policy-map-е. Причем циска не ругается, команду проглатывает, все как обычно.

Может кто-нибудь подсказать, сколько максимум class-ов может быть в одном policy-map? Доки читал но ничего такого не нашел.

Edited by netman

Share this post


Link to post
Share on other sites

Спасибо за ответ. Почитал, обидно..

Как же мне и дальше резать скорость, неужели все тупик - как же изобрести велосипед?

Share this post


Link to post
Share on other sites
Спасибо за ответ. Почитал, обидно..

Как же мне и дальше резать скорость, неужели все тупик - как же изобрести велосипед?

sup32 поставить

Share this post


Link to post
Share on other sites
Спасибо за ответ. Почитал, обидно..

Как же мне и дальше резать скорость, неужели все тупик - как же изобрести велосипед?

sup32 поставить

Злой Вы) Как серпом по яйцам)))

Share this post


Link to post
Share on other sites
sup32 поставить

Ну уж лучше тогда sup720. Но как обойтись малой кровью и реализовать это на sup2?

Share this post


Link to post
Share on other sites

тоже железо

Cisco Catalyst 6509

WS-X6K-S2-MSFC2 (PFC2, MSFC2) with 512MB

IOS Ver 12.2(18)SXF12 (s222-entservicesk9_wan-mz.122-18.SXF14.bin)

 

прочитав данную тему решил с генерировать конфиг

 

ip access-list extended v_1_1

permit ip any host 172.20.1.1

................................

ip access-list extended v_1_254

permit ip any host 172.20.1.254

 

ip access-list extended v_2_1

permit ip any host 172.20.1.1

................................

ip access-list extended v_2_254

permit ip any host 172.20.1.254

 

 

class-map match-all v_1_1

match access-group name v_1_1

................................

class-map match-all v_1_254

match access-group name v_1_254

class-map match-all v_2_1

match access-group name v_2_1

................................

class-map match-all v_2_254

match access-group name v_1_254

 

 

policy-map unlim_out

class local

class v_1_1

police cir 128000 bc 8000 be 8000 conform-action transmit exceed-action drop violate-action drop

...............................

class v_1_254

police cir 128000 bc 8000 be 8000 conform-action transmit exceed-action drop violate-action drop

class v_2_1

police cir 128000 bc 8000 be 8000 conform-action transmit exceed-action drop violate-action drop

...............................

class v_2_254

police cir 128000 bc 8000 be 8000 conform-action transmit exceed-action drop violate-action drop

 

interface Vlan20

ip address x.x.x.x x.x.x.x

service-policy input unlim_out

и того получилось 508 class-ов вложенных в policy-map, но к сожалению пользователь был только один, нарезка работает без тормозов.

Edited by -=Ghost=-

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this