Jump to content
Калькуляторы

Catalyst 3560 и ограничение скорости для IP-адресов Подскажите как лучше организовать

Коллеги, cisco-специалисты, подскажите как решить задачу)

Сам с Cisco стал разбираться недавно.

 

Имеется Catalyst 3560

Прошивка 12.2.46-SE IP SERVICES

Задача: на порту, который подключен к шлюзу, организовать ограничений скорости для некоторых ip-адресов. При этом скорость между узлами должна быть без ограничений, т.е. ограничить только скорость входящего и исходящего трафика из Интернета.

 

Порывшись в различной литературе прочитал про traffic-shape.

В том числе здесь http://www.opennet.ru/base/cisco/cisco_shaper.txt.html об этом написано.

Но traffic-shape в этом каталисте отсутствует!

 

Подсказали что нужно копать в сторону QoS.

Вот здесь нашлась неплохая статья http://www.network.xsp.ru/3_11.php и пример использования CBWFQ для разделения общей полосы в процентном соотношении или задание конкретной скорости.

access-list 101 permit ip host 192.168.0.100 any

class-map match-all User1

match access-group 101

policy-map Isp

class User1

bandwidth ????

И здесь облом, т.к. команды bandwidth почему-то не существует!

 

Коллеги, подскажите где копать. Может у кого-нибудь есть пример подобного решения?

Share this post


Link to post
Share on other sites

Каталисты шейпить могут только по порту, да и то довольно грубыми шагами.

Указанные выше статьи - про роутеры.

 

Так что ограничивайте лучше на шлюзе...

Share this post


Link to post
Share on other sites

шейпить они вообще не могут.

inf fa 0/1

traffic shape - отсутствует такая команда.

к тому же шейпинг на выходном интерфейсе используется.

тут полисинг нужен, насколько я понимаю.

 

а на шлюзе не можем ограничивать, ибо не наш он.

должны же быть какие-то еще решения с QoS-ом....

Edited by lgtlcm

Share this post


Link to post
Share on other sites

Получилось что-то подобное. Специалисты, подскажите, плз, насколько рабочая схема

 

Настройка ограничения общей скорости на интерфейсе, смотрящем в Инет, и скорости 2-х клиентов.

 

class-map match-all client1_in

match access-group 101

!

!

class-map match-all client2_in

match access-group 102

!

!

class-map match-all all_in

match access-group 199

!

policy-map inet_in

class client1_in

police 256000 8000 exceed-action drop

!

class client2_in

police 4000000 8000 exceed-action drop

!

class all_in

police 10000000 240000 exceed-action drop

!

!

int fa 0/24

service-policy input inet_in

!

!

access-list 101 permit ip any host 192.168.0.2

access-list 102 permit ip any 192.168.0.32 0.0.0.7

access-list 199 permit ip any 192.168.0.0 0.0.0.127

 

Share this post


Link to post
Share on other sites

256 килобит полисить - это не просто жесть, это мегажесть...

Share this post


Link to post
Share on other sites

Получилось что-то подобное. Специалисты, подскажите, плз, насколько рабочая схема

Работать-то она, может, и будет. Но вас пользователи порвут нафик. Это вам наверное конкуренты посоветовали так сделать

Share this post


Link to post
Share on other sites

Трафика много? Если мало - то маршрутизатор подходящий поставить, пусть шейпит. Если много - SCE.

Share this post


Link to post
Share on other sites
Трафика много? Если мало - то маршрутизатор подходящий поставить, пусть шейпит. Если много - SCE.

Что есть SCE?

я понимаю что это костыль))

но как еще ограничить траффик средствами каталиста? если без маршрутизатора..

Edited by lgtlcm

Share this post


Link to post
Share on other sites

но как еще ограничить траффик средствами каталиста? если без маршрутизатора..

Пока нет потребности в железках класса SCE - сливать трафик на сервер, который отшейпит. Вы стенд соберите и попробуйте iperf'ом для себя нарисовать картину того, что получит ваш пользователь при полисинге на такой скорости.

Share this post


Link to post
Share on other sites

это касательно 256к.

а если от мегабита и выше?

Share this post


Link to post
Share on other sites

Винда и при полисинге на 10 мегабит себя ведёт непредсказуемо - у кого 2-3 мегабита даёт, у кого и того меньше...

Share this post


Link to post
Share on other sites
это касательно 256к.

а если от мегабита и выше?

А вы попробуйте :) Я на 5Мб смотрел и мне не понравилось.

Share this post


Link to post
Share on other sites

так а в чем конкретно проблема выражаться будет?

и еще. с помощью srr-queue решение не лучше будет?

Edited by lgtlcm

Share this post


Link to post
Share on other sites

Нихрена работать не будет. Даже яндекс будет тормозить.

Share this post


Link to post
Share on other sites

с помощью srr-queue решение не лучше будет?

Лучше, но srr-queue работает только по порту и с довольно грубым шагом.

Share this post


Link to post
Share on other sites

вот еще какое решение пришло))

если на порту несколько Вланов, то можно использовать rate-limit для Влана, а не для физического интерфейса.

хотя странно, что для Вланов rate-limit имеется, а для fa - нет.

 

int Vlan 100

rate-limit input 10000000 240000 240000 conform-action transmit exceed-action drop #ограничение для всего Влана

rate-limit input access-group 101 256000 8000 8000 conform-action transmit exceed-action drop #ограничение для клиента

!

access-list 101 permit ip any host 192.168.0.2

 

этот метод более гуманный?))

Edited by lgtlcm

Share this post


Link to post
Share on other sites

а че такие наезды на полисинг при низких скоростях?

скажем, 512к гораздо симпотичнее выглядит отполисенное, нежели отшейпленное, т.к. при шейпинге почему-то принципиально задержки появляются, причем некислые такие. Такое ощущение, что циска при шейпинге приходящий пакет берет и начинает мариновать в буфере минимум 30мс, независимо от того, есть перегруз или нет.

Физики вон вообще все полисятся до единого на своих мегабитах - торрент себя прекрасно чувствует, как врочем и закачки с фтп, не говоря уже обо всяких игрулях и хттп

Share this post


Link to post
Share on other sites

Да тут никто не наезжает. Мы всегда рады вашим пользователям, особенно во времена кризиса =))

Share this post


Link to post
Share on other sites

не стал создавать новую тему, решил может тут кто отликнется:

есть Catalyst 2960, нужно зарезать скорость на порту gi0/1 до двушки, Unsupported Interface Configuration Commands rate-limit. Unsupported Policy-Map Configuration Command

class class-default where class-default is the class-map-name.

может кто подкинет кость.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this