Jump to content
Калькуляторы

Ограничение входящего трафика для абонента Catalyst 6500 sup2/msfc2/pfc2

Коллеги, выручайте.

 

Не могу понять, как ограничить входящий поток абонета.

 

Catalyst 6500 sup2/msfc2/pfc2

Канал 2мбит

Вилан на абонента

 

Думал сделать так.

 

class-map match-all cm_abonent_in
  match access-group name acl_abonent_in
!
policy-map pm_abonent_in
  class cm_abonent_in
   police cir 512000 bc 51200 be 51200 conform-action transmit exceed-action drop violate-action drop
!
ip access-list extended acl_abonent_in
permit ip any host 10.10.10.2
!
interface Vlan2
description Uplink
bandwidth 2048
ip address 80.20.132.74 255.255.255.252
ip nat outside
ip wccp web-cache redirect out
ip route-cache flow
ip route-cache policy
ip policy route-map mapNETUP
service-policy input pm_abonent_in

 

В итоге в ACL не попадаем. Подозреваю что из-за NATа - полиси отрабатывает до трансляции адреса и мы еще не знаем ip абонента.

Если так, то я чего-то не могу понять, как тогда абонентов то ограничивать?

 

http://www.cisco.com/en/US/tech/tk648/tk36...080133ddd.shtml

 

PS: Output полиси не поддерживается моим pfc2

The PFC2 supports only ingress PFC QoS, which includes ingress policing. The PFC3 supports both

ingress and egress PFC QoS, which includes ingress and egress policing.

Чего-то как-то грустно :(

Edited by kostas

Share this post


Link to post
Share on other sites

Не то железо Вы взяли - кроме халявной локалки ничего не выйдет, мозгов маловато.

А инет можно другими способами и на другой железке порезать.

Share this post


Link to post
Share on other sites
Не то железо Вы взяли - кроме халявной локалки ничего не выйдет, мозгов маловато.

А инет можно другими способами и на другой железке порезать.

Т.е. даже и париться нечего - выносить нат и резать полосу на стороне (софт или железка), так чтоли? :(

 

Кстати, есть 2610 - на ней можно чего нибудь толковое сделать или не париться и поставить в сторонке машинку на линуксе и делать как все? :)

 

PS: Аплинка больше 10ки вряд ли будет, по крайней мере в ближайшее время.

Share this post


Link to post
Share on other sites

если взяли 65xx, то и на SCE скупиться не стоит...

 

у нас тут картина такая, кроме нас по поводу анлимов напрягается ещё один провайдер, но у них нет SCE и технарей грамотных, в результате у нас абонентские базы отличаются в 4 раза как минимум (у нас больше), а полоса у них немногим (процентов на 25%) меньше нашей... и клиенты бегут из-за вечерних полок, ну и корпоратив массово "льётся" , а у нас оттока практически нет, только маниакальные качки, которых и мы так не держим... железка окупила себя очень быстро и эффективность её превзошла мои самые смелые прогнозы...

Edited by ae

Share this post


Link to post
Share on other sites

Почитайте доки, всё же L3-интерфейсы используете, может средствами MSFC что получится.

 

А вот 2610... на десятку... Она столько не прожуёт. :(

 

 

Share this post


Link to post
Share on other sites
если взяли 65xx, то и на SCE скупиться не стоит...

 

у нас тут картина такая, кроме нас по поводу анлимов напрягается ещё один провайдер, но у них нет SCE и технарей грамотных, в результате у нас абонентские базы отличаются в 4 раза как минимум (у нас больше), а полоса у них немногим (процентов на 25%) меньше нашей... и клиенты бегут из-за вечерних полок, ну и корпоратив массово "льётся" , а у нас оттока практически нет, только маниакальные качки, которых и мы так не держим... железка окупила себя очень быстро и эффективность её превзошла мои самые смелые прогнозы...

SCE дорого уж больно. Может конечно б/у поискать, что вряд ли...

 

Почитайте доки, всё же L3-интерфейсы используете, может средствами MSFC что получится.

 

А вот 2610... на десятку... Она столько не прожуёт. :(

Угумс, будем ковырять. Если бы не НАТ, то может обошлись бы и этим каталистом. Уж очень не хотелось городить огород...

Share this post


Link to post
Share on other sites

Не надо использовать индивидуальные policy-map, только групповые. Один тариф - одна policy-map. :)

 

Share this post


Link to post
Share on other sites

А сколько у вас ёмкость внешних каналов? Если небольшая, то можно рядышком 7200 с нпе-400 прикрутить, замутить на ней ИСГ и будет вам счастье в управлении абонентами через радиус)

Share this post


Link to post
Share on other sites
Не надо использовать индивидуальные policy-map, только групповые. Один тариф - одна policy-map. :)
Групповые начиная с 32 супа... Но тысячу-две абонентов можно и на 2-ом полисить, если память не изменяет.

С натом хуже. :-(

Хотя СУП1 пару мегабит (на офис) натит с трудноуловимой в %% загрузкой. ;-)

 

Share this post


Link to post
Share on other sites

Павел, так что там с б/у SCE2020??? не пора ли начать ими уже приторговывать??? ;) м.б. народ не в курсе, что для 65xx единственно правильный engine 720... ;) а всё остальное - лукавство... ;)

Share this post


Link to post
Share on other sites

Групповые - именно в смысле тарифов. Ведь для определения тарифа пофиг, какой именно ip у юзера, можно весь диапазон указать, всё равно там у каждого юзера свой SVI...

 

ip access-list extended NET2NET
  permit ip 10.0.0.0 0.0.255.255 10.0.0.0 0.0.255.255
!
class-map LOCALKA
  match access-group name NET2NET
!
policy-map TARIFF1
  class LOCALKA
    police 10240k
  class class-default
    police 1024k
!
int vlan101
  descr user1
  ...
  service-policy output TARIFF1
!
int vlan 102
  descr user2
  ...
  service-policy output TARIFF1

так понятно?

Share this post


Link to post
Share on other sites
Павел, так что там с б/у SCE2020??? не пора ли начать ими уже приторговывать??? ;) м.б. народ не в курсе, что для 65xx единственно правильный engine 720... ;) а всё остальное - лукавство... ;)
Да откуда им б.у.-то взяться...

Погоди годик, разорится какой-нить левелван, и на нашей улице перевернется грузовик с пивом.

А по 720 супу - и спорить не буду, но со 2-го легко втягиваться. :-)

Share this post


Link to post
Share on other sites
Не надо использовать индивидуальные policy-map, только групповые. Один тариф - одна policy-map. :)
Угумс, логично. Пасиб :)

 

А сколько у вас ёмкость внешних каналов? Если небольшая, то можно рядышком 7200 с нпе-400 прикрутить, замутить на ней ИСГ и будет вам счастье в управлении абонентами через радиус)
Емкость небольшая конечно. Пока 2мбита с расширением по необходимости до 10мбит. Большу думаю не получится чисто технически - нет у нас в районе операторов, ктобы по приемлемым ценам дал больше скорости. А ориентировочно во сколько может обойтись такая железка у нас в питере?

 

Павел, так что там с б/у SCE2020??? не пора ли начать ими уже приторговывать??? ;) м.б. народ не в курсе, что для 65xx единственно правильный engine 720... ;) а всё остальное - лукавство... ;)
Да откуда им б.у.-то взяться...

Погоди годик, разорится какой-нить левелван, и на нашей улице перевернется грузовик с пивом.

А по 720 супу - и спорить не буду, но со 2-го легко втягиваться. :-)

А 32й смысла не имеет уже, все равно где нибудь упремся? :)

Share this post


Link to post
Share on other sites
если взяли 65xx, то и на SCE скупиться не стоит...

 

у нас тут картина такая, кроме нас по поводу анлимов напрягается ещё один провайдер, но у них нет SCE и технарей грамотных, в результате у нас абонентские базы отличаются в 4 раза как минимум (у нас больше), а полоса у них немногим (процентов на 25%) меньше нашей... и клиенты бегут из-за вечерних полок, ну и корпоратив массово "льётся" , а у нас оттока практически нет, только маниакальные качки, которых и мы так не держим... железка окупила себя очень быстро и эффективность её превзошла мои самые смелые прогнозы...

sandvine получше будет. По последним проверкам на реальном трафике - 92% определения трафика. У sce там же поменьше будет.

Share this post


Link to post
Share on other sites
А ориентировочно во сколько может обойтись такая железка у нас в питере?

А 32й смысла не имеет уже, все равно где нибудь упремся? :)

1. Смотри у НАГа, + доставка. Недорого в общем...

2. 32-й - зло, ибо архитектура у него не очень-общая шина на 32Гбит; 67хх модули - не встанут, 65хх - будут работать на этой общей шине. Однако по функционалу - почти как 720-3В)))

Share this post


Link to post
Share on other sites

 

sandvine получше будет. По последним проверкам на реальном трафике - 92% определения трафика. У sce там же поменьше будет.

а вы как сравнивали/тестили ее с SCE

или у вас есть чьи-то результаты?

мне просто самому интерестно что предпочтительнее для p2p трафика без персонификации

Share this post


Link to post
Share on other sites
2. 32-й - зло, ибо архитектура у него не очень-общая шина на 32Гбит; 67хх модули - не встанут.
Плюс очень скромные возможности апгрейда.

А как Л3-молотилка суп32 в 2 раза медленнее чем суп2.

Но при его цене - многое можно простить. ;-)

Share this post


Link to post
Share on other sites
sandvine получше будет. По последним проверкам на реальном трафике - 92% определения трафика. У sce там же поменьше будет.

а вы как сравнивали/тестили ее с SCE

или у вас есть чьи-то результаты?

мне просто самому интерестно что предпочтительнее для p2p трафика без персонификации

Скажем так: Щас тестирование. Один Интергратор у одного ооочень "жирного" клиента. Это все что могу сказать. У себя запланировали тестирование месяца через 3 (очередь, однако)

Edited by Konstantin Klimchev

Share this post


Link to post
Share on other sites

я лично слышал такие отзывы:

- SCE более сыроват тяжел в настройке и ведет себя зачастую "не так как надо"

- sandvine больше инсталляций было по России в плане p2p трафика а не для "задач сотовых операторов"

по цене решения очень схожи

+ сандвайн также нормально интегрируется с тем же isg

 

а ваше текущее мнение?

Share this post


Link to post
Share on other sites

Ребят, может все таки есть варианты повесить полиси на NAT интерфейс? Очень не хочется сейчас вкладываться... Лучше потом что нибудь дельное возьмем.

Share this post


Link to post
Share on other sites
А ориентировочно во сколько может обойтись такая железка у нас в питере?

А 32й смысла не имеет уже, все равно где нибудь упремся? :)

1. Смотри у НАГа, + доставка. Недорого в общем...

2. 32-й - зло, ибо архитектура у него не очень-общая шина на 32Гбит; 67хх модули - не встанут, 65хх - будут работать на этой общей шине. Однако по функционалу - почти как 720-3В)))

Очень интересно. Т.е. предлагаете такой вариант?

http://shop.nag.ru/core.asp?main=catalog&a...d=430&cat=2

http://shop.nag.ru/core.asp?main=catalog&a...=1356&cat=2

 

Получаем pppoe? Каким образом будет радиус работать? Можно развернуть чуть подробнее - оченна интересно? :)

 

PS: Какой максимальный трафик эта штука потянет (чтобы уж знать, во что можем упереться)? :)

Edited by kostas

Share this post


Link to post
Share on other sites

ну да, только туда еще надо бп и адаптер на 2 fe

Share this post


Link to post
Share on other sites
ну да, только туда еще надо бп и адаптер на 2 fe
Угумс, это понятно :)

 

Это pppoe будет? Не томите :) С ISG не сталкивался, но слышал что хорошая штука :)

Share this post


Link to post
Share on other sites

sce-2020 я буду продавать месяца через 3 =)

так что скоро будет грузовик с пивом, ага

 

Share this post


Link to post
Share on other sites

Это pppoe будет? Не томите :) С ISG не сталкивался, но слышал что хорошая штука :)

Зачем pppoe? ISG прекрасно работает также и с ip и с dhcp сессиями=) В этой теме есть пример для dhcp с опт.82 например: http://forum.nag.ru/forum/index.php?showto...mp;#entry375866

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this