Перейти к содержимому
Калькуляторы

Cisco 2950 & QOS Промаркировать все пакеты на входе как?

Господа! А кто пробовал тупо промаркировать все пакеты, входящие с какого-то порта на этой железяке? Вроде все просто должно быть, а не работает что-то у меня.

 

 

Вот смотрите:

 

!System image file is "flash:c2950-i6q4l2-mz.121-22.EA12.bin"

 

access-list 2000 permit ip any any

 

class-map match-all all

match access-group 2000

 

policy-map prec6

class all

set ip dscp 48

 

interface FastEthernet0/1

switchport access vlan 804

switchport mode access

load-interval 180

no keepalive

duplex full

service-policy input prec6

 

 

Гоняю пакеты смотрю через Ethereal - не выставляет он precedence.

 

Что не так?

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

qos включен?

а вообще-то это можно сделать проще - выставить cos и воспользоваться cos to dscp map

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

А как его включить?

 

 

По каманде:

 

d-sw1(config)#mls qos ?

map qos map keyword

 

d-sw1(config)#mls qos

 

Есть только варинт "map", а мне он не нужен.

Это вам не 2960 :-)

 

Вот еще результат команды:

 

d-sw1#show mls qos interface f0/1

FastEthernet0/1

Attached policy-map for Ingress: prec6

trust state: not trusted

trust mode: not trusted

COS override: dis

default COS: 0

pass-through: none

trust device: none

Изменено пользователем shmyga

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

можно на интерфейсе

mls qos cos 5

например.

в wireshark

я вижу пакеты с пятым приоритетом вот так:

Differentiated Services Field: 0xa0 (DSCP 0x28: Class Selector 5; ECN: 0x00)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Господа! А кто пробовал тупо промаркировать все пакеты, входящие с какого-то порта на этой железяке? Вроде все просто должно быть, а не работает что-то у меня.

 

 

Вот смотрите:

 

!System image file is "flash:c2950-i6q4l2-mz.121-22.EA12.bin"

 

access-list 2000 permit ip any any

 

class-map match-all all

match access-group 2000

 

policy-map prec6

class all

set ip dscp 48

 

interface FastEthernet0/1

switchport access vlan 804

switchport mode access

load-interval 180

no keepalive

duplex full

service-policy input prec6

 

 

Гоняю пакеты смотрю через Ethereal - не выставляет он precedence.

 

Что не так?

у вас service-policy висит на l2 интерфейсе, а должна на l3.

 

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Господа! А кто пробовал тупо промаркировать все пакеты, входящие с какого-то порта на этой железяке? Вроде все просто должно быть, а не работает что-то у меня.

 

 

Вот смотрите:

 

!System image file is "flash:c2950-i6q4l2-mz.121-22.EA12.bin"

 

access-list 2000 permit ip any any

 

class-map match-all all

match access-group 2000

 

policy-map prec6

class all

set ip dscp 48

 

interface FastEthernet0/1

switchport access vlan 804

switchport mode access

load-interval 180

no keepalive

duplex full

service-policy input prec6

 

 

Гоняю пакеты смотрю через Ethereal - не выставляет он precedence.

 

Что не так?

добавить в глобальный конфиг mls qos

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

На первый взгляд такой конфиг должен работать. Правда я настраивал на 3550. К сожалению, 2950 счас далеко - настроить-то для пробы могу а вот с Wireshark-ом туда не подлезть. Но если вам достаточно весь трафик с порта маркировать - просто поставьте на этом порту cos 5, а дальше за вас cos to dhcp map отработает.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Спасибо за участие!

 

Не работает.

 

1. Команды mls qos на 2950 нету.

2. L3 интерфейс создать нельзя по определению.

3. Сейчас стоит

interface FastEthernet0/5

switchport access vlan 113

switchport mode access

no keepalive

mls qos cos 6

mls qos cos override

spanning-tree bpdufilter enable

 

не работает.

 

Ума не приложу, что еще ковырять?

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Что-то у вас не так. Я сейчас проверил - вот такая конфигурация прекрасно работает:

IOS C2950 Software (C2950-I6K2L2Q4-M), Version 12.1(22)EA10a, RELEASE SOFTWARE (fc2)

 

class-map match-all HIGH

match access-group name MARKER

!

!

policy-map TEST

class HIGH

set ip dscp 48

!

 

!

interface FastEthernet0/2

service-policy input TEST

!

 

!

ip access-list extended MARKER

permit ip any any

!

 

В результате Wireshark показывает в приходящих пакетах:

Differentiated Services Field: 0xc0 (DSCP 0x30: Class Selector 6; ECN: 0x00)

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Разобрался!

 

Оказалось - сам виноват.

 

Коммут стоит не на столе, а в точке, есс-но.

 

Так вот, на одном промежуточном(!) коммуте был включен "mls qos", а соответсвующие порты в trust qos dscp не были поставлены. Вот он-то и переписыл правильно установленные dscp.

 

 

Но все равно, спасибо за поддержу!

Изменено пользователем shmyga

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас