Jump to content
Калькуляторы

Cisco 2950 & QOS Промаркировать все пакеты на входе как?

Господа! А кто пробовал тупо промаркировать все пакеты, входящие с какого-то порта на этой железяке? Вроде все просто должно быть, а не работает что-то у меня.

 

 

Вот смотрите:

 

!System image file is "flash:c2950-i6q4l2-mz.121-22.EA12.bin"

 

access-list 2000 permit ip any any

 

class-map match-all all

match access-group 2000

 

policy-map prec6

class all

set ip dscp 48

 

interface FastEthernet0/1

switchport access vlan 804

switchport mode access

load-interval 180

no keepalive

duplex full

service-policy input prec6

 

 

Гоняю пакеты смотрю через Ethereal - не выставляет он precedence.

 

Что не так?

 

Share this post


Link to post
Share on other sites

qos включен?

а вообще-то это можно сделать проще - выставить cos и воспользоваться cos to dscp map

Share this post


Link to post
Share on other sites

А как его включить?

 

 

По каманде:

 

d-sw1(config)#mls qos ?

map qos map keyword

 

d-sw1(config)#mls qos

 

Есть только варинт "map", а мне он не нужен.

Это вам не 2960 :-)

 

Вот еще результат команды:

 

d-sw1#show mls qos interface f0/1

FastEthernet0/1

Attached policy-map for Ingress: prec6

trust state: not trusted

trust mode: not trusted

COS override: dis

default COS: 0

pass-through: none

trust device: none

Edited by shmyga

Share this post


Link to post
Share on other sites

можно на интерфейсе

mls qos cos 5

например.

в wireshark

я вижу пакеты с пятым приоритетом вот так:

Differentiated Services Field: 0xa0 (DSCP 0x28: Class Selector 5; ECN: 0x00)

Share this post


Link to post
Share on other sites
Господа! А кто пробовал тупо промаркировать все пакеты, входящие с какого-то порта на этой железяке? Вроде все просто должно быть, а не работает что-то у меня.

 

 

Вот смотрите:

 

!System image file is "flash:c2950-i6q4l2-mz.121-22.EA12.bin"

 

access-list 2000 permit ip any any

 

class-map match-all all

match access-group 2000

 

policy-map prec6

class all

set ip dscp 48

 

interface FastEthernet0/1

switchport access vlan 804

switchport mode access

load-interval 180

no keepalive

duplex full

service-policy input prec6

 

 

Гоняю пакеты смотрю через Ethereal - не выставляет он precedence.

 

Что не так?

у вас service-policy висит на l2 интерфейсе, а должна на l3.

 

 

 

Share this post


Link to post
Share on other sites
Господа! А кто пробовал тупо промаркировать все пакеты, входящие с какого-то порта на этой железяке? Вроде все просто должно быть, а не работает что-то у меня.

 

 

Вот смотрите:

 

!System image file is "flash:c2950-i6q4l2-mz.121-22.EA12.bin"

 

access-list 2000 permit ip any any

 

class-map match-all all

match access-group 2000

 

policy-map prec6

class all

set ip dscp 48

 

interface FastEthernet0/1

switchport access vlan 804

switchport mode access

load-interval 180

no keepalive

duplex full

service-policy input prec6

 

 

Гоняю пакеты смотрю через Ethereal - не выставляет он precedence.

 

Что не так?

добавить в глобальный конфиг mls qos

 

 

Share this post


Link to post
Share on other sites

На первый взгляд такой конфиг должен работать. Правда я настраивал на 3550. К сожалению, 2950 счас далеко - настроить-то для пробы могу а вот с Wireshark-ом туда не подлезть. Но если вам достаточно весь трафик с порта маркировать - просто поставьте на этом порту cos 5, а дальше за вас cos to dhcp map отработает.

Share this post


Link to post
Share on other sites

Спасибо за участие!

 

Не работает.

 

1. Команды mls qos на 2950 нету.

2. L3 интерфейс создать нельзя по определению.

3. Сейчас стоит

interface FastEthernet0/5

switchport access vlan 113

switchport mode access

no keepalive

mls qos cos 6

mls qos cos override

spanning-tree bpdufilter enable

 

не работает.

 

Ума не приложу, что еще ковырять?

 

Share this post


Link to post
Share on other sites

Что-то у вас не так. Я сейчас проверил - вот такая конфигурация прекрасно работает:

IOS C2950 Software (C2950-I6K2L2Q4-M), Version 12.1(22)EA10a, RELEASE SOFTWARE (fc2)

 

class-map match-all HIGH

match access-group name MARKER

!

!

policy-map TEST

class HIGH

set ip dscp 48

!

 

!

interface FastEthernet0/2

service-policy input TEST

!

 

!

ip access-list extended MARKER

permit ip any any

!

 

В результате Wireshark показывает в приходящих пакетах:

Differentiated Services Field: 0xc0 (DSCP 0x30: Class Selector 6; ECN: 0x00)

 

 

Share this post


Link to post
Share on other sites

Разобрался!

 

Оказалось - сам виноват.

 

Коммут стоит не на столе, а в точке, есс-но.

 

Так вот, на одном промежуточном(!) коммуте был включен "mls qos", а соответсвующие порты в trust qos dscp не были поставлены. Вот он-то и переписыл правильно установленные dscp.

 

 

Но все равно, спасибо за поддержу!

Edited by shmyga

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this