Jump to content
Калькуляторы

не корректно работает ubrl

Добрый день, возникла проблема ограничения пользователей по скорости, решил попробовать организовать это посредством ubrl (user-based rate limit), однако работает оно как-то нехорошо т.е. выставляю скорость 800000 а при скачке с ftp 75-78кб/сек, http дает 80-83кб/сек и т.д. однако торрент дает ровно 100кб/сек. Я конечно понимаю что это не шейп а простой дроп пакетов, но все же может это что-то недопонимаю (очень надеюсь на это :) ). Как не крутил burst не особо помогло :(

 

P.S. если у кого был такой же печальный опыт применения ubrl, напишите плиз как решили.

 

вот кофиг:

 

class-map match-all test_limit

match access-group name test_limit_in

....

policy-map test_limit

class

police flow mask dest-only 800000 8000 conform-action transmit exceed-action drop

 

....

interface GigabitEthernet1/1

mls qos vlan-based

switchport trunk allowed vlan 1020

 

....

interface Vlan1020

ip address x.x.x.x 255.255.255.252

service-policy input limit_in

 

....

ip access-list extended test_limit_in

permit ip any host 10.255.255.2

deny ip any any

 

Share this post


Link to post
Share on other sites

Значит надо шейпить, не подскажите какое оборудование для этого обычно используется (я имею в виду железяку, не софт :) ) ?

Share this post


Link to post
Share on other sites
Значит надо шейпить, не подскажите какое оборудование для этого обычно используется (я имею в виду железяку, не софт :) ) ?
Так ведь шейпинг только на выход работает из интерфейса. А у вас судя по конфигу полиси на вход прибита...

И имхо на свичах шейпинг не поддерживается (

 

PS фигню написал, настроено для UBRL имхо всё правильно. GigabitEthernet1/1-Vlan1020 - этот интерфейс как я понял смотрит на внешние сети?

А 10.255.255.2 адрес тестового юзверя?

 

 

Edited by Stak

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this