Jump to content
Калькуляторы

mrtg+snmp >120Mbit/s

FreeBSD 7.0

Стоят последние версии net-snmp и mrtg из портов. При превышении трафика 120Мбит/сек рисует лажу.

Нашел совет - заставить мртг снимать данные со счетчиков снмп по протоколу v2. Прописал в mrtg.conf:

Target [port]: 1:public@localhost:::::2

В итоге мртг вообще ничего не снимает, в файл port.log пишется два числа -1 -1

Я так понимаю, то ли снмп не умеет считать 64-битными счетчиками, то ли мртг не умеет их смотреть. Подскажите куда копать?

Share this post


Link to post
Share on other sites

snmp-options=:::::2 используется, если необходимо мониторить гигабитные порты.

cfgmaker --snmp-options=:::::2 --ifref=name --no-down public@xx.xx.xx.xx > device.cfg

Share this post


Link to post
Share on other sites
FreeBSD 7.0

Стоят последние версии net-snmp и mrtg из портов. При превышении трафика 120Мбит/сек рисует лажу.

Нашел совет - заставить мртг снимать данные со счетчиков снмп по протоколу v2. Прописал в mrtg.conf:

Target [port]: 1:public@localhost:::::2

В итоге мртг вообще ничего не снимает, в файл port.log пишется два числа -1 -1

Я так понимаю, то ли снмп не умеет считать 64-битными счетчиками, то ли мртг не умеет их смотреть. Подскажите куда копать?

RRD-Tools

Share this post


Link to post
Share on other sites

Снимать просто нужно каждую минуту а не 5 минут.

Share this post


Link to post
Share on other sites
snmp-options=:::::2 используется, если необходимо мониторить гигабитные порты.

cfgmaker --snmp-options=:::::2 --ifref=name --no-down public@xx.xx.xx.xx > device.cfg

Порты конечно же гиговые :)

Применил. Теперь счетчики опрашиваются, уже не пишется -1 -1, а пишутся большие числа. Но проблема та же - как только трафик превышает 12,5 Мбайт/сек, на графике отображаются какие-то жалкие килобайты.

Edited by Alexandr Ovcharenko

Share this post


Link to post
Share on other sites

А что за железка, с которой это всё снимается? Может на ней snmpv2 вообще нету, соотвественно и 64битных счетчиков тоже?

Share this post


Link to post
Share on other sites

<ifInOctets>

<name>Bytes In</name>

<method>walk</method>

<source>value</source>

<direction>output</direction>

<oid>.1.3.6.1.2.1.2.2.1.10</oid>

</ifInOctets>

<ifOutOctets>

<name>Bytes Out</name>

<method>walk</method>

<source>value</source>

<direction>output</direction>

<oid>.1.3.6.1.2.1.2.2.1.16</oid>

</ifOutOctets>

<ifHCInOctets>

<name>Bytes In - 64-bit Counters</name>

<method>walk</method>

<source>value</source>

<direction>output</direction>

<oid>.1.3.6.1.2.1.31.1.1.1.6</oid>

</ifHCInOctets>

Это из кактуса.

Edited by mikevlz

Share this post


Link to post
Share on other sites
FreeBSD 7.0

Стоят последние версии net-snmp и mrtg из портов. При превышении трафика 120Мбит/сек рисует лажу.

SNMP снимаете с интерфейсов сервера на FreeBSD ?

 

Share this post


Link to post
Share on other sites

в make.conf добавить

.if ${.CURDIR} == ${PORTSDIR}/net-mgmt/net-snmp
WITH_MFD_REWRITES="YES"
.endif

пересобрать net-snmp

и снимать не ifTable, а ifXTable там 64-битные счётчики

Edited by hizel

Share this post


Link to post
Share on other sites
Снимать просто нужно каждую минуту а не 5 минут.

 

Ага , а с 10Гбит порта прикажете снимать каждые 6 секунд ? :))

 

snmpv2 прекрасно снимает статистику.

 

P.S. на джуниперах (кстати оно на FreeBSD работает) все нормально работает

Share this post


Link to post
Share on other sites

Заработала! :)

после того как сделал по совету hizel, а уже потом как сказал vit:

cfgmaker --snmp-options=:::::2 --ifref=name --no-down public@xx.xx.xx.xx > device.cfg

Всем спасибо!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this