Jump to content
Калькуляторы

Совместимость MSTP и STP

kostas, попробуйте добавить первый влан в транк между каталистом и экстримами.

Во-вторых, настройте порт-мирроринг на каталисте, и посмотрите wireshark'ом или tcpdump'ом что бегает между каталистом и экстримом.

Вилан #1 добавил в транк - ничего не изменилось :(

 

interface GigabitEthernet2/3
description Test STP
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,3,4,1000
switchport mode trunk

 

Трафик на днях проанализирую. А на что именно обратить внимание?

Share this post


Link to post
Share on other sites
kostas, попробуйте добавить первый влан в транк между каталистом и экстримами.

Во-вторых, настройте порт-мирроринг на каталисте, и посмотрите wireshark'ом или tcpdump'ом что бегает между каталистом и экстримом.

Вилан #1 добавил в транк - ничего не изменилось :(

 

interface GigabitEthernet2/3
description Test STP
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,3,4,1000
switchport mode trunk

 

Трафик на днях проанализирую. А на что именно обратить внимание?

Попробуйте воспроизвести ситуацию как у D^2. Т.е. транк только с одним вланом (дефолтовым 1-м).

 

Сложно сказать на что обратить внимание, просто дамп бпду-шек от каталиста, и от экстрима покажите.

Может они в разных вланах гуляют(?), хз, надо смотреть в чем различие, почему свитчи не видят друг друга.

 

У D^2 еще native влан прописан на каталисте на транке с экстримом. Тоже отличие какое-то от вашей схемы.

Share this post


Link to post
Share on other sites

Необходимость в кольцах снова назрела, поэтому поднимаю топик.

Пробовал включать debug spanning-tree all и менять топологию кольца - никаких сообщений в дебаге по этому поводу нет.

В кольце сейчас три комутатора - рутовый каталист + 2 эктрима. Эктримы друг друга видят и на изменение топологии реагируют, а вот каталист как считает себя рутом, так оно и не меняется + дебаг по stp ничего на нем не дает.

К чему бы это?

Share this post


Link to post
Share on other sites

Коллеги, выручайте - любой совет будет на пользу.

Share this post


Link to post
Share on other sites

D^2, есть идеи почему дебаг ничего не кажет по stp? Получается до каталиста вообще ничего не доходит?

Share this post


Link to post
Share on other sites

у Вас в sh span det видно что на порты каталиста BPDU не приходят.

почему?

Share this post


Link to post
Share on other sites
у Вас в sh span det видно что на порты каталиста BPDU не приходят.

почему?

Теперь вроде приходят - кольцо подключено на 3й модуль. Сори, что изменения не закинул.

 

 VLAN0003 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 8192, address 0004.de18.b403
  Configured hello time 2, max age 20, forward delay 15
  We are the root of the spanning tree
  Topology change flag not set, detected flag not set
  Number of topology changes 52 last change occurred 11:24:30 ago
          from GigabitEthernet3/2
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15 
  Timers: hello 0, topology change 0, notification 0, aging 300

Port 257 (GigabitEthernet3/1) of VLAN0003 is forwarding 
   Port path cost 4, Port priority 128, Port Identifier 128.257.
   Designated root has priority 8192, address 0004.de18.b403
   Designated bridge has priority 8192, address 0004.de18.b403
   Designated port id is 128.257, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   Link type is point-to-point by default
   BPDU: sent 204246, received 7

Port 258 (GigabitEthernet3/2) of VLAN0003 is blocking 
   Port path cost 4, Port priority 128, Port Identifier 128.258.
   Designated root has priority 8192, address 0004.de18.b403
   Designated bridge has priority 8192, address 0004.de18.b403
   Designated port id is 128.257, designated path cost 0
   Timers: message age 1, forward delay 0, hold 0
   Number of transitions to forwarding state: 0
   Link type is point-to-point by default
   BPDU: sent 14, received 20527

 

 

 

Share this post


Link to post
Share on other sites

Можно я вставлю свое слово.

По моему, kostas, Вы с D^2 уже почти решили проблему.

Взгляните еще раз внимательно на пример D^2 с транком.

 

Прочтите вот это http://blog.internetworkexpert.com/2008/07...pvst-explained/

и это http://cciethebeginning.wordpress.com/2008...-pvst-and-pvst/

 

Я не цисковод, но люди пишут, что каталист сваливается в pvst+ режим на dot1q транках если в конфигурации стоит pvst (изначально применимый только к isl). Однозначно сможете это прояснить если посмотрите дампы. Наличие (кроме bpdu на IEEE мак 0180.0CCC.CCCD) bpdu на мак 0100.0CCC.CCCD, укажет, что режим pvst+, иначе голый STP.

 

 

D^2 неспроста native влан поставил в 999.

 

Теперь почитайте документацию экстрима, и снимите дамп его bpdu, когда порты 24, 26 стоят в транке.

Опять же, из примера D^2 видно, что первый влан у него стал tagget, а в примере с акцессными портами был в untagget.

У меня нет опыта с экстримом, но по видимому он тегирует bpdu фрейм единицей в этом случае, т.е. ведет себя также как каталист, и на его порту стоит native 999.

 

Вцелом у вас проблема скорее с тегированием bpdu фреймов.

Конфиг каталиста должен быть такой

 

spanning-tree mode pvst

spanning-tree vlan 1 priority 8192

no spanning-tree vlan все_ваши_вланы_кроме_1

 

interface GigabitEthernet2/1

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 999

switchport trunk allowed vlan 1, ваши_дополнительные_вланы

switchport mode trunk

 

Можно ли сделать, так чтобы в режиме транка не менять native влан, зависит от экстрима. Если Вы сможете его настроить так, чтобы для первого влана порты 24,26 были untagget, а для остальных вланов tagget, то все возможно.

 

И еще, запускать STP на экстриме нужно в первом влане, т.е. в выводе

 

Summit24e3:47 # sh stp

Stpd: s0 Stp: ENABLED Number of Ports: 26

Rapid Root Failover: Disabled

Ports: 1,2,3,4,5,6,7,8,9,10,11,12

13,14,15,16,17,18,19,20,21,22,23,24

25,26

Vlans: Default MacVlanDiscover

 

последняя строчка явно указывает на перый влан.

А у Вас иногда выглядит так

 

Summit24e3:1 # sh stpd test_st

Stpd: test_st Stp: ENABLED Number of Ports: 26

Rapid Root Failover: Disabled

Ports: 1,2,3,4,5,6,7,8,9,10,11,12

13,14,15,16,17,18,19,20,21,22,23,24

25,26

Vlans: Manage Office

 

Похоже на то, что Вы включили pvst на экстриме.

 

 

 

Share this post


Link to post
Share on other sites
D^2, есть идеи почему дебаг ничего не кажет по stp? Получается до каталиста вообще ничего не доходит?

Осмелюсь вставить свои 5 коп. и предположить, что соединяетесь с каталистом не через консоль, а по ssh/telnet

тогда

terminal monitor

ответ на вопрос

Share this post


Link to post
Share on other sites
D^2, есть идеи почему дебаг ничего не кажет по stp? Получается до каталиста вообще ничего не доходит?

Осмелюсь вставить свои 5 коп. и предположить, что соединяетесь с каталистом не через консоль, а по ssh/telnet

тогда

terminal monitor

ответ на вопрос

К сожалению через консоль цепляюсь :(

Share this post


Link to post
Share on other sites
Можно я вставлю свое слово.

По моему, kostas, Вы с D^2 уже почти решили проблему.

Взгляните еще раз внимательно на пример D^2 с транком.

 

Прочтите вот это http://blog.internetworkexpert.com/2008/07...pvst-explained/

и это http://cciethebeginning.wordpress.com/2008...-pvst-and-pvst/

 

Я не цисковод, но люди пишут, что каталист сваливается в pvst+ режим на dot1q транках если в конфигурации стоит pvst (изначально применимый только к isl). Однозначно сможете это прояснить если посмотрите дампы. Наличие (кроме bpdu на IEEE мак 0180.0CCC.CCCD) bpdu на мак 0100.0CCC.CCCD, укажет, что режим pvst+, иначе голый STP.

 

 

D^2 неспроста native влан поставил в 999.

 

Теперь почитайте документацию экстрима, и снимите дамп его bpdu, когда порты 24, 26 стоят в транке.

Опять же, из примера D^2 видно, что первый влан у него стал tagget, а в примере с акцессными портами был в untagget.

У меня нет опыта с экстримом, но по видимому он тегирует bpdu фрейм единицей в этом случае, т.е. ведет себя также как каталист, и на его порту стоит native 999.

 

Вцелом у вас проблема скорее с тегированием bpdu фреймов.

Конфиг каталиста должен быть такой

 

spanning-tree mode pvst

spanning-tree vlan 1 priority 8192

no spanning-tree vlan все_ваши_вланы_кроме_1

 

interface GigabitEthernet2/1

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 999

switchport trunk allowed vlan 1, ваши_дополнительные_вланы

switchport mode trunk

 

Можно ли сделать, так чтобы в режиме транка не менять native влан, зависит от экстрима. Если Вы сможете его настроить так, чтобы для первого влана порты 24,26 были untagget, а для остальных вланов tagget, то все возможно.

 

И еще, запускать STP на экстриме нужно в первом влане, т.е. в выводе

 

Summit24e3:47 # sh stp

Stpd: s0 Stp: ENABLED Number of Ports: 26

Rapid Root Failover: Disabled

Ports: 1,2,3,4,5,6,7,8,9,10,11,12

13,14,15,16,17,18,19,20,21,22,23,24

25,26

Vlans: Default MacVlanDiscover

 

последняя строчка явно указывает на перый влан.

А у Вас иногда выглядит так

 

Summit24e3:1 # sh stpd test_st

Stpd: test_st Stp: ENABLED Number of Ports: 26

Rapid Root Failover: Disabled

Ports: 1,2,3,4,5,6,7,8,9,10,11,12

13,14,15,16,17,18,19,20,21,22,23,24

25,26

Vlans: Manage Office

 

Похоже на то, что Вы включили pvst на экстриме.

rus-p, спасибо за помощь, сейчас буду вникать - оченна много букаф :)

Но если честно, что-то я совсем запутался.

Что мы имеем:

--

Extreme -- поддержка только чистого STP (802.1D)

Catalyst 6500 + SUP2/MSFC2/PFC2 (s222-ipservicesk9_wan-mz.122-18.SXF15a) -- поддержка MST (802.1s), RSTP (802.1w), PVST (его отбрасываем сразу)

--

Можете еще раз развернуть мысль? У меня управляющий Vlan - Manage, поэтому от дефолта ушел и его не использую. Но на время тестирования в vlan Default включен в STP s0 на экстримах

Summit24e3:1 # sh stpd test_st
Stpd: test_st        Stp: ENABLED        Number of Ports: 26
Rapid Root Failover: Disabled
Ports: 1,2,3,4,5,6,7,8,9,10,11,12
       13,14,15,16,17,18,19,20,21,22,23,24
       25,26
Vlans:  Default MacVlanDiscover Manage

Share this post


Link to post
Share on other sites

rus-p, хм, по ссылке интересная фраза http://cciethebeginning.wordpress.com/2008...-pvst-and-pvst/

-IEEE 802.1q native VLAN (VLAN 1 by default) cooperate with PVST, PVST+ and MSTI (802.1s).

Это то, о чем я подумал?

 

К сожалению снять дамп средствами железок не понял как, а включать снифер пока нет возможности.

Share this post


Link to post
Share on other sites

rus-p, cсылки интересные, но там везде идет разбор PVST, который в моем случае не используется. Но судя по этим хитростям с PVST, есть подозрение что подобное может быть и с MST.

Хотя с другой стороны, на каталисте установлена опция

spanning-tree mode pvst

Которя как я понимаю подразумевает включение PVST. Чего-то я совсем запутался :(

 

Гуру, выручайте уже - моск уже не соображает ничего. Кто на 6500 использует STP (с dlink хотя бы), как вы у себя поднимали его? В чем были засады, если таковые были.

 

PS: Думаю если бы не отказался от дефолтового vlan'a, то траблов было бы меньше с STP... но нет же, мы легких путей не ищем.

 

Share this post


Link to post
Share on other sites

Вот так раз, как же забыть pvst, если он у Вас включен ?

Лучше Вы пока забудьте про режим msti (пререлиз последующего mst) и доведите до конца разбор полетов с pvst, отказываться от которого нет смысла, так как он работает на dot1q транках, вопрос в каком виде.

Режим mst Вы же сами не хотели использовать из за необходимости покупки второго супа, или уже передумали ?

Определитесь что есть в наличии, иначе трудно вести разговор.

Мирроринг порта через span, и выложите сюда bpdu каталиста и экстрима вместе с их конфигурацией.

 

от экстрима нужно что-то похожее на это:

show stpd mode

show stpd s0

show Manage

show default

show stpd s0 ports 24,26

 

Просветите меня, экстрим "e серии" c Вашей прошивкой точно умеет только 802.1d, и порты могут быть только в этом режиме ?

Потому как не "е", умеет много чего больше судя по мануалу.

 

Насчет, развернуть мысль, попробую.

Используйте влан Manage, но помните, что командой добавления влана к stp инстансу, вы добавляете на самом деле порты этого влана. Сам влан имеет опосредованное значение.

Используйте в тесте инстанс s0, опять же, по причине упрощения конфигурации, т.к. по мануалу он работает по дефолту в 1d, с собственными инстансами начинаются вкусности которые Вам пока не нужны.

 

Edited by rus-p

Share this post


Link to post
Share on other sites
Вот так раз, как же забыть pvst, если он у Вас включен ?

Лучше Вы пока забудьте про режим msti (пререлиз последующего mst) и доведите до конца разбор полетов с pvst, отказываться от которого нет смысла, так как он работает на dot1q транках, вопрос в каком виде.

Режим mst Вы же сами не хотели использовать из за необходимости покупки второго супа, или уже передумали ?

Определитесь что есть в наличии, иначе трудно вести разговор.

Мирроринг порта через span, и выложите сюда bpdu каталиста и экстрима вместе с их конфигурацией.

 

от экстрима нужно что-то похожее на это:

show stpd mode

show stpd s0

show Manage

show default

show stpd s0 ports 24,26

 

Просветите меня, экстрим "e серии" c Вашей прошивкой точно умеет только 802.1d, и порты могут быть только в этом режиме ?

Потому как не "е", умеет много чего больше судя по мануалу.

 

Насчет, развернуть мысль, попробую.

Используйте влан Manage, но помните, что командой добавления влана к stp инстансу, вы добавляете на самом деле порты этого влана. Сам влан имеет опосредованное значение.

Используйте в тесте инстанс s0, опять же, по причине упрощения конфигурации, т.к. по мануалу он работает по дефолту в 1d, с собственными инстансами начинаются вкусности которые Вам пока не нужны.

Ребят, спасибо большое за участие в решении моей проблемы. Приятно осознавать, что можно надеяться на помощь...

История в общих чертах такая. Дело в том, что меня ввело в заблуждение утверждение что pvst это проприетарный протокол cisco, с которым стороннее оборудование не работает. Такое утверждение несколько раз встречал в инете. Где конкретно - если найду сейчас, то допишу следующим постом. Соответственно изначально его не стал рассматривать и стал пробовать с mst, что в общем-то не увенчалось успехом и было выдвинуто предположение, что на моей прошивке (тогда еще 12.1) поддержка mst не полная. Затем Дима (D^2) собрал у себя подобный стенд и в режиме pvst завел таки у себя дерево. Но действительно, как Вы правильно обратили внимание, там использовался Vlan1 - дефолтный, про который так же упоминалось в статьях, ссылки на которые Вы запостили, из которых на сколько я понял, каталист использует именно Vlan1 для рассылки bpdu (поправьте, если я не доконца понял).

В итоге я выставил у себя так же режим stp в pvst и не получил рабочего дерева. И скорее всего Вы правы - из-за того, что у меня не используется Vlan1. Хоть я и пробовал после этого включать в транк vlan1, но сейчас уже не могу утверждать, что vlan1 был на обоих двевайсах в транке кольца. Тогда еще небыло понимания, если это можно назвать пониманием, сути проблемы :)

Кстати говоря, голову и соответственно прошивку мы в итоге поменяли, так что если верить циске, в моей прошивке теперь есть более менее правильная поддержка mts. Так что вариант еще есть... Но хочу признаться - каша уже в голове от этих деревьев :)

 

Очень надеюсь на помощь в разгребании этой каши :)

 

И так что мы имеем.

 

1. Catalyst 6500 SUP2/MSFC2/PFC2

- IOS 122-18.SXF15a (s222-ipservicesk9_wan-mz.122-18.SXF15a)

- поддержка MST (802.1s), RSTP (802.1w), PVST

 

2. Extreme Summit24e3

- поддержка STP (802.1D)

 

Summary of Features

The Summit24e3 supports the following ExtremeWare features:

• Virtual local area networks (VLANs) including support for IEEE 802.1Q and IEEE 802.1p

Spanning Tree Protocol (STP) (IEEE 802.1D)

• Quality of Service (QoS) including support for IEEE 802.1p, MAC QoS, and four hardware queues

• Wire-speed Internet Protocol (IP) routing

• DHCP/BOOTP Relay

• Network Address Translation (NAT)

• Extreme Standby Router Protocol (ESRP) - Aware support

• Ethernet Automated Protection Switching (EAPS) support

• Routing Information Protocol (RIP) version 1 and RIP version 2

• Open Shortest Path First (OSPF) routing protocol

• Wire-speed IP multicast routing support

• DiffServ support

• Access-policy support for routing protocols

• Access list support for packet filtering

• Access list support for rate-limiting

• IGMP snooping to control IP multicast traffic

• Load sharing on multiple ports

• RADIUS client and per-command authentication support

• TACACS+ support

• Network Login

• Console command-line interface (CLI) connection

• Telnet CLI connection

• SSH2 connection

• Simple Network Management Protocol (SNMP) support

• Remote Monitoring (RMON)

• Traffic mirroring for ports

Catalyst

 

spanning-tree mode pvst
spanning-tree vlan 3 priority 8192
!         
interface GigabitEthernet3/1
description TestSTP
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 888
switchport trunk allowed vlan 3
switchport mode trunk
no ip address
!
interface GigabitEthernet3/2
description TestSTP
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 888
switchport trunk allowed vlan 3
switchport mode trunk
no ip address
!
interface Vlan1
no ip address
shutdown
!
interface Vlan3
description Management
ip address 10.3.0.1 255.255.255.0

 

#sh spanning-tree vlan 1

Spanning tree instance(s) for vlan 1 does not exist.

 

#sh spanning-tree vlan 3

VLAN0003
  Spanning tree enabled protocol ieee
  Root ID    Priority    8192
             Address     0004.de18.b403
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    8192 
             Address     0004.de18.b403
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi2/1            Desg FWD 4         128.129  P2p 
Gi2/2            Desg FWD 4         128.130  P2p 
Gi2/3            Desg FWD 4         128.131  P2p 
Gi2/4            Desg FWD 4         128.132  P2p 
Gi2/5            Desg FWD 4         128.133  P2p 
Gi2/6            Desg FWD 4         128.134  P2p 
Gi2/7            Desg FWD 4         128.135  P2p 
Gi3/1            Desg FWD 4         128.257  P2p 
Gi3/2            Back BLK 4         128.258  P2p

 

#sh spanning-tree vlan 3 detail 

VLAN0003 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 8192, address 0004.de18.b403
  Configured hello time 2, max age 20, forward delay 15
  We are the root of the spanning tree
  Topology change flag not set, detected flag not set
  Number of topology changes 59 last change occurred 23:35:08 ago
          from GigabitEthernet3/2
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15 
  Timers: hello 0, topology change 0, notification 0, aging 300

Port 257 (GigabitEthernet3/1) of VLAN0003 is forwarding 
   Port path cost 4, Port priority 128, Port Identifier 128.257.
   Designated root has priority 8192, address 0004.de18.b403
   Designated bridge has priority 8192, address 0004.de18.b403
   Designated port id is 128.257, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   Link type is point-to-point by default
   BPDU: sent 262466, received 13

Port 258 (GigabitEthernet3/2) of VLAN0003 is blocking 
   Port path cost 4, Port priority 128, Port Identifier 128.258.
   Designated root has priority 8192, address 0004.de18.b403
   Designated bridge has priority 8192, address 0004.de18.b403
   Designated port id is 128.257, designated path cost 0
   Timers: message age 2, forward delay 0, hold 0
   Number of transitions to forwarding state: 0
   Link type is point-to-point by default
   BPDU: sent 52, received 47800

 

 

Extreme Summit24e3 (на обоих комутаторах конфигурация одинакова)

 

# sh vlan
Name        VID Protocol Addr        Flags     Proto   Super Ports
   Default 0001 0.0.0.0        /BP -----------    ANY          0/  0
MacVlanDis 4094 ------------------ -----          ANY          0/  0
    Manage 0003 10.3.0.9       /24 -----------    ANY          2/  2
    Office 0004 ------------------ -----          ANY          2/  2

Flags : L=Loopback Enabled, r=RIP Enabled, o=OSPF Enabled
        f=IP Forwarding Enabled, m=IPmc Forwarding Enabled

 

# sh manage
VLAN Interface[2-202] with name "Manage" created by user
     Tagging:    802.1Q Tag 3 
     Priority:    802.1P Priority 0 
     IP:    10.3.0.9/255.255.255.0    
     STPD:    Domain "s0" is running spanning tree protocol
     Protocol:    Match all unfiltered protocols.
     Loopback:    Disable
     QosProfile:QP1 
     Ports:    2.     (Number of active ports = 2)
        Flags: * = active, ! = disabled

        Tagged:    25* 26* 
     Protected by 0 count of EAPS Domains

 

# sh default
VLAN Interface[0-200] with name "Default" created by user
     Tagging:    802.1Q Tag 1 
     Priority:    802.1P Priority 0 
     IP:    Waiting for bootp reply.
     STPD:    Domain "s0" is running spanning tree protocol
     Protocol:    Match all unfiltered protocols.
     Loopback:    Disable
     QosProfile:QP1 
     Ports:    0.     (Number of active ports = 0)
        Flags: * = active, ! = disabled

     Protected by 0 count of EAPS Domains

 

# sh stp s0
Stpd: s0        Stp: ENABLED        Number of Ports: 2
Rapid Root Failover: Disabled
Ports: 25,26
Vlans:  Default MacVlanDiscover Manage Office
Bridge Priority: 32768
BridgeID:        80:00:00:01:30:12:4c:d3
Designated root:    80:00:00:01:30:12:4c:d3
RootPathCost: 0     Root Port: ----
MaxAge: 20s        HelloTime: 2s        ForwardDelay: 15s
CfgBrMaxAge: 20s    CfgBrHelloTime: 2s    CfgBrForwardDelay: 15s
Topology Change Time: 35s            Hold time: 1s
Topology Change Detected: FALSE            Topology Change: FALSE
Number of Topology Changes: 1
Time Since Last Topology Change: 57984s

 

Дамп к сожалению пока снять не могу - доступ к железкам только удаленно. На выходных постараюсь сделать.

 

Share this post


Link to post
Share on other sites

stp опять запустили в 3-м влане, а надо в первом. ((

Замените 3 на 1 и поставьте 1 native на транковых портах.

Никто не запрещает Вам иметь менеждмент коммутаторов в 3-м влане, дайте только bpdu ходить в первом ))

Если ваш экстрим умеет только 1d, и порты не могут быть в режиме emistp, нельзя запрещать первый влан на экстриме, как это сейчас сделали Вы, дефолтный влан пустой.

Я посмотрел cli на extremeware, там можно явно задать первому быть untagget, остальным tagget, сделайте это.

Еще не превели команду sh stpd s0 ports 25,26

 

 

 

Share this post


Link to post
Share on other sites

Т.е. делаем примерно так?

 

Catalyst

 

spanning-tree mode pvst
spanning-tree vlan 1 priority 8192
!        
interface GigabitEthernet3/1
description TestSTP
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 1
switchport trunk allowed vlan 1,3
switchport mode trunk
no ip address
!
interface GigabitEthernet3/2
description TestSTP
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 1
switchport trunk allowed vlan 1,3
switchport mode trunk
no ip address
!
interface Vlan1
no ip address
shutdown
!
interface Vlan3
description Management
ip address 10.3.0.1 255.255.255.0

 

Extreme Summit24e3

 

# sh default
VLAN Interface[0-200] with name "Default" created by user
     Tagging:    802.1Q Tag 1 
     Priority:    802.1P Priority 0 
     IP:    Waiting for bootp reply.
     STPD:    Domain "s0" is running spanning tree protocol
     Protocol:    Match all unfiltered protocols.
     Loopback:    Disable
     QosProfile:QP1 
     Ports:    2.     (Number of active ports = 2)
        Flags: * = active, ! = disabled

        Untag:    25* 26* 
     Protected by 0 count of EAPS Domains

 

# sh manage
VLAN Interface[2-202] with name "Manage" created by user
     Tagging:    802.1Q Tag 3 
     Priority:    802.1P Priority 0 
     IP:    10.3.0.9/255.255.255.0    
     STPD:    Domain "s0" is running spanning tree protocol
     Protocol:    Match all unfiltered protocols.
     Loopback:    Disable
     QosProfile:QP1 
     Ports:    2.     (Number of active ports = 2)
        Flags: * = active, ! = disabled

        Tagged:    25* 26* 
     Protected by 0 count of EAPS Domains

 

# sh stpd s0 ports 25,26
Stpd: s0    Port: 25    PortId: 4019    Stp: ENABLED    Path Cost: 4
Port State: FORWARDING        Topology Change Ack: FALSE
Port Priority: 16
Designated Root:   80:00:00:01:30:12:4c:d3    Designated Cost: 0
Designated Bridge: 80:00:00:01:30:12:4c:d3    Designated Port Id: 4019

#
#
Stpd: s0    Port: 26    PortId: 401a    Stp: ENABLED    Path Cost: 4
Port State: FORWARDING        Topology Change Ack: FALSE
Port Priority: 16
Designated Root:   80:00:00:01:30:12:4c:d3    Designated Cost: 0
Designated Bridge: 80:00:00:01:30:12:4c:d3    Designated Port Id: 401a

Edited by kostas

Share this post


Link to post
Share on other sites

rus-p, нет слов - все работает! Даже не пришлось менять native vlan.

Получается что при наличии одного только дерева (а оно у меня одно, т.к. сидит в ядре и никуда не ходит), pvst в 802.1q работает без проблем?

Да, вот это дела...

 

PS: Пойдука я перечитаю еще раз Ваши две ссылочки про pvst :)

 

Пасиб огромное!!!

Share this post


Link to post
Share on other sites

А где работает, что-то не видно чтоб каталист рутом стал.

 

Share this post


Link to post
Share on other sites
А где работает, что-то не видно чтоб каталист рутом стал.

Да вроде работает :)

Пробовал даже порты убрать из Default vlan - все равно bpdu видит и отрабатывает.

 

Catalyst

 

#sh spa

VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    8192
             Address     0004.de18.b401
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    8192 
             Address     0004.de18.b401
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi3/1            Desg FWD 4         128.257  P2p 
Gi3/2            Desg FWD 4         128.258  P2p 
         
VLAN0003
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     0004.de18.b403
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32768
             Address     0004.de18.b403
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi2/1            Desg FWD 4         128.129  P2p 
Gi2/2            Desg FWD 4         128.130  P2p 
Gi2/3            Desg FWD 4         128.131  P2p 
Gi2/4            Desg FWD 4         128.132  P2p 
Gi2/5            Desg FWD 4         128.133  P2p 
Gi2/6            Desg FWD 4         128.134  P2p 
Gi2/7            Desg FWD 4         128.135  P2p 
Gi3/1            Desg FWD 4         128.257  P2p 
Gi3/2            Desg FWD 4         128.258  P2p

 

#sh spanning-tree vlan 1 detail 

VLAN0001 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 8192, address 0004.de18.b401
  Configured hello time 2, max age 20, forward delay 15
  We are the root of the spanning tree
  Topology change flag not set, detected flag not set
  Number of topology changes 12 last change occurred 09:30:22 ago
          from GigabitEthernet3/2
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15 
  Timers: hello 0, topology change 0, notification 0, aging 300

Port 257 (GigabitEthernet3/1) of VLAN0001 is forwarding 
   Port path cost 4, Port priority 128, Port Identifier 128.257.
   Designated root has priority 8192, address 0004.de18.b401
   Designated bridge has priority 8192, address 0004.de18.b401
   Designated port id is 128.257, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   Link type is point-to-point by default
   BPDU: sent 57206, received 4

Port 258 (GigabitEthernet3/2) of VLAN0001 is forwarding 
   Port path cost 4, Port priority 128, Port Identifier 128.258.
   Designated root has priority 8192, address 0004.de18.b401
   Designated bridge has priority 8192, address 0004.de18.b401
   Designated port id is 128.258, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   Link type is point-to-point by default
   BPDU: sent 49363, received 33

 

#sh spanning-tree vlan 3 detail 

VLAN0003 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 32768, address 0004.de18.b403
  Configured hello time 2, max age 20, forward delay 15
  We are the root of the spanning tree
  Topology change flag not set, detected flag not set
  Number of topology changes 72 last change occurred 09:25:26 ago
          from GigabitEthernet3/2
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15 
  Timers: hello 0, topology change 0, notification 0, aging 300

Port 257 (GigabitEthernet3/1) of VLAN0003 is forwarding 
   Port path cost 4, Port priority 128, Port Identifier 128.257.
   Designated root has priority 32768, address 0004.de18.b403
   Designated bridge has priority 32768, address 0004.de18.b403
   Designated port id is 128.257, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   Link type is point-to-point by default
   BPDU: sent 28514, received 1

Port 258 (GigabitEthernet3/2) of VLAN0003 is forwarding 
   Port path cost 4, Port priority 128, Port Identifier 128.258.
   Designated root has priority 32768, address 0004.de18.b403
   Designated bridge has priority 32768, address 0004.de18.b403
   Designated port id is 128.258, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   Link type is point-to-point by default
   BPDU: sent 17010, received 7574

 

Extreme

 

# sh stp s0 ports all
Stpd: s0    Port: 25    PortId: 4019    Stp: ENABLED    Path Cost: 4
Port State: FORWARDING        Topology Change Ack: FALSE
Port Priority: 16
Designated Root:   20:00:00:04:de:18:b4:01    Designated Cost: 4
Designated Bridge: 80:00:00:01:30:12:4c:d3    Designated Port Id: 401a

#
#
Stpd: s0    Port: 26    PortId: 401a    Stp: ENABLED    Path Cost: 4
Port State: FORWARDING        Topology Change Ack: FALSE
Port Priority: 16
Designated Root:   20:00:00:04:de:18:b4:01    Designated Cost: 8
Designated Bridge: 80:00:00:01:30:11:8e:00    Designated Port Id: 401a

 

 # sh stp
Stpd: s0        Stp: ENABLED        Number of Ports: 3
Rapid Root Failover: Disabled
Ports: 1,25,26
Vlans:  Default MacVlanDiscover Manage Office
Bridge Priority: 32768
BridgeID:        80:00:00:01:30:11:8e:00
Designated root:    20:00:00:04:de:18:b4:01
RootPathCost: 8     Root Port: 25
MaxAge: 20s        HelloTime: 2s        ForwardDelay: 15s
CfgBrMaxAge: 20s    CfgBrHelloTime: 2s    CfgBrForwardDelay: 15s
Topology Change Time: 35s            Hold time: 1s
Topology Change Detected: FALSE            Topology Change: FALSE
Number of Topology Changes: 6
Time Since Last Topology Change: 34397s

 

Сейчас вот пробую к этому зоопарку DES-3028 добавить... Стоит первым в кольце от каталиста, затем оба экстрима.

 

DES-3028:4#show stp   
Command: show stp

STP Bridge Global Settings
---------------------------
STP Status         : Enabled
STP Version        : STP compatible
Max Age            : 20     
Hello Time         : 2      
Forward Delay      : 15     
Max Hops           : 20     
TX Hold Count      : 3      
Forwarding BPDU    : Disabled
Loopback Detection : Enabled
LBD Recover Time   : 60

 

DES-3028:4#show stp ports instance 0                                    
Command: show stp ports instance 0
Port Designated Bridge  IntrCost  ExtrCost   Pri Edge P2P LBD Hello Status Role
---- ------------------ --------- ---------- --- ---- --- --- ----- ------ ----
1   N/A                *200000   *200000    128 No   Yes No  2     DIS    DIS 
2   N/A                *200000   *200000    128 No   Yes No  2     DIS    DIS 
3   N/A                *200000   *200000    128 No   Yes No  2     DIS    DIS 
4   N/A                *200000   *200000    128 No   Yes No  2     DIS    DIS 
5   N/A                *200000   *200000    128 No   Yes No  2     DIS    DIS 
6   N/A                *200000   *200000    128 No   Yes No  2     DIS    DIS 
7   N/A                *200000   *200000    128 No   Yes No  2     DIS    DIS 
8   N/A                *200000   *200000    128 No   Yes No  2     DIS    DIS 
9   N/A                *200000   *200000    128 No   Yes No  2     DIS    DIS 
10  N/A                *200000   *200000    128 No   Yes No  2     DIS    DIS 
11  N/A                *200000   *200000    128 No   Yes No  2     DIS    DIS 
12  N/A                *200000   *200000    128 No   Yes No  2     DIS    DIS 
13  N/A                *200000   *200000    128 No   Yes No  2     DIS    DIS 
14  N/A                *200000   *200000    128 No   Yes No  2     DIS    DIS 
15  N/A                *200000   *200000    128 No   Yes No  2     DIS    DIS 
16  N/A                *200000   *200000    128 No   Yes No  2     DIS    DIS 
17  N/A                *200000   *200000    128 No   Yes No  2     DIS    DIS 
18  N/A                *200000   *200000    128 No   Yes No  2     DIS    DIS 
19  N/A                *200000   *200000    128 No   Yes No  2     DIS    DIS 
20  N/A                *200000   *200000    128 No   Yes No  2     DIS    DIS 
21  N/A                *200000   *200000    128 No   Yes No  2     DIS    DIS 
22  N/A                *200000   *200000    128 No   Yes No  2     DIS    DIS 
23  N/A                *200000   *200000    128 No   Yes No  2     DIS    DIS 
24  N/A                *200000   *200000    128 No   Yes No  2     DIS    DIS 
25  8000/000130118E00  *20000    *20000     128 No   Yes No  2     BLOCK  ALT 
26  2000/0004DE18B401  *20000    *20000     128 No   Yes No  2     FWD    ROOT
27  N/A                *200000   *200000    128 No   Yes No  2     DIS    DIS 
28  N/A                *200000   *200000    128 No   Yes No  2     DIS    DIS

 

Только в отличии от эктримов тут пришлось транковые порты указать у Default вилана..

 

DES-3028:4#sh vlan
Command: show vlan


VID             : 1           VLAN Name       : default
VLAN Type       : Static      Advertisement   : Enabled
Member Ports    : 25-26               
Static Ports    : 25-26               
Current Tagged Ports   :                     
Current Untagged Ports : 25-26               
Static Tagged Ports    :                     
Static Untagged Ports  : 25-26               
Forbidden Ports        :                     

VID             : 3           VLAN Name       : Manage
VLAN Type       : Static      Advertisement   : Disabled
Member Ports    : 25-26               
Static Ports    : 25-26               
Current Tagged Ports   : 25-26               
Current Untagged Ports :                     
Static Tagged Ports    : 25-26               
Static Untagged Ports  :                     
Forbidden Ports        :                     


Total Entries  : 2

Share this post


Link to post
Share on other sites

пока читаю тему спрошу

кто пробовал подружить rstp от d-link и cisco???

 

есть узел от него идет несколько линий которые закольцованы (звезда, пара лучей которых закольцована)

используются свичи DGS-3100 используется около 150 вланов. настроен rstp. все замечательно работает. (rtsp тоже когда надо отрабатывает на ура)

по техническим причинам центральный свич заменяется на catalyst 3750g.

на всех работающих (в кольце) DGS-3100 включено:

enable stp

config stp version rstp

+ там где надо разорвать петлю выставлен высокий/низкий приоритет на портах

 

 

на тестовом стенде на cisco 3750g выполняю:

spanning-tree mode rapid-pvst

spanning-tree vlan 1-4094 priority 8193

вторая строчка чтобы сisco была рутом во всех вланахэтот свич рут во всех вланах

на dlink dgs-3100:

enable stp

config stp version rtsp

(все остальное по дефолту. минимум настроек больше не надо)

+ добавляю на свичи нужные вланы

 

все циска считает себя рутом все вроде работает, но время схождения каталиста и длинка гдето 10 секунд.

 

берем 2 DGS-3100 настраиваем аналогично на одном ставим приоритет пониже что был рутом - время схождения пару сек

 

на действующей сети время схождения где то 2-4 сек.

 

в чем может быть проблема??!? куда смотреть?!?!?

 

какие еще грабли могут быть!?

 

Share this post


Link to post
Share on other sites
ап
На каталистах нет RSTP, есть Per Vlan RSTP, со своими отличиями. Попробуйте включить MSTP c Instance 0.

 

Share this post


Link to post
Share on other sites

да когда стало кольцо из 3х длинков и каталиста совсем туго стало.

 

то сработает то нет... точнее первый раз при включении всегда срабатывает на первый разрыв тоже всегда.. а вот обратно кольцо "собрать" не может. :D

 

ps всезде настроил mstp c одним регионом и все в Instance 0. вроде работает. сходитсья стало пару секунд.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this