Jump to content
Калькуляторы

Совместимость MSTP и STP

Да и еще вопрос, с каких это пор на каталистах только MSTP?

Share this post


Link to post
Share on other sites

#sh ver
Cisco Internetwork Operating System Software 
IOS (tm) c6sup1_rp Software (c6sup1_rp-PK2S-M), Version 12.1(27b)E, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2006 by cisco Systems, Inc.
Compiled Fri 10-Feb-06 23:02 by hqluong
Image text-base: 0x60020F90, data-base: 0x618C8000

ROM: System Bootstrap, Version 12.0(3)XE, RELEASE SOFTWARE 
BOOTLDR: MSFC Software (C6MSFC-BOOT-M), Version 12.0(7)XE1, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

Core uptime is 6 days, 2 hours, 42 minutes
Time since Core switched to active is 6 days, 2 hours, 41 minutes
System returned to ROM by power-on (SP by power-on)
System restarted at 10:59:10 MSK Fri Dec 19 2008
System image file is "sup-bootflash:c6sup11-pk2s-mz.121-27b.E.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

cisco WS-C6506 (R5000) processor (revision 2.0) with 114688K/16384K bytes of memory.
Processor board ID TBA05040254
R5000 CPU at 200Mhz, Implementation 35, Rev 2.1
Last reset from power-on
X.25 software, Version 3.0.0.
Bridging software.
7 Virtual Ethernet/IEEE 802.3  interface(s)
18 Gigabit Ethernet/IEEE 802.3 interface(s)
381K bytes of non-volatile configuration memory.
4096K bytes of packet SRAM memory.

16384K bytes of Flash internal SIMM (Sector size 256K).
Configuration register is 0x2102

 

STP не вижу. По умолчанию PVST.

 

#spanning-tree mode ?
  mst         Multiple spanning tree mode
  pvst        Per-Vlan spanning tree mode
  rapid-pvst  Per-Vlan rapid spanning tree mode

 

Share this post


Link to post
Share on other sites

* SWITCH1 # sh stpd
Stpd: s0                Stp: ENABLED            Number of Ports: 26
Rapid Root Failover: Disabled
Ports: 1,2,3,4,5,6,7,8,9,10,11,12
       13,14,15,16,17,18,19,20,21,22,23,24
       25,26
Vlans:  Default MacVlanDiscover
Bridge Priority: 32768
BridgeID:               80:00:00:01:30:11:90:1f
Designated root:        20:00:00:03:fd:d3:78:01
RootPathCost: 4         Root Port: 26
MaxAge: 20s             HelloTime: 2s           ForwardDelay: 15s
CfgBrMaxAge: 20s        CfgBrHelloTime: 2s      CfgBrForwardDelay: 15s
Topology Change Time: 35s                       Hold time: 1s
Topology Change Detected: FALSE                 Topology Change: TRUE
Number of Topology Changes: 5
Time Since Last Topology Change: 103s

 

 

* SWITCH2 ## sh stpd
Stpd: s0                Stp: ENABLED            Number of Ports: 26
Rapid Root Failover: Disabled
Ports: 1,2,3,4,5,6,7,8,9,10,11,12
       13,14,15,16,17,18,19,20,21,22,23,24
       25,26
Vlans:  Default MacVlanDiscover
Bridge Priority: 32768
BridgeID:               80:00:00:01:30:11:9a:4b
Designated root:        20:00:00:03:fd:d3:78:01
RootPathCost: 4         Root Port: 26
MaxAge: 20s             HelloTime: 2s           ForwardDelay: 15s
CfgBrMaxAge: 20s        CfgBrHelloTime: 2s      CfgBrForwardDelay: 15s
Topology Change Time: 35s                       Hold time: 1s
Topology Change Detected: FALSE                 Topology Change: FALSE
Number of Topology Changes: 5
Time Since Last Topology Change: 91s

 

Router#sh spanning-tree 

VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    8192
             Address     0003.fdd3.7801
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    8192 
             Address     0003.fdd3.7801
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi2/1            Desg FWD 4         128.65   P2p 
Gi2/2            Desg FWD 4         128.66   P2p 

Router#sh spanning-tree detail 

VLAN0001 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 8192, address 0003.fdd3.7801
  Configured hello time 2, max age 20, forward delay 15
  We are the root of the spanning tree
  Topology change flag not set, detected flag not set
  Number of topology changes 8 last change occurred 00:02:43 ago
          from GigabitEthernet2/1
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15 
  Timers: hello 1, topology change 0, notification 0, aging 300

Port 65 (GigabitEthernet2/1) of VLAN0001 is forwarding 
   Port path cost 4, Port priority 128, Port Identifier 128.65.
   Designated root has priority 8192, address 0003.fdd3.7801
   Designated bridge has priority 8192, address 0003.fdd3.7801
   Designated port id is 128.65, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   Link type is point-to-point by default
   BPDU: sent 84, received 2

Port 66 (GigabitEthernet2/2) of VLAN0001 is forwarding 
   Port path cost 4, Port priority 128, Port Identifier 128.66.
   Designated root has priority 8192, address 0003.fdd3.7801
   Designated bridge has priority 8192, address 0003.fdd3.7801
   Designated port id is 128.66, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   Link type is point-to-point by default
   BPDU: sent 707, received 162

Router#

 

кольцо замкнуто из 3-х коммутаторов.

при размыкании линка от каталиста к Экстриму

* SWITCH1 # sh stpd
Stpd: s0                Stp: ENABLED            Number of Ports: 26
Rapid Root Failover: Disabled
Ports: 1,2,3,4,5,6,7,8,9,10,11,12
       13,14,15,16,17,18,19,20,21,22,23,24
       25,26
Vlans:  Default MacVlanDiscover
Bridge Priority: 32768
BridgeID:               80:00:00:01:30:11:90:1f
Designated root:        20:00:00:03:fd:d3:78:01
RootPathCost: 4         Root Port: 26
MaxAge: 20s             HelloTime: 2s           ForwardDelay: 15s
CfgBrMaxAge: 20s        CfgBrHelloTime: 2s      CfgBrForwardDelay: 15s
Topology Change Time: 35s                       Hold time: 1s
Topology Change Detected: FALSE                 Topology Change: TRUE
Number of Topology Changes: 6
Time Since Last Topology Change: 12s

* SWITCH2 # sh stpd
Stpd: s0                Stp: ENABLED            Number of Ports: 26
Rapid Root Failover: Disabled
Ports: 1,2,3,4,5,6,7,8,9,10,11,12
       13,14,15,16,17,18,19,20,21,22,23,24
       25,26
Vlans:  Default MacVlanDiscover
Bridge Priority: 32768
BridgeID:               80:00:00:01:30:11:9a:4b
Designated root:        20:00:00:03:fd:d3:78:01
RootPathCost: 23        Root Port: 24
MaxAge: 20s             HelloTime: 2s           ForwardDelay: 15s
CfgBrMaxAge: 20s        CfgBrHelloTime: 2s      CfgBrForwardDelay: 15s
Topology Change Time: 35s                       Hold time: 1s
Topology Change Detected: FALSE                 Topology Change: FALSE
Number of Topology Changes: 6
Time Since Last Topology Change: 55s

Router#sh spanning-tree 

VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    8192
             Address     0003.fdd3.7801
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    8192 
             Address     0003.fdd3.7801
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi2/2            Desg FWD 4         128.66   P2p 

Router#sh span det

VLAN0001 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 8192, address 0003.fdd3.7801
  Configured hello time 2, max age 20, forward delay 15
  We are the root of the spanning tree
  Topology change flag not set, detected flag not set
  Number of topology changes 9 last change occurred 00:02:03 ago
          from GigabitEthernet2/1
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15 
  Timers: hello 1, topology change 0, notification 0, aging 300

Port 66 (GigabitEthernet2/2) of VLAN0001 is forwarding 
   Port path cost 4, Port priority 128, Port Identifier 128.66.
   Designated root has priority 8192, address 0003.fdd3.7801
   Designated bridge has priority 8192, address 0003.fdd3.7801
   Designated port id is 128.66, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   Link type is point-to-point by default
   BPDU: sent 850, received 163

Router#

Share this post


Link to post
Share on other sites
Извиняюсь. На MST00 то же самое сделайте
Сделал

 

#sh spanning-tree mst 

###### MST00        vlans mapped:   none
Bridge      address 0004.de18.b400  priority  24576 (24576 sysid 0)
Root        this switch for CST and IST
Configured  hello time 2, forward delay 15, max age 20, max hops 20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi2/3            Desg FWD 20000     128.67   P2p Bound(STP) 
Gi2/4            Desg FWD 20000     128.68   P2p Bound(STP) 

###### MST01        vlans mapped:   1-4094
Bridge      address 0004.de18.b400  priority  24577 (24576 sysid 1)
Root        this switch for MST01

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi2/3            Boun FWD 20000     128.67   P2p Bound(STP) 
Gi2/4            Boun FWD 20000     128.68   P2p Bound(STP)

 

Но каталист подох практически сразу после открытия порта 2/4 - скорее всего комутаторы опять не увидели его рутом.

А что в данном случае значит подох? Информацию ты ж с него снял как-то.

Share this post


Link to post
Share on other sites
А что в данном случае значит подох? Информацию ты ж с него снял как-то.
Просто начались тормоза жуткие, получилось снять один раз :)

 

А вот интересный тест провел D^2 постом выше. Судя по логам кольцо действительно работает, при чем не в MST режиме.

Жаль только он не привел настройки STP на каталисте, потому как они очень интересны в этом случае. Сейчас попробовал сделать подобное у себя - все комытаторы на всякий случай перенес в stp дерево s0, как на этом примере. Отключил режим MST на каталисте.

 

Картинка на каталисте похожа, кольцо замыкать пока не стал, дабы не положить каталист.

 

#sh spanning-tree 

VLAN0003
  Spanning tree enabled protocol ieee
  Root ID    Priority    8192
             Address     0004.de18.b403
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    8192 
             Address     0004.de18.b403
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi2/3            Desg FWD 4         128.67   P2p 

          
VLAN0004
  Spanning tree enabled protocol ieee
  Root ID    Priority    8192
             Address     0004.de18.b404
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    8192 
             Address     0004.de18.b404
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi2/3            Desg FWD 4         128.67   P2p

 

#sh spanning-tree detail active 

VLAN0003 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 8192, address 0004.de18.b403
  Configured hello time 2, max age 20, forward delay 15
  We are the root of the spanning tree
  Topology change flag not set, detected flag not set
  Number of topology changes 4 last change occurred 02:01:36 ago
          from GigabitEthernet2/5
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15 
  Timers: hello 1, topology change 0, notification 0, aging 300

Port 67 (GigabitEthernet2/3) of VLAN0003 is forwarding 
   Port path cost 4, Port priority 128, Port Identifier 128.67.
   Designated root has priority 8192, address 0004.de18.b403
   Designated bridge has priority 8192, address 0004.de18.b403
   Designated port id is 128.67, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   Link type is point-to-point by default
   BPDU: sent 4549, received 0

          
VLAN0004 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 8192, address 0004.de18.b404
  Configured hello time 2, max age 20, forward delay 15
  We are the root of the spanning tree
  Topology change flag not set, detected flag not set
  Number of topology changes 1 last change occurred 02:31:09 ago
          from GigabitEthernet2/2
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15 
  Timers: hello 1, topology change 0, notification 0, aging 300

Port 67 (GigabitEthernet2/3) of VLAN0004 is forwarding 
   Port path cost 4, Port priority 128, Port Identifier 128.67.
   Designated root has priority 8192, address 0004.de18.b404
   Designated bridge has priority 8192, address 0004.de18.b404
   Designated port id is 128.67, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   Link type is point-to-point by default
   BPDU: sent 4560, received 0

 

Настройки STP на каталисте теперь выглядят так. Оба вилана в транке пущены в кольцо (в данном случае полукольцо).

 

spanning-tree mode pvst
no spanning-tree vlan 2
spanning-tree vlan 3-4 priority 8192

 

Теперь смотрим что же на комутаторах.

 

Ближайший к каталисту SW1.

 

Summit24e3:1 # sh stpd s0  
Stpd: s0        Stp: ENABLED        Number of Ports: 2
Rapid Root Failover: Disabled
Ports: 25,26
Vlans:  Default MacVlanDiscover Manage Office
Bridge Priority: 32768
BridgeID:        80:00:00:01:30:11:a7:e4
Designated root:    80:00:00:01:30:11:8e:00
RootPathCost: 4     Root Port: 25
MaxAge: 20s        HelloTime: 2s        ForwardDelay: 15s
CfgBrMaxAge: 20s    CfgBrHelloTime: 2s    CfgBrForwardDelay: 15s
Topology Change Time: 35s            Hold time: 1s
Topology Change Detected: FALSE            Topology Change: FALSE
Number of Topology Changes: 4
Time Since Last Topology Change: 3946s

 

Опять это пресловутый

80:00:00:01:30:11:8e:00

второй комутатор. Опять он рут.

 

Смотрим на него - SW2.

 

# sh stpd s0
Stpd: s0        Stp: ENABLED        Number of Ports: 2
Rapid Root Failover: Disabled
Ports: 25,26
Vlans:  Default MacVlanDiscover Manage Office
Bridge Priority: 32768
BridgeID:        80:00:00:01:30:11:8e:00
Designated root:    80:00:00:01:30:11:8e:00
RootPathCost: 0     Root Port: ----
MaxAge: 20s        HelloTime: 2s        ForwardDelay: 15s
CfgBrMaxAge: 20s    CfgBrHelloTime: 2s    CfgBrForwardDelay: 15s
Topology Change Time: 35s            Hold time: 1s
Topology Change Detected: FALSE            Topology Change: FALSE
Number of Topology Changes: 4
Time Since Last Topology Change: 4510s

 

Так и есть - рут.

 

Ничего уже не понимаю :(

 

Share this post


Link to post
Share on other sites

2 kostas: Вы пробовали отключать режим MSTP на SW*? Я так понял, у Вас сейчас каталист работает в режиме PVST, а остальные коммутаторы в MSTP. У меня работает немного другая схема, но суть та же:

catalyst1---edge-core---catalyst2

\__________________/

Была схема, где подряд шли несколько edge-core.

Настройки на каталистах - режим везде pvst, а на edge-core обычный stp (может даже rstp, завтра гляну).

Попробуйте на SW* поставить режим stp.

Share this post


Link to post
Share on other sites
#sh ver
Cisco Internetwork Operating System Software 
IOS (tm) c6sup1_rp Software (c6sup1_rp-PK2S-M), Version 12.1(27b)E, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2006 by cisco Systems, Inc.
Compiled Fri 10-Feb-06 23:02 by hqluong
Image text-base: 0x60020F90, data-base: 0x618C8000

ROM: System Bootstrap, Version 12.0(3)XE, RELEASE SOFTWARE 
BOOTLDR: MSFC Software (C6MSFC-BOOT-M), Version 12.0(7)XE1, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

Core uptime is 6 days, 2 hours, 42 minutes
Time since Core switched to active is 6 days, 2 hours, 41 minutes
System returned to ROM by power-on (SP by power-on)
System restarted at 10:59:10 MSK Fri Dec 19 2008
System image file is "sup-bootflash:c6sup11-pk2s-mz.121-27b.E.bin"

kostas, судя по имиджу, у Вас IOS не поддерживает:

IEEE 802.1s - Multiple Spanning Tree (MST) Standard Compliance

 

Это такая заморочка у Cisco, есть две фичи:

IEEE 802.1s VLAN Multiple Spanning Trees

This feature is the original implementation of MST which is based on a pre-standards draft. MST allows you to build multiple spanning trees over trunks. You can group and associate VLANs to spanning tree instances. Each instance can have a topology independent of other spanning tree instances. This new architecture provides multiple forwarding paths for data traffic and enables load balancing. Network fault tolerance is improved because a failure in one instance (forwarding path) does not affect other instances (forwarding paths).

и
IEEE 802.1s - Multiple Spanning Tree (MST) Standard Compliance

MST extends the 802.1w Rapid Spanning Tree to multiple spanning trees, providing rapid convergence and load balancing.

В вашем иосе есть только первая, второй нет, подробнее - http://www.cisco.com/go/fn

 

Я не знаю какой у вас супервизор, FN выдает, что ваш имидж может работать как на sup1/mfsc1, так и на sup2/mfsc2

Если у Вас sup2, то вам надо - 12.2SXF иос, чтобы поддерживался MSTP Standard Compliance, если же sup1, то, судя по FN, поддержки нормального MSTP у вас не будет.

 

PS. Сами с таким сталкивались, после того как не заработал MSTP между cat4500, edge-core 4612 и dlink 3526

 

 

Share this post


Link to post
Share on other sites
2 kostas: Вы пробовали отключать режим MSTP на SW*? Я так понял, у Вас сейчас каталист работает в режиме PVST, а остальные коммутаторы в MSTP. У меня работает немного другая схема, но суть та же:

catalyst1---edge-core---catalyst2

\__________________/

Была схема, где подряд шли несколько edge-core.

Настройки на каталистах - режим везде pvst, а на edge-core обычный stp (может даже rstp, завтра гляну).

Попробуйте на SW* поставить режим stp.

В том то и дело, что на SW* только STP и поддерживается, там другого не дано :(

Share this post


Link to post
Share on other sites
kostas, судя по имиджу, у Вас IOS не поддерживает:
IEEE 802.1s - Multiple Spanning Tree (MST) Standard Compliance

 

Это такая заморочка у Cisco, есть две фичи:

IEEE 802.1s VLAN Multiple Spanning Trees

This feature is the original implementation of MST which is based on a pre-standards draft. MST allows you to build multiple spanning trees over trunks. You can group and associate VLANs to spanning tree instances. Each instance can have a topology independent of other spanning tree instances. This new architecture provides multiple forwarding paths for data traffic and enables load balancing. Network fault tolerance is improved because a failure in one instance (forwarding path) does not affect other instances (forwarding paths).

и

IEEE 802.1s - Multiple Spanning Tree (MST) Standard Compliance

MST extends the 802.1w Rapid Spanning Tree to multiple spanning trees, providing rapid convergence and load balancing.

 

В вашем иосе есть только первая, второй нет, подробнее - http://www.cisco.com/go/fn

 

Я не знаю какой у вас супервизор, FN выдает, что ваш имидж может работать как на sup1/mfsc1, так и на sup2/mfsc2

Если у Вас sup2, то вам надо - 12.2SXF иос, чтобы поддерживался MSTP Standard Compliance, если же sup1, то, судя по FN, поддержки нормального MSTP у вас не будет.

 

PS. Сами с таким сталкивались, после того как не заработал MSTP между cat4500, edge-core 4612 и dlink 3526

 

О как, интересно. Т.е. у циски есть два стандарта, которые называются одинаково, но трактуются по разному? :)

 

Супервизор у меня sup1/mfsc1.

 

Интересно, D^2 а у вас какой супервизор на лабе стоял и с каким IOS?

Share this post


Link to post
Share on other sites

sup2/msfc

System image file is "sup-bootflash:c6sup22-pk2o3sv-mz.121-26.E9.bin"

 

отличие настроек от дефолтных в 2-х строчках

conf t

span vl 1

span vl 1 root

 

IEEE 802.1s - Multiple Spanning Tree (MST) Standard Compliance как я понимаю для того, чтобы в каждой Instance RSTP крутился. В IEEE 802.1s VLAN Multiple Spanning Trees крутится STP.

Share this post


Link to post
Share on other sites
Oleg_S, можно с вами как-то связаться? Не совсем улавливаю, в чем различия того о чем вы писали. Уже надежда начала пропадать в решении этой проблемы. В НАГе собирали лабу и все у них работает. Различие супервизора налицо (у них был sup2), но принципиальных различий там не признают. Дмитрий из НАГа к сожалению не прокомментировал Вашу версию, постараюсь завтра его еще раз обратить внимание на этот момент. Очень не хотелось бы тратить деньги на другой супервизор только ради проверки этой версии.

Share this post


Link to post
Share on other sites
sup2/msfc

System image file is "sup-bootflash:c6sup22-pk2o3sv-mz.121-26.E9.bin"

 

отличие настроек от дефолтных в 2-х строчках

conf t

span vl 1

span vl 1 root

 

IEEE 802.1s - Multiple Spanning Tree (MST) Standard Compliance как я понимаю для того, чтобы в каждой Instance RSTP крутился. В IEEE 802.1s VLAN Multiple Spanning Trees крутится STP.

Все так оно и есть, кроме супервизора.

Share this post


Link to post
Share on other sites
sup2/msfc

System image file is "sup-bootflash:c6sup22-pk2o3sv-mz.121-26.E9.bin"

 

отличие настроек от дефолтных в 2-х строчках

conf t

span vl 1

span vl 1 root

 

IEEE 802.1s - Multiple Spanning Tree (MST) Standard Compliance как я понимаю для того, чтобы в каждой Instance RSTP крутился. В IEEE 802.1s VLAN Multiple Spanning Trees крутится STP.

Все так оно и есть, кроме супервизора.

Не надо ничего покупать, просто вместо pre-standard MST на каталисте используй PVST

Share this post


Link to post
Share on other sites
Не надо ничего покупать, просто вместо pre-standard MST на каталисте используй PVST
Ммм, как? PVST это разве не собственный стандарт циски с которым другое оборудование не живет?

 

Но в любом случае сейчас конфиг каталиста выглядит так

 

spanning-tree mode pvst
spanning-tree vlan 3-4 priority 8192

#sh spa detail 

VLAN0003 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 8192, address 0004.de18.b403
  Configured hello time 2, max age 20, forward delay 15
  We are the root of the spanning tree
  Topology change flag not set, detected flag not set
  Number of topology changes 6 last change occurred 02:45:32 ago
          from GigabitEthernet2/3
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15 
  Timers: hello 0, topology change 0, notification 0, aging 300

Port 67 (GigabitEthernet2/3) of VLAN0003 is forwarding 
   Port path cost 4, Port priority 128, Port Identifier 128.67.
   Designated root has priority 8192, address 0004.de18.b403
   Designated bridge has priority 8192, address 0004.de18.b403
   Designated port id is 128.67, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   Link type is point-to-point by default
   BPDU: sent 4980, received 0

 

Как раз стоит PVST (по умолчанию), в общем-то так на стенде у НАГа и работало, а у меня нет.

На комутаторах кольца ничего кроме стандартного STP не поддерживается.

 

Чего-то я совсем уже запутался...

Edited by kostas

Share this post


Link to post
Share on other sites

2kostas: в двух словах Pre-Standard MST и 802.1s MST - не совместимы.

То, что мы наблюдали: два одинаково сконфигурированных бриджа (cat4500 sup2 и edge-core 4612) не видят друг друга.

Считали что они находятся в разных регионах. С помощью wireshark было установлено, что BPDU-шки от циско и от эджкора имеют разные чексумы,

и свитчи работают согласно:

MST BPDUs contain the MST configuration ID and the checksum. An MST bridge accepts an MST BPDU only if the MST BPDU configuration ID and the checksum match its own MST region configuration ID and checksum. If one value is different, the MST BPDU is considered to be an SST BPDU.
© cisco

 

Изучение Feature Navigator'а привело к тому, что выше я уже писал: у циско есть две реализации MST - prestandard и standard.

Вам нужна поддержка standard 802.1s MST на вашем sup'е для совместимости с другим свитчами не-циско.

 

http://www.ciscosystems.com/en/US/docs/swi.../guide/mst.html:

The IEEE MST protocol has transitioned from a prestandard state to a released state. This chapter describes the standard-compliant MST implementation supported in Release 12.2(18)SXF and later releases. Chapter 20, "Configuring STP and Prestandard IEEE 802.1s MST," describes the prestandard MST implementation supported in releases earlier than Release 12.2(18)SXF.

 

Из вышенаписанного следует, что вам нужен ios не ниже 12.2(18)SXF. Но, к сожалению, похоже, что для sup1 такого не бывает.

 

Share this post


Link to post
Share on other sites
The IEEE MST protocol has transitioned from a prestandard state to a released state. This chapter describes the standard-compliant MST implementation supported in Release 12.2(18)SXF and later releases. Chapter 20, "Configuring STP and Prestandard IEEE 802.1s MST," describes the prestandard MST implementation supported in releases earlier than Release 12.2(18)SXF.
Из вышенаписанного следует, что вам нужен ios не ниже 12.2(18)SXF. Но, к сожалению, похоже, что для sup1 такого не бывает.

Ага, понял. Олег, спасибо огромное, было подозрение в несовместимости изначально, так оно похоже и есть. НАГ в понедельник подтвердит эти предположения, собрав лабу на sup1 и моей прошивкой. Если эффект будет тот же, чем я практически не сомневаюсь, то будем брать sup2... там и ip unnumbered есть, что в нашем случае будет хорошим плюсом.
Edited by kostas

Share this post


Link to post
Share on other sites

кольцо не замкнуто

6506+sup1a

Router#sh mod
Mod Ports Card Type                              Model              Serial No.
--- ----- -------------------------------------- ------------------ -----------
  2    2  Cat 6k sup 1 Enhanced QoS (Active)     WS-X6K-SUP1A-2GE   SAD04210F7T

Mod MAC addresses                       Hw    Fw           Sw           Status
--- ---------------------------------- ------ ------------ ------------ -------
  2  0030.96b1.3d44 to 0030.96b1.3d45   3.1   5.3(1)       12.1(27b)E   Ok

Mod Sub-Module                  Model           Serial           Hw     Status 
--- --------------------------- --------------- --------------- ------- -------
  2 Policy Feature Card         WS-F6K-PFC      SAD04280US8      1.1    Ok
  2 MSFC Cat6k daughterboard    WS-F6K-MSFC     SAD04030B8P      1.3    Ok

Mod Online Diag Status 
--- -------------------
Router#sh span

VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    8192
             Address     0003.fdd3.7801
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    8192 
             Address     0003.fdd3.7801
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi2/1            Desg FWD 4         128.65   P2p 
Gi2/2            Desg FWD 4         128.66   P2p 

Router#sh span det

VLAN0001 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 8192, address 0003.fdd3.7801
  Configured hello time 2, max age 20, forward delay 15
  We are the root of the spanning tree
  Topology change flag not set, detected flag not set
  Number of topology changes 3 last change occurred 00:02:31 ago
          from GigabitEthernet2/2
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15 
  Timers: hello 1, topology change 0, notification 0, aging 300

Port 65 (GigabitEthernet2/1) of VLAN0001 is forwarding 
   Port path cost 4, Port priority 128, Port Identifier 128.65.
   Designated root has priority 8192, address 0003.fdd3.7801
   Designated bridge has priority 8192, address 0003.fdd3.7801
   Designated port id is 128.65, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   Link type is point-to-point by default
   BPDU: sent 207, received 2

Port 66 (GigabitEthernet2/2) of VLAN0001 is forwarding 
   Port path cost 4, Port priority 128, Port Identifier 128.66.
   Designated root has priority 8192, address 0003.fdd3.7801
   Designated bridge has priority 8192, address 0003.fdd3.7801
   Designated port id is 128.66, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   Link type is point-to-point by default
   BPDU: sent 206, received 2

Router#

Switch 2

* Summit24e3:5 # sh stpd
Stpd: s0                Stp: ENABLED            Number of Ports: 26
Rapid Root Failover: Disabled
Ports: 1,2,3,4,5,6,7,8,9,10,11,12
       13,14,15,16,17,18,19,20,21,22,23,24
       25,26
Vlans:  Default MacVlanDiscover
Bridge Priority: 32768
BridgeID:               80:00:00:01:30:11:9a:4b
Designated root:        20:00:00:03:fd:d3:78:01
RootPathCost: 4         Root Port: 26
MaxAge: 20s             HelloTime: 2s           ForwardDelay: 15s
CfgBrMaxAge: 20s        CfgBrHelloTime: 2s      CfgBrForwardDelay: 15s
Topology Change Time: 35s                       Hold time: 1s
Topology Change Detected: FALSE                 Topology Change: FALSE
Number of Topology Changes: 1
Time Since Last Topology Change: 133s

Switch 3

* Summit24e3:5 # sh stpd
Stpd: s0                Stp: ENABLED            Number of Ports: 26
Rapid Root Failover: Disabled
Ports: 1,2,3,4,5,6,7,8,9,10,11,12
       13,14,15,16,17,18,19,20,21,22,23,24
       25,26
Vlans:  Default MacVlanDiscover
Bridge Priority: 32768
BridgeID:               80:00:00:01:30:11:90:1f
Designated root:        20:00:00:03:fd:d3:78:01
RootPathCost: 4         Root Port: 26
MaxAge: 20s             HelloTime: 2s           ForwardDelay: 15s
CfgBrMaxAge: 20s        CfgBrHelloTime: 2s      CfgBrForwardDelay: 15s
Topology Change Time: 35s                       Hold time: 1s
Topology Change Detected: FALSE                 Topology Change: TRUE
Number of Topology Changes: 0
Time Since Last Topology Change: 3s

 

замыкаем кольцо

6506

Router#sh span

VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    8192
             Address     0003.fdd3.7801
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    8192 
             Address     0003.fdd3.7801
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi2/1            Desg FWD 4         128.65   P2p 
Gi2/2            Desg FWD 4         128.66   P2p 

Router#sh span det

VLAN0001 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 8192, address 0003.fdd3.7801
  Configured hello time 2, max age 20, forward delay 15
  We are the root of the spanning tree
  Topology change flag not set, detected flag not set
  Number of topology changes 4 last change occurred 00:08:56 ago
          from GigabitEthernet2/2
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15 
  Timers: hello 1, topology change 0, notification 0, aging 300

Port 65 (GigabitEthernet2/1) of VLAN0001 is forwarding 
   Port path cost 4, Port priority 128, Port Identifier 128.65.
   Designated root has priority 8192, address 0003.fdd3.7801
   Designated bridge has priority 8192, address 0003.fdd3.7801
   Designated port id is 128.65, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   Link type is point-to-point by default
   BPDU: sent 516, received 2

Port 66 (GigabitEthernet2/2) of VLAN0001 is forwarding 
   Port path cost 4, Port priority 128, Port Identifier 128.66.
   Designated root has priority 8192, address 0003.fdd3.7801
   Designated bridge has priority 8192, address 0003.fdd3.7801
   Designated port id is 128.66, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   Link type is point-to-point by default
   BPDU: sent 516, received 3

Router#

Switch2

* Summit24e3:10 # sh def
VLAN Interface[0-200] with name "Default" created by user
     Tagging:   802.1Q Tag 1
     Priority:  802.1P Priority 0
     IP:        1.1.1.2/255.255.255.0
     STPD:      Domain "s0" is running spanning tree protocol
     Protocol:  Match all unfiltered protocols.
     Loopback:  Disable
     QosProfile:QP1
     Ports:     26.     (Number of active ports = 1)
                Flags: * = active, ! = disabled

                Untag:  1  2  3  4  5  6  7  8  9  10  11  12  13  14
                15  16  17  18  19  20  21  22  23  24* 25  26*
     Protected by 0 count of EAPS Domains

* Summit24e3:11 # sh stpd
Stpd: s0                Stp: ENABLED            Number of Ports: 26
Rapid Root Failover: Disabled
Ports: 1,2,3,4,5,6,7,8,9,10,11,12
       13,14,15,16,17,18,19,20,21,22,23,24
       25,26
Vlans:  Default MacVlanDiscover
Bridge Priority: 32768
BridgeID:               80:00:00:01:30:11:9a:4b
Designated root:        20:00:00:03:fd:d3:78:01
RootPathCost: 4         Root Port: 26
MaxAge: 20s             HelloTime: 2s           ForwardDelay: 15s
CfgBrMaxAge: 20s        CfgBrHelloTime: 2s      CfgBrForwardDelay: 15s
Topology Change Time: 35s                       Hold time: 1s
Topology Change Detected: FALSE                 Topology Change: FALSE
Number of Topology Changes: 1
Time Since Last Topology Change: 671s

Switch3

* Summit24e3:6 # sh def
VLAN Interface[0-200] with name "Default" created by user
     Tagging:   802.1Q Tag 1
     Priority:  802.1P Priority 0
     IP:        1.1.1.3/255.255.255.0
     STPD:      Domain "s0" is running spanning tree protocol
     Protocol:  Match all unfiltered protocols.
     Loopback:  Disable
     QosProfile:QP1
     Ports:     26.     (Number of active ports = 2)
                Flags: * = active, ! = disabled

                Untag:  1  2  3  4  5  6  7  8  9  10  11  12  13  14
                15  16  17  18  19  20  21  22  23  24* 25  26*
     Protected by 0 count of EAPS Domains

* Summit24e3:7 # sh stp
Stpd: s0                Stp: ENABLED            Number of Ports: 26
Rapid Root Failover: Disabled
Ports: 1,2,3,4,5,6,7,8,9,10,11,12
       13,14,15,16,17,18,19,20,21,22,23,24
       25,26
Vlans:  Default MacVlanDiscover
Bridge Priority: 32768
BridgeID:               80:00:00:01:30:11:90:1f
Designated root:        20:00:00:03:fd:d3:78:01
RootPathCost: 4         Root Port: 26
MaxAge: 20s             HelloTime: 2s           ForwardDelay: 15s
CfgBrMaxAge: 20s        CfgBrHelloTime: 2s      CfgBrForwardDelay: 15s
Topology Change Time: 35s                       Hold time: 1s
Topology Change Detected: FALSE                 Topology Change: FALSE
Number of Topology Changes: 2
Time Since Last Topology Change: 478s

* Summit24e3:8 #

 

размыкаем кольцо

Router

Router# sh span

VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    8192
             Address     0003.fdd3.7801
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    8192 
             Address     0003.fdd3.7801
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi2/1            Desg FWD 4         128.65   P2p 

Router#sh span det

VLAN0001 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 8192, address 0003.fdd3.7801
  Configured hello time 2, max age 20, forward delay 15
  We are the root of the spanning tree
  Topology change flag not set, detected flag not set
  Number of topology changes 6 last change occurred 00:02:23 ago
          from GigabitEthernet2/1
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15 
  Timers: hello 1, topology change 0, notification 0, aging 300

Port 65 (GigabitEthernet2/1) of VLAN0001 is forwarding 
   Port path cost 4, Port priority 128, Port Identifier 128.65.
   Designated root has priority 8192, address 0003.fdd3.7801
   Designated bridge has priority 8192, address 0003.fdd3.7801
   Designated port id is 128.65, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   Link type is point-to-point by default
   BPDU: sent 76, received 4

Router#

Switch2

* Summit24e3:12 # sh def
VLAN Interface[0-200] with name "Default" created by user
     Tagging:   802.1Q Tag 1
     Priority:  802.1P Priority 0
     IP:        1.1.1.2/255.255.255.0
     STPD:      Domain "s0" is running spanning tree protocol
     Protocol:  Match all unfiltered protocols.
     Loopback:  Disable
     QosProfile:QP1
     Ports:     26.     (Number of active ports = 2)
                Flags: * = active, ! = disabled

                Untag:  1  2  3  4  5  6  7  8  9  10  11  12  13  14
                15  16  17  18  19  20  21  22  23  24* 25  26*
     Protected by 0 count of EAPS Domains

* Summit24e3:13 # sh stp
Stpd: s0                Stp: ENABLED            Number of Ports: 26
Rapid Root Failover: Disabled
Ports: 1,2,3,4,5,6,7,8,9,10,11,12
       13,14,15,16,17,18,19,20,21,22,23,24
       25,26
Vlans:  Default MacVlanDiscover
Bridge Priority: 32768
BridgeID:               80:00:00:01:30:11:9a:4b
Designated root:        20:00:00:03:fd:d3:78:01
RootPathCost: 4         Root Port: 26
MaxAge: 20s             HelloTime: 2s           ForwardDelay: 15s
CfgBrMaxAge: 20s        CfgBrHelloTime: 2s      CfgBrForwardDelay: 15s
Topology Change Time: 35s                       Hold time: 1s
Topology Change Detected: FALSE                 Topology Change: FALSE
Number of Topology Changes: 6
Time Since Last Topology Change: 39s

* Summit24e3:14 #

Switch3

* Summit24e3:27 # sh def
VLAN Interface[0-200] with name "Default" created by user
     Tagging:   802.1Q Tag 1
     Priority:  802.1P Priority 0
     IP:        1.1.1.3/255.255.255.0
     STPD:      Domain "s0" is running spanning tree protocol
     Protocol:  Match all unfiltered protocols.
     Loopback:  Disable
     QosProfile:QP1
     Ports:     26.     (Number of active ports = 1)
                Flags: * = active, ! = disabled

                Untag:  1  2  3  4  5  6  7  8  9  10  11  12  13  14
                15  16  17  18  19  20  21  22  23  24* 25  26
     Protected by 0 count of EAPS Domains

* Summit24e3:28 # sh stp
Stpd: s0                Stp: ENABLED            Number of Ports: 26
Rapid Root Failover: Disabled
Ports: 1,2,3,4,5,6,7,8,9,10,11,12
       13,14,15,16,17,18,19,20,21,22,23,24
       25,26
Vlans:  Default MacVlanDiscover
Bridge Priority: 32768
BridgeID:               80:00:00:01:30:11:90:1f
Designated root:        20:00:00:03:fd:d3:78:01
RootPathCost: 23        Root Port: 24
MaxAge: 20s             HelloTime: 2s           ForwardDelay: 15s
CfgBrMaxAge: 20s        CfgBrHelloTime: 2s      CfgBrForwardDelay: 15s
Topology Change Time: 35s                       Hold time: 1s
Topology Change Detected: FALSE                 Topology Change: TRUE
Number of Topology Changes: 4
Time Since Last Topology Change: 15s

* Summit24e3:29 #

 

Router#sh run
Building configuration...

Current configuration : 789 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service counters max age 10
!
hostname Router
!
boot bootldr bootflash:c6msfc-boot-mz.121-27b.E.bin
!
ip subnet-zero
!
!
!
ip ssh time-out 120
ip ssh authentication-retries 3
mls flow ip destination
mls flow ipx destination
!
!
!         
spanning-tree mode pvst
spanning-tree vlan 1 priority 8192
!
redundancy
mode rpr-plus
main-cpu
  auto-sync running-config
  auto-sync standard
!
!
!
interface GigabitEthernet2/1
switchport
switchport mode access
switchport nonegotiate
!
interface GigabitEthernet2/2
switchport
switchport mode access
switchport nonegotiate
!
interface Vlan1
ip address 1.1.1.1 255.0.0.0
!
ip classless
no ip http server
!
!
!
line con 0
line vty 0 4
!
!
end

Router#

* Summit24e3:14 # sh ver

System Serial Number: 800096-04-0234R00703
CPU Serial Number: 700048-08  0233R-01936 CPLD Rev 02
Image  :  Extremeware Version 6.2e.1 (Build 15) by Release_Master_ABU Tue 08/13/
2002 14:50:31

BootROM : 1.3

Router#sh ver
Cisco Internetwork Operating System Software 
IOS (tm) c6sup1_rp Software (c6sup1_rp-PK2S-M), Version 12.1(27b)E, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2006 by cisco Systems, Inc.
Compiled Fri 10-Feb-06 23:02 by hqluong
Image text-base: 0x60020F90, data-base: 0x618C8000

ROM: System Bootstrap, Version 12.0(3)XE, RELEASE SOFTWARE 
BOOTLDR: MSFC Software (C6MSFC-BOOT-M), Version 12.1(27b)E, RELEASE SOFTWARE (fc2)

Router uptime is 33 minutes
Time since Router switched to active is 30 minutes
System returned to ROM by power-on (SP by power-on)
System image file is "sup-bootflash:c6sup11-pk2s-mz.121-27b.E.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

cisco WS-C6506 (R5000) processor (revision 2.0) with 114688K/16384K bytes of memory.
Processor board ID TBA04420431
R5000 CPU at 200Mhz, Implementation 35, Rev 2.1
Last reset from power-on
X.25 software, Version 3.0.0.
Bridging software.
1 Virtual Ethernet/IEEE 802.3  interface(s)
2 Gigabit Ethernet/IEEE 802.3 interface(s)
381K bytes of non-volatile configuration memory.
4096K bytes of packet SRAM memory.

16384K bytes of Flash internal SIMM (Sector size 256K).
Configuration register is 0x2102

Router#

Edited by D^2

Share this post


Link to post
Share on other sites

D^2, спасибо огромное за тесты! Но вы меня ставите в тупик... :)

Если вы еще не разобрали лабу, можно попросить интерфейсы gi2/1 и gi2/2 переключить в транк?

 

interface GigabitEthernet2/1
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1
switchport mode trunk

 

Больше отличий я не вижу. Ну разве что прошивка на экстримах слегка другая, но она по крайней мере новее :)

 

Summit24e3:3 # sh ver

System Serial Number:  Summit24e3 800096-01-04 0248R-01009 CLEI:           QC:       CP:02
CPU    ID:             700048-00-08 0248R-00199 CP:02
Image  :  Extremeware Version 6.2e.1 (Build 20) by Release_Master_ABU Tue 05/27/2003 16:46:08

BootROM : 1.3

 

Ничего не понимаю, маразм какой-то...

 

Share this post


Link to post
Share on other sites

6506

Router#sh run
Building configuration...

Current configuration : 953 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service counters max age 10
!
hostname Router
!
boot bootldr bootflash:c6msfc-boot-mz.121-27b.E.bin
!
ip subnet-zero
!
!
!
ip ssh time-out 120
ip ssh authentication-retries 3
mls flow ip destination
mls flow ipx destination
!
!
!         
spanning-tree mode pvst
spanning-tree vlan 1 priority 8192
!
redundancy
mode rpr-plus
main-cpu
  auto-sync running-config
  auto-sync standard
!
!
!
interface GigabitEthernet2/1
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 999
switchport trunk allowed vlan 1
switchport mode trunk
!
interface GigabitEthernet2/2
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 999
switchport trunk allowed vlan 1
switchport mode trunk
!
interface Vlan1
ip address 1.1.1.1 255.255.255.0
!
ip classless
no ip http server
!
!
!
line con 0
line vty 0 4
!
!
end

Router#sh span 

VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    8192
             Address     0003.fdd3.7801
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    8192 
             Address     0003.fdd3.7801
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi2/1            Desg FWD 4         128.65   P2p 
Gi2/2            Desg FWD 4         128.66   P2p 

Router# sh span det

VLAN0001 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 8192, address 0003.fdd3.7801
  Configured hello time 2, max age 20, forward delay 15
  We are the root of the spanning tree
  Topology change flag not set, detected flag not set
  Number of topology changes 3 last change occurred 00:02:36 ago
          from GigabitEthernet2/2
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15 
  Timers: hello 0, topology change 0, notification 0, aging 300

Port 65 (GigabitEthernet2/1) of VLAN0001 is forwarding 
   Port path cost 4, Port priority 128, Port Identifier 128.65.
   Designated root has priority 8192, address 0003.fdd3.7801
   Designated bridge has priority 8192, address 0003.fdd3.7801
   Designated port id is 128.65, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   Link type is point-to-point by default
   BPDU: sent 525, received 1

Port 66 (GigabitEthernet2/2) of VLAN0001 is forwarding 
   Port path cost 4, Port priority 128, Port Identifier 128.66.
   Designated root has priority 8192, address 0003.fdd3.7801
   Designated bridge has priority 8192, address 0003.fdd3.7801
   Designated port id is 128.66, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   Link type is point-to-point by default
   BPDU: sent 661, received 6

Router#

Switch2

* Summit24e3:13 # sh def
VLAN Interface[0-200] with name "Default" created by user
     Tagging:   802.1Q Tag 1
     Priority:  802.1P Priority 0
     IP:        1.1.1.2/255.255.255.0
     STPD:      Domain "s0" is running spanning tree protocol
     Protocol:  Match all unfiltered protocols.
     Loopback:  Disable
     QosProfile:QP1
     Ports:     26.     (Number of active ports = 1)
                Flags: * = active, ! = disabled

                Untag:  1  2  3  4  5  6  7  8  9  10  11  12  13  14
                15  16  17  18  19  20  21  22  23  25
                Tagged: 24* 26*
     Protected by 0 count of EAPS Domains

* Summit24e3:14 # sh stp
Stpd: s0                Stp: ENABLED            Number of Ports: 26
Rapid Root Failover: Disabled
Ports: 1,2,3,4,5,6,7,8,9,10,11,12
       13,14,15,16,17,18,19,20,21,22,23,24
       25,26
Vlans:  Default MacVlanDiscover
Bridge Priority: 32768
BridgeID:               80:00:00:01:30:11:9a:4b
Designated root:        20:00:00:03:fd:d3:78:01
RootPathCost: 4         Root Port: 26
MaxAge: 20s             HelloTime: 2s           ForwardDelay: 15s
CfgBrMaxAge: 20s        CfgBrHelloTime: 2s      CfgBrForwardDelay: 15s
Topology Change Time: 35s                       Hold time: 1s
Topology Change Detected: FALSE                 Topology Change: TRUE
Number of Topology Changes: 2
Time Since Last Topology Change: 362s

Switch3

* Summit24e3:46 # sh def
VLAN Interface[0-200] with name "Default" created by user
     Tagging:   802.1Q Tag 1
     Priority:  802.1P Priority 0
     IP:        1.1.1.3/255.255.255.0
     STPD:      Domain "s0" is running spanning tree protocol
     Protocol:  Match all unfiltered protocols.
     Loopback:  Disable
     QosProfile:QP1
     Ports:     26.     (Number of active ports = 2)
                Flags: * = active, ! = disabled

                Untag:  1  2  3  4  5  6  7  8  9  10  11  12  13  14
                15  16  17  18  19  20  21  22  23  25
                Tagged: 24* 26*
     Protected by 0 count of EAPS Domains

* Summit24e3:47 # sh stp
Stpd: s0                Stp: ENABLED            Number of Ports: 26
Rapid Root Failover: Disabled
Ports: 1,2,3,4,5,6,7,8,9,10,11,12
       13,14,15,16,17,18,19,20,21,22,23,24
       25,26
Vlans:  Default MacVlanDiscover
Bridge Priority: 32768
BridgeID:               80:00:00:01:30:11:90:1f
Designated root:        20:00:00:03:fd:d3:78:01
RootPathCost: 4         Root Port: 26
MaxAge: 20s             HelloTime: 2s           ForwardDelay: 15s
CfgBrMaxAge: 20s        CfgBrHelloTime: 2s      CfgBrForwardDelay: 15s
Topology Change Time: 35s                       Hold time: 1s
Topology Change Detected: FALSE                 Topology Change: FALSE
Number of Topology Changes: 11
Time Since Last Topology Change: 63s

Share this post


Link to post
Share on other sites
Застрелиться

Не стоит пока. Не понятно из-за чего стреляться. В приведенном выше тесте на каталисте pvst, на экстримах, как я понимаю, stp.

В таком виде должно все работать. Правда на каталисте заведен все один влан, для которого и построено дерево. Интересней будет

проверить с несколькими вланами. На каталисте при этом будет свое дерево для каждого влана, а на экстримах общее дерево на все вланы.

По идее (100% не ручаюсь, надо проверять), если руты для всех вланов держать на одном этом каталисте, то должно все работать, а вот если

захочется рут для какого-то влана вынести на, например, другой каталист c pvst, то тогда хз что будет.

 

Share this post


Link to post
Share on other sites
Не стоит пока. Не понятно из-за чего стреляться. В приведенном выше тесте на каталисте pvst, на экстримах, как я понимаю, stp.

В таком виде должно все работать. Правда на каталисте заведен все один влан, для которого и построено дерево. Интересней будет

проверить с несколькими вланами. На каталисте при этом будет свое дерево для каждого влана, а на экстримах общее дерево на все вланы.

По идее (100% не ручаюсь, надо проверять), если руты для всех вланов держать на одном этом каталисте, то должно все работать, а вот если

захочется рут для какого-то влана вынести на, например, другой каталист c pvst, то тогда хз что будет.

Олег, я не совсем понял что мне нужно сделать для этого. У меня вроде так же стоит PVST на каталисте и STP на экстримах. Разница только в количестве виланов - у меня их несколько. Рут указан для всех виланов на каталист. Так что вроде конфигурация идентичная? Или я чего-то не улавливаю?

Share this post


Link to post
Share on other sites
Не стоит пока. Не понятно из-за чего стреляться. В приведенном выше тесте на каталисте pvst, на экстримах, как я понимаю, stp.

В таком виде должно все работать. Правда на каталисте заведен все один влан, для которого и построено дерево. Интересней будет

проверить с несколькими вланами. На каталисте при этом будет свое дерево для каждого влана, а на экстримах общее дерево на все вланы.

По идее (100% не ручаюсь, надо проверять), если руты для всех вланов держать на одном этом каталисте, то должно все работать, а вот если

захочется рут для какого-то влана вынести на, например, другой каталист c pvst, то тогда хз что будет.

Олег, я не совсем понял что мне нужно сделать для этого. У меня вроде так же стоит PVST на каталисте и STP на экстримах. Разница только в количестве виланов - у меня их несколько. Рут указан для всех виланов на каталист. Так что вроде конфигурация идентичная? Или я чего-то не улавливаю?

Ну так покажите вашу диагностику, посмотрим чем оно отличается от того, что D^2 привел.

Share this post


Link to post
Share on other sites
Ну так покажите вашу диагностику, посмотрим чем оно отличается от того, что D^2 привел.

Catalyst 6506

 

Подключение - к порту gi2/3 каталиста подключена герлянда экстримов (sw1,sw2,sw3) как на схеме в первом посте. Кольцо не замкнуто на каталисте - порт gi2/4 отключен на время тестов.

 

#sh run
Building configuration...

Current configuration : 8734 bytes
!
! Last configuration change at 21:24:51 MSK Tue Dec 30 2008 by kostas
! NVRAM config last updated at 21:34:04 MSK Tue Dec 30 2008 by kostas
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service counters max age 10
!
hostname Core
!
boot system sup-bootflash:c6sup11-pk2s-mz.121-27b.E.bin
aaa new-model
enable password master
!
username root privilege 15 secret 5 $1$iRa.$5xQ1seR7,w0abLftSrA.0
clock timezone MSK 3
clock summer-time MSK recurring last Sun Mar 2:00 last Sun Oct 3:00
clock calendar-valid
ip subnet-zero
no ip rcmd domain-lookup
ip rcmd rsh-enable
ip rcmd remote-host netup 10.0.0.2 netup enable
ip wccp web-cache redirect-list WCCP_REDIRECT_TEST
!
!
ip domain-name link.local
ip name-server x.x.x.x
ip name-server x.x.x.x
ip dhcp excluded-address 10.4.0.1
ip dhcp excluded-address 10.4.0.255 10.4.255.254
!
ip dhcp pool office
   network 10.4.0.0 255.255.0.0
   default-router 10.4.0.1
   dns-server 10.0.0.2
   domain-name link-spb.ru
   lease infinite
!
ip ssh time-out 60
ip ssh authentication-retries 3
ip ssh version 2
mls flow ip destination
mls flow ipx destination
mls qos
!
!
!
spanning-tree mode pvst
no spanning-tree vlan 2
spanning-tree vlan 3-4 priority 8192
!
redundancy
mode rpr-plus
main-cpu
  auto-sync running-config
  auto-sync standard
!
!
class-map match-any ManageCLASS
  match access-group name PolicyManage
!
!
policy-map TESTPOLICY
  class ManageCLASS
    bandwidth percent 3
    set ip dscp 16
  class class-default
    random-detect
!
!
!
interface Loopback0
ip address 192.168.10.1 255.255.255.0
ip route-cache policy
ip route-cache flow
!
interface GigabitEthernet2/3
description Test STP
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 3,4,1000
switchport mode trunk
!
interface GigabitEthernet2/4
description Test STP
shutdown
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 3,4,1000
switchport mode trunk
!
interface Vlan1
no ip address
shutdown
!
interface Vlan3
description Management
ip address 10.3.0.1 255.255.255.0
!
interface Vlan4
description Office
ip address 10.4.0.1 255.255.255.0
ip nat inside
!
!
ip default-gateway <GW-IP>
ip classless
ip route 0.0.0.0 0.0.0.0 <GW-IP> tag 999 name Uplink
ip flow-export version 5
ip flow-export destination 10.0.0.2 9996
no ip http server
!
!
ip access-list standard FWD-2-SQUID
ip access-list standard NAT-ACCESS
permit 10.0.0.0 0.0.0.255
permit 10.4.0.0 0.0.0.255
permit 10.5.0.0 0.0.0.255
permit 10.6.0.0 0.0.0.255
permit 10.100.0.0 0.0.255.255
deny   any
!
ip access-list extended LOOP
permit ip any 10.0.0.0 0.255.255.255
ip access-list extended PolicyManage
permit tcp any any eq 22
permit tcp any eq 22 any
permit tcp any any eq telnet
permit tcp any eq telnet any
deny   ip any any
ip access-list extended WCCP_REDIRECT
permit tcp 10.0.0.0 0.255.255.255 any eq www
permit tcp 10.0.0.0 0.255.255.255 any eq 8080
permit tcp 10.0.0.0 0.255.255.255 any eq 3128
deny   ip any any
ip access-list extended WCCP_REDIRECT_TEST
deny   tcp host 10.0.0.2 any eq www
permit tcp host 10.0.0.5 any eq www
deny   ip any any
ip access-list extended inet
deny   tcp any host x.x.x.x eq telnet
permit ip any any
access-list 100 permit tcp 0.0.0.0 255.0.0.0 any eq www
access-list 100 permit tcp 0.0.0.0 255.0.0.0 host 10.0.0.2 eq domain
access-list 100 permit udp 0.0.0.0 255.0.0.0 host 10.0.0.2 eq domain
access-list 100 permit tcp 0.0.0.0 255.0.0.0 any eq ftp
access-list 100 permit tcp 0.0.0.0 255.0.0.0 any eq ftp-data
access-list 100 permit tcp 0.0.0.0 255.0.0.0 any eq smtp
access-list 100 permit tcp 0.0.0.0 255.0.0.0 any eq pop3
access-list 100 deny   ip any any
access-list 101 permit tcp any any eq www
access-list 101 permit tcp any host 10.0.0.2 eq domain
access-list 101 permit udp any host 10.0.0.2 eq domain
access-list 101 permit tcp any any eq ftp
access-list 101 permit tcp any any eq ftp-data
access-list 101 permit tcp any any eq smtp
access-list 101 permit tcp any any eq pop3
access-list 101 deny   ip any any
access-list 105 dynamic test1 permit ip any any
access-list 105 permit ip host 10.0.0.5 any
access-list 106 dynamic test2 permit ip any any
access-list 106 permit ip any host 10.0.0.5
route-map NETUP_MAP permit 10
match ip address LOOP
set interface Loopback0 GigabitEthernet1/1
!
!
privilege exec level 8 access-template
privilege exec level 8 clear access-template
!
line con 0
line vty 0 4
!
ntp clock-period 17179684
ntp master 15
ntp update-calendar
ntp server 194.149.67.130
ntp server 192.36.143.152 version 2
!
end

 

 

 

#sh span

VLAN0003
  Spanning tree enabled protocol ieee
  Root ID    Priority    8192
             Address     0004.de18.b403
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    8192
             Address     0004.de18.b403
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi2/3            Desg FWD 4         128.67   P2p


VLAN0004
  Spanning tree enabled protocol ieee
  Root ID    Priority    8192
             Address     0004.de18.b404
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    8192
             Address     0004.de18.b404
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi2/3            Desg FWD 4         128.67   P2p

 

 

#sh span deta

VLAN0003 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 8192, address 0004.de18.b403
  Configured hello time 2, max age 20, forward delay 15
  We are the root of the spanning tree
  Topology change flag not set, detected flag not set
  Number of topology changes 16 last change occurred 00:02:49 ago
          from GigabitEthernet2/3
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15
  Timers: hello 0, topology change 0, notification 0, aging 300

Port 67 (GigabitEthernet2/3) of VLAN0003 is forwarding
   Port path cost 4, Port priority 128, Port Identifier 128.67.
   Designated root has priority 8192, address 0004.de18.b403
   Designated bridge has priority 8192, address 0004.de18.b403
   Designated port id is 128.67, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   Link type is point-to-point by default
   BPDU: sent 101, received 0


VLAN0004 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 8192, address 0004.de18.b404
  Configured hello time 2, max age 20, forward delay 15
  We are the root of the spanning tree
  Topology change flag not set, detected flag not set
  Number of topology changes 13 last change occurred 00:03:45 ago
          from GigabitEthernet2/3
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15
  Timers: hello 0, topology change 0, notification 0, aging 300

Port 67 (GigabitEthernet2/3) of VLAN0004 is forwarding
   Port path cost 4, Port priority 128, Port Identifier 128.67.
   Designated root has priority 8192, address 0004.de18.b404
   Designated bridge has priority 8192, address 0004.de18.b404
   Designated port id is 128.67, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   Link type is point-to-point by default
   BPDU: sent 128, received 0

 

SW1

 

Summit24e3:2 # sh Manage
VLAN Interface[2-202] with name "Manage" created by user
     Tagging:   802.1Q Tag 3
     Priority:  802.1P Priority 0
     IP:        10.3.0.7/255.255.255.0
     STPD:      Domain "s0" is running spanning tree protocol
     Protocol:  Match all unfiltered protocols.
     Loopback:  Disable
     QosProfile:QP1
     Ports:     2.     (Number of active ports = 2)
                Flags: * = active, ! = disabled

                Tagged: 25* 26*
     Protected by 0 count of EAPS Domains

Summit24e3:3 # sh Office
VLAN Interface[3-204] with name "Office" created by user
     Tagging:   802.1Q Tag 4
     Priority:  802.1P Priority 0
     STPD:      Domain "s0" is running spanning tree protocol
     Protocol:  Match all unfiltered protocols.
     Loopback:  Disable
     QosProfile:QP1
     Ports:     2.     (Number of active ports = 2)
                Flags: * = active, ! = disabled

                Tagged: 25* 26*
     Protected by 0 count of EAPS Domains

Summit24e3:4 # sh stpd
Stpd: s0                Stp: ENABLED            Number of Ports: 2
Rapid Root Failover: Disabled
Ports: 25,26
Vlans:  Default MacVlanDiscover Manage Office
Bridge Priority: 32768
BridgeID:               80:00:00:01:30:11:a7:e4
Designated root:        80:00:00:01:30:11:8e:00
RootPathCost: 4         Root Port: 25
MaxAge: 20s             HelloTime: 2s           ForwardDelay: 15s
CfgBrMaxAge: 20s        CfgBrHelloTime: 2s      CfgBrForwardDelay: 15s
Topology Change Time: 35s                       Hold time: 1s
Topology Change Detected: FALSE                 Topology Change: FALSE
Number of Topology Changes: 5
Time Since Last Topology Change: 411s

 

SW2

 

Summit24e3:1 # sh Manage
VLAN Interface[2-202] with name "Manage" created by user
     Tagging:   802.1Q Tag 3
     Priority:  802.1P Priority 0
     IP:        10.3.0.8/255.255.255.0
     STPD:      Domain "s0" is running spanning tree protocol
     Protocol:  Match all unfiltered protocols.
     Loopback:  Disable
     QosProfile:QP1
     Ports:     2.     (Number of active ports = 2)
                Flags: * = active, ! = disabled

                Tagged: 25* 26*
     Protected by 0 count of EAPS Domains

Summit24e3:2 # sh Office
VLAN Interface[3-204] with name "Office" created by user
     Tagging:   802.1Q Tag 4
     Priority:  802.1P Priority 0
     STPD:      Domain "s0" is running spanning tree protocol
     Protocol:  Match all unfiltered protocols.
     Loopback:  Disable
     QosProfile:QP1
     Ports:     2.     (Number of active ports = 2)
                Flags: * = active, ! = disabled

                Tagged: 25* 26*
     Protected by 0 count of EAPS Domains

Summit24e3:5 # sh stpd
Stpd: s0                Stp: ENABLED            Number of Ports: 2
Rapid Root Failover: Disabled
Ports: 25,26
Vlans:  Default MacVlanDiscover Manage Office
Bridge Priority: 32768
BridgeID:               80:00:00:01:30:11:8e:00
Designated root:        80:00:00:01:30:11:8e:00
RootPathCost: 0         Root Port: ----
MaxAge: 20s             HelloTime: 2s           ForwardDelay: 15s
CfgBrMaxAge: 20s        CfgBrHelloTime: 2s      CfgBrForwardDelay: 15s
Topology Change Time: 35s                       Hold time: 1s
Topology Change Detected: FALSE                 Topology Change: FALSE
Number of Topology Changes: 3
Time Since Last Topology Change: 464s

 

SW3

 

Summit24e3:1 # sh Manage
VLAN Interface[2-205] with name "Manage" created by user
     Tagging:   802.1Q Tag 3
     Priority:  802.1P Priority 0
     IP:        10.3.0.9/255.255.255.0
     STPD:      Domain "s0" is running spanning tree protocol
     Protocol:  Match all unfiltered protocols.
     Loopback:  Disable
     QosProfile:QP1
     Ports:     2.     (Number of active ports = 1)
                Flags: * = active, ! = disabled

                Tagged: 25  26*
     Protected by 0 count of EAPS Domains

Summit24e3:2 # sh Office
VLAN Interface[3-209] with name "Office" created by user
     Tagging:   802.1Q Tag 4
     Priority:  802.1P Priority 0
     STPD:      Domain "s0" is running spanning tree protocol
     Protocol:  Match all unfiltered protocols.
     Loopback:  Disable
     QosProfile:QP1
     Ports:     2.     (Number of active ports = 1)
                Flags: * = active, ! = disabled

                Tagged: 25  26*
     Protected by 0 count of EAPS Domains

Summit24e3:3 # sh stpd
Stpd: s0                Stp: ENABLED            Number of Ports: 2
Rapid Root Failover: Disabled
Ports: 25,26
Vlans:  Default MacVlanDiscover Manage Office
Bridge Priority: 32768
BridgeID:               80:00:00:01:30:12:4c:d3
Designated root:        80:00:00:01:30:11:8e:00
RootPathCost: 4         Root Port: 26
MaxAge: 20s             HelloTime: 2s           ForwardDelay: 15s
CfgBrMaxAge: 20s        CfgBrHelloTime: 2s      CfgBrForwardDelay: 15s
Topology Change Time: 35s                       Hold time: 1s
Topology Change Detected: FALSE                 Topology Change: FALSE
Number of Topology Changes: 7
Time Since Last Topology Change: 797158s

 

 

Share this post


Link to post
Share on other sites

kostas, попробуйте добавить первый влан в транк между каталистом и экстримами.

Во-вторых, настройте порт-мирроринг на каталисте, и посмотрите wireshark'ом или tcpdump'ом что бегает между каталистом и экстримом.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this