Jump to content
Калькуляторы

cisco+debian - multilink vpn

Добрый день!

 

У меня задача хитрая.. уже неделю голову ломаю и гугль замучал..

 

схема такая:

 

 

 

server Debian [eth0] (192.168.1.1) ----switch----adsl router (192.168.1.2)----provaider (pppoe)----internet----cisco 3620 vpn server [eth0/0] (1.2.3.4)

--adsl router (192.168.1.3)----provaider (pppoe)-------

--adsl router (192.168.1.4)----provaider (pppoe)-------

Как понятно из схемы имеется сервер linux Debian, 3 АДСЛ модема настроенных роутерами с НАТом и на другом конце интернета сидит cisco.

Надо поднять на Cisco 3620 - VPN сервер чтоб он понимал мультилинк и каким то чудом настроить vpn слиентов в Linux чтоб они образовали ДОП. ИНТЕРФЕЙС на который я смогу посадить белый IP.

 

Долго думал как можно заставить конектиться VPN клиентов через разные шлюзы, и придумал:

На интерфейсе Cisco eth0/0 я поднимаю несколько белых ip адресов и настраиваю маршруты на кажды ip cisco через разные шлюзы.

Например: (виндовая версия)

route add 1.2.3.4 mask 255.255.255.255 192.168.1.2

route add 1.2.3.5 mask 255.255.255.255 192.168.1.3

route add 1.2.3.6 mask 255.255.255.255 192.168.1.4

 

Сам я как с Cisco так и с Linux только начинающий пользователь.

 

Что именно я не понимаю:

- как VPN серверу на циске сказать - "понимай мультилинк" и как этот vpn север должен быть организован. чует мой нос, что не просто через один Virtual-Template

- как в Linux создать VPN соединение (результатом должен быть наверное какой нибудь ppp0)

- как Linux сказать - "используй ppp0 ppp1 ppp2 как мультилинк и зарули его на ppp3"

 

Спасибо за внимание.

 

p.s. гугль на тему ppp multilink ничего не сказал (про freebsd говорит как сервер pppd с multilink поднять), а по cisco multilink рассказывает в основном как циски между собой связать через Serial.

Edited by Yaten

Share this post


Link to post
Share on other sites

насчет мультилинка - непонятно, зачем нужен именно мультилинк?

если подойдет просто несколько тунелей между дебианом и цыской, то все проще: на цыске поднимаем VPDN, на дебиане - poptop.

можно попробовать прописать ppp multilink на virtual-temmplate, но я не уверен, что оно адекватно сработает.

на линухе накручивать что-то вроде http://www.opennet.ru/base/modem/eql.txt.html

Share this post


Link to post
Share on other sites

EQL интересная технология, может быть дже что то получится. но на http://rus-linux.net/MyLDP/HOWTO-ru/NET-3-...-3-HOWTO-6.html написано что вторая сторона так же должна поддерживать EQL. Cisco 3620 умеет это? google.ru что то ничего не говорит на эту тему.

 

А пока я настроил как и планировал через multilink.

Конфиг Cisco:

 

Router#sh run

Building configuration...

 

Current configuration : 1418 bytes

!

version 12.3

no service timestamps debug uptime

service timestamps log datetime msec

service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

enable password xxxxx

!

no aaa new-model

ip subnet-zero

!

!

ip cef

!

ip audit po max-events 100

vpdn enable

!

vpdn-group 1

! Default L2TP VPDN group

! Default PPTP VPDN group

accept-dialin

protocol any

virtual-template 1

!

!

!

!

!

!

!

!

!

!

!

!

!

username admin password xxxxxxxxxxxxxxxxxxxxx

!

!

!

!

!

!

interface Ethernet0/0

ip address x.y.9.99 255.255.255.248 secondary

ip address x.y.9.98 255.255.255.248

ip nat outside

full-duplex

no cdp enable

!

interface Ethernet1/0

no ip address

shutdown

full-duplex

!

interface Virtual-Template1

mtu 1300

ip address 192.168.10.1 255.255.255.0

ip nat inside

ip policy route-map clear-df

peer default ip address pool vpnpool

ppp authentication ms-chap-v2 chap

ppp ipcp dns x.y.a.b

ppp multilink

bridge-group 1

!

ip local pool vpnpool 192.168.10.2 192.168.10.254

ip nat inside source list 10 interface Ethernet0/0 overload

no ip http server

no ip http secure-server

ip classless

ip route 0.0.0.0 0.0.0.0 x.y.9.97

!

!

access-list 10 permit 192.168.10.0 0.0.0.255

access-list 150 permit tcp any any

!

route-map clear-df permit 20

match ip address 150

set ip df 0

!

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

login local

transport input all

!

!

end

 

В линуксе настроил 2 pptp соединения:

 

pty "pptp x.y.9.98 --nolaunchpppd"

user xx

password "yy"

nodeflate

nobsdcomp

noauth

mtu 1300

defaultroute

multilink

 

и

 

pty "pptp x.y.9.99 --nolaunchpppd"

user xx

password "yy"

nodeflate

nobsdcomp

noauth

mtu 1300

defaultroute

multilink

 

Все поднимается, появляется интерфейс ppp0, на циске висит два vpn конекта. В общем все пучкам.

 

Но, есть одно но.

 

Это уже в следующей теме. http://forum.nag.ru/forum/index.php?showtopic=45829

Edited by Yaten

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this