Перейти к содержимому
Калькуляторы

cisco 2950T (дефолтный влан)

Здравствуйте, нужна помошь

 

Имеется в наличии C2950T 13 вланов, все работает норм кроме дефолтного. Трабла заключается в том что циска выплевывает из транкого порта не меченый пакет (vid 1) как по native vlan

 

Роутер, дефолтный влан, сетевуха (sk0) на которой куча вланов . 192.168.192.200 - каталиста

 

ifconfig vlan1

vlan1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500

inet 192.168.192.1 netmask 0xffffff00 broadcast 192.168.192.255

ether 00:1b:11:c4:c1:68

media: Ethernet autoselect (1000baseTX <full-duplex,flag0,flag1,flag2>)

status: active

vlan: 1 parent interface: sk0

 

tcpdump -nnli vlan1 icmp

tcpdump: verbose output suppressed, use -v or -vv for full protocol decode

listening on vlan1, link-type EN10MB (Ethernet), capture size 96 bytes

09:12:27.716354 IP 192.168.192.1 > 192.168.192.200: ICMP echo request, id 2031, seq 512, length 40

 

все норм, тегированный эхо запрос пошел по влану, но ... ответ приходит в сетевуху не меченым, как по native vlan-у

tcpdump -nnli sk0 icmp

tcpdump: WARNING: sk0: no IPv4 address assigned

tcpdump: verbose output suppressed, use -v or -vv for full protocol decode

listening on sk0, link-type EN10MB (Ethernet), capture size 96 bytes

09:12:27.717835 IP 192.168.192.200 > 192.168.192.1: ICMP echo reply, id 2031, seq 512, length 40

 

Транковый порт каталисты, куда подключен роутер и сам дефолтный влан

 

interface GigabitEthernet0/2

description GW-trunk

switchport trunk allowed vlan 1-6,8-13

switchport mode trunk

!

interface Vlan1

ip address 192.168.192.200 255.255.255.0

no ip route-cache

!

ip default-gateway 192.168.192.1

 

каталиста понимает токо 802.1ку, ISL не понимает

switchport trunk encapsulation dot1q такая команда вообще отсутвует

 

куда копать ? подскажите плз?

 

Cisco Internetwork Operating System Software

IOS C2950 Software (C2950-I6Q4L2-M), Version 12.1(22)EA11, RELEASE SOFTWARE (fc2)

Copyright © 1986-2008 by cisco Systems, Inc.

Compiled Tue 08-Jan-08 10:50 by amvarma

 

Изменено пользователем Ромарь

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Если я чего-нибудь понял, то должно помочь это:

SW1(config-if)#switchport trunk native vlan ?

<1-4094> VLAN ID of the native VLAN when this port is in trunking mode

По умолчанию на транках у цыски vlan 1 является нативным. Поправьте на какой-нибудь другой. Или не используйте влан с номером 1.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Если я чего-нибудь понял, то должно помочь это:

SW1(config-if)#switchport trunk native vlan ?

<1-4094> VLAN ID of the native VLAN when this port is in trunking mode

По умолчанию на транках у цыски vlan 1 является нативным. Поправьте на какой-нибудь другой. Или не используйте влан с номером 1.

пробовал, не помогает

дело в том что очень много обуродования (управление им) работает именно в вид 1 (tag) не хотелось бы использовать native vlan, есть похожая железка

Cisco Internetwork Operating System Software

IOS C3500XL Software (C3500XL-C3H2S-M), Version 12.0(5)WC16, RELEASE SOFTWARE (fc1)

Copyright © 1986-2006 by cisco Systems, Inc.

 

она понимает ISL , но работает на 802.1ку вот через этот порт все прекрасно работает

 

interface FastEthernet0/1

description "Uplink"

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-4,7,1002-1005

switchport mode trunk

no cdp enable

 

не понятно почему 2950 на выходе не вешает тег на первый влан (хотя он там явно указан) а выплевывает его через native, да еше забыл сказать пока статикой мак цискы не забьешь на роутере .. ее не видно

Изменено пользователем Ромарь

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

потому что native vlan собирает пакеты без тэга... вам поможет команда vlan dot1q tag native

 

или можете просто сделать switchport trunk native vlan №любого неиспользуемого влана.

 

по умолчанию на любом свиче стоит native vlan 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
потому что native vlan собирает пакеты без тэга... вам поможет команда vlan dot1q tag native

 

или можете просто сделать switchport trunk native vlan №любого неиспользуемого влана.

 

по умолчанию на любом свиче стоит native vlan 1

простите, но нету такой ((( или я не туда ее ввожу?

 

k14a#vlan ?

database Configure VLAN database

 

k14a#conf t

Enter configuration commands, one per line. End with CNTL/Z.

k14a(config)#vlan

k14a(config)#vlan ?

WORD ISL VLAN IDs 1-4094

internal internal VLAN

 

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ромарь

Значит поставте switchport trunk native vlan №любого неиспользуемого влана на интерфейсе. Тогда у вас будет теггироваться 1-й влан.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Ромарь

Значит поставте switchport trunk native vlan №любого неиспользуемого влана на интерфейсе. Тогда у вас будет теггироваться 1-й влан.

Огромное спасибо, помогло, вопрос можно считать закрытым

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас