Перейти к содержимому
Калькуляторы

Конфликт между ADSL модемами ZYXEL в одной локальной сети. Нужна помощь.

В одноуровневой локальной сети (без сервера, маршрутизатора) соеденённой неуправляемыми свитчами, подключено около 90 кмпьютеров и установлено 3 модема ZYXEL. Два ZYXEL 660RT 2 и один 660RT1. Работают они в одном диапазоне локальных IP-адресов. Один из модемов подключен провайдеру X, а два других к провайдеру Y.

Проблема состоит в том, что после установки дополнительного модема 660RT2 подключенного к провайдеру Y стали постоянно происходить зависания модемов.

Выражаются они в том, что неожиданно, либо совсем пропадает связь со всеми модемами, либо они очень медленно отвечают на посылаемые им запросы (ping)

Локальная сеть при этом продолжает работать нормально. Решается проблема временным (достаточно и нескольких секунд)отключением от локальной сети одного из модемов 660RT2. После обратного включения в сеть этого 660RT2 некоторое время все модемы работают нормально, но потом возникает та же проблема, которую приходится решать таким же образом.

Хотелось бы узнать в чём может быть причина такого поведения модемов.

 

А вот какие настройки у этих модемов (все они используют протокол ENET ENCAP)

 

modem 1

 

System Name: AT

ZyNOS F/W Version: V3.40(AHO.2) | 09/27/2006

DSL FW Version:DMT FwVer: 3.5.14.0_A_TC, HwVer: T14F7_0.0

Standard:ADSL_G.dmt

IP Address:10.1.2.10

IP Subnet Mask:255.255.255.0

Default Gateway:127.0.0.1

VPI/VCI:2/ 35

LAN Information

MAC Address:00:13:49:c6:5e:23

IP Address: 10.40.5.4

IP Subnet Mask: 255.255.255.0

DHCP: N/A

DHCP Start IP: N/A

DHCP Pool Size: N/A

 

 

modem 2

Host Name: P660RT2

Model Number: P660RT2

MAC Address: 00:19:cb:52:b2:9f

ZyNOS Firmware Version: V3.40(AXN.1) | 07/24/2007

DSL Firmware Version: DMT FwVer: 3.7.9.8_A_TC, HwVer: T14F7_3.0

WAN Information

- DSL Mode: ADSL_G.dmt

- IP Address: 10.1.2.72

- IP Subnet Mask: 255.255.255.0

- Default Gateway: 127.0.0.1

- VPI/VCI: 2/35

LAN Information

- IP Address: 10.40.5.5

- IP Subnet Mask: 255.255.255.0

- DHCP: N/A

 

modem 3

Host Name: P660RT2

Model Number: P660RT2

MAC Address: 00:19:cb:52:e9:8c

ZyNOS Firmware Version: V3.40(AXN.1) | 07/24/2007

DSL Firmware Version: DMT FwVer: 3.7.9.8_A_TC, HwVer: T14F7_3.0

WAN Information

- DSL Mode: ADSL_G.dmt

- IP Address: 10.40.102.2

- IP Subnet Mask: 255.255.255.252

- Default Gateway: 10.40.102.1

- VPI/VCI: 0/33

LAN Information

- IP Address: 10.40.5.7

- IP Subnet Mask: 255.0.0.0

- DHCP: N/A

 

Схематично набросал в Пэинте схему их подключения и IP адреса. Проблему с зависанием решаем отключением от сети модема № 2.

 

 

схема.bmp

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Два канала инета не совместить простым втыканием DSL модемов в свитч, нужна балансировка нагрузки, т.е. либо сервер, либо D-link железка с 2я WAN портами.

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Немного неверно описал проблему, поправлюсь.

При зависаниях модемов сеть так же ложится. Настройки самого модема не спасают... даже если он работает совершенно в другом диапазоне ай-пи адресов, сеть всё равно падает. Само интересное что 2 модема (независимо какие из них)вместе работают нормально, но при появлении третьего собрата начинается такая свистопляска..

Захватывал траффик во время этих зависаний сети.. В сети в это время идёт шторм либо по NBNS либо ICMP протоколам. Причём адреса отправки и назначения пакетов различные. Якобы с одного компьютера к другому, но компьютеры эти в данный момент в сеть не подключены.

Останавливается шторм отключением одного из модемов.

Вот такая ерунда.

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
modem 3

Host Name: P660RT2

 

LAN Information

- IP Address: 10.40.5.7

- IP Subnet Mask: 255.0.0.0

- DHCP: N/A

Почему маска такая?

 

И на модемах WAN как настроен (Static IP, PPPoE и т.п.)?

Изменено пользователем Iapetus

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Маска теперь везде одинаковая 255.255.255.0

эффекта нет...

WAN настроен

режим routing

encapsulation ENET ENCAP

на всех модемах

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

И откуда ей взяться ? Глючный свитч ? Но тогда почему проявляет себя именно... когда все 3 модема включены...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ещё вопрос:

"Default Gateway:127.0.0.1"

это почему так?

 

может обрисуете схему включения модемов вовне, что-то есть подозрения что петля через wan модемов каким-то образом получается...

 

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Ещё вопрос:

"Default Gateway:127.0.0.1"

это почему так?

 

может обрисуете схему включения модемов вовне, что-то есть подозрения что петля через wan модемов каким-то образом получается...

Вот и у меня были такие подозрения.. но ведь локальный ай-пи ставлю в другом диапазоне.. у нас 10.40. а ставлю 192.168 и всё равно штормит сеть..

Разве что попробую полностью один из модемов обнулить.. отключить от телефонки и тупо воткнуть в сеть..

 

А "Default Gateway:127.0.0.1" получает модем автоматом от провайдера (такие у них настройки) Два других модема висят на другом провайдере.. там статические ай-пи

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

модемы точно не работают как бриджи?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
модемы точно не работают как бриджи?
Да точно нет..

post-56355-1214923819_thumb.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

поставте роутер, чесслово.

Изменено пользователем prema

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Один из модемов подключен провайдеру X, а два других к провайдеру Y.

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
А "Default Gateway:127.0.0.1" получает модем автоматом от провайдера (такие у них настройки) Два других модема висят на другом провайдере.. там статические ай-пи
эээ, этот шлюз стоит у двух модемов, подключенных к одному провайдеру! Уверен, что петля идет через DSLAM провайдера, ведь по сути это тупой коммутатор. Вы вообще у него спрашивали о такой возможности включения?

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
А "Default Gateway:127.0.0.1" получает модем автоматом от провайдера (такие у них настройки) Два других модема висят на другом провайдере.. там статические ай-пи
эээ, этот шлюз стоит у двух модемов, подключенных к одному провайдеру! Уверен, что петля идет через DSLAM провайдера, ведь по сути это тупой коммутатор. Вы вообще у него спрашивали о такой возможности включения?

Да.. извиняюсь что напутал..

Дело в том что ситуция такова..

Сейчас у нас сеть состоит из двух подсетей.. работают они в разных диапазонах ай-пи.. и разделены маршрутизатором на базе Mikrotik

пул DHCP для одной подсети 10.40.4.11-254, для другой 10.40.5.11-254 Модемы висят на статических адресах... Не говорил этого сразу поптому как точно такая проблема возникает когда подсети работают сепаратно. И симптомы все те же. По 2 ZYXEL в одной подсети работают нормально .. при появлении третьего.. сеть падает.

По поводу провайдера... В одной из подсетей действительно 2 модема получают ай-пи от одного провайдера а один на статике.. так что мысль по поводу петли не лишена смысла.. но во второй подсети ситуация обратная.. два модема на статике один на автомате...

И самое интересное то.. что вчера включил третий модем, предварительно обнулив настройки и отключив от телефонной линии и всё равно.. через какое то время сеть упала.. пришлось его снова отключать... после этого всё заработало...

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Да.. извиняюсь что напутал..

Дело в том что ситуция такова..

Сейчас у нас сеть состоит из двух подсетей.. работают они в разных диапазонах ай-пи.. и разделены маршрутизатором на базе Mikrotik

пул DHCP для одной подсети 10.40.4.11-254, для другой 10.40.5.11-254 Модемы висят на статических адресах... Не говорил этого сразу поптому как точно такая проблема возникает когда подсети работают сепаратно. И симптомы все те же. По 2 ZYXEL в одной подсети работают нормально .. при появлении третьего.. сеть падает.

По поводу провайдера... В одной из подсетей действительно 2 модема получают ай-пи от одного провайдера а один на статике.. так что мысль по поводу петли не лишена смысла.. но во второй подсети ситуация обратная.. два модема на статике один на автомате...

И самое интересное то.. что вчера включил третий модем, предварительно обнулив настройки и отключив от телефонной линии и всё равно.. через какое то время сеть упала.. пришлось его снова отключать... после этого всё заработало...

Ндаа... Если и дальше продолжите талдычить про включение третьего модема - проблему не решите. Статикой или динамикой получает модем ip - на создание петли влияния не оказывает.

Вообщем давайте рисуйте реальную схему с правильными адресами и народ будет разбираться, а методом тыка - ну тычьте... только здесь думаю тогда никто вам не поможет.

 

Изменено пользователем Iapetus

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Набросал полную схему в Ворде.

А по поводу метода тыка.. то да .. грешен этим .. к сожалению в теории слабоват пока.. но пытаюсь самобразовываться.. Спасибо тем кто помогает разобраться с возникшей у меня проблемой..

CXEMA.doc

Изменено пользователем stalk

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Набросал полную схему в Ворде.
Еще пара вопросов:

1. На модемах включен NAT?

2. По умолчанию на модемах запущен dhcp-сервер - выключен ли он?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Набросал полную схему в Ворде.
Еще пара вопросов:

1. На модемах включен NAT?

2. По умолчанию на модемах запущен dhcp-сервер - выключен ли он?

1. NAT включен (иначе как несколько локальных ай-пи будут пользоваться одним внешним..)

Lругой вопрос не возникает ли путаницы при работе нескольких NAT систем... пользователи подключаются к модемам через VPN предварительно прописывая путь.. на манер route add 10.1.2.1 mask 255.255.255.255 10.40.5.4 -p Причём одновременно могут создать второе подключение и прописать путь на модем второго провайдера так route add 81.25.32.68 mask 255.255.255.255 10.40.5.7 -p В таком случае и всегда ли NAT может как надо преобразовывать IP-адреса ?

2. DHCP на модемах выключен. Его функции выполняет только обший маршрутизатор на Mikrotik.

 

ЗЫ:

Была ещё такая .. быть может глупая мысль.. Пользователи любят сидеть на одних и тех же игровых серверах... ВОВ, Линейка и т.д. Может ли нарисоваться петля только из-за того что они с разных модемов (1 и 3) например подключены к одному и тому же серверу (ну например.. к игровому серверу провайдера ) ?

Изменено пользователем stalk

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Сталкивался с аналогичной проблемой.

Модемы ZYXEL 660RT (как минимум 1, ZyNOS F/W Version: V3.40(AHO.2) | 09/27/2006 DSL FW Version:DMT FwVer: 3.5.14.0_A_TC, HwVer: T14F7_0.0)

и Billion BiPAC 5102 (2+ шт, похоже на том же чипсете что и ZYXEL).

На всех модемах NAT, routing, ENET ENCAP.

Насколько я помню, удалось выяснить следующее:

1. падают не только модемы, но и сетка

2. пинг до Биллионов становится 1000+, загрузка CPU ~ 100%

3. проблемы возникают, даже если тел. линии отключена

4. модемы похоже работают в promiscous mode, т.е ловят все пакеты (на любые MAC адреса), даже в режиме router. любая петля в сетке, и модемы ложатся (100% cpu)

-> было предположение, что причина в этом: раз они ловят не свои пакеты, значит могут и отправлять их назад в сетку, создавая петлю

5. решить проблему не удалось

В данный момент все известные модемы спрятаны за роутерами/wifi-роутерами (самый дешевый - Edimax BR-6104k с прошитым linux, они вроде стоили 26$) и все ОК...

Изменено пользователем Enf14

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
отключи UPnP
Пробовал, не помогает.

 

Любопытную вещь обнаружил в autoexec.net на Zyxel:

ras> sys edit autoexec.net

EDIT cmd: q(uit) x(save & exit) i(nsert after) d(elete) r(eplace) n(ext)

sys errctl 0

sys trcl level 5

sys trcl type 1180

sys trcp cr 64 96

sys trcl sw off

sys trcp sw off

ip tcp mss 512

ip tcp limit 2

ip tcp irtt 65000

ip tcp window 2

ip tcp ceiling 6000

ip rip activate

ip rip merge on

ppp ipcp compress off

sys wdog sw on

ip icmp discovery enif0 off

bridge mode 1

sys quick enable

wan adsl rate off

wan adsl errorsecond shutdown 30

wan ghs set adsl2first off

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

как уже сказано было кольцуют они сеть по всем признакам, так что хоть один из двух кольцующих за роутер спрятать нужно

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Таже самая проблема ... отсюда пара вопросов

 

Захватывал траффик во время этих зависаний сети.. В сети в это время идёт шторм либо по NBNS либо ICMP

как и чем это делается?

 

В данный момент все известные модемы спрятаны за роутерами/wifi-роутерами (самый дешевый - Edimax BR-6104k с прошитым linux, они вроде стоили 26$) и все ОК...

Раскажите принципы спрятываения за роутер. например какие адреса будут у роутера на интерфейсах .. ну и т.д. :) что сочтете важным

Изменено пользователем Forvad

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Присоединяюсь к проблеме ... Одноранговая сеть (приблизительно 130-150 компов) соединена неуправляемыми свичами, с 1 файловым сервером (DHCP нигде не включен). В сети уже 5 модемов Zyxel 660 два RT1 и три RT2. Все это работает в одном локальном Ip диапазоне (маска в сети у всех устройств 255.255.255.0). Модемы настроены на одного провайдера с одинаковыми настройками, а именно:

lKPOoQo698.jpg

RA1bnW1VR7.jpg

tI9d51WblU.jpg

Так вот вначале было только 2 модема rt1 потом как появился третий начались проблемы: пару раз в день сеть висла со всеми девайсами в ней (пинги от 100 и выше, загрузка CPU модемов выше 80 % со временем до 100 %), сразу не понял в чем дело (думал в свичах, т.к. перезагрузив где нибудь в центре сети свич все становилось нормально (прикольно что именно в центре, где и стоят модемы, если на окраине ребутнуть свич,то не помогает, все так же будет висеть). Потом заметил что бы убрать лаги можно было ребунуть просто любой из dsl модемов. Недавно наткнувшись на эту тему проверил действительно если 2 модема оставить в сети - все норм (тестили 2 с половиной дня), но включаешь 3тий модем и обязательно за день случится неизбежное - сеть будет висеть пока что то не сделать.

Нехочется же покупать роутеры - модемов много, может кто нибудь все же найдет ответ в чем дело ??? (какие нибудь хитрые манипуляции с настройками модемов или прошивка их последними прошивками) или все же в этом провайдер виноват ???

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас