Jump to content
Калькуляторы

хотел собрать ядро 2.6.25.4 и поднять ifb но неполучается

хотел собрать ядро 2.6.25.4 и поднять ifb

и поднять ifb

только не могу понять как скомпилить этот ifb ( вроде в ядре оно есть и все такое .. а не компилится.. помогите где провтыкал )

 

Share this post


Link to post
Share on other sites

Хм, а что там сложного-то?

 

у меня

anarxist log # cat /boot/config-2.6.25.2-sirmax1  | grep IFB
CONFIG_IFB=m



lsmod  | grep ifbanarxist log # ifconfig | grep ifb
ifb                     6848  0

ifb0      Link encap:Ethernet  HWaddr 3E:BD:84:81:60:9D
ifb1      Link encap:Ethernet  HWaddr 66:1F:BB:AD:7F:9F
ifb2      Link encap:Ethernet  HWaddr 7E:FA:56:11:71:EB
ifb3      Link encap:Ethernet  HWaddr 3E:CE:0C:B8:98:3A

 

 

Share this post


Link to post
Share on other sites

Animal, что значит не компилится??? ядро просто обязано скомпилиться, тем более, как я понимаю, оно без сторонних патчей.

Да, и для начала: какой дистрибутив хоть?

Edited by Nic

Share this post


Link to post
Share on other sites
Animal, что значит не компилится??? ядро просто обязано скомпилиться, тем более, как я понимаю, оно без сторонних патчей.

Да, и для начала: какой дистрибутив хоть?

[root@rlan linux-2.6.25.4]# cat .config | grep IFB
[root@rlan linux-2.6.25.4]# cat .config | grep Ifb
[root@rlan linux-2.6.25.4]# cat .config | grep ifb

 

    Networking  ---> 
      Networking options  ---> 
        Choose IP: FIB lookup algorithm (choose FIB_HASH if unsure) (FIB_HASH)  ---> 
[b](X) FIB_HASH[/b]

 

[root@rlan linux-2.6.25.4]# uname -an
Linux rlan 2.6.25.4 #4 Fri Jun 6 01:33:33 EEST 2008 i686 athlon i386 GNU/Linux
[root@rlan linux-2.6.25.4]#

 

 

ось фидора 5тая

 

[root@rlan linux-2.6.25.4]# find ./ -name "*ifb*"
./drivers/video/amifb.c
./drivers/video/efifb.c
./drivers/video/stifb.c
./drivers/net/ifb.c
[root@rlan linux-2.6.25.4]#

Edited by Animal

Share this post


Link to post
Share on other sites

ааа))) прогнал ))) сорри ((

так а ifb все же где искать ?(((

Share this post


Link to post
Share on other sites

Depends on: NET && NETDEVICES && NET_CLS_ACT                          
  x   Location:                                                             x
  x     -> Device Drivers                                                   x
  x       -> Network device support                                         x
  x         -> Network device support (NETDEVICES [=y])

Соотвественно, проверить для начала, включены ли NET && NETDEVICES && NET_CLS_ACT

Share this post


Link to post
Share on other sites

echo CONFIG_IFB=m >> ./.config

и вообще, 2.6.25.4 на сервер... да под федорой... удачи.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this