Jump to content
Калькуляторы

Rtl8186 Firmware Всем, кто пишет под RTL8186

N.leiten

pererabotal www interfeis, posmotret mozno www.zuk.lv:81

usr:admin psw:rtl8186

 

 

moi mail janis@zukk.lv

 

sorry janis@zuk.lv

Share this post


Link to post
Share on other sites

uvi normalno rabotajet tolko s firefox, IE peredajot parametri inache

Share this post


Link to post
Share on other sites

janisz

За проделанную работу спасибо. Готовлю след. релиз - нашел еще парочку проблемных моментов в прошивке, которые желательно вылечить, что поможет не только для этой платформы...

 

Теперь по существу. Есть пара моментов с конфигами, которые пофиксю в след. прошивке (из разряда левые значения в конфиге беспроводного интерфейса, неправильные пути для запуска httpd и его наличие в inetd, из которого надобно удалять и т.п.) Есть проблема с нат2.5/макклон. В принципе китайцы правильно всё сделали на уровне драйвера беспроводного интерфейса, но немного не так я себе его работу представлял. В общем кто пробовал ставить точки в режим клиента и на пути стоит что-то из разряда DOCSIS тот меня поймет. Есть проблема с проскакивающими мак-адресами сетевой платы на компьютере за точкой в режиме клиента с включенным нат2.5, макклон вообще отказывается срабатывать подобающим образом. Буду писать патч для бриджа. Уже есть идеи реализации.

 

Параллельно, насколько я смотрю уже закончены концпетуальные разработки по веб-интерфейсу. Буду приводить в порядок и включать в релиз. Неуверен насчет надобности Vtund в прошивке, поэтому вполне возможно, что он останется в дереве исходников и не более того, так сказать - кому надо добавит сам. :)

 

Ну и потихонечку ридми пишу, если есть желающие - всегда рад, т.к. на все рук нехватает.

Share this post


Link to post
Share on other sites

Podskazite pozalasta kak stdelat 4tobi rabatalo kak klient:

 

iwpriv wlan0 set_mib opmode=8

 

AP videt no nekonektisja (s orginalnoi prowivkoi rabotaet)

 

takze rabotaet esli pomenjat naoborot AP zdelat kak klient a RTL8186 kak AP ( iwpriv wlan0 set_mib opmode=16)

 

AP - Mikrotik router

Share this post


Link to post
Share on other sites

Всем привет. Вот такие дела:

Оборудование DWL-G700AP (Wive-0.6.0)

1. Девайс смог нормально заработать в режиме AP и обслуживать клиентов с параметрами:

iwpriv wlan0 set_mib nat25_disable=1

iwpriv wlan0 set_mib macclone_enable=0

А не как говорил многоуважаемый N.leiten:

iwpriv wlan0 set_mib nat25_disable=0

iwpriv wlan0 set_mib macclone_enable=0

2. На что может конкретно повлиять параметр:

iwpriv wlan0 set_mib dhcp_bcst_disable=0

3. Если клиенты (адаптеры поддерживают B и G) находятся на разных расстояниях от 50 до 300 метров, то такие параметры могут подойти для точки доступа:

iwpriv wlan0 set_mib basicrates=4095

iwpriv wlan0 set_mib oprates=4095

iwpriv wlan0 set_mib fixrate=1

iwpriv wlan0 set_mib autorate=1

iwpriv wlan0 set_mib band=3

4. Команда: wl scangraph. Должна работать, и показывать то что нашла, в режиме AP?

5. Значение RSSI: хорошо - это когда в большую сторону?

 

Создателю данной прошивки громадный респект. Молодцы.

Share this post


Link to post
Share on other sites

столкнулся сегодня с проблемой, прошил один г700 в wive 0.6, сделал все нужные настройки, текстовики естественно сохранял как обычно, ошибок при записи файлов не писало. После настройки сделал ребут - и после ребута все сбросилось на дефолтные параметры. Это я не знаю о какой то новой фишке, или с флешкой того длинка что-то было не так? Залил в него 0.5.7 - все прекрасно работает.

Share this post


Link to post
Share on other sites

MT-Te@m

Насчет

iwpriv wlan0 set_mib nat25_disable=1

iwpriv wlan0 set_mib macclone_enable=0

почитайте внимательней выше что я писал. Естественно с учетом семантики мибов. Эта тема обсуждалась неоднократно.

 

насчет остальных параметров - проблема со временем, т.к. исходники я потерял, а восстанавливать надо было быстро для релиза, поэтому многие параметры были взяты с рабочей точки и не изменены. В след. прошивке будут исправлены.

 

Насчет wl scangraph должна искать/показывать в любом режиме. Естественно если беспроводной интерфейс включен (в файле /etc/network/interfaces по-умолчанию выключен).

 

Насчет RSSI чем выше тем лучше. Для подключенных станций рекомендую использовать команду 'wl sta'

 

 

MaksMMS

Читайте Хистори/ридми/анонсы. В 0.6.0 версии удалена файловая система JFFS2 по-причине нестабильности, а ковырять в ней методы архивации и прочее времени нет. Поэтому теперь для сохранения конфигов есть команда 'fs save'

Share this post


Link to post
Share on other sites
MT-Te@m

Насчет

iwpriv wlan0 set_mib nat25_disable=1

При значении = 0, у меня на компе вылезает ошибка:

В системе обнаружен конфликт IP-адреса 192.168.0.10 (мой комп) с системой, имеющей адрес сетевого устройства 00:19:5B:FF:76:5A (это удалённый клиент). В результате могут быть нарушены сетевые операции на этих системах.

Всплывающее окно приложения: Windows - Системная ошибка : Конфликт IP-адреса с другой системой в сети

Share this post


Link to post
Share on other sites
MaksMMS

Читайте Хистори/ридми/анонсы. В 0.6.0 версии удалена файловая система JFFS2 по-причине нестабильности, а ковырять в ней методы архивации и прочее времени нет. Поэтому теперь для сохранения конфигов есть команда 'fs save'

понятно, большое спасибо

хистори краем глаза смотрел, видимо не разглядел такой достаточно важный момент :)

Share this post


Link to post
Share on other sites

Насчет wl scangraph должна искать/показывать в любом режиме. Естественно если беспроводной интерфейс включен

wpriv wlan0 set_mib nat25_disable=0 когда так стоит. Сканер не выдаёт ничего. Хотя рядом есть стоящая точка доступа. Как понял на 1, сканер сразу выдал её. Вот.

Share this post


Link to post
Share on other sites

MT-Te@m

Чудеса какие-то. Или с точкой что-то не то или есть какие-то еще факторы. Это первый случай такого поведения точки доступа.

nat2.5 ну никак не может влиять на сканирование интерфейса.

Скорее всего просто интерфейс был отключен. А насчет совпадения ip-адресов - значит где-то такой уже есть в сети.

Share this post


Link to post
Share on other sites

N.leiten

na etot moment ja prosto pererabotal www interface s starimi failami konfiguraciji

ctob usovershenstvovatj dalshe, mne dumajetsja cto nado inache formirovatj konfiguracionije faili, to jestj vinositj osnovnije konfiguracionnije parametri v fail parametrov kak sdelana s 'interfaces', pritom naprimer dlja wifi razbit na neskolko malenkih failov, dlja kazhdovo MENU svoi

Share this post


Link to post
Share on other sites

N.leiten

mozhbit napishi mne na mail

Share this post


Link to post
Share on other sites
Или с точкой что-то не то или есть какие-то еще факторы. Это первый случай такого поведения точки доступа. nat2.5 ну никак не может влиять на сканирование интерфейса.
С точкой доступа все нормально. 100%. Родные прошивки работают как надо и от Conceptronic версии 1.26 (на что сейчас перешил) то-же всё отлично работает.
Скорее всего просто интерфейс был отключен.
Извините, я не первый день за компом сижу. Я сам работаю админом в крупной компании. И решал проблемы по хлеще этой. То, что он был отключён - это исключено на 10000%.
А насчет совпадения ip-адресов - значит где-то такой уже есть в сети.
В сети не могло быть по определению 2 одинаковых IP-адреса/имён компов/или ещё чего. Опять же не впервый раз я занимаюсь настройкой сети.

 

Так что выводы делайте сами.

 

 

или есть какие-то еще факторы.
Что скорей всего и есть....

Share this post


Link to post
Share on other sites
iwpriv wlan0 set_mib nat25_disable=0

iwpriv wlan0 set_mib macclone_enable=0

вот здесь тоже зря. Могут быть проблемы с ppoe и мак-адресами. нат2.5 выключай.

Вот и получилось что при выключеном NAT таких ошибок винда не выдаёт.

Вы уж разберитесь молодой человек в этом: то в одном посте Вы пишете вкл, а в другом выкл. При тех же условиях, что точка должна работать в режиме AP.

 

Извините за грубость :) Но Вы всё равно молодцы

Share this post


Link to post
Share on other sites

MT-Te@m

Повторяю - перечитайте внимательно, что я писал раньше, прежде чем выдвигать обвинения. Насчет режима Клиент-инфраструктура, режима АП-инфраструктура. А также зачем нат2.5/макклон. А то получается обвиняем не слушая.

 

ЗЫ. Есил уж так совсем интересно, то более подробно обо всем написано в ридми для прошивки:

http://downloads.sourceforge.net/rtl8186/W...mp;big_mirror=0

 

ЗЫЫ. Убедительно прошу обратить внимание на семантику мибов, в частности отрицание в nat25_disable и то, что я именно говорил выключить нат2.5, а не миб.

Edited by N.leiten

Share this post


Link to post
Share on other sites

Убедительно прошу обратить внимание на семантику мибов, в частности отрицание в nat25_disable и то, что я именно говорил выключить нат2.5, а не миб.

Хорошо. Ткните меня носом в то место где можно отключить нат2.5 а не миб.

Share this post


Link to post
Share on other sites

MT-Te@m

Ок. Я говорил отключить нат2.5, учитывая, что миб указывает отрицание, то есть nat25_disable указывает на выключенный статус, то мы должны указывать там 0 для включения (двойное отрицание) и 1 для включения (не выключен, значит включен). На практике вы сами этого добились изменив параметры должным образом...

Share this post


Link to post
Share on other sites
MT-Te@m

Ок. Я говорил отключить нат2.5, учитывая, что миб указывает отрицание, то есть nat25_disable указывает на выключенный статус, то мы должны указывать там 0 для включения (двойное отрицание) и 1 для включения (не выключен, значит включен). На практике вы сами этого добились изменив параметры должным образом...

Ошибка в словах у тебя. У тебя везде написано: вкл. И 0 включено и 1 включено.

 

Т.е. для нормальной работы девайса в режиме AP (а у клиентов стоит Infrastructure) нужно выставить так параметры:

iwpriv wlan0 set_mib nat25_disable=1 (т.е. технология выключена)

iwpriv wlan0 set_mib macclone_enable=0

Edited by MT-Te@m

Share this post


Link to post
Share on other sites

toshka kak klient s proshivkoi 0.6.0 nevidila AP

posle mnogih eksperimentov fail general priobrel sledujuchij vid

sravnivajte sami

general.gz

Share this post


Link to post
Share on other sites

Люди кто менял память на точке помогите вот с чем, нашел модуль km416s8030t на 16 метров, организация x16. припаяли, точка работает но видит только 8 метров.

 

Kernel command line: root=/dev/ram console=0 ramdisk_start=0

179.40 BogoMIPS

Memory: 5464k/8192k available (2146k kernel code, 2728k reserved, 180k data, 64k

init, 0k highmem)

Что сделать что бы увидело остальное???

буду благодарен за любую помощь

Share this post


Link to post
Share on other sites

Помоему сколько памяти задействовать в прошивке указанно...

Share this post


Link to post
Share on other sites

ams666

К сожалению P-snake прав. Сейчас эта проблема решается, но непосредственно количество памяти зашивается в ядро линукса, что не есть гут для универсальности прошивки... Если ххотите решение своей проблемы быстрее - можете взять исходники и собрать свою прошивку.

Share this post


Link to post
Share on other sites

Спасибо за проявленное внимание к проблеме, особенно P-snake, очень помог. проблема решилась прошивкой последней wive и все само зароботало как надо

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now