Jump to content
Калькуляторы

Rtl8186 Firmware Всем, кто пишет под RTL8186

Я именно так и делаю, но тем не меее не работает.

Share this post


Link to post
Share on other sites

drobyshev

смотри dmesg тогда... может чего интересного там напишет...

Share this post


Link to post
Share on other sites

Что именно смотреть?

вот что у меня выдало на эту команду:

 

# dmesg

Linux version 2.4.18-MIPS (root@Source-services) (gcc version 3.3.3) #702 Thu Se p 28 10:51:18 EEST 2006

early printk enabled

Determined physical RAM map:

memory: 00800000 @ 00000000 (usable)

Initial ramdisk at: 0x80239000 (22522 bytes)

On node 0 totalpages: 2048

zone(0): 2048 pages.

zone(1): 0 pages.

zone(2): 0 pages.

Kernel command line: root=/dev/ram console=0 ramdisk_start=0

179.40 BogoMIPS

Memory: 5572k/8192k available (2059k kernel code, 2620k reserved, 164k data, 60k init, 0k highmem)

Dentry-cache hash table entries: 1024 (order: 1, 8192 bytes)

Inode-cache hash table entries: 512 (order: 0, 4096 bytes)

Mount-cache hash table entries: 512 (order: 0, 4096 bytes)

Buffer-cache hash table entries: 1024 (order: 0, 4096 bytes)

Page-cache hash table entries: 2048 (order: 1, 8192 bytes)

check_wait... unavailable.

POSIX conformance testing by UNIFIX

bogomips: Initialized.

user_watchdog: Initialized.

led0: Initialized.

led1: Initialized.

sysmem: Initialized.

Linux NET4.0 for Linux 2.4

Based upon Swansea University Computer Society NET3.039

Initializing RT netlink socket

Starting kswapd

JFFS2 version 2.1. © 2001 Red Hat, Inc., designed by Axis Communications AB.

pty: 256 Unix98 ptys configured

Serial driver version 6.02 (2003-03-12) with no serial options enabled

ttyS00 at 0x00c3 (irq = 3) is a rtl_uart1

state->flags=00000000

block: 64 slots per queue, batch=16

RAMDISK driver initialized: 16 RAM disks of 512K size 1024 blocksize

NET4: Frame Diverter 0.52

divert: not allocating divert_blk for non-ethernet device teql0

loop: loaded (max 8 devices)

RTL8185 driver version 1.9 (2006-03-31)

divert: allocating divert_blk for wlan0

divert: allocating divert_blk for wlan0-wds0

divert: allocating divert_blk for wlan0-wds1

divert: allocating divert_blk for wlan0-wds2

divert: allocating divert_blk for wlan0-wds3

divert: allocating divert_blk for wlan0-wds4

divert: allocating divert_blk for wlan0-wds5

divert: allocating divert_blk for wlan0-wds6

divert: allocating divert_blk for wlan0-wds7

divert: allocating divert_blk for wlan0-vxd

RealTek E-Flash System Driver. © 2002 RealTek Corp.

Found 1 x 2M Byte AMD AM29LV160DB at 0xbe000000

=> Scan for ROOT signature in flash from pos=0x000000

Founded at pos=0x0DFFF4

Checksumm ok for 0x0E1000 bytes calced=0x808C, stored=0x808C) Checksumm OK . Use as ROOT partition (/dev/mtd2)

Reallocate pertition for root size=0x0E1000 bytes

Creating 3 MTD partitions on "DiskOnChip Millennium":

0x00000000-0x000e0000 : "boot+cfg+linux"

0x000e0000-0x001d0000 : "root fs"

0x001d0000-0x00200000 : "jffs2 fs"

8186NIC Ethernet driver v0.0.2 (Jan 30, 2004)

divert: allocating divert_blk for eth0

eth0: RTL8186-NIC at 0xbd200000, 00:01:02:03:04:05, IRQ 4

divert: allocating divert_blk for eth1

eth1: RTL8186-NIC at 0xbd300000, 04:05:06:07:08:09, IRQ 5

NET4: Linux TCP/IP 1.0 for NET4.0

IP Protocols: ICMP, UDP, TCP

IP: routing cache hash table of 512 buckets, 4Kbytes

TCP: Hash tables configured (established 512 bind 1024)

IPv4 over IPv4 tunneling driver

divert: not allocating divert_blk for non-ethernet device tunl0

GRE over IPv4 tunneling driver

divert: not allocating divert_blk for non-ethernet device gre0

ip_conntrack version 2.1 (64 buckets, 512 max) - 360 bytes per conntrack

ip_tables: © 2000-2002 Netfilter core team

ipt_time loading

ipt_recent v0.2.3: Stephen Frost <sfrost@snowman.net>. http://snowman.net/proje cts/ipt_recent/

NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.

NET4: Ethernet Bridge 008 for NET4.0

RAMDISK: Compressed image found at block 0

Freeing initrd memory: 21k freed

VFS: Mounted root (ext2 filesystem).

Freeing unused kernel memory: 60k freed

mount /proc file system ok!

mount /dev/mtdblock1 file system ok!

divert: allocating divert_blk for br0

device eth0 entered promiscuous mode

eth0:phy is 8201

device wlan0 entered promiscuous mode

wlan0: A wireless client is associated - 00:0F:3D:61:6A:31

br0: port 2(wlan0) entering listening state

br0: port 1(eth0) entering listening state

wlan0: A wireless client is associated - 00:14:2A:AB:73:3E

wlan0: A wireless client is associated - 00:14:2A:AB:73:3E

wlan0: A wireless client is associated - 00:18:F3:A6:CD:3C

wlan0: A expired STA is resumed - 00:14:2A:AB:73:3E

br0: received tcn bpdu on port 2(wlan0)

br0: topology change detected, propagating

br0: port 2(wlan0) entering learning state

br0: port 1(eth0) entering learning state

br0: port 2(wlan0) entering forwarding state

br0: topology change detected, propagating

br0: port 1(eth0) entering forwarding state

br0: topology change detected, propagating

eth0: rx work limit reached

wlan0: A wireless client is associated - 00:0F:3D:61:6A:31

wlan0: A wireless client is associated - 00:18:F3:A6:CD:3C

wlan0: A STA is expired - 00:18:F3:A6:CD:3C

wlan0: A STA is expired - 00:0F:3D:61:6A:31

wlan0: A wireless client is associated - 00:14:2A:AB:73:3E

wlan0: A wireless client is associated - 00:14:2A:AB:73:3E

wlan0: A wireless client is associated - 00:14:2A:AB:73:3E

wlan0: A expired STA is resumed - 00:14:2A:AB:73:3E

wlan0: A STA is expired - 00:14:2A:AB:73:3E

wlan0: A wireless client is associated - 00:0D:88:8B:90:12

wlan0: A wireless client is disassociated - 00:0D:88:8B:90:12

wlan0: A wireless client is associated - 00:0D:88:8B:90:12

wlan0: A expired STA is resumed - 00:0F:3D:61:6A:31

wlan0: A wireless client is associated - 00:0F:3D:61:6A:31

wlan0: A wireless client is associated - 00:18:F3:A6:CD:3C

wlan0: A wireless client is associated - 00:0D:88:8B:90:12

wlan0: A wireless client is disassociated - 00:0D:88:8B:90:12

wlan0: A wireless client is associated - 00:0D:88:8B:90:12

eth0: rx work limit reached

wlan0: A wireless client is associated - 00:11:95:E9:3A:98

wlan0: A wireless client is deauthenticated - 00:11:95:E9:3A:98

wlan0: A wireless client is associated - 00:11:95:E9:3A:98

wlan0: A wireless client is associated - 00:11:95:E9:3A:98

wlan0: A wireless client is deauthenticated - 00:11:95:E9:3A:98

wlan0: A wireless client is associated - 00:11:95:E9:3A:98

wlan0: A wireless client is deauthenticated - 00:11:95:E9:3A:98

wlan0: A wireless client is associated - 00:11:95:E9:3A:98

wlan0: A wireless client is deauthenticated - 00:11:95:E9:3A:98

wlan0: A wireless client is associated - 00:19:5B:54:24:37

br0: received tcn bpdu on port 2(wlan0)

br0: topology change detected, propagating

wlan0: A wireless client is associated - 00:14:2A:AB:73:3E

br0: received tcn bpdu on port 2(wlan0)

br0: topology change detected, propagating

wlan0: A STA is expired - 00:19:5B:54:24:37

eth0: rx work limit reached

wlan0: A wireless client is associated - 00:0D:88:8B:90:12

wlan0: A wireless client is disassociated - 00:0D:88:8B:90:12

wlan0: A wireless client is associated - 00:0D:88:8B:90:12

wlan0: A STA is expired - 00:0F:3D:61:6A:31

wlan0: A STA is expired - 00:18:F3:A6:CD:3C

wlan0: A expired STA is resumed - 00:0F:3D:61:6A:31

wlan0: A wireless client is associated - 00:0F:3D:61:6A:31

wlan0: A wireless client is associated - 00:0D:88:8B:90:12

wlan0: A wireless client is disassociated - 00:0D:88:8B:90:12

wlan0: A wireless client is associated - 00:0D:88:8B:90:12

Share this post


Link to post
Share on other sites

wlan0: A wireless client is associated - 00:11:95:E9:3A:98

wlan0: A wireless client is deauthenticated - 00:11:95:E9:3A:98

wlan0: A wireless client is associated - 00:11:95:E9:3A:98

wlan0: A wireless client is associated - 00:11:95:E9:3A:98

wlan0: A wireless client is deauthenticated - 00:11:95:E9:3A:98

wlan0: A wireless client is associated - 00:11:95:E9:3A:98

wlan0: A wireless client is deauthenticated - 00:11:95:E9:3A:98

wlan0: A wireless client is associated - 00:11:95:E9:3A:98

wlan0: A wireless client is deauthenticated - 00:11:95:E9:3A:98

 

Вот эти строки нас интересуют. Скорее всего это и есть Д-линк 700, который не цепляется за точку :) его мак есть в мак-фильтре. В общем его не может приассоциировать, точнее идентифицировать по списку. Обычно такое сообщение выводится при отказе в соединении по мак-списку или по 802.1х, последний в прошивке не поддерживается... в основной ветке, по-крайней мере.

 

ЗЫ. неплохо было бы еще посмотреть эту команду на самом клиенте, когда он пытается приконнектится с включенной мак-фильтрацией.

Edited by N.leiten

Share this post


Link to post
Share on other sites

Эту команду я запускал с отключенной мак фильтрацией.

Этот клиент 00:11:95:E9:3A:98 чужой и я не знаю с чем он подключился. Именно против таких клиентов и хочу включить фильтрацию.

Вобщем я понял что надо запустить # dmesg на точке доступа, когда включена мак фильтрация, а потом его же запустить на клиенте который не может подключиться.

Вот только непонятно почему клиент использующий точку 1000АР+ с родной д-линковской прошивкой, тоже не может подключиться.

Share this post


Link to post
Share on other sites

Возникла следующая проблема... Есть 5460АР. У неё вылетел контроллер Lan1 порта. При включении сильно грелся и точка через минут 5 вырубалась(может какая защита). Я его выпаял. Заработала... Но както странно... работает гдето часов 10 и виснет но уже не вырубается. Думаю мож поставить на неё Wive. Но как ? Ведь Lan1 ушёл :(( Можно както обойти ?

Share this post


Link to post
Share on other sites

Здраствуйте!

Подскажите, всетаки шъется чем нибудь Planet WAP-4035 кроме заводской прошивки? А то девайс вроде не плохой, а функционала прошивки не хватает...

Share this post


Link to post
Share on other sites

sn355

Можно залить последнюю Wive. Но не рекомендую, там сейчас всплыли старые проблемы при работе с флешью, на днях выложу исправленную версию.

 

 

XNeo

Скорее всего никак... надо перепаять контроллер со второго на первый порт.

 

 

drobyshev

Эта проблема не у тебя одного, просто мне не удавалось ее изучить лично.

Edited by N.leiten

Share this post


Link to post
Share on other sites
sn355

Можно залить последнюю Wive. Но не рекомендую, там сейчас всплыли старые проблемы при работе с флешью, на днях выложу исправленную версию.

пробовал уже - ревижн а не выходит из виса как я понимаю после прошивки, а ревижн б похоже вообще не принимается - консоли нет, сужу по диоду WLAN ...

кстати, киньте плиз ссылкой, куда в 4035 прицепить консоль, желательно с фоткой...

Edited by sn355

Share this post


Link to post
Share on other sites

sn355

Если не сложно - глянь сколько там памяти... Есть проблема с 16 метровыми платами. То есть в ревизии Аесли 16 метров, то прошивка не может загрузится.

Share this post


Link to post
Share on other sites

Если не сложно - глянь сколько там памяти... Есть проблема с 16 метровыми платами. То есть в ревизии Аесли 16 метров, то прошивка не может загрузится.

2 корпуса A2V64S40DTP 5059LAOC - не знаю что за жуки, но по ходу все же 8 метровые...

Share this post


Link to post
Share on other sites

to N.leiten

Есть пожелание, а может это фича такая - поправить в wive busybox чтобы у него ls -l стандартный вывод делал, а то winscp в него зайти не может - не нравится ему такой вид, когда символические ссылки сразу рядом раскрываются...

Share this post


Link to post
Share on other sites

Здравствуйте.

Я недавно наткнулся на этот форум, очень много полезной инфы.

Появился такой вопрос. У меня есть вот такой зверь DI-524 от длинка.

Можно его тоже как клиента запустить? Сильно надо. Или никак?

Share this post


Link to post
Share on other sites
drobyshev

Эта проблема не у тебя одного, просто мне не удавалось ее изучить лично.

Потому вопрос для всех кто использует Ж700 с прошивкой Wive в качестве точки доступа. Кто как решает проблему защиты сети от нелегалов ? Я так понимаю нужна или Мак фильтрация (у меня она работает коряво), или шифрование, или думаю может сменить SSID и настроить точку так чтоб он не транслировался в эфир (насколько я понимаю это защити только от ламеров и не более). Как всетаки защитить сеть?
Edited by drobyshev

Share this post


Link to post
Share on other sites

drobyshev

Эта проблема не у тебя одного, просто мне не удавалось ее изучить лично.

Потому вопрос для всех кто использует Ж700 с прошивкой Wive в качестве точки доступа. Кто как решает проблему защиты сети от нелегалов ? Я так понимаю нужна или Мак фильтрация (у меня она работает коряво), или шифрование, или думаю может сменить SSID и настроить точку так чтоб он не транслировался в эфир (насколько я понимаю это защити только от ламеров и не более). Как всетаки защитить сеть?

На мой взгляд кроме как использование шифрования WPA2 с мак-фильтрацией в комбинации с IPtables.

Либо опять же шифрование WPA2 и внутри VPN тунель.

На данный момент вроде другой эффективной альтернативы нет.

Share this post


Link to post
Share on other sites

Можно по виланам растасовать точки/клиенты... Это след. этап работы :)

Share this post


Link to post
Share on other sites

Здравствуйте. Подскажите пожалуйта такой момент, есть wap 4033 прошитая wive 0.5.9 пытаюсь

настроить в режим client infrastructure так это называлось в стандартной прошивке planet.

Я перешил wap 4033 в wive настройки wive можно посмотреть ниже. С этоми конфигами связь есть и не плохая. Но проблема в том, что когда запускаешь в проводной части сети програмку NetLook, она повидимому рассылает достаточно много широковещательных пакетов, что приводит к зависанию точьки с прошивкой wive 0.5.9. Причем зависание происходит в разные моменты. Что конкретно виснет я понять пока не могу, она просто становится не доступна по SSH и не пингуется.

 

Вопрос: может я что-то не правильно настроил?

может надо добавить wds, но зачем?

 

подскажите кто знает. Спасибо.

 

конфиги вот такие

network

 

BRIDGE_START=yes

#When auto_bridge is "yes" then init.script makes bridge itself

# when aut_bridge is "no" then init.script start /etc/network/bridge

AUTO_BRIDGE=no

 

# Just to make faster load, when not needed.

STP_ENABLE=yes

FD_TIMER=0

GCINT_TIMER=0

 

BR0_IPADDR=10.10.3.26/24

 

IPV4_FORWARD_ENABLE=yes

START_IPTABLES=yes

 

VLAN_START=yes

 

ETH0_ENABLED=yes

ETH0_FORCEIP=no

ETH0_IN_BR0=yes

ETH0_IPADDR=10.10.3.26/24

ETH0_MACADDR=00106c576976

 

ETH1_ENABLED=no

ETH1_FORCEIP=no

ETH1_IN_BR0=no

ETH1_IPADDR=192.168.1.50/24

ETH1_MACADDR=00006c576977

 

WLAN_ENABLED=yes

WLAN_FORCEIP=no

WLAN_IN_BR0=yes

WLAN_IPADDR=10.10.3.26/24

WLAN_MACADDR=00106c576976

 

#Be carefull. There're many Hardware-specific mibs

WLAN_USE_UNCHECKED_MIBS=no

 

 

general

 

 

#!/bin/sh

 

#Set ESSID of wirelless Infrastructure Network

iwpriv wlan0 set_mib ssid="souther_WIFI"

#Uncomment and Set prior bssid to connect

# iwpriv wlan0 set_mib bssid2join=0016b6526bd7

 

iwpriv wlan0 set_mib hiddenAP=0

 

#Set Mode: 8 - Client;16 - AP; 32 - AdHoc

iwpriv wlan0 set_mib opmode=8

 

#Set Regulatory Domain:

# "3" - 13 channels available, "6" - 14 channels available.

# FCC=1;IC=2;ETSI=3;SPAIN=4;FRANCE=5;MKK=6

iwpriv wlan0 set_mib regdomain=6

 

#Set Channel here

iwpriv wlan0 set_mib channel=6

 

#Set Initial Gain: in range 0-7

# It seems to be sens but maybe not. Just test

iwpriv wlan0 set_mib initialGain=4

 

#Set TransmitPower for CCK(802.11b) modulation

# Please Change it in variable

CCKPOWER=12

iwpriv wlan0 set_mib TxPowerCCK=`ader $CCKPOWER 14`

#iwpriv wlan0 set_mib TxPowerCCK=1010101010101010101010101010

 

#Set TransmitPower for OFDM(802.11g) modulation

# Please Change it in variable

OFDMPOWER=12

iwpriv wlan0 set_mib TxPowerOFDM=`ader $OFDMPOWER 162`

#iwpriv wlan0 set_mib TxPowerOFDM=10101010101010101010101010101010101010101010101010101010101010101010

101010101010101010101010101010101010101010101010101010101010101010101010101010101

010101010101010101010101010101010101010101010101010101010101010101010101010101010

101010101010101010101010101010101010101010101010101010101010101010101010101010101

0101010101010

 

iwpriv wlan0 set_mib basicrates=4095

iwpriv wlan0 set_mib oprates=4095

iwpriv wlan0 set_mib fixrate=4095

iwpriv wlan0 set_mib autorate=1

 

iwpriv wlan0 set_mib band=3

 

iwpriv wlan0 set_mib bcnint=50

 

#RTS/CTS Threshold

iwpriv wlan0 set_mib rtsthres=2346

 

iwpriv wlan0 set_mib fragthres=2346

iwpriv wlan0 set_mib expired_time=50

iwpriv wlan0 set_mib dtimperiod=1

 

iwpriv wlan0 set_mib show_hidden_bss=1

iwpriv wlan0 set_mib preamble=0

 

iwpriv wlan0 set_mib shortretry=6

iwpriv wlan0 set_mib longretry=6

 

iwpriv wlan0 set_mib Diversity=0

iwpriv wlan0 set_mib DefaultAnt=0

iwpriv wlan0 set_mib RFChipID=7

iwpriv wlan0 set_mib led_type=0

 

#G protection

iwpriv wlan0 set_mib disable_protection=0

 

#For bridged mode set this parameters

# Nat2.5 is technology to change the source MAC to MAC of Wlan-interface

# be carefull it says disabled, so make inverse in your decision

iwpriv wlan0 set_mib nat25_disable=0

# Macclone says all about itself. It just takes MAC of ETHERNET device on other end of line

# and take it for Wlan-interface. be carefull if this enabled it must be one device on a line.

iwpriv wlan0 set_mib macclone_enable=0

 

iwpriv wlan0 set_mib dhcp_bcst_disable=1

 

#Block packets between clients connected

# 0 - disable; 1 - block relay;2 - block relay but passup

iwpriv wlan0 set_mib block_relay=0

 

iwpriv wlan0 set_mib wifi_specific=0

Share this post


Link to post
Share on other sites

al_k

Проблема скорее всего неизлечима, т.к. нехватает мощности процессора на пересылку большого количества пакетов, вот она и залипает. Я попробую что-то сотворить, но пока ничего не могу обещать конкретного.

Попробуйте зажать скорость на беспроводном интерфейсе до 18-24мбит, может полегчает.

И не по теме - у вас ошибка в конфигурации:

iwpriv wlan0 set_mib fixrate=4095

тут нужно не список, а одно значение указывать... Т.к. здесь указывается четко скорость на которой работать, списки указываются при автовыборе. Но т.к. этот параметр отключен (у вас авторейт включен), то это нестрашно.

Share this post


Link to post
Share on other sites

дело в том что на автомате у меня уже точка работает на скорости 18-24,

то есть если я правильно понимаю что ограничев скорость (допустим до 9-12)в без проводном сегменте,

я тем самым объясню ядру, что надо убивать часть пакетов из проводного сегмента? или я что то не понимаю. тоеть в моем случае виснет ядро а не мост?

 

а по поводу

iwpriv wlan0 set_mib fixrate=4095

я уже просто экспериментировал

но в документации не совсем ясно написано что у этого параметра может быть только одна "1"

 

и теперь вопрос про память sdram, ее получается и добавлять то как-то без смысленно

 

 

 

а за ответ спасибо!

Share this post


Link to post
Share on other sites

al_k

Проблема в драйверах от риалтека, которые в бинарном виде поставляются. Т.к. я в ассемблере полный новичек (чтоб не сказать грубо :) ), то с драйвером приходится играться на уровне предоставленных возможностей. Так вот проблема в том, что при указании в списке всех скоростей для автоподбора драйвер пытается задрать скорость повыше. Не совсем так, конечно, насколько мне позволяет наблюдательность в дизассемблированном виде я заметил табличку соответствия rssi и скорости. так вот уважаемые китаезы поступили очень банально - привязали уровень сигнала к допустимой скорости. То есть для офисного варианта это работать будет, но для наших уссловий, когда есть еще параметры шума и еще куча физики тут приходится зажимать всё ручками. Очень редко получается повысить скорость/стабильность при зажимании выше 24Мбит. Самые стабильные варианты до 18Мбит. Поэтому вручную рекомендую установить эти скорости (поставьте в oprates, basicrates значение 255 или 511 для 18 и 24мбит соответственно, экспериментируйте)

 

насчет зависаний. Попробуйте зажать скорость - это может исправить ситуацию. В нашем случае это разгрузит систему от лишнего переключения по скорости, производительность возрастет и зависания удастся избежать. В общем экспериментируйте. :)

 

насчет памяти - легко догадаться, что без экспериментов не обойтись :) имея в руках исходники вполне спокойно можно установить значения в ядре и на 32метра памяти и на 16 :) Думаю след. прошивку буду собирать и по этому критерию.

 

ЗЫ. насчет зависания - сталкивался только с одним таким случаем. У клиента вирус на Висте - заражает сетевую подсистему таким образом, что там посылает около 1000 днс-запросов удп-шных за 2.5секунды, точка после 20-25 минут такой напряженки уходила в даун, причем точка на магистрали, а не раздающая...

Share this post


Link to post
Share on other sites
Очень редко получается повысить скорость/стабильность при зажимании выше 24Мбит. Самые стабильные варианты до 18Мбит. Поэтому вручную рекомендую установить эти скорости (поставьте в oprates, basicrates значение 255 или 511 для 18 и 24мбит соответственно, экспериментируйте)

В общем-то нормально оно зажимается, во всяком случае например у меня :) зажато на 48-54Mbit и скорость в общем-то ожидаемая - 2.5-2.7Мбайт

 

насчет зависаний. Попробуйте зажать скорость - это может исправить ситуацию. В нашем случае это разгрузит систему от лишнего переключения по скорости, производительность возрастет и зависания удастся избежать. В общем экспериментируйте. :)

А вот висло - это да! Причем действительно, если зажать до 18-24Мбит, то не виснет... Виснет на больших скоростях... Но! Я поднял IP-IP соединение (у меня стоят с двух сторон линка серваки под линухом) и виснуть перестало. Правда нетбиос и всякие виндовые порты (виндовая сетка) у меня порезан, но висло и без них пока не было IP-IP поднято.

 

ЗЫ. насчет зависания - сталкивался только с одним таким случаем. У клиента вирус на Висте - заражает сетевую подсистему таким образом, что там посылает около 1000 днс-запросов удп-шных за 2.5секунды, точка после 20-25 минут такой напряженки уходила в даун, причем точка на магистрали, а не раздающая...

Я тут проводил эксперимент, линк на G700 проталкивает через себя до 4000 пакетов в секунду. Размер пакета был 100байт.

Share this post


Link to post
Share on other sites

Такая история... была гроза. После грозы 5460 перестала работать. Загружается по индикаторам вроде норм но нету ни пинга ни ВЕБ. Пробовал сбросить, не вышло... Залил туда Wive. Залилось нормально, перезапустилась, стартанула... зашёл телнетом... всё засияло... но... пробую вводить wl scangraph (вроде так) и в списке не вижу ниодной точки (хотя они точно есть). Хотел попробовать обратно прошить оригинальную чтобы кликнуть привычный "Site Survey", удостовериться рабочий или пленый радиомодуль и не выходит... заливаю оригинальную прошивку. Заливается и всё... точка стоит и ждёт завтрашнего дня. Сама не перегружается. Есси вырубаю питание то стартует снова Wive :)

Как уверенно проверить радиомодуль?

Share this post


Link to post
Share on other sites

rsst

Насчет скоростей - значит счастливчик :) Насчет эксперимента... Я тоже его проводил и результаты подобные были. Вот только проблема в том, что днс-запросы идут в пакетах размером от 32байт и выше. Может точка просто захлебывается на уровне преамбул. В данном случае преамбула будет превышать размер самих данных и точка не будет успечать формировать пакеты?

Надо подумать о написании ускорителей - типа объединения нескольких пакетов в один фрейм - никто не встречал патчей, чтоб хоть от чего-то отталкиваться, а то самому с нуля писать - еще полгода пройдет и так занят на работе по самые нехочу :)

Share this post


Link to post
Share on other sites
Надо подумать о написании ускорителей - типа объединения нескольких пакетов в один фрейм - никто не встречал патчей, чтоб хоть от чего-то отталкиваться, а то самому с нуля писать - еще полгода пройдет и так занят на работе по самые нехочу :)

С таким ускорителем всякие игрушки лагать будут :( На сколько я знаю есть софтовая реализация подобного ускорителя и именно проблема лагов имеет место быть...

Share this post


Link to post
Share on other sites

rsst

ну если дать в руки управление параметрами. Из разряда объединять по времени каждые 50мс/10мс или управляемость по размеру пакета. объединять пакеты размером до 100байт... Суть в управляемости и лагать не будет. Лагает из-за возникающих задержек, а если от них уйти, то будет прикольно :)

Да и возможность включения/октлючения всегда доступна.

Ссылочку не подкинешь случайно?

Edited by N.leiten

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now