Перейти к содержимому
Калькуляторы

Rtl8186 Firmware Всем, кто пишет под RTL8186

D-Link G700AP, wive-ng 0.3.18. Хочу настоить wpa2-psk. Подключаюсь телефоном, пароль не подходит. ЧЯДНТ? В конфигах поменял вот что:

/etc/network/wifi/general

AUTHTYPE=SHARED
WPA=yes

/etc/wpa.conf

#0 – disable, 1 – WEP, 2 – WPA, 4 – WPA2 only, 6 – WPA2 mixed
encryption = 4
#“string_value”, 1-32 char
ssid = "SOME-WiFi"
#0/1 – disable/enable 1x Radius authentication
enable1x = 0
#0/1 – disable/enable MAC authentication
enableMacAuth = 0
#0/1 – disable/enable none WPA client support when WPA is set
supportNonWpaClient = 0
#1 – WEP64, 2 – WEP128 Refer when encryption is set 1 (wep)
wepKey = 0
wepGroupKey = ""
#1 – Radius, 2 – PSK (pre-shared key)
authentication = 2
#1 – TKIP, 2 – AES
unicastCipher = 1
wpa2UnicastCipher = 1
#0 – use psk value as key in raw data, 1 – use passphrase algorithm to convert psk value
usePassphrase = 1
#“string_value”, if usePassphrase=0 (raw data), it should be 64 hex digits.
#If usePassphrase=1, the string length should be >=8 and <=64.
psk = "123456789"
#Group key re-key time
groupRekeyTime = 86400
#UDP Port number of radius server
rsPort = 1812
#IP address of radius server (e.g., 192.168.1.1)
rsIP = 0.0.0.0
#“string_value”, password of radius server with 31 char in max
rsPassword = ""
#Max retry number of request packet with radius server
rsMaxReq = 3
#Timeout time (in second) of waiting rsp packet of radius
rsAWhile = 5
#0/1 – disable/enable accounting radius server
accountRsEnabled = 0
#UDP Port number of accounting radius server
accountRsPort = 1813
#IP address of accounting radius server
accountRsIP = 0.0.0.0
#“string_value”, password of accounting radius server with 31 char in max
accountRsPassword = ""
#0/1 – disable/enable the feature of statistic update with accounting server
accountRsUpdateEnabled = 0
#Update time in seconds
accountRsUpdateTime = 60
#Max retry number of request packet with accounting radius server
accountRsMaxReq = 3
#Timeout time (in second)of waiting rsp packet of accounting radius server
accountRsAWhile = 5

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

D-Link G700AP, wive-ng 0.3.18. Хочу настоить wpa2-psk. Подключаюсь телефоном, пароль не подходит. ЧЯДНТ? В конфигах поменял вот что:

/etc/network/wifi/general

AUTHTYPE=SHARED
WPA=yes

/etc/wpa.conf

#0 – disable, 1 – WEP, 2 – WPA, 4 – WPA2 only, 6 – WPA2 mixed
encryption = 4
#”string_value”, 1-32 char
ssid = "SOME-WiFi"
#0/1 – disable/enable 1x Radius authentication
enable1x = 0
#0/1 – disable/enable MAC authentication
enableMacAuth = 0
#0/1 – disable/enable none WPA client support when WPA is set
supportNonWpaClient = 0
#1 – WEP64, 2 – WEP128 Refer when encryption is set 1 (wep)
wepKey = 0
wepGroupKey = ""
#1 – Radius, 2 – PSK (pre-shared key)
authentication = 2
#1 – TKIP, 2 – AES
unicastCipher = 1
wpa2UnicastCipher = 1
#0 – use psk value as key in raw data, 1 – use passphrase algorithm to convert psk value
usePassphrase = 1
#”string_value”, if usePassphrase=0 (raw data), it should be 64 hex digits.
#If usePassphrase=1, the string length should be >=8 and <=64.
psk = "123456789"
#Group key re-key time
groupRekeyTime = 86400
#UDP Port number of radius server
rsPort = 1812
#IP address of radius server (e.g., 192.168.1.1)
rsIP = 0.0.0.0
#”string_value”, password of radius server with 31 char in max
rsPassword = ""
#Max retry number of request packet with radius server
rsMaxReq = 3
#Timeout time (in second) of waiting rsp packet of radius
rsAWhile = 5
#0/1 – disable/enable accounting radius server
accountRsEnabled = 0
#UDP Port number of accounting radius server
accountRsPort = 1813
#IP address of accounting radius server
accountRsIP = 0.0.0.0
#”string_value”, password of accounting radius server with 31 char in max
accountRsPassword = ""
#0/1 – disable/enable the feature of statistic update with accounting server
accountRsUpdateEnabled = 0
#Update time in seconds
accountRsUpdateTime = 60
#Max retry number of request packet with accounting radius server
accountRsMaxReq = 3
#Timeout time (in second)of waiting rsp packet of accounting radius server
accountRsAWhile = 5

 

 

 

Загрузил Putty зашел в menu\3 и ищешь эти обозначения и меняешь, походу из-за этого!

 

#---------------------------------GENERAL WIRELESS INTERFACE CONFIG--------

#Set Mode: AP/CLIENT/ADHOC

RMODE=AP

 

#Set ESSID of wirelless Infrastructure Network

ESSID=Non_Hacking

 

 

---------------------------------------------------------------------------

#---------------------------------------ACCESS OPTIONS---------------------

 

#802.11 Authentication type OPEN-open system, SHAREDБ-?shared key, AUTO-aut

AUTHTYPE=AUTO

 

#Enable/disable access list

ACL=no

 

#Allowed macs of client (on one through a blank)

ALLOWMACS="001D92C7B5AB 0015AF8BD700 004F6A010719 003005DF2049 0019CB7515A2

 

#Enable/disable wep

WEP=no

 

#WepKey 26 digits for 128bit

WEPKEY=11223344556677889910111213

 

#Enable/disable wpa/wpa2

WPA=yes

SSID

ssid = "Non_Hacking"

Password

psk = "77777777"

 

Ну я вообщем не спец в этом деле, но вроде на первый взгляд из-за этого;)

 

P.S.

Кто бы мне чутка помог узнать по чему у меня PPPoE когда торрент загружаю или же при многопоточности (вкладок 15 в лисе обновишь и повис)!

Изменено пользователем CoolPepper

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Есть 2 точки, расстояние 610м, прямая видимость, оптику копануть возможности нет.

Стоят 2 точки G700AP. До сего момента на них стояла старенькая wive-ng, один из первых релизов, и две маленьких Яги антенны, спаянных на коленке из медной проволоки. Все работало, хоть и не очень быстро, пара МБит всего.

Захотелось бОльшей скорости, было куплено 2 параболических антенны на 27Дб. Поставлено, заодно обновил прошивку на точках до последней (0.3.18 бинарные образы с sf.net). Настроил. Не работает :(

Вот основные настройки:

/etc/boot

/etc/network/interfaces

/etc/network/wifi/general

/etc/wpa.conf

 

В поиске то есть то нет противоположной точки, чаще всего нет.

Могут они друг друга слепить, или дело в настройках?

 

Заранее ОГРОМНО благодарен за Ваши ответы. Спасибо.

Можно ссылку на антенны, которые стоят?

Конечно, Антенна сегменто-параболическая 27дб

Обе стоят в горизонтальной поляризации, расстояние 610м, высоты 20м и 8м, прямая видимость, телескопические облучатели "выдвинуты" на максимум.

Когда стоишь у одной антенны рядом, ноутбук видит обе точки.

скорее всего не попадают в луч одна другой из-за разницы в высотах. у ноута антенна по сути всенаправленная - он хоть боковой лепесток ловит.

можно попробовать немного расфокусировать антенны (вдвинуть облучатели) - луч станет шире. или поюстировать по возвышению.

ну и сигнал на передатчике уменьшить понятное дело, так чтобы уровни были примерно -50...-55dBm

уровни можно запостить?

При указанных в конфигах выше настройках мощности - потери стандартных пингов 83-90%%, rssi вот прямо сейчас 11% -92dBm, при кручении антенн получалось поймать до 46% -70dBm (примерно, точно не помню сколько 46% в децибелах по wive-ng-шному). Связь лучше при этом не становилась.

Замечено, что при увеличении мощности передатчиков качество связи улучшается, но недостаточно, чтобы этим можно было решить проблему.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Привет! Может кто-то пожалуйста, компиляции последнего снимка wive-NG (http://wive-ng.git.sourceforge.net/git/gitweb.cgi?p=wive-ng/wive-ng;a=shortlog)? Независимо от того, что я пытаюсь я всегда получаю ошибку во время процесса компиляции. Мне это нужно из-за исправить PPTP плагин автодозвон в сети вниз.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

есть вопрос! вобщем сделали с другом сеть..У него инет.точка доступа zyxel p330 w ee, антенна на крыше 7дби. у меня карта длинк dwa 520 и комнатная антенна в окне тоже 7 дби. видимось как бы прямая, т.е. из окна видно крышу его дома(он в пятиэтажке, я в частном доме.). получается что сигнал идет под углом примерно 45градусов.. Что интересно сигнал на приеме у меня 40% у него до 20%..Скорость должна быть 6мегабит. но у меня всего 1!!!! в точке доступа прошивка линуксовая wive ng. Может какие настройки по этому поводу можно перебрать?

ps. Антенну на крышу вынести нет возможности.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

О каком решении идет речь?

Я ваабще не понимаю в чем разница ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Прошил G700AP 0.3.18, после весьма безобидных настроек при включении перестал поднматься eth0. В логах чисто, в чем может быть проблема? Если сбросить настройки, то поднимается на ура...
ищи мои посты с аналогичной проблемой на предыдущих страницах

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
P.S.

Кто бы мне чутка помог узнать по чему у меня PPPoE когда торрент загружаю или же при многопоточности (вкладок 15 в лисе обновишь и повис)!

ты сумбурно написал . как именно отваливается - в логе то не видно - внешние симптомы какие и как лечишь ?(глянь мои посты 2 страницы назад) - попробуй у торрента поставить глобальный максимум соединений типа 10 , на один торрент файл - 2 соединения,

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Вот возникла необходимость вкомпилить очень полезную утилитку iftop в wive-ng.
Я собрал себе iftop (правда довольно неряшливо), но он работает.
Изменено пользователем w422g

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

А где лежат конфигурации W422G_v3 / W530G / W532G?

Вытащил git://wive-ng.git.sourceforge.net/gitroot/wive-ng/wive-ng-dsl но там только LAN110v2 / LAN410v2 / USBv3.

Прошивку таким образом пересобрать довольно затруднительно, т.к. нет нужных настроек.

...

Нашел цитату sfstudio "Никаких других wive-ng в природе не существует. Все кроме wive-ng-dsl-2.6 доступны в исходниках в git. dsl-2.6 исходники будут опубликованы когда избавлюсь от проприретарных кусков кода от риалтэка." Теперь всё понятно. Очень жалко, что прошивку не собрать.

Изменено пользователем w422g

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Доброго времени суток, пытаюсь подключить 64 Мб ММС карточку. Версия прошивки wive-ng 0.3.8. Включил поддержку ММС в конфиге. Подключил так:

MMC --- JTAG --- GPIO

CLK 5 <---> 1 --> 8 RTL8186 pin 146

DO 7 <---> 3 --> 6 RTL8186 pin 33

DI 2 <---> 5 --> 9 RTL8186 pin 116

CS 1 <---> 7 --> 7 RTL8186 pin 8

GND и VCC перепаял с UART разъёма, на фото ешё не видно. Так как у меня JTAG порт не разведён, то пришлось паять на ноги проца:

 

d0e5251cc6f004477696be7cd7f35a62.jpg

 

При загрузке столкнулся с проблемой, в dmesg вижу:

mmc: GPIO init
mmc: initialising MMC
GPIO_SD_CS dir: 1
GPIO_SD_DI dir: 1
GPIO_SD_DO dir: 0
GPIO_SD_CLK dir: 1
mmc: card init 1/2
mmc: card init 2/2
mmc: card init 3/3
Size = 62720, hardsectsize = 512, sectors = 125440
Partition check:
mmca:end_request: I/O error, dev 79:00 (mmc), sector 0
end_request: I/O error, dev 79:00 (mmc), sector 2
end_request: I/O error, dev 79:00 (mmc), sector 4
end_request: I/O error, dev 79:00 (mmc), sector 6
end_request: I/O error, dev 79:00 (mmc), sector 0
end_request: I/O error, dev 79:00 (mmc), sector 2
end_request: I/O error, dev 79:00 (mmc), sector 4
end_request: I/O error, dev 79:00 (mmc), sector 6
unable to read partition table

Значит размер карточки wive видит, а партицию почему-то не читает. Карточку форматировал в ext2 так:

cfdisk /dev/mmcblk0, создал партицию, пометил как тип 83 (Linux), записал изменения.

fdisk -l /dev/mmcblk0 выдаёт:

/dev/mmcblk0p1

Потом пробовал: mke2fs /dev/mmcblk0 и пробовал: mke2fs /dev/mmcblk0p1

В обоих случаях ошибка таже самая, пробовал на своём лаптопе. Может кард ридер у меня немного глючный так как пробуя в Gparted подготовить карточку лаптоп виснет намертво.

Может кто нибуть таки удачно подключал MMC к RTL8186, поделитесь опытoм или пните в нужном направлении, где я накосячил непойму

Изменено пользователем Jumboman

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

у ка во нибудь остались прошивки rtl8186.dgreen.v2.zip ни где ни магу найти их ..веб серверы все по умерли..

 

?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Возможно ли прошить Planet WRT-416? Он тоже на чипе RTL8186.

На плате 2 нераспаянных 4х-контактных разъема - это ком-порты или...?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Народ дайте простую вайву.а то все умерло,не отрыть в просторах сети.А винт с ней утонул.

Заранее благодарен.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Подскажите плиз на wive-ng 3.18 точка G700 постоянно отпадает pppoe

 

[Wive-NG@/]# cat /var/log/ppp-connect-errors

Killed

Killed

pppoe: read (asyncReadFromPPP): Session 5163: Input/output error

pppoe: read (asyncReadFromPPP): Session 5375: Input/output error

pppoe: read (asyncReadFromPPP): Session 5115: Input/output error

pppoe: read (asyncReadFromPPP): Session 5392: Input/output error

pppoe: read (asyncReadFromPPP): Session 5348: Input/output error

pppoe: read (asyncReadFromPPP): Session 5496: Input/output error

Killed

 

Такие сообщения собираются... что может быть?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Подскажите пож. люди добрые...

Жил был девайс DAP-1150 (h/w ver A1 f/w ver 1.00, RTL8186)работал в режиме AP долго и счастливо. Но вдруг в один прекрасный (а точнее ужасный) момент перестало работать радио (погас индикатор WI-FI) попытался ресетить кнопкой ресет в итоге девайс потерялся вовсе... Теперь нет возможности даже по ethernet подключиться. При нажатии и удержании кнопки "reset" индикатор питания не риагирует вообще. Есть ли возможность его оживить? Спасибо.

https://lh3.googleusercontent.com/-Jlex_FRSSgg/Tjg9tO06SuI/AAAAAAAAAOk/HrAiFlyDcjI/s144/IMG_20110802_220427.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Люди добрые помогите.

http://forum.justlan.net/viewtopic.php?f=88&t=1322&p=15201#p15201

Тупанул с моделью роутера ( оказалось, что у меня Acorp WR-G(2.0)- хотел прошить в Zuxel, дошёл до пункта 12 по интрукции (ссылка выше) и нашь роутер "пал смертью храбрых", точнее он жив (он работает- горит POWER и LAN или WAN, смотря через какой порт подключать), но tftp по адресу 192.168.1.6 перестал работать. В ходе выполнения той инструкции получил следующее: Удалил прошивку Acorp, залил установщик Zuxel - теперь мой роут пустой.

Помогите пожалуйста с JTAG если можно подробнее как и что распаивать и как шить. (прошу прощения если такой вопрос уже был, просто поймите- не вариант перечитывать 211 страниц данного форума дабы найти нужную информацию). Помогите пожалуйста!!!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Добрый день.Прошу помощи в востановлении mac адреса точки доступа dap 1150.

Была прошита в Conceptronic C54APM.bin.

После прошивки заработал всего один режим раздачи интернета от компа,в вебморду так и не зайти.Стандартная прошивка становиться режимы при преключении тумблера срабатывают но также не зайти в веб морду,ни dlinkap не 192.168.0.50.

Опять зашиваеш Conceptronic и раздает интернет,mac адрес отображаеться как BSSID 001122334455 в место родного.Очень прошу вас о помощи.Руки прямые,любую схему или програматор смогу спаять.

Данные с точки доступа:

p/n IAP1150eeu...a1g

s/n F3OU184005620

mac id 001E58E7A69B

WPS PIN 60872142

H/W Ver A1 F/W Ver 1.00

 

FCC ID KA2AP1150A1

IC 4216A-AP1150

 

Данные с материнской платы.

 

21514P1150A11A1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

В общем поднял trendnet TEW-432BRP H/W:D1.1R

1 присвоил в комп адрес 192.168.1.151

2 ping 192.168.1.1 - тишина

3 arp -a увидел mac, сравнил его с написаанным на пузе коробочки - совпадает.

4 скачал прошивку по принципу чем свежее тем кузявее.

5 tftp -i 192.168.1.1 PUT TEW432BRP_D1.2R_FW3.10B15_nml.bin

 

Огромное спасибо! Сей девайс успешно оживлен багодаря Вам!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Доброго всем времени суток!

Впервые на вашем форуме, да и вообще ищу альтернативную прошивку на свой роутер впервые..

Вопросы такие:

Данные прошивки можно залить на роутер Trendnet TEW432BRP/C H/W D2.1R? на нем так-же стоит чипсет RTL-8186.

Есть ли в этих прошивках возможность настройки роутера через Веб-интерфейс или все в терминале делать?

И как все это дело заливат ьи ставить? =)

 

Заранее спасибо!

Изменено пользователем Lorence

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

hello to all Russians & Co. from CROATIA :D

 

I have my AIRLIVE/OVISLINK WL-5470AP RTL8186

 

Flash: MX 29LV160DBTI-70G (2MB)

 

SDRAM : 2x ISSI IC42S16400F-6TL XA658500W 0923 IC SDRAM 64MBIT 166MHZ 54TSOP (LINK)

There says it is 64mb but i think this router has only 16MB RAM ?

 

Board Pic (1600x1200) : http://i45.tinypic.com/2z6uqgh.jpg

 

Can i maybe replace FLASH or SDRAM to incrase some memory and which linux firmware can i put on to it.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

печально что тему никто из спецов не поддерживает :(

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Прошил точку DAP-1160 прошивкой Wive-NG. Настроил сеть между eth1 (PC) и wlan0 (Tablet wifi). Дело за малым - получить интернет на eth0.

Собственно если ETH0_USE_DHCP=yes, то роутер не получает ни IP-адреса, ни маршрутов, ни DNS. Прописываю IP, DNS вручную. Вот такой вид настроек сейчас:

 

ETH0_ENABLED=yes
ETH0_FORCEIP=yes
ETH0_IN_BR0=no
ETH0_USE_DHCP=yes
ETH0_IPADDR=37.235.176.177

DNS:

192.168.50.50
8.8.8.8
8.8.4.4

Затем маршрут

ip ro add default via 37.235.176.0 dev eth0

Маршруты получаются такие:

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.2.0     *               255.255.255.0   U     0      0        0 wlan0
192.168.1.0     *               255.255.255.0   U     0      0        0 eth1
37.235.176.0    *               255.255.248.0   U     0      0        0 eth0

И вроде как все хорошо, но ничего не пингуется. Даже сам шлюз.

В логах ничего. Что посоветуете?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

А порты слуайно местами не поменялись?

 

ifconfig что говорит, особенно статус?

 

А сорри, в линуксе нет этой фичи, она бсд-шная,

Для линукса:

cat /sys/class/net/eth0/carrier
cat /sys/class/net/eth1/carrier

Изменено пользователем NewUse

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Какие порты?

Каталога /sys/ в прошивке нет вообще.

[GATE@/]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:1D:7D:A1:6E:2E
         inet addr:37.235.179.177  Bcast:37.235.183.255  Mask:255.255.248.0
         UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
         RX packets:109174 errors:0 dropped:0 overruns:0 frame:0
         TX packets:122256 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:1000
         RX bytes:55957502 (53.3 MiB)  TX bytes:109024623 (103.9 MiB)
         Interrupt:4

eth1      Link encap:Ethernet  HWaddr 04:05:06:07:08:09
         inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
         UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
         RX packets:179337 errors:0 dropped:0 overruns:0 frame:0
         TX packets:59393 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:1000
         RX bytes:111274930 (106.1 MiB)  TX bytes:11392571 (10.8 MiB)
         Interrupt:5

lo        Link encap:Local Loopback
         inet addr:127.0.0.1  Mask:255.0.0.0
         UP LOOPBACK RUNNING  MTU:16436  Metric:1
         RX packets:3692 errors:0 dropped:0 overruns:0 frame:0
         TX packets:3692 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:0
         RX bytes:334637 (326.7 KiB)  TX bytes:334637 (326.7 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:E0:4C:81:86:86
         inet addr:192.168.2.1  Bcast:192.168.2.255  Mask:255.255.255.0
         UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
         RX packets:15843 errors:0 dropped:0 overruns:0 frame:0
         TX packets:30474 errors:758 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:200
         RX bytes:1688189 (1.6 MiB)  TX bytes:43389540 (41.3 MiB)
         Interrupt:2

[GATE@/]# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.2.0     *               255.255.255.0   U     0      0        0 wlan0
192.168.1.0     *               255.255.255.0   U     0      0        0 eth1
37.235.176.0    *               255.255.248.0   U     0      0        0 eth0
default         37.235.176.1    0.0.0.0         UG    0      0        0 eth0

Собственно теперь проблема изменилась. Интернет пропадает через 5-7 минут. Т.е. Тупо всё перестает пинговаться.

Где теперь искать проблему?)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас