Jump to content
Калькуляторы

QinQ На 4507R

Добрый день, что-то с наскоку не нашел. 

Есть:

Cisco IOS Software, Catalyst 4500 L3 Switch Software (cat4500-ENTSERVICESK9-M), Version 15.0(2)SG1, RELEASE SOFTWARE (fc4)
5407R 
Supervisor IV 1000BaseX (GBIC)         WS-X4515 

Пытаюсь сделать QinQ туннелирование.

interface GigabitEthernet4/2
 description # QinQ Tunnel #
 switchport
 switchport access vlan 910
 switchport mode dot1q-tunnel
                                              ^
% Invalid input detected at '^' marker.

Собственно вот что оно предлагает на выбор 

#switchport mode ?
  access        Set trunking mode to ACCESS unconditionally
  dynamic       Set trunking mode to dynamically negotiate access or trunk mode
  private-vlan  Set private-vlan mode
  trunk         Set trunking mode to TRUNK unconditionally

#switchport mode private-vlan ?
  host         Set the mode to private-vlan host
  promiscuous  Set the mode to private-vlan promiscuous
  trunk        Set the mode to private-vlan trunk

 

Тут надо не ошибиться, циска поедет далеко, а проверить там где я настраиваю негде.

Схема такая:

На 45ю прилетает пачка вланов, упаковывается в один через локальную физическую петлю и улетает через сеть провайдера.

 

На 6506 оно сейчас работает вот так:

interface GigabitEthernet4/1
 description # QinQ Loop #
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 10,160,999
 switchport mode trunk
 no cdp enable
 spanning-tree bpdufilter enable
 spanning-tree bpduguard enable
!
interface GigabitEthernet4/2
 description # QinQ Tunnel #
 switchport
 switchport access vlan 910
 switchport mode dot1q-tunnel
 mtu 1514
 no cdp enable
 spanning-tree bpdufilter enable
 spanning-tree bpduguard enable
(Это физический линк из одного порта в другой.

И так же приземляется на 3750ю с той стороны

Спасибо.

Share this post


Link to post
Share on other sites

Ну вы посмотрите в фиче-навигаторе, может прошивку обновить надо. Должно быть (если есть поддержка) через 

switchport mode dot1q-tunnel

Share this post


Link to post
Share on other sites

В 24.11.2021 в 20:31, VolanD666 сказал:

Ну вы посмотрите в фиче-навигаторе, может прошивку обновить надо. Должно быть (если есть поддержка) через 

switchport mode dot1q-tunnel

я думал CFN давно протух, последняя пара попыток использования этого поделия окончились провалом... кстати, заете что самое забавное:

#sh dot1q-tunnel 

dot1q-tunnel mode LAN Port(s)
-----------------------------
No ports have been configured as dot1q-tunnel
 

Share this post


Link to post
Share on other sites

В 25.11.2021 в 00:29, kapydan сказал:

Ну и, там же видим

Step 4 

Switch(config-if)# switchport mode dot1q-tunnel

А если прочитать мой первый пост видим 

 

 switchport mode dot1q-tunnel
                                              ^
% Invalid input detected at '^' marker.

 

Share this post


Link to post
Share on other sites

On 11/25/2021 at 11:29 AM, kapydan said:

шляпа какая-то, просто по feature-navigatorу этот функционал должен поддерживаться

Добрый день.
dot1q-tunnel поддерживается начиная с Supervisor V.

Share this post


Link to post
Share on other sites

В 25.11.2021 в 19:35, chonka5 сказал:
Добрый день.
dot1q-tunnel поддерживается начиная с Supervisor V.

От спасибо! Коротко и по делу. 

Меня вот это в заблуждение сильно ввело (ну и куча юзергайдов по 45й где туннель настраивается стандартно)

#sh dot1q-tunnel 

dot1q-tunnel mode LAN Port(s)
-----------------------------
No ports have been configured as dot1q-tunnel

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.