Jump to content
Калькуляторы

OSPF ФЛАПАЕТ

Добрый день , обратился клиент  с проблемой  при переключение на наш канал  оспф автоматом переключается на резерв , диагноз потеря hello  пакетов  по мультикасту . 

как то проверить оспф нет возможности  , клиент берет просто выделенный влан и гоняет OSPF  все внутри влана  . у нас просто выделен влан и подается на клиента    в режиме access .

проблема обнаружена у нескольких клиентов , закономерность  то что они подключены  по gpon    OLT  Huawei  5608T  , онушку  меняли не помогает .  на агрегации стоят свитчи eltex   там все проверили нет ограничений мультикаста 

 

самое интересное что все работало ранее , пару дней назад просто пошли потери ,  подняли  интерфейс  проверить физику . потерь icmp   нет  канал работает без потерь , потери только по мультикасту . 

 

 

 одного их клиентов  переключили на FTTH  поставили просто медик и включили прямым линком , и проблема ушла , т.е  проблема идет на конечноv узле   видимо  olt  не пропускает . 

 

Подскажите как быть кто сталкивался ? 

 

Edited by Igore

Share this post


Link to post
Share on other sites

максимальное  mtu  стоит 1560  , на агг Елтекс  откуда бошка  включена ,  jumbo frame  9000 mtu  

Edited by Igore

Share this post


Link to post
Share on other sites

Вы расскажите чуть больше. Как часто флапает и есть ли периодичность. ?

Есть логи ospf ? Приложите , хотя бы будет понятно с какой стороны не получают пакеты. 

Снимите дамп трафика, может там будет что-то видно. ? 

Share this post


Link to post
Share on other sites

та в том то и проблема что клиент не дает логи ,   когда включает к нам  оспф , флапает  в течении 2 минут и переключается на другой маршрут . все работало ранее никаких изменений на сети не было ,  но точно у нас потому что обращается сразу пару клиентов  .

 

Share this post


Link to post
Share on other sites

это клиента железо  ничего не будут переключать  , просят решит вопрос  , а у нас все как было  и ранее вот неделю  назад все работало   )))  MTU  1560  на  olt  максимальное  а на елтексах везде 9000 jumbo frame 

уже везде сняли даже storm control  интерфейсы чистые только вланы проходят . 

Share this post


Link to post
Share on other sites

17 минут назад, Igore сказал:

это клиента железо  ничего не будут переключать  , просят решит вопрос  , а у нас все как было  и ранее вот неделю  назад все работало   )))  MTU  1560  на  olt  максимальное  а на елтексах везде 9000 jumbo frame 

уже везде сняли даже storm control  интерфейсы чистые только вланы проходят . 

может все таки где то режется unuicast? попробуйте сами снять дамп, или по пути может какое оборудование обновляли?

Share this post


Link to post
Share on other sites

44 минуты назад, Igore сказал:

это клиента железо  ничего не будут переключать  , просят решит вопрос  , а у нас все как было  и ранее вот неделю  назад все работало   )))  MTU  1560  на  olt  максимальное  а на елтексах везде 9000 jumbo frame 

уже везде сняли даже storm control  интерфейсы чистые только вланы проходят . 

Я бы проверил MTU пингом на всякий случай. Еще можно сдампить трафик с двух концов и смотреть что уходит на одном конце и приходит на другом, искать место где теряется. Можно попробовать дебаг еще включить где-нить.

 

Клиенты точно разные? Может у них в настройках что? Там тип инт-са не совпадает, например.

Share this post


Link to post
Share on other sites

1 hour ago, VolanD666 said:

Вы точно уверены что с MTU все ок?

Согласен, почти наверняка проблема в mtu, вопрос только в том какой mtu включен на стороне клиента и какой максимальный проходит по сети.

@Igore, вы бы подняли тестовый vlan и проверили какой MTU проходит при ваших настройках и потом поинтересовались у клиента , какие у него настройки, а так вы ещё долго будете гадать и предполагать ..

Share this post


Link to post
Share on other sites

клиенты разные и точки включения 

 

кто знает как работает на елтексе bridge multicast filtering  ???   ,  есть подозрения что когда выключаем на главном , режит полностью мультикаст  . оспф   вроде как вообще теряем мультикаст , а когда включем   отпадает но хоть трафик есть 

Edited by Igore

Share this post


Link to post
Share on other sites

1 час назад, Igore сказал:

как работает на елтексе bridge multicast filtering

Если верить доке, то работает в связке с igmp snooping:
 

bridge multicast filtering
ip igmp snooping
ip igmp snooping vlan <vlanid>

В вашем же случае надо в клиентском vlan разрешить прохождение мультика ospf на всем пути.

Share this post


Link to post
Share on other sites

насколько знаю igmp должен быть выключен так просит клиент .  bridge  multicast filtering  по сути не нужен если по сети не проходит конкретно настройка самого потока  ?

Share this post


Link to post
Share on other sites

9 hours ago, VolanD666 said:

Я бы проверил MTU пингом на всякий случай.

Эээ, MTU mismatch пингом не выяснишь (точнее, тяжело выяснить, тем более надо иметь доступ к клиентскому оборудованию).
Было дело, когда на L3 интерфейсе MTU не совпадали, а на L2 (в туннеле) совпадали. В итоге пинг ходил на ура, а MTU флапалось.

 

8 hours ago, Igore said:

дело не в mtu  т.к ранее все работало  и mtu  там используют 1500 

1500 и MTU mismatch немного разные вещи, хотя аббревиатуры расшифровываются одинаково.

 

Edited by dr Tr0jan

Share this post


Link to post
Share on other sites

8 часов назад, dr Tr0jan сказал:

Эээ, MTU mismatch пингом не выяснишь

Ну почему, хотя бы можно понять что где-то не так как у тебя.

 

8 часов назад, dr Tr0jan сказал:

1500 и MTU mismatch немного разные вещи, хотя аббревиатуры расшифровываются одинаково.

Можно MTU ignore попробовать, но правда не у всех оно есть.

 

ТС, можно для теста другой протокол даже попробовать. Убедиться что дело не в мультикасте или в нем.

Share this post


Link to post
Share on other sites

16 часов назад, Igore сказал:

насколько знаю igmp должен быть выключен так просит клиент .  bridge  multicast filtering  по сути не нужен если по сети не проходит конкретно настройка самого потока  ?

Если хоть в одном влане есть включенный  igmp snooping, то bridge  multicast filtering нужен.
Я не знаю что у вас за Eltex'ы, но да igmp snooping у клиента в влане выключить. У eltex есть вещи типа

sh bridge multicast filtering <vlanid>
sh bridge multicast reserved-addresses

попробуйте их 
 

Share this post


Link to post
Share on other sites

все завелось , переключили на другой АГГ , со свитчем huawei  лажа  , хотя ограничений нет  , всем спасибо 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.