Jump to content
Калькуляторы

Потерялась сеть

Коммутатор:

Скрытый текст

!

interface Loopback10
 ip address 1.1.1.2 255.255.255.255

!

interface GigabitEthernet4/0/20

description --abon--
switchport access vlan 3000
switchport mode access

!

interface Vlan10
 ip address 10.99.1.2 255.255.255.248

!

interface Vlan3000
 ip unnumbered Loopback10

!

router ospf 10
router-id 10.99.1.2
no log-adjacency-changes
redistribute connected subnets route-map OSPF-OUT
passive-interface default
no passive-interface Vlan10
network 10.99.1.2
0.0.0.0 area 0
!
ip route 1.1.1.200 255.255.255.255 Vlan3000

!

ip prefix-list OSPF seq 5 permit 1.1.1.0/24 le 32
route-map OSPF-OUT permit 10
 match ip address prefix-list OSPF

 

 

Маршрутизатор:

Скрытый текст

!

interface Loopback10
 description output_user_in_this_word_0
 ip address 1.1.1.1 255.255.255.255
 ip ospf network point-to-point
 ip ospf flood-reduction

!

interface GigabitEthernet0/3.10
 description Output_Users_in_the_World_through_XXXX_XX_Primary_port_GI4/0/3
 encapsulation dot1Q 10
 ip address 10.99.1.1 255.255.255.248
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip ospf priority 255
 ip ospf flood-reduction
 no cdp enable

!

router ospf 10
 router-id 10.99.1.1
 no log-adjacency-changes
 redistribute connected subnets route-map OSPF-OUT
 passive-interface default
 no passive-interface Vlan10
 network 10.99.1.1 0.0.0.0 area 0

 network 1.1.1.1 0.0.0.0 area 0

default-information originate always

 

ip route коммутатора:

XX_Primary#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.99.1.1 to network 0.0.0.0

     10.0.0.0/29 is subnetted, 1 subnets
C       10.99.1.0 is directly connected, Vlan10
     1.0.0.0/32 is subnetted, 3 subnets
S       1.1.1.200 is directly connected, Vlan3000
O       1.1.1.1 [110/2] via 10.99.1.1, 18:36:06, Vlan10
C       1.11.2 is directly connected, Loopback10
O*E2 0.0.0.0/0 [110/1] via 10.99.1.1, 18:36:06, Vlan10
 

ip route маршрутизатора:

XXXX_XX_Primary#sh ip route              
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is XX.XX.143.133 to network 0.0.0.0

B*    0.0.0.0/0 [20/0] via XX.XX.143.133, 17:45:00
      1.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
S        1.1.1.0/24 is directly connected, Null0
O E2     1.1.1.2/32 
           [110/20] via 10.99.1.2, 18:38:34, GigabitEthernet0/3.10
C        1.1.1.1/32 is directly connected, Loopback10
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.99.1.0/29 is directly connected, GigabitEthernet0/3.10
L        10.99.1.1/32 is directly connected, GigabitEthernet0/3.10

 

 

 

И вот на этом моменте не разумею, на коммутаторе есть запись "S 1.1.1.200 is directly connected, Vlan3000" - а до маршрутизатора этот выученный маршрут не долетает...

Share this post


Link to post
Share on other sites
36 минут назад, RN3DCX сказал:

S 1.1.1.200 is directly connected, Vlan3000

так он тут не коннектед, а статик

37 минут назад, RN3DCX сказал:

ip route 1.1.1.200 255.255.255.255 Vlan3000

 

Share this post


Link to post
Share on other sites
38 минут назад, RN3DCX сказал:

S       1.1.1.200 is directly connected, Vlan3000

Эмм, а почему S ?

 

Вы посмотрите DB OSPF, там точно есть нужная LSA?

Share this post


Link to post
Share on other sites

@GrandPr1de Спасибо, заработало!

Косяк, конечно, что на этот момент не обратил внимания... 

Share this post


Link to post
Share on other sites
11 часов назад, RN3DCX сказал:

@GrandPr1de Спасибо, заработало!

Косяк, конечно, что на этот момент не обратил внимания... 

connected прокатил бы (поидее) если б роут выучился через dhcp snooping 

я уже за давностью лет не вспомню как я крутил аннамберед на каталистах, уже благо давно роутеры пришли на эту роль в моей жизни

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this