Jump to content
Калькуляторы

2011UAS-2HnD куда копать что б накатить 7-ю routerOS. Очень хочется поиграть с VXLAN

Весь вопрос в теме
 

/system package> /system package update download
            channel: development
  installed-version: 6.44
     latest-version: 7.1beta6
             status: ERROR: connection timed out


т е железка как бы роутерос видит а скачать не может

/system routerboard print
       routerboard: yes
             model: 2011UAS-2HnD
     serial-number:
     firmware-type: ar9344
  factory-firmware: 3.0
  current-firmware: 3.33
  upgrade-firmware: 6.44

 


VXLAN нужден для сексуальных игр с openvswitch

Share this post


Link to post
Share on other sites
3 минуты назад, sirmax сказал:

Весь вопрос в теме
 


/system package> /system package update download
            channel: development
  installed-version: 6.44
     latest-version: 7.1beta6
             status: ERROR: connection timed out


т е железка как бы роутерос видит а скачать не может


/system routerboard print
       routerboard: yes
             model: 2011UAS-2HnD
     serial-number:
     firmware-type: ar9344
  factory-firmware: 3.0
  current-firmware: 3.33
  upgrade-firmware: 6.44

 

 


VXLAN нужден для сексуальных игр с openvswitch

Дык залейте на саму железку прошивку и обновитесь? Или с 7ой так нельзя?

 

Вам принципиально именно на Микротике VXLAN? Может для поиграться взять вируталыный Нексус?

 

Share this post


Link to post
Share on other sites

та микрот есть и с ним уже вроде бы все понятно
а то ВМку городить или еще что-то
Не могу откуда качнуть 7-ку или туплю? Что б руками залить 

 

Share this post


Link to post
Share on other sites

Если не трудно, напишите потом свое впечатление про VXLAN в ROS 7. Интересно как у них там сделано и какие могут быть грабли )

 

Share this post


Link to post
Share on other sites
4 часа назад, VolanD666 сказал:

Если не трудно, напишите потом свое впечатление про VXLAN в ROS 7. Интересно как у них там сделано и какие могут быть грабли )

 

Базовая настройка со статическим тунелем заработала 

Linux:


ip link  \
    add vxlan51 \
    type vxlan \
    local 185.11.22.33 \
    remote 159.44.55.66 \
    dstport 4790 \
    vni 51

 

ip link set up dev vxlan51
ip addr add 192.168.98.2/30 dev vxlan51



 

Mikrotik


/interface/vxlan/export
/interface vxlan
add name=vxlan51 port=4790 vni=51
/interface vxlan vteps
add interface=vxlan51 port=4790 remote-ip=185.11.22.33



В результате траффик пошел

Со стороны микротика я сбриджевал с езернетом, со стороны линукса с клиентским вланом и получил адрес как обычный клиент сети


Это конечно детские игры
как скрещу с openvswitch  - отпишу


 

Share this post


Link to post
Share on other sites

При этом траффик между двумя линуксами (VNI 50)

18:37:53.236644 IP 159.44.55.66.44740 > 185.11.22.33.4789: VXLAN, flags  (0x08), vni 50


и между линуксом и микротиком

18:37:53.100745 IP 159.44.55.66.46870 > 185.11.22.33.4790: VXLAN-GPE, flags [I], vni 51: ERROR: unknown-next-protocol


Оба линка работают нормально при этом 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this